Subject: Re: [dispatch] SIP media load balancer requirement

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 5 Jan 2012 11:45:28 +0530

Hi Partha,

I would be interested in this work. See more inline

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ravindran, Parthasarathi
> Sent: Thursday, December 22, 2011 8:02 AM
> To: [email-masked]
> Subject: [dispatch] SIP media load balancer requirement
> 
> Hi all,
> 
> As a continuation of IETF-81 Dispatch minutes
> (http://www.ietf.org/mail-archive/web/dispatch/current/msg03742.html)
> about SIP load balancing, I thought of discussing about SIP media
> servers load balancing as mentioned in the SIP load balancing proposed
> charter (http://www.ietf.org/mail-
> archive/web/dispatch/current/msg03615.html).
> 
> "As SIP request resource consumption in SIP signaling only server
> varies drastically from SIP media servers [3], should the solution be
> split such that load balancing of a pure signaling server is different
> than that of a SIP server that handles signaling as well as media?"
> 
> SIP media server load balancing solution will be different from
> signaling only because the downstream resource consumption is mainly
> because of media  (RTP) than signaling (SIP) and the units to indicate
> the load balancing information will be different in both solution.
> There is a need to indicate those media resource consumption to the
> load balancer in the standard manner. Please let me know your comment
> on this.

I think what we need is some text/document saying how media overload is
different from signaling overload and what are the different resources
that need to considered for media overload. In that way we will have
good starting point to discuss on this topic.

Regards,
Ram
> 
> Thanks
> Partha
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Thu, 5 Jan 2012 06:28:22 +0000

Hi Ram,

Nice to see your interest. Please read inline for more comments.

Thanks
Partha

>From: Ram Mohan R (rmohanr) [mailto:[email-masked]]
>Sent: Thursday, January 05, 2012 11:45 AM
>To: Ravindran, Parthasarathi; [email-masked]
>Subject: RE: [dispatch] SIP media load balancer requirement
>
>Hi Partha,
>

<partha> The focus of this charter is about SIP media load balancing and not media overload handling. I agree with you that SIP media load balancing algorithm works in conjunction with media overload mechanism and selection of the load balancing algorithm majorly depends upon media overload mechanism. 

SIP media load balancer requirement is to consider media resource consumption of the peer apart from the signaling resource consumption.  </partha>