Subject: [dispatch] SIP Traceroute with media-loopback I-D

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 14 Oct 2011 17:22:09 +0000

Howdy,
I've submitted an I-D with a strawman proposal for how to provide the ability to make media-loopback test calls to B2BUAs along the path to a target.  The current proposal is to use a new SIP header, but there are other possible solutions.

Any comments/flames/feedback are welcome.

In particular, I'm trying to see if there's interest in DISPATCHing this work anywhere in the IETF, or if I should go the individual path instead.
Thanks!

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : A Media-based Traceroute Function for the Session Initiation Protocol (SIP)
	Author(s)       : Hadriel Kaplan
	Filename        : draft-kaplan-dispatch-sip-traceroute-00.txt
	Pages           : 7
	Date            : 2011-10-14

  SIP already provides the ability to perform hop-by-hop traceroute
  for SIP messages using the Max-Forwards header field, in order to
  determine the reachability path of requests to a target.  A new
  mechanism for media-loopback calls is also being defined separately,
  which enables test calls to be generated which result in media being
  looped back to the originator.  This document is a strawman proposal
  for a means of performing hop-by-hop traceroute-style test calls
  using the media-loopback mechanism, in order to test the media path
  when SIP sessions go through media-relaying B2BUAs.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-kaplan-dispatch-sip-traceroute-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-kaplan-dispatch-sip-traceroute-00.txt

---

From: Dean Willis <[email-masked]>
Date: Tue, 18 Oct 2011 18:46:07 -0500

> I've submitted an I-D with a strawman proposal for how to provide the ability to make media-loopback test calls to B2BUAs along the path to a target.  The current proposal is to use a new SIP heade…

Sadly, a needed thing. We have created a monstrosity, might as well
add some bolts to its neck for the jumper cables to attach to.

--
Dean