Subject: Re: [dispatch] Charter Proposal - Remote Call/Device Control WG

From: Paul Kyzivat <[email-masked]>
Date: Sun, 02 Oct 2011 17:57:43 -0400

On 9/27/11 8:34 AM, Shekh-Yusef, Rifaat (Rifaat) wrote:
> Our intention with the original SIP Action Referral proposal and later on with the INVOKE method proposal was to extend the Remote *Call* Control mechanism defined by the REFER method.
> During the discussion of these proposals some people showed interest in a Remote *Device* Control, but it was clear that the line between Remote Call Control and Remote Device Control is blurry.
> Different people have different ideas on how to address these needs:
>    * One mechanism over SIP should address both Call and Device control
>    * SIP should be used for Call control and a non-SIP mechanism for Device control
>    * non-SIP mechanism should be used for both Call and Device control
>
> That is the reason for the questions stated below.

I agree here. As it started out, it was a mechanism to do "stuff", which 
seemed too loosy-goosey to me. I do want to see a bounded scope to what 
can be controlled. But it also seemed to be the case that some aspects 
of device control are encompassed. In fact it may turn out to be all 
about device control, since there are existing solutions for a lot of 
call control.

I agree that there are serious security concerns for device control, but 
that doesn't mean it shouldn't be addressed. Security concerns may limit 
what device features are in scope. (E.g. declare the "explode device" 
feature out of scope.) Clearly there will have to be some limitations 
that prevent using this to turn a phone into a bugging device.

So I'm fine with including investigation of both call control and device 
control while narrowing down what we mean by those.

	Thanks,
	Paul

> In any case, I would welcome any suggestions on how to improve the text of this charter proposal.

> Regards,
>   Rifaat
>
>
>> -----Original Message-----
>> From: Hadriel Kaplan [mailto:[email-masked]]
>> Sent: Friday, September 23, 2011 7:40 PM
>> To: Shekh-Yusef, Rifaat (Rifaat)
>> Cc: [email-masked]
>> Subject: Re: [dispatch] Charter Proposal - Remote Call/Device Control WG
>>
>>
>> I don't mean to argue for or against this work in any way, but the charter
>> seems very odd to me.
>> I could be totally wrong, but I don't think WG charters usually have goals
>> like the first two you have listed:
>>> * Clearly answer the following questions:
>>>     a. What is "call control"?
>>>     b. What is "device control"?
>>> * Will the new mechanism address "call control", "device control" or both?
>>
>> Those types of questions are usually answered *before* a WG is chartered, as
>> far as I can recall.  Otherwise it's like saying one of the goals of the
>> Working Group is to define it's own scope.  Well... usually the IETF wants to
>> know the scope before creating a WG.
>>
>> Also, for some topics DISPATCH needs a "mini-BOF" at a face-to-face IETF
>> meeting, with a presentation(s) on the problem and possible solutions, and the
>> chairs ask for hands on who's interested in the work and would be willing to
>> contribute and such.  Are you planning on doing that for the Taipei meeting?
>>
>> -hadriel
>>
>>
>>
>> On Sep 20, 2011, at 2:36 PM, Shekh-Yusef, Rifaat (Rifaat) wrote:
>>
>>> Hi,
>>>
>>> The following is a charter proposal for a Remote Call/Device Control WG.
>>> We would appreciate it if you review it and provide us with your feedback.
>>>
>>> Thanks,
>>> Rifaat
>>>
>>> -------
>>>
>>> Remote Call/Device Control WG
>>>
>>> The Session Initiation Protocol (SIP) [RFC3261] provides users with the
>> ability to initiate, manage, and terminate multimedia sessions.
>>> A SIP application is a program running on a SIP network element that
>> provides some value-added function to a user.
>>> Many deployments have SIP applications in the SIP signaling path that get
>> involved in the setup and management of these multimedia sessions.
>>> Third-Party Application might also be interested in interacting with User
>> Agents and the setup of multimedia sessions.
>>> Some of these applications need a mechanism to remotely invoke some actions
>> or/and monitor the invocation of actions on a SIP User Agent.
>>> SIP allows for the invocation of actions on a remote User Agent using the
>> REFER method.
>>> The actions that can be invoked by the REFER method are limited, and there
>> is a need for more actions by some SIP applications.
>>> The purpose of this WG is to evaluate the various available mechanisms or
>> proposed mechanism and recommend one or more of them,
>>> or define a new mechanism if none of the available are good enough to
>> address this need.
>>>
>>> The work group will need to address the following:
>>> * Clearly answer the following questions:
>>>     a. What is "call control"?
>>>     b. What is "device control"?
>>> * Will the new mechanism address "call control", "device control" or both?
>>> * Will the new mechanism be a SIP or a non-SIP based mechanism?
>>> * If a non-SIP mechanism is used, how to deal with the fact that some of
>> these
>>>    actions already covered by the SIP REFER method and widely used in the
>> industry
>>> * Define a model for the actions
>>> * Define a scope for the actions
>>> * Define a set of initial actions that can be later extended, if needed.
>>> * Others?
>>>
>>> _______________________________________________
>>> dispatch mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/dispatch
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: "Ravindran Parthasarathi" <[email-masked]>
Date: Mon, 3 Oct 2011 12:01:11 +0530

I agree with Paul and interested in the progress of this work in the
correct WG this time :-)

Thanks
Partha

>From: [email-masked] [mailto:[email-masked]] On
>Behalf Of Paul Kyzivat
>Sent: Monday, October 03, 2011 3:28 AM
>To: [email-masked]
>> Our intention with the original SIP Action Referral proposal and
later
>on with the INVOKE method proposal was to extend the Remote *Call*
>Control mechanism defined by the REFER method.
>> During the discussion of these proposals some people showed interest
>in a Remote *Device* Control, but it was clear that the line between
>Remote Call Control and Remote Device Control is blurry.
>>> Subject: Re: [dispatch] Charter Proposal - Remote Call/Device
Control
>WG
>>>> * Will the new mechanism address "call control", "device control"
or
>both?
>>>> The following is a charter proposal for a Remote Call/Device
Control
>WG.
>>>> Third-Party Application might also be interested in interacting
with
>User
>>>> The actions that can be invoked by the REFER method are limited,
and
>there
>>>> * Will the new mechanism address "call control", "device control"
or
>both?