Subject: [dispatch] Proposed WG Charter for UDP based BFCP

From: Cullen Jennings <[email-masked]>
Date: Tue, 9 Aug 2011 07:44:00 -0700

At the last IETF there was a strong hum from the folks in the room to do a UDP based version of BFCP. To get moving on seeing what we have consensus on, I have written up a draft charter as strawman to start getting some comments. Can people have a look at this, and if you think parts of need changes or additions, send proposed text.

Thanks, Cullen <dispatch co-chair>

Working Group Name: <insert something clever here> 

Chairs:
    TBD

Real-time Applications and Infrastructure Area Directors:
    Gonzalo Camarillo <[email-masked]>
    Robert Sparks <[email-masked]>

Real-time Applications and Infrastructure Area Advisor:
    TBD

Mailing Lists:
    General Discussion: TBD
    To Subscribe:       TBD
    Archive:            TBD

The BFCPBIS working group is charted to specify a revision of BFCP (RFC 4582) to support using both TCP and UDP as transports. The current version of BFCP only supports TCP but when both endpoints are behind NATs or firewalls, this has a lower success rate than using the ICE techniques with an UDP based transport for BFCP.  The need for video endpoints to work in these types of environments is driving a strong desire to support a UDP based transport as well as TCP. 

This WG will create a revision of RFC 4582 which adds optional support for UDP to BFCP. The security when using UDP will be based on DTLS. The updated protocol will use an existing approach to congestion safety and be TCP friendly as well as congestion safe. It is likely that the WG will choose to use a stop and wait with a single outstanding transaction approach to congestion safety and reliability. The WG will provide a way to deal with reliable response deliver for the case where it is needed. The WG will research the size of messages used and decide what if fragmenting a request or response over multiple UDP packets is required. The new protocol will be backwards compatible with RFC 4582 when used in TCP mode. 

The BFCPBIS WG will coordinate closely with the MMUSIC WG to create a revision of RFC 4583 specifying how BFCP is signaled in SDP so that it supports UDP as well as TCP transports.  This WG would ask the MMUSIC WG to add a milestone to create a revisions of  RFC 4583 to address signaling the use of UDP in SDP. The WG will coordinate with International Multimedia Telecommunications Consortium (IMTC) and other industry forums. 

Milestones:

April 2012   Draft revision of RFC 4582 to IESG

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 12 Aug 2011 13:33:02 -0700

This looks good to me, and I am interested in working toward this
charter.

Cheers,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of Cullen Jennings
> (fluffy)
> Sent: Tuesday, August 09, 2011 7:44 AM
> To: DISPATCH list
> Subject: [dispatch] Proposed WG Charter for UDP based BFCP
> 
> 
> At the last IETF there was a strong hum from the folks in the room to
do a UDP based version of BFCP.
> To get moving on seeing what we have consensus on, I have written up a
draft charter as strawman to
> start getting some comments. Can people have a look at this, and if
you think parts of need changes or
> additions, send proposed text.
> 
> The BFCPBIS working group is charted to specify a revision of BFCP
(RFC 4582) to support using both
> TCP and UDP as transports. The current version of BFCP only supports
TCP but when both endpoints are
> behind NATs or firewalls, this has a lower success rate than using the
ICE techniques with an UDP
> based transport for BFCP.  The need for video endpoints to work in
these types of environments is
> driving a strong desire to support a UDP based transport as well as
TCP.
> 
> This WG will create a revision of RFC 4582 which adds optional support
for UDP to BFCP. The security
> when using UDP will be based on DTLS. The updated protocol will use an
existing approach to congestion
> safety and be TCP friendly as well as congestion safe. It is likely
that the WG will choose to use a
> stop and wait with a single outstanding transaction approach to
congestion safety and reliability. The
> WG will provide a way to deal with reliable response deliver for the
case where it is needed. The WG
> will research the size of messages used and decide what if fragmenting
a request or response over
> multiple UDP packets is required. The new protocol will be backwards
compatible with RFC 4582 when
> used in TCP mode.
> 
> The BFCPBIS WG will coordinate closely with the MMUSIC WG to create a
revision of RFC 4583 specifying
> how BFCP is signaled in SDP so that it supports UDP as well as TCP
transports.  This WG would ask the
> MMUSIC WG to add a milestone to create a revisions of  RFC 4583 to
address signaling the use of UDP in
> SDP. The WG will coordinate with International Multimedia
Telecommunications Consortium (IMTC) and
> other industry forums.
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Roni Even <[email-masked]>
Date: Sat, 13 Aug 2011 01:52:11 +0300

+1
Roni Even

> Behalf Of Charles Eckel (eckelcu)
> Sent: Friday, August 12, 2011 11:33 PM
> To: Cullen Jennings (fluffy); DISPATCH list
> Subject: Re: [dispatch] Proposed WG Charter for UDP based BFCP
>

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 25 Aug 2011 13:03:04 +0200

Looks good.

John 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Roni Even
> Sent: 12 August 2011 23:52
> To: 'Charles Eckel (eckelcu)'; 'Cullen Jennings (fluffy)'; 
> 'DISPATCH list'
> > > To get moving on seeing what we have consensus on, I have 
> written up
> > a
> > > when using UDP will be based on DTLS. The updated 
> protocol will use
> > an