Subject: Re: [dispatch] Emergency Text Messaging using SIP MESSAGE

From: Shida Schubert <[email-masked]>
Date: Thu, 2 Jun 2011 09:04:38 +0900

I agree with James here. It should be run by ECRIT WG.

 Also, although I haven't gone through this draft, ECRIT 
already has a draft discussing the use of MESSAGE method 
in the context of emergency call. 

 http://tools.ietf.org/html/draft-ietf-ecrit-data-only-ea-01

 Regards
  Shida

On May 31, 2011, at 8:34 AM, James M. Polk wrote:

> At 07:54 AM 5/30/2011, Jong Yul Kim wrote:
>> Hi everyone,
>> 
>> This draft presents mechanisms to allow page-mode text messaging in emergency situations.
> 
> Doesn't this whole idea of including text that talks about emergency services need to get run by the ECRIT WG before the topic can be included anywhere?
> 
> James
> 
> 
>> An example of page-mode messaging is when a person sends SMS to an emergency number to get help. In this case, there needs to be a way for the SMS message to reach the same call taker until the "conversation" ends.
>> 
>> As emergency call centers are transitioning to a SIP-based solution, the draft outlines a mechanism based on SIP MESSAGE method to deliver page-mode messages consistently to a call taker.
>> 
>> http://tools.ietf.org/html/draft-kim-dispatch-text-01
>> 
>> Comments on the draft or which WG it should go to are much appreciated.
>> Please let us know your thoughts.
>> 
>> Best regards,
>> 
>> Jong Yul
>> _______________________________________________
>> dispatch mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dispatch
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: Jong Yul Kim <[email-masked]>
Date: Wed, 1 Jun 2011 23:22:40 -0400

Thank you, everyone, for your valuable comments. 
The draft has been 'floating' around the ECRIT WG until it was suggested that we submit it to this WG to see where it would fit. 

I wasn't aware of another ECRIT draft about the MESSAGE method. 
I will check it out and perhaps move the discussion to ECRIT if it's appropriate. 

Dale: thank you for your comments on the draft. I will get back to you soon. 

Regards, 
Jong Yul

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Mon, 6 Jun 2011 15:36:53 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Shida Schubert [[email-masked]]

Though I see that this draft does not envision a series of MESSAGE requests, only a single request.

Dale

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 7 Jun 2011 12:35:09 +0200

1)	I think you need to spend more time arguing the use case for this. I agree that some PSAPs seem to be currently using SMS but they are doing this with very limiting restrictions - only for deaf users, the limitations of SMS itself, etc. 3GPP themselves do not define SMS for this use. 3GPP are looking at adding message like data, but they are adding this in conjunction with some other existing conversational mode media. Support of the hard of hearing is specified using real time text, with a defined mechanism of interworking with PSAPs supported in the PS domain. I see noone arguing for SMS usage in 3GPP or page mode messaging by itself.

2)	I think we need to understand better the compatibility issues with what you propose. How does the solution you propose avoid having to upgrade every proxy / SBC along the path in order to have successful conversational type communication? How does it interact with something like outbound, where multiple outbound proxies exist? Does interworking with SMS require the upgrade of all SMS systems in the same manner? 

Regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Jong Yul Kim
> Sent: 30 May 2011 13:54
> To: [email-masked]
> Subject: [dispatch] Emergency Text Messaging using SIP MESSAGE
> 
> Hi everyone,
> 
> An example of page-mode messaging is when a person sends SMS to an
> emergency number to get help. In this case, there needs to be a way for
> the SMS message to reach the same call taker until the "conversation"
> ends.
> 
> As emergency call centers are transitioning to a SIP-based solution, the
> draft outlines a mechanism based on SIP MESSAGE method to deliver page-
> mode messages consistently to a call taker.
>

---

From: "DOLLY, MARTIN C (ATTSI)" <[email-masked]>
Date: Tue, 7 Jun 2011 10:15:39 -0400

Greetings,

To add to Keith's points, there is a 4G America white paper and a FCC
CSRIC 4B report that recommends/disallows emergency SMS, as SMS is not
real-time communications and there is no conversation (e.g.,
acknowledgement, response).

Regards,

Martin Dolly
Lead Member Technical Staff
Core & Government/Regulatory Standards
AT&T Services, Inc.
[email-masked]
+1-609-903-3360

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of DRAGE, Keith (Keith)
Sent: Tuesday, June 07, 2011 6:35 AM
To: Jong Yul Kim; [email-masked]
Subject: Re: [dispatch] Emergency Text Messaging using SIP MESSAGE

1)	I think you need to spend more time arguing the use case for
this. I agree that some PSAPs seem to be currently using SMS but they
are doing this with very limiting restrictions - only for deaf users,
the limitations of SMS itself, etc. 3GPP themselves do not define SMS
for this use. 3GPP are looking at adding message like data, but they are
adding this in conjunction with some other existing conversational mode
media. Support of the hard of hearing is specified using real time text,
with a defined mechanism of interworking with PSAPs supported in the PS
domain. I see noone arguing for SMS usage in 3GPP or page mode messaging
by itself.

2)	I think we need to understand better the compatibility issues
with what you propose. How does the solution you propose avoid having to
upgrade every proxy / SBC along the path in order to have successful
conversational type communication? How does it interact with something
like outbound, where multiple outbound proxies exist? Does interworking
with SMS require the upgrade of all SMS systems in the same manner? 

Regards

Keith