Subject: Re: [dispatch] charter proposal: SIP end-to-end Session Identifier

From: Simon Pietro Romano <[email-masked]>
Date: Fri, 03 Jun 2011 20:35:04 +0200

This idea has been around for a while. I find it both interesting and 
worth discussing in a narrow-scoped WG like the one you are proposing.

Simon

Il 23/05/2011 08:49, Salvatore Loreto ha scritto:
>
> Hi there,
>
> below a charter proposal for a new wg working on End-to-end Session 
> Identifier in SIP.
>
>
> In an effort to make progress and to facilitate the discussion
> we have also created an Internet Draft that captures, at a high level,
> the requirements and use cases.
> (It was submitted by Paul E. Jones last Friday; here the link:
> http://www.ietf.org/id/draft-jones-ipmc-session-id-reqts-00.txt )
>
>
> cheers
> /Sal
>
> End-to-end Session Identifier in SIP (charter proposal )
> ----------------------------------------------
>
>
> The end-to-end Session Identifier in an SIP-based multimedia 
> communication refers to the ability
> for endpoints, intermediate devices, and management and monitoring 
> system to identify
> and correlate SIP messages and dialogs of the same higher-level 
> end-to-end "communication
> session" across multiple SIP devices and hops.
>
> Unfortunately, there are a number of factors that contribute to the 
> fact that the current
> dialog identifiers as defined in SIP is not suitable for end-to-end 
> session identification.
> Perhaps the most important factor worth describing is that in real-world
> deployments devices like Session Border Controllers (SBC) often change 
> the current call
> identifiers (e.g., the From-tag and To-tag that are used in 
> conjunction with the Call-ID header
> to make the dialog-id) as the session signaling passes through.
>
>
>
> An end-to-end Session Identifier should allow the possibility to 
> identify the communication session
> from the point of origin, passing through any number of 
> intermediaries, to the ultimate point
> of termination. It should have the same aim as the From-tag, To-tag 
> and Call-ID conjunction,
> but should not be mangled by intermediaries.
>
>
> A SIP end-to-end Session Identifier has been consideredas possible 
> solution of different use cases like
> troubleshooting, billing, session tracking, session recording, media 
> and signaling correlation, and so forth.
> Some of these requirements have also been identified and come directly 
> from other existing
> working group within the RAI area (e.g. SIPRec, Splices).
>
>
> Moreover, otherSDOs have identified the need for SIP and H.323 to 
> carry the same "session ID" value(s)
> so that it is possible identify a call end-to end even when performing 
> inter working between
> protocols.
>
>
> This group will first focus on adocument that will identify, collect 
> and discuss all the
> requirements and the use cases that have been identified.
> The document may identify the possibility to design a general 
> mechanism or the need
> to design multiple purpose built identifiers.
> Once the needs are clear and identified, the working group will 
> specify the mechanism(s).
>
>
> Specifically, the proposed working group will develop the following 
> deliverable:
>
>    1. A requirement and use case document with key consideration for
>       SIP Session
>       End-to-End identifier. The document will discuss the possibility
>       of designing
>       a general mechanism or the needs to design multiple purpose
>       build identifier.
>    2. Specification of new mechanism(s).
>
>
> Goal and Milestone:
>     October 2011 - Requirement and use case document sent to the IESG 
> (Information)
>
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]
           http://www.comics.unina.it/simonpietro.romano

     <<Molti mi dicono che lo scoraggiamento è l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/

---

From: Georg Mayer <[email-masked]>
Date: Mon, 06 Jun 2011 11:50:12 +0200

Hello Salvatore,
 
Thanks for taking this forward - this is an important issue from 3GPP
perspective and it would be great to see this progressing. I fully support
your proposal.
 
Best regards,
Georg

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Salvatore Loreto
Sent: Montag, 23. Mai 2011 08:50
To: [email-masked]
Subject: [dispatch] charter proposal: SIP end-to-end Session Identifier
 
Hi there,

cheers
/Sal

The end-to-end Session Identifier in an SIP-based multimedia communication
refers to the ability
for endpoints, intermediate devices, and management and monitoring system to
identify
and correlate SIP messages and dialogs of the same higher-level end-to-end
"communication 
session" across multiple SIP devices and hops. 

Unfortunately, there are a number of factors that contribute to the fact
that the current
dialog identifiers as defined in SIP is not suitable for end-to-end session
identification.
Perhaps the most important factor worth describing is that in real-world 
deployments devices like Session Border Controllers (SBC) often change the
current call 
identifiers (e.g., the From-tag and To-tag that are used in conjunction with
the Call-ID header
to make the dialog-id) as the session signaling passes through.

An end-to-end Session Identifier should allow the possibility to identify
the communication session
from the point of origin, passing through any number of intermediaries, to
the ultimate point
of termination. It should have the same aim as the From-tag, To-tag and
Call-ID conjunction,
but should not be mangled by intermediaries. 

A SIP end-to-end Session Identifier has been considered as possible solution
of different use cases like 
troubleshooting, billing, session tracking, session recording, media and
signaling correlation, and so forth.
Some of these requirements have also been identified and come directly from
other existing 
working group within the RAI area (e.g. SIPRec, Splices).

Moreover, other SDOs have identified the need for SIP and H.323 to carry the
same "session ID" value(s)
so that it is possible identify a call end-to end even when performing inter
working between
protocols.

This group will first focus on a document that will identify, collect and
discuss all the 
requirements and the use cases that have been identified.
The document may identify the possibility to design a general mechanism or
the need
to design multiple purpose built identifiers. 
Once the needs are clear and identified, the working group will specify the
mechanism(s).

Specifically, the proposed working group will develop the following
deliverable:
1.	A requirement and use case document with key consideration for SIP
Session
End-to-End identifier. The document will discuss the possibility of
designing
a general mechanism or the needs to design multiple purpose build
identifier.
2.	Specification of new mechanism(s).

Goal and Milestone:

---

From: "DOLLY, MARTIN C (ATTSI)" <[email-masked]>
Date: Mon, 6 Jun 2011 10:16:07 -0400

Greetings from Asbury Park,

AT&T supports this work progressing and supports the proposal.

Cheers,

Martin

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Georg Mayer
Sent: Monday, June 06, 2011 5:50 AM
To: [email-masked]
Subject: Re: [dispatch] charter proposal: SIP end-to-end Session
Identifier

Hello Salvatore,

Thanks for taking this forward - this is an important issue from 3GPP
perspective and it would be great to see this progressing. I fully
support your proposal.

Best regards,

Georg

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Salvatore Loreto
Sent: Montag, 23. Mai 2011 08:50
To: [email-masked]
Subject: [dispatch] charter proposal: SIP end-to-end Session Identifier

Hi there,

In an effort to make progress and to facilitate the discussion
we have also created an Internet Draft that captures, at a high level, 
the requirements and use ed by Paul E. Jones last Friday; here the link:

cheers
/Sal

The end-to-end Session Identifier in an SIP-based multimedia
communication refers to the ability
for endpoints, intermediate devices, and management and monitoring
system to identify
and correlate SIP messages and dialogs of the same higher-level
end-to-end "communication 
session" across multiple SIP dev ices and ely, there are a number of
factors that contribute to the fact that the current
dialog identifiers as defined in SIP is not suitable for end-to-end
session identification.
Perhaps the most important factor worth describing is that in real-world

deployments devices like Session Border Controllers (SBC) often change
the current call 
identifiers (e.g., the From-tag and To-tag that are used in conjunction
with the Call-ID header
to make the dialog-id) as the session signaling passes through.

from the point of origin, passing through any number of intermediaries,
to the ultimate point

A SIP end-to-end Session Identifier has been considered as possible

Moreover, other SDOs have identified the need for SIP and H.323 to carry
the same "session ID" value(s)
so that it is possible identify a call end-to end even when performing
inter working between
protocols.

This group will first focus on a document that will identify, collect
and discuss all the 
requirements and the use cases that have been identified.
The document may identify the poss ibility nism or the need
to design multiple purpose built identifiers. 
Once the needs are clear and identified, the working group will specify
the mechanism(s).

Goal and Milestone:

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 6 Jun 2011 16:49:12 +0200

Hi,

I support the charter proposal. I think this is an important feature.

Regards,

Christer

________________________________
From: [email-masked] [[email-masked]] On Behalf Of Salvatore Loreto [[email-masked]]
Sent: Monday, May 23, 2011 9:49 AM
To: [email-masked]
Subject: [dispatch] charter proposal: SIP end-to-end Session Identifier

Hi there,
below a charter proposal for a new wg working on End-to-end Session Identifier in SIP.

cheers
/Sal

The end-to-end Session Identifier in an SIP-based multimedia communication refers to the ability
for endpoints, intermediate devices, and management and monitoring system to identify
and correlate SIP messages and dialogs of the same higher-level end-to-end "communication
session" across multiple SIP devices and hops.

Unfortunately, there are a number of factors that contribute to the fact that the current
dialog identifiers as defined in SIP is not suitable for end-to-end session identification.
Perhaps the most important factor worth describing is that in real-world
deployments devices like Session Border Controllers (SBC) often change the current call
identifiers (e.g., the From-tag and To-tag that are used in conjunction with the Call-ID header
to make the dialog-id) as the session signaling passes through.

An end-to-end Session Identifier should allow the possibility to identify the communication session
from the point of origin, passing through any number of intermediaries, to the ultimate point
of termination. It should have the same aim as the From-tag, To-tag and Call-ID conjunction,
but should not be mangled by intermediaries.

A SIP end-to-end Session Identifier has been considered as possible solution of different use cases like
troubleshooting, billing, session tracking, session recording, media and signaling correlation, and so forth.
Some of these requirements have also been identified and come directly from other existing
working group within the RAI area (e.g. SIPRec, Splices).

Moreover, other SDOs have identified the need for SIP and H.323 to carry the same "session ID" value(s)
so that it is possible identify a call end-to end even when performing inter working between
protocols.

This group will first focus on a document that will identify, collect and discuss all the
requirements and the use cases that have been identified.
The document may identify the possibility to design a general mechanism or the need
to design multiple purpose built identifiers.
Once the needs are clear and identified, the working group will specify the mechanism(s).

Specifically, the proposed working group will develop the following deliverable:

 1.  A requirement and use case document with key consideration for SIP Session
End-to-End identifier. The document will discuss the possibility of designing
a general mechanism or the needs to design multiple purpose build identifier.
 2.  Specification of new mechanism(s).

Goal and Milestone:
    October 2011 - Requirement and use case document sent to the IESG (Information)

---

From: "Richard Shockey" <[email-masked]>
Date: Mon, 6 Jun 2011 12:11:17 -0400

Long Long overdue ..  +1 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Christer Holmberg
Sent: Monday, June 06, 2011 10:49 AM
To: Salvatore Loreto; [email-masked]
Subject: Re: [dispatch] charter proposal: SIP end-to-end Session Identifier

Hi,

Regards,

Christer

________________________________
From: [email-masked] [[email-masked]] On Behalf Of
Salvatore Loreto [[email-masked]]
Sent: Monday, May 23, 2011 9:49 AM
To: [email-masked]
Subject: [dispatch] charter proposal: SIP end-to-end Session Identifier

Hi there,

cheers
/Sal

Goal and Milestone:

---

From: Peter Musgrave <[email-masked]>
Date: Mon, 6 Jun 2011 19:40:40 -0400

+1

Peter Musgrave

On Mon, Jun 6, 2011 at 12:11 PM, Richard Shockey <[email-masked]> wrote:

> Behalf
> with
> inter

---

From: Laura Liess <[email-masked]>
Date: Tue, 7 Jun 2011 08:44:18 +0200

Sal,

Thank you for for doing this work. As Richard already wrote, it's long
overdue.

I am willing to contribute to take this issue forward. I read the
charter and it is OK for me. At some point in time, when it is more
clear how many documents we need to specify the mechanism(s), we will
need to add  one or more additional  milestones for these documents.

Thanks
Laura

2011/5/23 Salvatore Loreto <[email-masked]>:
> A requirement and use case document with key consideration for SIP Session
> Specification of new mechanism(s).
>
> Goal and Milestone:

---

From: Xavier Marjou <[email-masked]>
Date: Tue, 7 Jun 2011 11:28:13 +0200

+1

---

From: <[email-masked]>
Date: Wed, 8 Jun 2011 12:12:04 +0200

Hi Sal,
I'm also fully supporting that work. Thank you for the work you did on charter proposal I'm fine with the proposal.

Best Regards

Roland

Mit freundlichen Grüßen
Roland Jesske

Deutsche Telekom Netzproduktion GmbH
Fixed Mobile Engineering Deutschland
Roland Jesske
Heinrich-Hertz-Straße 3-7, 64295 Darmstadt
+49 6151 58 12766 (Tel.)
+49 391 580 133 831 (Fax)
+49 171 8618-445 (Mobil)
E-Mail: [email-masked]<mailto:[email-masked]>
www.telekom.de<http://www.telekom.de/>

Erleben, was verbindet.

Deutsche Telekom Netzproduktion GmbH
Aufsichtsrat: Dr. Steffen Roehn (Vorsitzender)
Geschäftsführung: Dr. Bruno Jacobfeuerborn (Vorsitzender), Albert Matheis, Klaus Peren
Handelsregister: Amtsgericht Bonn HRB 14190
Sitz der Gesellschaft Bonn
USt-IdNr. DE 814645262

Große Veränderungen fangen klein an - Ressourcen schonen und nicht jede E-Mail drucken.

________________________________
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Xavier Marjou
Gesendet: Dienstag, 7. Juni 2011 11:28
An: DISPATCH list
Betreff: Re: [dispatch] charter proposal: SIP end-to-end Session Identifier

+1

On Mon, Jun 6, 2011 at 6:11 PM, Richard Shockey <[email-masked]<mailto:[email-masked]>> wrote:
Long Long overdue ..  +1

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf
Of Christer Holmberg
Sent: Monday, June 06, 2011 10:49 AM
To: Salvatore Loreto; [email-masked]<mailto:[email-masked]>
Subject: Re: [dispatch] charter proposal: SIP end-to-end Session Identifier

Hi,

Regards,

Christer

________________________________
From: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] On Behalf Of
Salvatore Loreto [[email-masked]<mailto:[email-masked]>]
Sent: Monday, May 23, 2011 9:49 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [dispatch] charter proposal: SIP end-to-end Session Identifier

Hi there,

cheers
/Sal

Goal and Milestone:

_______________________________________________
dispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dispatch

_______________________________________________
dispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dispatch

---

From: Salvatore Loreto <[email-masked]>
Date: Mon, 13 Jun 2011 18:51:38 +0300

Hi there,

the charter proposal [1] has got a slot for the Quebec City meeting and
on the list there seems to be a good support to initiating work on this 
item

comments on the charter proposal [1] and on the requirement draft for
an End-to-End Session identification [2] and the use cases described there
are very welcome

[1] http://www.ietf.org/mail-archive/web/dispatch/current/msg03647.html
[2] http://www.ietf.org/id/draft-jones-ipmc-session-id-reqts-00.txt

/Sal

-- 
Salvatore Loreto
www.sloreto.com