Subject: Re: [dispatch] SIP responses carrying Q.850 cause values in Reason header fields

From: Christer Holmberg <[email-masked]>
Date: Fri, 20 May 2011 21:59:05 +0200

Hi,

>>The concern is that that sip reason codes in sip responses are like
>>having multiple responses to the same request. How should one behave?
>>
>>Fundamentally the problem isn't with the mechanics of delivering the
>>reason - its with the semantics of what has been sent. This has the
>>potential to lead to interoperation problems.
>
>My memory is that in Prage there was general agreement that in a Reason header in a SIP response,
>there should be no reason-value (clause) with protocol "SIP".  That avoids the Reason header
>giving one SIP response code while the containing response gives another SIP response code.

...with the exception being the case when a forking proxy generates a 199 response, when it MUST insert a Reason header field with the SIP response code that triggered the 199 response.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 20 May 2011 16:21:19 -0400

OK, its coming back to me now.

The idea was that the rule about reason codes in responses would be 
relaxed for Q.850 codes only, not for sip codes. Then 199 is *defined* 
as a case when sip response codes are allowed - but its not generalized 
to allowing sip response codes in *other* responses.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 20 May 2011 22:30:30 +0200

Hi, 

>The idea was that the rule about reason codes in responses would be relaxed for Q.850 codes only, not for sip codes. Then 199 is *defined* as a case when sip response codes are allowed - but its not 
>generalized to allowing sip response codes in *other* responses.

Couldn't we then simply say that sip response codes in Reason headers of SIP responses is only allowed in cases when explicitly defined for the the response code of the SIP response?

Regards,

Christer

On 5/20/2011 3:59 PM, Christer Holmberg wrote:
>> My memory is that in Prage there was general agreement that in a 
>> Reason header in a SIP response, there should be no reason-value 
>> (clause) with protocol "SIP".  That avoids the Reason header giving one SIP response code while the containing response gives another SIP response code.
>

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Fri, 20 May 2011 17:27:46 -0400

> From: Christer Holmberg [[email-masked]]
> 
> >relaxed for Q.850 codes only, not for sip codes. Then 199 is
> >*defined* as a case when sip response codes are allowed - but its
> >not generalized to allowing sip response codes in *other* responses.
> 
> Couldn't we then simply say that sip response codes in Reason
> headers of SIP responses is only allowed in cases when explicitly
> defined for the the response code of the SIP response?

That would work.  (The goal being that any additional "protocol" values
would be handled like "Q.850" rather than like "SIP".)

Dale