Subject: [dispatch] SIP responses carrying Q.850 cause values in Reason header fields

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 5 Apr 2011 15:02:43 +0300

Hi,

last week in the DISPATCH session, there was consensus to allow SIP
responses to carry Reason header fields with Q.850 cause values. As I
said some time ago, I am willing to AD sponsor this draft if/when the
DISPATCH chairs confirm such consensus on the list.

In the mean time, I have some comments on how to document this decision.
The following (fairly short) draft updates a couple of paragraphs in RFC
3326 in order to achieve the desired outcome:

http://www.ietf.org/id/draft-jesske-dispatch-update3326-reason-responses-02.txt

I think this is not a particularly elegant way to define what we want.
For example, if we wanted to define a solution to HERFP in the future
based on the Reason header, we would need to update those paragraphs
again, making them longer every time we added a new use case.

Instead, I would prefer to explicitly define what we want to do and be
done with it. Such a (also fairly short) draft would say something along
the following lines:

"RFC 3326 allows the presence of the Reason header field in any response
whose status code explicitly allows its presence. This document
explicitly allows any SIP response to carry a Reason header field with a
Q.850 cause value. SIP responses with Reason header fields carrying
values other than Q.850 cause values are outside of the scope of this
document."

I would like to know the opinion of the WG on this matter (i.e., how to
document the WG's consensus). Note that reaching consensus was the
difficult part. Agreeing on how to document it should be easy.

Thanks,

Gonzalo

---

From: <[email-masked]>
Date: Wed, 6 Apr 2011 11:24:10 +0200

Hi Gonzalo,
I'm OK with your proposal so I could change it if people would like it.
It makes it shorter.
The only I would propose to have in is the explicit mentioning of the Response values due to the fact that a 100OK or 200OK should not include a Reason header with a Q.850 Cause Value.

Best Regards
Roland Jesske

> -----Ursprüngliche Nachricht-----
> Von: [email-masked]
> [mailto:[email-masked]] Im Auftrag von Gonzalo Camarillo
> Gesendet: Dienstag, 5. April 2011 14:03
> An: DISPATCH
> Betreff: [dispatch] SIP responses carrying Q.850 cause values
> in Reason header fields
>
> Hi,
>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: James Rafferty <[email-masked]>
Date: Wed, 6 Apr 2011 14:05:49 -0400

Hi,  

I ran this proposal by one of our architects and got the following feedback and questions for clarification: 

	The change actually makes sense and we do support the majority of the change already. The main part that we do not support is the use of the Reason 	header in 18x or 199 provisional responses as it is not defined how you want to interwork that overall message. 
	
	For example, if you get IAM send Invite, then 100 Trying, then you get 180 Ringing that has a Reason header with Q.850 of cause code 31, do you 	release the call after that and send REL with cause code 31 to the PSTN or do you send ACM back to the PSTN?

James

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, April 06, 2011 5:24 AM
To: [email-masked]; [email-masked]
Subject: Re: [dispatch] SIP responses carrying Q.850 cause values in Reason header fields

Hi Gonzalo,

Best Regards
Roland Jesske

---

From: <[email-masked]>
Date: Fri, 8 Apr 2011 13:17:11 +0200

Hi James,
we have discussed 199 please see mail from Paul:
----Start Pauls Mail
I've realized via discussions with Christer that the changes here are
introducing a conflict with the 199 draft.

That draft is explicitly calling for use of a Reason header with sip
cause code to indicate the final sip response that caused a 199 response
to be sent.

Because 199 is being defined to explicitly allow this usage, it is in
compliance with 3326. If we were to revise 3326 as we are discussing,
then the 199 usage would be in conflict with the revision.

So, I think we have to craft the wording very carefully here, to allow
the use of Q.850 codes in a range of responses, while leaving the use of
sip reason codes up to per-response-code specifications, as it was.

And I'll restate that it probably doesn't make good sense to use any/all
Q.850 response codes in an arbitrary sip response either.

        Thanks,
        Paul
---- End Pauls Mail

With regard to 18x. Within ISUP a cause value could be also sent within an ACM to progress "early media" for specific announcements. Earlier the reason within 18x were discussed, and it was agreed to include these within this scope.

Best Regards
Roland Jesske

> Von: James Rafferty [mailto:[email-masked]]
> Gesendet: Mittwoch, 6. April 2011 20:06
> An: Jesske, Roland; [email-masked]; [email-masked]
> Betreff: RE: [dispatch] SIP responses carrying Q.850 cause
> values in Reason header fields
>
> Hi,
>
> I ran this proposal by one of our architects and got the
> following feedback and questions for clarification:
>
>       The change actually makes sense and we do support the
> majority of the change already. The main part that we do not
> support is the use of the Reason      header in 18x or 199
> provisional responses as it is not defined how you want to
> interwork that overall message.
>
>       For example, if you get IAM send Invite, then 100
> Trying, then you get 180 Ringing that has a Reason header
> with Q.850 of cause code 31, do you   release the call after
> that and send REL with cause code 31 to the PSTN or do you
> send ACM back to the PSTN?
>
> James
>
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of [email-masked]
> The only I would propose to have in is the explicit
> mentioning of the Response values due to the fact that a
> 100OK or 200OK should not include a Reason header with a
> Q.850 Cause Value.
>
> Best Regards
> Roland Jesske
>
>
>