Subject: [dispatch] Fwd: New Version Notification for draft-gellens-mime-bucket-bis-02

From: David Singer <[email-masked]>
Date: Wed, 2 Feb 2011 11:36:20 -0800

Friends

I have been working on a minor update to RFC 4281 (the 'buckets RFC' as it is sometimes known),  This does various minor updates:
* clarify what mime types it can be used with
* integrate the text from 3GPP on handling AVC (aka H.264)
* extend that to clarify the handling of SVC and MVC
* add the profiles parameter (file compatibility indicators)
* other minor cleanups (e.g. case corrections)

I am unsure how to get this update proceeding along towards RFC status, or who at the IETF could/should review it.

Guidance from this group would be welcome.

Thanks!

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: February 2, 2011 11:26:23 PST
> To: [email-masked]
> Cc: [email-masked], [email-masked]
> Subject: New Version Notification for draft-gellens-mime-bucket-bis-02
> 
> 
> A new version of I-D, draft-gellens-mime-bucket-bis-02.txt has been successfully submitted by David Singer and posted to the IETF repository.
> 
> Filename:	 draft-gellens-mime-bucket-bis
> Revision:	 02
> Title:		 The Codecs and Profiles Parameters for "Bucket" Media Types
> Creation_date:	 2011-02-01
> WG ID:		 Independent Submission
> Number_of_pages: 23
> 
> Abstract:
> Several MIME type/subtype combinations exist that can contain
> different media formats.  A receiving agent thus needs to examine the
> details of such media content to determine if the specific elements
> can be rendered given an available set of codecs.  Especially when
> the end system has limited resources, or the connection to the end
> system has limited bandwidth, it would be helpful to know from the
> Content-Type alone if the content can be rendered.
> 
> This document specifies two parameters, "codecs" and "profiles",
> which are used with various MIME types or type/subtype combinations
> to allow for unambiguous specification of the codecs and/or profiles
> employed by the media formats contained within.
> 
> By labeling content with the specific codecs indicated to render the
> contained media, receiving systems can determine if the codecs are
> supported by the end system, and if not, can take appropriate action
> (such as rejecting the content, sending notification of the
> situation, transcoding the content to a supported type, fetching and
> installing the required codecs, further inspection to determine if it
> will be sufficient to support a subset of the indicated codecs, etc.)
> 
> Similarly, the profiles can provide an overall indication, to the
> receiver, of the specifications with which the content complies.  The
> receiver may be able to work out the extent to which it can handle
> and render the content by examining to see which of the declared
> profiles it supports, and what they mean.
> 
> 
> 
> The IETF Secretariat.
> 
> 

David Singer
Multimedia and Software Standards, Apple Inc.

---

From: Thomas Stockhammer <[email-masked]>
Date: Tue, 15 Feb 2011 01:21:42 +0800

All,

I am be very supportive to move this work forward as fast as possible, primarily as the Dynamic Adaptive Streaming over HTTP (DASH) in 3GPP and MPEG relies on this updated draft RFC. This is really cool stuff and solves many problems at the same time.

I have some minor proposed updates, namely to add a similar functionality for media segments as well to enable signaling the compatibility brands in the MIME type. I will work on this with the authors directly to get this integrated in an updated version asap.

Meanwhile, please let's get this work progressed. Thanks to Dave to kicking this off ...

Best regards

Thomas

On Feb 3, 2011, at 3:36 AM, David Singer wrote:

> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---
Dr. Thomas Stockhammer (CEO) || [email-masked] || phone +49 89 978980 02 || cell +491725702667 || http://www.nomor-research.com
Nomor Research GmbH  -  Sitz der Gesellschaft: München - Registergericht: München, HRB 165856 – Umsatzsteuer-ID: DE238047637 - Geschäftsführer: Dr. Thomas Stockhammer, Dr. Ingo Viering.