Subject: [dispatch] SIP Action Referral charter proposal

From: "Shekh-Yusef, Rifaat (Rifaat)" <[email-masked]>
Date: Thu, 20 Jan 2011 20:09:24 -0500

Hi,

The following is a charter proposal for the SIP Action Referral WG.
While the SPLICES WG seems like a possible place for this work, the SIP Action Referral has a wider scope than the Loosely Coupled UAs use case.
We would appreciate any thoughts and comments on the charter proposal and on the SPLICES idea as a WG for this work.

We would also appreciate any ideas for a name for the WG.

Regards,
 Rifaat

-----------------------------

Charter Proposal (version 1)

Possible WG Names: Open for ideas 

Hard phones often work in conjunction with software on other device, such as a soft phone on a PC. For example, a soft phone on the PC might want to answer a phone call but use the user's speakerphone on their desk for the call instead of the soft phone. To do this, it would need to signal to the speakerphone to answer the call.

This working group will define a SIP extension that allows a SIP User Agent to instruct another SIP User Agent to perform an action. An action is an event or a series of events that modify the state of a UA at different levels, e.g. SIP state, UI, etc. An action can be triggered either in the context of an existing dialog or outside the context of any existing dialog. An action is not necessarily tied to a SIP request.

The following is a list example actions: Answer a call, mute or unmute a call, put the call on hold or take off, add or remove the call to conference bridge. 

The Working group will be a very short lived working group that will use frequent phone calls and IETF meetings to quickly progress a single specification. This working group will closely coordinate with the SPLICES working group as this work seems to be applicable to their work. 

Deliverables

Nov 2011     Use Cases and Requirements to IESG as Informational RFC
Feb 2012     Protocol specification to IESG as PS

---

From: [email-masked]
Date: Fri, 21 Jan 2011 13:01:06 +0800

Hi Rifaat,

> While the SPLICES WG seems like a possible place for this work, the 
> SIP Action Referral has a wider scope than the Loosely Coupled UAs use 
case.

IMO, loosely coupled sip device could be about coordination and 
cooperation of multiple media streams. REFER-Action should be treated as 
subset of it. 

> Hard phones often work in conjunction with software on other device,
> such as a soft phone on a PC. For example, a soft phone on the PC 
> might want to answer a phone call but use the user's speakerphone on
> their desk for the call instead of the soft phone. To do this, it 
> would need to signal to the speakerphone to answer the call.
> 
> This working group will define a SIP extension that allows a SIP 
> User Agent to instruct another SIP User Agent to perform an action. 
> An action is an event or a series of events that modify the state of
> a UA at different levels, e.g. SIP state, UI, etc. An action can be 
> triggered either in the context of an existing dialog or outside the
> context of any existing dialog. An action is not necessarily tied to
> a SIP request.
> 
> The following is a list example actions: Answer a call, mute or 
> unmute a call, put the call on hold or take off, add or remove the 
> call to conference bridge. 
> 
> The Working group will be a very short lived working group that will
> use frequent phone calls and IETF meetings to quickly progress a 
> single specification. This working group will closely coordinate 
> with the SPLICES working group as this work seems to be applicable 
> to their work. 

As I said in the previous mail in this thread, the use cases you mentioned 
are meaningful for some typical networks, such as enterprise usage and 
end-to-end Internet VoIP. 

In fact, making a very short lived new working group is a way to progress 
the specification. But I have another suggestion:
Considering the current SPLICES working group having the similar use cases 
and background, your work might be suitable to be added into the SPLICES 
working group. Then you can do the special specification for those typical 
networks as supplement for the WG.

Thanks,

Gao

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Simon Pietro Romano <[email-masked]>
Date: Fri, 21 Jan 2011 19:02:38 +0100

Hi Rifaat,

I believe that this kind of work might easily fit within the (perhaps a 
bit extended) scope of SPLICES.

Simon

Il 21/01/2011 02:09, Shekh-Yusef, Rifaat (Rifaat) ha scritto:
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]
           http://www.comics.unina.it/simonpietro.romano

     <<Molti mi dicono che lo scoraggiamento è l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/

---

From: Salvatore Loreto <[email-masked]>
Date: Fri, 21 Jan 2011 19:07:38 +0100

> bit extended) scope of SPLICES.
+1

/Sal