Subject: RE: [Diffserv] [OFFLIST] MPLS+Diffserv(mapping DSCP to EXP)

From: Shahram Davari <[email-masked]>
Date: Tue, 4 Feb 2003 13:29:35 -0800

> -----Original Message-----
> From: Mark Duffy [mailto:[email-masked]]
> Sent: Tuesday, February 04, 2003 7:29 AM
> To: [email-masked]; [email-masked]

> >2. Further, since the DSCP  ( pow(2,8) = 256 combinations ) 
> is 8 bits and
> >provides 22 different PHB's(or roughly 7 different classes),
> >      and the EXP is just 3 bits and therefore can provide 
> only upto 8
> >different classes, wouldnt there be loss of info while 
> mapping DSCP->EXP ?
> >

No because in MPLS we do DSCP=> PHB translation and PHB=> EXP+Label encoding. The label gives you the context info, so each label can support up to 8 PHBs. To support all 64 PHBs (which are not defined yet) you need 8 parallel LSPs.

-Shahram
_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: "Jeff Norman" <[email-masked]>
Date: Tue, 4 Feb 2003 17:04:54 -0500 (EST)

Shahram,
  You are referring to L-LSPs where a one-to-one mapping can
be done, where as E-LSPs there isn't, which is what I believe
nerdboy is asking about.

Best Regards,
--Jeff