Subject: [Diffserv] RE: FlowId and FlowIdOrAny

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 21 Jan 2003 13:09:45 +0100

Ok, good, cause I was surprised to see a -1 in an Unsigned32.

Now... if we do this, then this could still be used by the
framework pib. 
However, for the diffserv-mib it would mean they must 
deprecate a current object and create a new one (switching
from Unsigned to Integer32 causes a change on the wire!).

The solution presented earlier could be considered as a
bug fix and would not require the diffserv-MIB to
deprecate the existing object

Thanks,
Bert 

> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]]
> Sent: dinsdag 21 januari 2003 11:24
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: FlowId and FlowIdOrAny
> 
> 
> 
> I changed the subject line and fixed the proposed TC. So here is where
> I think we are. I have also reduced the CC list and I have added the
> diffserv mailing list since diffserv folks should be in the loop I
> think.
> 
>   FlowId TECTUAL-CONVENTION
>       DISPLAY-HINT "d"
>       STATUS       current
>       DESCRIPTION 
> 	"The flow identifier in an IPv6 header that may be used to
> 	 discriminate traffic flows."
>       REFERENCE
> 	"RFC 2460"
>       SYNTAX       Integer32 (0..1048575)
> 
>   FlowIdOrAny TECTUAL-CONVENTION
>       DISPLAY-HINT "d"
>       STATUS       current
>       DESCRIPTION 
> 	"The flow identifier in an IPv6 header that may be used to
> 	 discriminate traffic flows. The value of -1 is used to
> 	 indicate a wildcard, i.e. any value."
>       REFERENCE
> 	"RFC 2460"
>       SYNTAX       Integer32 (-1 | 0..1048575)
> 
> Open issues:
> 
> - Is the flow identifier the same as the flow label? I guess so. If
>   this is true, then we should probably use the TC names FlowLabel
>   and FlowLableOrAny and also change the wordings in the description
>   clause.
> 
> - The name of the MIB modules which will contain these definitions.
> 
> - Since Fred kind of said that the diffServMultiFieldClfrFlowId
>   object should have had a wildcard, can we agree that this is 
>   actually a bug in RFC 3289 which will be fixed by using FlowIdOrAny
>   in the next revision of the DIFFSERV-MIB?
> 
> /js
> 
> -- 
> Juergen Schoenwaelder    
<http://www.informatik.uni-osnabrueck.de/schoenw/>

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 21 Jan 2003 13:39:43 +0100

>>>>> Wijnen, Bert (Bert) writes:

Bert> Now... if we do this, then this could still be used by the
Bert> framework pib.  However, for the diffserv-mib it would mean they
Bert> must deprecate a current object and create a new one (switching
Bert> from Unsigned to Integer32 causes a change on the wire!).

Oops, I missed that part of the picture. So if there is concensus to
change the range as a bug fix in the DIFFSERV0MIB without introducing
a new object (which formally the SMIv2 would require to do), then
using Unsigned32 makes some sense. Note that this will also most
likely include the definition of a DEFVAL which is in fact the new
value.  However, if we decided that it is safer to use deprecate the
filter obejct and introduce a new one, I prefer to use Integer32.

BTW, this is what I found in the INTEGRATED-SERVICES-MIB:

    intSrvFlowFlowId OBJECT-TYPE
        SYNTAX      INTEGER (0..16777215)
        MAX-ACCESS  read-only
        STATUS      current
        DESCRIPTION
           "The flow ID that  this  sender  is  using,  if
           this  is  an IPv6 session."
       ::= { intSrvFlowEntry 11 }

Note that this range is [0..2^24-1] while the other definitions under
discussion use a range of [0..2^20-1]. Note that RFC 2460 says:

:    Flow Label           20-bit flow label.  See section 6.

/js

-- 
Juergen Schoenwaelder    <http://www.informatik.uni-osnabrueck.de/schoenw/>
_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 21 Jan 2003 15:17:45 +0100

The flow label in IPv6 was 24 bits at one time. So that looks like
a minor obsolescence in the Intserv MIB.

    Brian