Subject: [Diffserv] SLA & admission control in DiffServ

From: Amoakoh Gyasi-Agyei <[email-masked]>
Date: Thu, 28 Nov 2002 14:05:25 +1030

Hi,

Should the SLA be static or dynamically negotiated? Assuming a static SLA with bandwidth limit, how can the service provider guarantee the
SLA on a connection with a wireless component which is spatio-temporarily varying and whose bandwidth can degrade ungraciously? What is
the need to differentiate a policer from an admission controller?

So, Brian, do you mean that the admission controller in this case will operate in the traffic source while the policer sits somewhere else
or be integrated? I just do not know why and how some of these functionalities were separated although their functionalities appear to be
very similar, if not identical.

Thanks,
Amoakoh

>
> Message: 3
> Date: Wed, 27 Nov 2002 17:17:57 +0100
> From: Brian E Carpenter <[email-masked]>
> Organization: IBM
> To: Geunhyung Kim <[email-masked]>
> Cc: diffserv <[email-masked]>
> Subject: Re: [Diffserv] SLA & admission control
>
> It depends on the PDB in use. If it has a bandwidth limit,
> then ingress policing will be used to discard excess traffic.
> In this case, it may be desirable to apply admission control,
> rather than let the policing throw traffic away. Actually,
> that is something that the SLA should specify.
>
>      Brian
>
> Geunhyung Kim wrote:
> >
> > Hello, All,
> >
> > I have some confusion about the SLA and admission control.
> > When the provider contracts the SLA with the customer
> >  - the provide check if the network can support the SLA and the provider make the contract when the SLA can be supported.
> >
> > As far as I know, when the SLA mechanism is used in the DiffServ domain, the admission control mechanism is not required, I thought.
> > Is my thought correct ?
> > If not, please let me know why the admission control is required after SLA is entered into agreement.
> >
> > Thanks in advance,
> >
> > Geunhyung Kim
> >
> > None of us is as smart as all of us
> > ==========================================
> > Geunhyung Kim
> >
> > E-mail: [email-masked]
> >
> > Tel: +82-54-279-5655
> > Fax: +82-54-279-5699
> >
> > Networking & Distributed Systems Lab.
> > CSE
> > POSTECH
>

_______________________________________________________
Amoakoh Gyasi-Agyei
Centre for Internet Technology Research (CITR)
Electrical & Electronic Engineering Department
Adelaide University
Tel: +61 8 8303 6209 (office)
Tel: +61 402 638 141 (mbl)
Fax: +61 8 8303 4405
http://aaron.eleceng.adelaide.edu.au/Personal/amoakoh/

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 28 Nov 2002 09:24:35 +0100

Would you sign a contract to guarantee bandwidth on a variable
bandwidth network? I wouldn't, so what you are describing is
an SLA that should never exist.

I don't know what a dynamic SLA is. We certainly don't have any
standards for such things.

You might well have rate control in a source, admission control
in an ingress router, and policing in a downstream router.
I suggest you read RFC 3086 and RFC 3290.

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment at the IBM Zurich Laboratory, Switzerland
_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: SERBAN Rares <[email-masked]>
Date: Thu, 28 Nov 2002 02:02:17 -0800 (PST)

I have a question:

Which part from Diffserv SLA could be negotiated in
the case of Dynamic SLA? Which are the funcionalities
from Diffserv involved in this
negociation/re-negotiation?

Thank you,

R.

--- Brian E Carpenter <[email-masked]> wrote:
> > Should the SLA be static or dynamically
> negotiated? Assuming a static SLA with bandwidth
> limit, how can the service provider guarantee the
> > SLA on a connection with a wireless component
> which is spatio-temporarily varying and whose
> bandwidth can degrade ungraciously? What is
> > So, Brian, do you mean that the admission
> controller in this case will operate in the traffic
> source while the policer sits somewhere else
> > or be integrated? I just do not know why and how
> some of these functionalities were separated
> although their functionalities appear to be
> > > >  - the provide check if the network can
> support the SLA and the provider make the contract
> when the SLA can be supported.
> > > >
> > > > As far as I know, when the SLA mechanism is
> used in the DiffServ domain, the admission control
> mechanism is not required, I thought.
> > > > Is my thought correct ?
> > > > If not, please let me know why the admission
> control is required after SLA is entered into
> agreement.
> > > >
> > > > Thanks in advance,
> > > >
> > > > Geunhyung Kim
> > > >
> Archive:
http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html