Subject: [Diffserv] A PHB question

From: Ali badilli <[email-masked]>
Date: Tue, 18 Jun 2002 00:49:55 -0700 (PDT)

Hi,

Does a particular PHB requires same constraints from
each router within the domain?,

For example, let say we configure router A to make
maximum delay for AFxy (PHBxy) 1 ms. Do other routers
need to be configured in same way to have 1 ms maximum
delay for AFxy?

The question is only for AF PHB, EF is clear.

Thanks

__________________________________________________
Do You Yahoo!?
LAUNCH - Your Yahoo! Music Experience
http://launch.yahoo.com

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Jun 2002 16:52:38 +0200

The answer is clearly yes; all routers along the path need appropriate 
configuration.

However, maximum delay is not a parameter of AF as far as I know.

It would be best to continue this discussion on the diffserv
implementation list.
http://www.tip.csiro.au/dsimplementation/

  Brian Carpenter
  diffserv co-chair

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment at the IBM Zurich Laboratory, Switzerland

---

From: Ali badilli <[email-masked]>
Date: Tue, 18 Jun 2002 14:37:46 -0700 (PDT)

Hi,

That's right. Delay is not a parameter of AF. 
But I am just wondering if none of AF classes defines
delay, delay jitter bounds, then how a PDB, which is
built from particular PHB,can defines bounds for
delay, delay jitter? (not assuming EF)

Thanks, 

Ali

--- Brian E Carpenter <[email-masked]> wrote:
> > Archive:
http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
> Archive:
http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Scott Brim <[email-masked]>
Date: Tue, 18 Jun 2002 18:15:38 -0400

> delay, delay jitter? (not assuming EF)

PDBs also include edge behavior, and one of the inputs to edge behavior
is knowing your network's capacity.  You adjust your traffic
conditioning to be able to deliver the services you need.

---

From: Nabil Seddigh <[email-masked]>
Date: Tue, 18 Jun 2002 19:18:07 -0400

The issue of delay and jitter in relation to the AF PHB 
arose when the Assured Rate PDB was first discussed.
The draft has now expired but can be found at old id repositories:

http://www.ietf.org/proceedings/01dec/I-D/draft-ietf-diffserv-pdb-ar-01.txt

See the thread surrounding this one for the evolution of the
discussion: 

http://www1.ietf.org/mail-archive/working-groups/diffserv/current/msg02805.html

As a result of mailing list discussion, the AR PDB draft was 
modified so that it stated the following:

 "It may be possible to determine delay and jitter bounds  
  for  traffic aggregates  using the AR PDB. However, such 
  parameters are beyond the scope of this PDB definition and 
  no attempt is made  to  characterize them. Development of a 
  mathematical model to predict delay and jitter for the  
 AR  PDB  is  left  as  a  subject  of  future  research  and
 investigation."

Best,
Nabil Seddigh
[email-masked]