Subject: [Diffserv] RE: Applications broken by diff-sev remarking?

From: [email-masked]
Date: Wed, 15 May 2002 14:58:42 +0100

> Dear diff-serv community,
> 
> I seem to recall that in the very early days of diff-serv, there was some
> kind of survey to establish whether there were any applications that would
> be broken if the TOS value (i.e. pre diff-serv days) was changed to any
> value other than the transmitted value.
> 
> Is there a list of applications known to show problems with remapping of
> TOS values, and which could therefore be considered "Non diff-serv
> compliant"?
> 
> Any answers most appreciated,
> 
> Simon
> 
> -----------------------------------------------------------------
> Simon Carter 
> IP Network Engineering, BTexact Technologies
> MLB G pp8, Adastral Park, Martlesham Heath,
> Ipswich, IP5 3RE, UK
> [email-masked]
> Tel:	 +44 1473 606360
> Fax:	 +44 1473 606727
> -----------------------------------------------------------------
> 

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 May 2002 17:33:54 +0200

The problem we identified was a very small number of TCP implementations
that failed if the TOS byte is changed on the return packets. I don't recall
any application dependencies (although of course anything is possible).

   Brian