Subject: Re: [Diffserv] Is the diffServ preemptive ?

From: Zyad Dwekat <[email-masked]>
Date: Thu, 30 May 2002 09:15:08 -500

In the question below , I think he is trying to say what if we need to service two types of PHB in same router i.e we have different classes of AF but we have a traffic that we need to give it delay gurantee by EF PHB .so the question how to coordinate the requirements of both PHBs

 > Geunhyung Kim wrote:
 > 
 > Hello all,
 > 
 > I have basic question about diffServ architecture.
 > As far as I know, AF flow may use the excess bandwidth when there is underload, end the minimum bandwidth
 should be guaranteed even though
 > the link state is overloaded.

 But that is not a question about the diffserv architecture. The 
 diffserv architecture (RFC 2475) applies equally to all PHBs, not
 just AF, and says nothing about guarantees or bandwidth.

 > Is that correct ?

 Assuming your question applies to AF, i.e. RFC 2597, AF does not define
 an AF "flow". It defines a set of AF behaviors allowing the creation
 of a set of AF traffic aggregates. If I assume your question applies to
 an AF traffic class (i.e. all the data packets carrying the code
 points {AFn1,AFn2,AFn3} for a given n), then the relevant part of the RFC is:

 >    A DS node MUST allocate a configurable, minimum amount of forwarding
 >    resources (buffer space and bandwidth) to each implemented AF class.
 >    Each class SHOULD be serviced in a manner to achieve the configured
 >    service rate (bandwidth) over both small and large time scales.
 > 
 >    An AF class MAY also be configurable to receive more forwarding
 >    resources than the minimum when excess resources are available either
 >    from other AF classes or from other PHB groups.  This memo does not
 >    specify how the excess resources should be allocated, but
 >    implementations MUST specify what algorithms are actually supported
 >    and how they can be parameterized.
 > 
 So, the answer to your first question is more subtle than "yes" or "no".

 > If it is correct, when the higher priority flow enters into network, the excee bandwidth that the lower
 priority flow used may be preempted by the higher priority.
 > Even in this case, the higher priority flow can not use the bandwidth that the lower priority flow
 required minimally.
 > Is that correct ?

 Neither diffserv, nor AF, defines "priority" among traffic classes.
 Let's be very clear about that: there is no priority ordering between
 AF1x, AF2x, AF3x, AF4x. They each have their assigned resources as
 defined in the above extract.

    Brian Carpenter

 > 
 > Thanks in advance,
 > 
 > Geunhyung
 > 
 > None of us is as smart as all of us
 > ==========================================
 > Geunhyung Kim
 > 
 > E-mail: [email-masked]
 > 
 > Tel: +82-54-279-5655
 > Fax: +82-54-279-5699
 > 
 > Networking & Distributed Systems Lab.
 > CSE
 > POSTECH
 > ===========================================

 --__--__--

Zyad Dwekat
**********************************************************************
Research Assistant                                                   *
North Carolina State University                                      *
home:(919)854-9667                                                   *
work:(919)515-8661                                                   *
http://www4.ncsu.edu/unity/users/z/zadwekat/public/resume/myresume.htm
**********************************************************************

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 30 May 2002 17:25:52 +0200

I was answering a question about the standards, since this is
the standards WG list. Implementation discussions belong at
http://www.tip.csiro.au/dsimplementation/
  
   Brian