Subject: [Diffserv] ifSpeed with DiffServ PIB and Framework PIB [Previously Re: draft-ietf-rap-frameworkpib-06]

From: Kwok Ho Chan <[email-masked]>
Date: Sun, 03 Feb 2002 09:55:57 -0500

An alternative to the treatment of ifSpeed by the DiffServ PIB is to add
an attribute qosIfSchedulerCapsIfSpeed to qosIfSchedulerCapsEntry
to indicate the bit rate that can "sink" the output of the Scheduler
Data Path Element.  This will allow the DiffServ PIB to not rely on the
Interface MIB.

The above alternative is possible because the Framework PIB now
allows multiple interface capability sets belonging to the same Role
Combination, hence policies belonging to the same Role Combination
can be used for interfaces with different interface capability sets
(different interface speeds).

I have also put this on the diffserv mailing list as this need to be decided
with the DiffServ WG.
I can change this in the DiffServ PIB-06 I am submitting.
Notice DiffServ PIB-05 have already passed WG Last Call,
so this will be a minor change after WG Last Call before IESG Review.

-- Kwok --

At 06:18 PM 2/1/02 -0500, Chan, Kwok-Ho [BL60:470:EXCH] wrote:
>Saurabh:
>Sorry for not responding to this earlier.
>Currently the "ifSpeed" refers to the interface speed provided by
>the MIB's ifTable in RFC 2863.
>Design of the DiffServ PIB is to be Role Combination specific and not
>interface specific.  We also didn't want to pull in the MIB's ifTable into
>a PIB as there are many proprietary extensions to the ifTable already.
>Another point is that we can add this as part of the capabilities for
>a specific Role Combination, but we may want to have a single Role
>Combination containing interfaces of more than one interface speed.
>
>I would like to leave it the way it is and just use the ifSpeed from the 
>MIB's ifTable.
>Let the DiffServ PIB get to Proposed Standard RFC.
>Get more implementation experience to determine what is the right thing to do
>before modifying it, as there are other things we will learn from more
>implementation experience.
>
>-- Kwok --
>
>
>At 06:21 PM 1/2/02 +0530, [email-masked] wrote:
>>     The qosAssuredRateAbs parameter of the qosAssuredRate table specifies
>>the minimum absolute rate, in kbps that a downstream scheduler element
>>should allocate to the queue.
>>This attributes value is coupled to that of qosAssuredRateRel : changes to
>>one will affect the value of other. They are related to each other by the
>>equation :
>>RateRel = [ (RateAbs * 1000) / ifSpeed ] * 10000
>>
>>My question is how does the PDP get the value of 'ifSpeed'? Does the PEP
>>specify the value? If yes, then in which PIb is the value found ?
>>
>>Regards,
>>Saurabh Kapoor
>>----------------------------------------------------------------------------
>>----------
>>
>>
>

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 04 Feb 2002 09:13:33 +0100

Even though it's a small change, it's technical not editorial. So if this change
is made in the -06 version (which seems entirely reasonable since it removes
a dependency), it would be a legitimate topic for discussion in the IETF-wide
last call. So if anyone thinks it is a Bad Idea to make this change,
please say so *now*.

Thanks
   Brian Carpenter  
   diffserv co-chair

---

From: "webmaster" <[email-masked]>
Date: Mon, 4 Feb 2002 15:10:58 -0200

Hi

Let introduce myself : My name is Bernardo Oliveira and I am a pos-graduate
student of Rio Grande do Norta Federal University (this is a state of
northwest
of Brazil).
Now  I'm searching  material for my thesis. My subject refer to
DIFFSERV over IPNG to transport VOIP traffic.
So I am interested in the use of flow label field for DIFFSERV.
In draft-conta-ipv6-flow-label-02 of july/01 (A. Conta and B. Carpenter)
we have a proposal to use the flow label field to DIFFSERV, but I dont
understand yet how to do it !
The flow label field is bigger than traffic class field (this is a fact), so
to me it means that we have a possibility to  use one more granularity
that is, we can define more classes beyond of  AF,EF,BE existent classes, or
more  "levels" of these classes , something like "AF Super"  or "EF GOLD
Hiper".
So to do this it is necessary create a news DSCPs .  This idea looks like a
"new
DIFFSERV" or a "Extended DIFFSERV"
Are my ideas corrects ???
Is there anybody talking (writing) about this new classification (news
DSCPs) ?. I found nothing
about it.
On the other hand in draft-rajahalme-ipv6-flow.label-00 of November/01 (A.
Conta
and  J. Rajahalme) Alex Conta doesn´t talk anything about DIFFSERV.
what does it means ? Is The first draft a dead idea ? ,  Wouldn't we use the
flow label to DIFFSERV ?

Bernardo Oliveira

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 05 Feb 2002 10:42:13 +0100

Bernardo,

This is a mailing list for standardisation work, not for thesis research. Also,
you are looking at an obsolete draft - please look at 
draft-rajahalme-ipv6-flow-label-00.txt (which will be updated soon).

For general discussion of diffserv, please use [email-masked] instead.
To join the list, go to
   http://www.ietf.org/mailman/listinfo/diffserv-interest

  Brian Carpenter
  diffserv WG co-chair

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment at the IBM Zurich Laboratory, Switzerland
Board Chairman, Internet Society http://www.isoc.org

---

From: "webmaster" <[email-masked]>
Date: Tue, 5 Feb 2002 14:38:13 -0200

Ok Carpenter, Brian

I will change to diffserv-interest list , my apologise .

But , if you read my  mail completely  you wil see when I talk (write) about
draft-rajahalme-ipv6-flow-label-00.txt .

Thanks .

Bernardo Oliveira .

----- Original Message -----
From: "Brian E Carpenter" <[email-masked]>
To: "webmaster" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, February 05, 2002 7:42 AM
Subject: Re: [Diffserv] IPng and Diffserv

Bernardo,

This is a mailing list for standardisation work, not for thesis research.
Also,
you are looking at an obsolete draft - please look at
draft-rajahalme-ipv6-flow-label-00.txt (which will be updated soon).

For general discussion of diffserv, please use [email-masked]
instead.
To join the list, go to
   http://www.ietf.org/mailman/listinfo/diffserv-interest

  Brian Carpenter
  diffserv WG co-chair

webmaster wrote:
> Archive:
http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.ht
ml

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive:
http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.ht
ml