Subject: [Diffserv] A multi-domain PHB question

From: Ali badilli <[email-masked]>
Date: Wed, 6 Feb 2002 17:26:41 -0800 (PST)

Hi all,

I am doing researh that is partly related Diffserv. I
have the following question if anybody has comments I
will be really appreciated.

In a single Diffserv domain a customer has SLA that
specifies the service will be received by customer.
For example a domain can guarantee that the customer's
traffic will receive EF PHB within domain. SLA does
not specifies the metrics value. Lets say EF require
less than 20 ms delay and 0.1% loss, but this not
specified in SLA. This is ok in single domain.

If a domain is geting service from another domain and
providing its customer how it will make sure that the
requirements are still satisfied. For clarification
let consider the following situation.

 Domain A is the customer of domain B and has service
from B for EF traffic, and then provides this service
to its customers. Now, assume that in domain B EF
packets will have 15ms delay, and 0.1%loss and in
domain A will have 15ms delay and 0.1% loss.  Now, the
EF traffic from a customer in domain A to any
destination in domain B will have 30ms which exceeds
the EF requirement. We cannot avoid this situation
because the value of constraints are not specified.

How this situation will be taken care of it? 

I am sorry if I am missing something.

Thanks.

__________________________________________________
Do You Yahoo!?
Send FREE Valentine eCards with Yahoo! Greetings!
http://greetings.yahoo.com

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Shahram Davari <[email-masked]>
Date: Fri, 8 Feb 2002 09:06:31 -0800

Hi Brian

I agree with you that NSIS WG is the right place for this topic.

Yours,
-Shahram

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Friday, February 08, 2002 2:58 AM
> To: Shahram Davari
> Cc: 'Ali badilli'; [email-masked]
> Subject: Re: [Diffserv] A multi-domain PHB question
> 
> 
> Shahram,
> 
> An even more basic point is that there must be an SLA in place
> at every ISP/ISP boundary, in order for end to end diffserv
> to work in the general case. This is clearly many years into
> the future, and it's a business issue and not something we
> can usefully debate in the IETF.
> 
> Certainly RFC 3086 is relevant, but beyond that it is perhaps more
> in the scope of the NSIS working group than this one.
> 
>   Brian
> 
> Shahram Davari wrote:
> > 
> > Hi Ali,
> > 
> > I think what you have missed is that the SLA should not
> > be based on PHB, rather it should be based on PDB. Any
> > Diffserv provider will probably offer a number of PDB
> > services, with some bounds on delay, jitter, and loss.
> > 
> > If a customer requires a service with < 0.1% loss
> > and <15ms delay, then it is up to the service provider A to
> > come up with a combination of its own PDB and PDBs offered
> > by service provider B, to fulfill customer's SLA.
> > 
> > For example service provider A may offer 3 types of services
> > based on some PDBs which are in turn based on some PHBs:
> > 
> > A1) delay < 5ms, jitter < 5ms, loss < 0.02%
> > A2) delay < 10ms, jitter < 10ms, loss < 0.1%
> > A3) delay < 50ms , jitter < 50ms, loss < 1%
> > And service provider B may offer 3 types of services
> > based on some PDBs which are in turn based on some PHBs:
> > 
> > B1) delay < 10 ms, jitter < 10ms, loss < 0.05%
> > B2) delay < 50ms, jitter < 50ms, loss < 0.5%
> > B3) delay not guaranteed , jitter not guaranteed, loss < 10%
> > 
> > To fulfill customer's SLA provider A could choose A1+B1.
> > 
> > Note: This means that provider A may not be able to
> > fulfill some customer's SLAs. For example if a customer
> > was asking for delay <10ms and the packet had to be routed
> > through provider B.
> > 
> > Does that answer your question?
> > 
> > -Shahram
> > 
> > > -----Original Message-----
> > > From: Ali badilli [mailto:[email-masked]]
> > > Sent: Wednesday, February 06, 2002 8:27 PM
> > > To: [email-masked]
> > > Subject: [Diffserv] A multi-domain PHB question
> > >
> > >
> > > Hi all,
> > >