Subject: [Diffserv] DiffServ MIB implementation on Linux

From: "Leonidas A. Lymberopoulos" <[email-masked]>
Date: Wed, 30 Jan 2002 11:19:53 +0000

Hi,
I have used ucd-snmp package and I have written an snmp agent that supports 
the IETF's
diffserv MIB (version 0.4).
I can set a mib value at the snmpd memory space,
but the value must be set at an appropriate entry to the kernel.
Is there is an implementation for setting the IETF MIBs parameters to
the Linux kernel using the netlink interface? Linux kernel supports different
utilities (qdisc, class, filters and policing); therefore there is the need 
to translate the MIB to
these elements and to use netlink. Have anyone done this?

Thank you in advance,

Leonidas
_________________________________________________________

Leonidas A. Lymberopoulos, Research Associate,
Department of Computing,
Imperial College of Science Technology and Medicine,
180 Queen's Gate,
London SW7 2BZ, U.K
Phone: ( +44 | 0 ) 207 594 8394      Fax:     ( +44 | 0 ) 207 581 8024
E-mail: [email-masked] 

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 30 Jan 2002 15:02:20 +0100

I would try the diffserv implementation list for this question

See http://www.atnf.csiro.au/news/exploders/dsimplementation.html

   Brian