Subject: [Diffserv] diffserv PIB: a question to the WG

From: Brian E Carpenter <[email-masked]>
Date: Mon, 10 Dec 2001 17:03:09 +0100

Diffservers,

As you know the Diffserv PIB recently passed WG last call, and will be forwarded 
to the IESG as soon as the draft is updated.

Now I have a question, at the request of the Ops and Management Area Directors:

Can anyone who plans to implement the diffserv PIB (or has already done so)
please let us know? If you don't want to answer on the list, please send
me a private response.

Thanks
   Brian Carpenter
   diffserv co-chair

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Lloyd Wood <[email-masked]>
Date: Mon, 10 Dec 2001 16:29:00 +0000 (GMT)

On Mon, 10 Dec 2001, Brian E Carpenter wrote:

> Diffservers,
>
> As you know the Diffserv PIB recently passed WG last call, and will
> be forwarded to the IESG as soon as the draft is updated.
>
> Can anyone who plans to implement the diffserv PIB (or has already
> done so) please let us know?

Brian, doesn't this sort of implementation question really belong on
the diffserv implementation list? Please see
http://www.atnf.csiro.au/news/exploders/dsimplementation.html

> If you don't want to answer on the list,

can't think why...

L.

> please send me a private response.
>
> Thanks
>    Brian Carpenter
>    diffserv co-chair

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 10 Dec 2001 17:54:43 +0100

Lloyd,

No, it belongs here because it is a formal request from two Area Directors
as part of the IESG's decision process.

  Brian

---

From: demir <[email-masked]>
Date: Mon, 10 Dec 2001 09:12:03 -0800 (PST)

Lloyd,
I don't think it does cause It says "who plans to implement.". I have a
suggestion. May be there should be "DiffservPlanToImplement" discussion
group so that this sort of questions can be directed to that discussion
group :) :)

Alper K. Demir

---

From: "Jim Fleming" <[email-masked]>
Date: Mon, 10 Dec 2001 12:13:15 -0600

BTW, while on the subject of TCP, Qs, etc. It seems rather odd that people
engrossed in protocols, would not consider the long history of making sure that
layers are preserved or at least considered. You may have heard of Layer 2
(Network) and Layer 3 (Transport). It would seem that much of the work on
Queues and the shaping of flows would most properly be located in Layer 3.
The additions we are making to Layer 2, focus on extending the addressing
and other functionality of Layer 2. It seems that Layer 2 will not have enough
bits to accommodate all of the ideas that people are pouring into it.

This may help...
http://www.dot-biz.com/IPv4/Tutorial/

http://www.dot-biz.com/RepliGate/RIFRAF/
RIFRAF Routing
RIFRAF (Remote Identification Field Random Action Filter) Routing is part of a phased approach to evolving from 32-bit IPv4 Internet
Addressing to larger address spaces. The RIFRAF feature in an IP stack, allows for remote access control of  the left-most 8-bits of
the normally 16-bit IPv4 Identification Field. The feature is part of the IPv8 PeaceKeeper/GateKeeper series. The feature allows a
PeaceKeeper for a /16 prefix to remotely set StarGate values in a marking engine via simple ICMP+ extensions via the TOS field. The
4-bit StarGate values are rotated through an 8-bit field which is used in a 50/50 coin-toss marking process as packets are processed
with the /16 prefix. Source and Destination StarGate marking is distinct, and all 65,536 /16 prefixes have two choices for the
source addresses and two choices for destination addresses. The random marking can be prevented by loading both StarGate values to
be the same. The GateKeeper can be restored to legacy Identification Field marking by the PeaceKeeper. Packets marked via RIFRAF can
be further routed or queued based on the marks which effectively add 4 bits to the 32-bit IPv4 legacy addresses. All of the packets
pass transparently through legacy IPv4 equipment with no change. For legacy equipment not prepared to handle the markings, it
appears as the left 8-bits of the Identification Field. For each of the 256 marking values, an independent counter is maintained for
the right-most 8-bits of the Identification Field. There is no API required or other user-level tools. RIFRAF can exist silently
inside of the stack and be totally controlled remotely via existing connection(s) to the IPv4 private Intranets or the IPv4 Global
Public Internet. Spoofing of the PeaceKeeper is possible and the PeaceKeeper will receive the return reply, at which point the
PeaceKeeper can restore the desired values. When RIFRAF is used in conjunction with other routing devices and on an IPv16 network,
these problems can be minimized. RIFRAF is mostly intended for use in extending the addressing of leaf-nodes, which generally are
protected behind fire-walls and NAT devices, but can also be used on the IPv4 Global Public Internet to increase the addressing used
by edge devices on /16 networks.

Jim Fleming
http://www.IPv8.info
IPv16....One Better !!

---

From: "Andrew Smith" <[email-masked]>
Date: Tue, 11 Dec 2001 18:44:09 -0800

Jim,

What is it in the definitions of "Layer 2" and "Layer 3" that you are using
that makes you put queueing and shaping of "flows" (your word, not mine) at
one or other of these layers? Do you really subscribe to the
flat-earth-society view that an internet is made up of perfect links with
infinite capacity and zero propagation delays, joined together by IP
switching nodes that are the only places that can affect the propagation of
packets across the internet? That view is a little outdated today.

The issue of "not enough bits at a given layer" is irrelevant - in most
common internet architectures those bits are used purely for classification
purposes at a switching node: those nodes can use whatever information is
deemed appropriate, whether it be explicit in each packet (or packet
fragment in some obselete technologies :-)) or implicitly carried by some
other state (e.g. the arrival interface number).

Andrew Smith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Jim Fleming
Sent: Monday, December 10, 2001 10:13 AM
To: Brian E Carpenter; Diff Serv
Subject: Re: [Diffserv] diffserv PIB: a question to the WG

BTW, while on the subject of TCP, Qs, etc. It seems rather odd that people
engrossed in protocols, would not consider the long history of making sure
that
layers are preserved or at least considered. You may have heard of Layer 2
(Network) and Layer 3 (Transport). It would seem that much of the work on
Queues and the shaping of flows would most properly be located in Layer 3.
The additions we are making to Layer 2, focus on extending the addressing
and other functionality of Layer 2. It seems that Layer 2 will not have
enough
bits to accommodate all of the ideas that people are pouring into it.

---

From: "Andrew Smith" <[email-masked]>
Date: Tue, 11 Dec 2001 18:35:38 -0800

Brian,

Seems odd that this formal request would come when it's only "proposed
standard" that is being sought - have They changed the rules? It used to be
that such implementation experience was only requested when "draft standard"
status was sought.

Andrew Smith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Brian E Carpenter
Sent: Monday, December 10, 2001 8:55 AM
To: Lloyd Wood
Cc: Diff Serv
Subject: Re: [Diffserv] diffserv PIB: a question to the WG

Lloyd,

  Brian

---

From: "Jim Fleming" <[email-masked]>
Date: Tue, 11 Dec 2001 21:29:34 -0600

I think we agree.
Classification is what RIFRAF Routing uses.
http://www.dot-biz.com/IPv4/Tutorial/
http://www.RepliGate.net

The Netfilter Project: Packet Mangling for Linux 2.4
http://netfilter.samba.org

Jim Fleming
http://www.IPv8.info
IPv16....One Better !!

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 Dec 2001 15:49:23 +0100

You'll have to ask the Ops & Mgt ADs that. As far as Draft Standard
is concerned, the actual requirement is proven interoperability. We
aren't there yet.

  Brian

---

From: "Kwok-Ho Chan" <[email-masked]>
Date: Wed, 12 Sep 2001 10:40:37 -0600

Brian:
I think you have the duty to keep the info provided as reply to your
question private when asked.

As condition to replying to your question, I need you indicate the
info will only be used just as one of the counts, and no indication
of what company is implementing what.

We have proto-typed both the DiffServ MIB and PIB and have plan
on continuing the effort into creation of revenue.
We are also thinking of inter-op testing with other vendors who
have shown interest.
But I must keep those info private as I have make my promises.
I hope you will do the same.

FYI: 3G Wireless will also use the DiffServ PIB.

-- Kwok --

At 05:03 PM 12/10/01 +0100, Brian E Carpenter wrote:
>Archive: 
>http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: "Jim Fleming" <[email-masked]>
Date: Wed, 12 Dec 2001 12:31:01 -0600

The "one true IPv4 core transport" is the collection of all networks
that transparently pass all of the TOS and Protocol values, as well
as the RIRRAF Routing values in the Identification Field. All other
networks have to be considered private or not fully connected. They
are running some sort of "alternate" protocols, just like alt DNS.

RIFRAF Routing
RIFRAF (Remote Identification Field Random Action Filter) Routing is part of a phased approach to evolving from 32-bit IPv4 Internet
Addressing to larger address spaces. The RIFRAF feature in an IP stack, allows for remote access control of  the left-most 8-bits of
the normally 16-bit IPv4 Identification Field. The feature is part of the IPv8 PeaceKeeper/GateKeeper series. The feature allows a
PeaceKeeper for a /16 prefix to remotely set StarGate values in a marking engine via simple ICMP+ extensions via the TOS field. The
4-bit StarGate values are rotated through an 8-bit field which is used in a 50/50 coin-toss marking process as packets are processed
with the /16 prefix. Source and Destination StarGate marking is distinct, and all 65,536 /16 prefixes have two choices for the
source addresses and two choices for destination addresses. The random marking can be prevented by loading both StarGate values to
be the same. The GateKeeper can be restored to legacy Identification Field marking by the PeaceKeeper. Packets marked via RIFRAF can
be further routed or queued based on the marks which effectively add 4 bits to the 32-bit IPv4 legacy addresses. All of the packets
pass transparently through legacy IPv4 equipment with no change. For legacy equipment not prepared to handle the markings, it
appears as the left 8-bits of the Identification Field. For each of the 256 marking values, an independent counter is maintained for
the right-most 8-bits of the Identification Field. There is no API required or other user-level tools. Most modern "ping" programs
can be used to set the bits. RIFRAF can exist silently inside of the stack and be totally controlled remotely via existing
connection(s) to the IPv4 private Intranets or the IPv4 Global Public Internet. Spoofing of the PeaceKeeper is possible and the real
PeaceKeeper will receive the return reply, at which point the PeaceKeeper can restore the desired values. When RIFRAF is used in
conjunction with other routing devices and on an IPv16 network, these problems can be minimized. RIFRAF is mostly intended for use
in extending the addressing of leaf-nodes, which generally are protected behind fire-walls and NAT devices, but can also be used on
the IPv4 Global Public Internet to increase the addressing used by edge devices on /16 networks.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 Dec 2001 22:34:40 +0100

> question private when asked.

Of course
> of what company is implementing what.

Requests for anonymity will of course be honoured. Bits sent to
the mailing list are hard to get back.

...
> FYI: 3G Wireless will also use the DiffServ PIB.

Well, their specs are not 100% frozen yet but right now they do indeed
include the PIB.

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment at the IBM Zurich Laboratory, Switzerland
Board Chairman, Internet Society http://www.isoc.org

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 Dec 2001 22:47:35 +0100

Summary so far:

Plan to use the PIB: 1
May use and implement the PIB: 1
Implemented/now implementing the draft PIB: 3

Also, the PIB is currently a normative reference in 3GPP.

More replies welcome; anonymity guaranteed if requested.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 Dec 2001 22:46:26 +0100

Summary so far:

Plan to use the PIB: 1
May use and implement the PIB: 1
Implemented/now implementing the draft PIB: 2

   Brian

---

From: "Kwok-Ho Chan" <[email-masked]>
Date: Thu, 13 Sep 2001 03:07:17 -0600

DiffServ PIB just completed WG last call and sought only
"proposed standard" now.
When I asked this question in tonight's IESG Planary,
Scott Bradner, Transport Area (DiffServ's Area) Director have confirmed
many implementations and proven interoperability is not required at this point.
-- Kwok --

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 13 Dec 2001 15:15:01 +0100

I think the notes from Bert and Randy have explained why they
asked me to ask the question.

BTW, Kwok, your mail agent seems to think it is still September 13.

   Brian

---

From: "Jim Fleming" <[email-masked]>
Date: Thu, 13 Dec 2001 09:00:32 -0600

http://www.google.com/search?q=foreign+espionage+act

THE ECONOMIC ESPIONAGE ACT OF 1996: THE THEFT OF TRADE ...
... be cited as the "Economic Espionage Act of 1996.". ... Section 1831 Economic espionage. ... the
offense will benefit any foreign government, foreign instrumentality, or ...
www.execpc.com/~mhallign/federal.html - 13k - Cached - Similar pages

THE ECONOMIC ESPIONAGE ACT OF 1996: THE THEFT OF TRADE ...
... were transported in "interstate or foreign commerce" and that the defendant knew ... reasons
for enacting the Economic Espionage Act of 1996 was to fill these ...
www.execpc.com/~mhallign/crime.html - 19k - Cached - Similar pages
[ More results from www.execpc.com ]

18 USC 90 - Economic Espionage Act of 1996
... as the "Economic Espionage Act of 1996". ... 1831. Economic espionage. (a) In General.--
Whoever ... will benefit any foreign government, foreign instrumentality, or ...
www.tscm.com/USC18_90.html - 13k - Cached - Similar pages

NCIX - Economic Espionage Act of 1996
... be cited as the "Economic Espionage Act of 1996.". ... 1831. Economic Espionage. ... the offense
will benefit any foreign government, foreign instrumentality, or foreign ...
www.nacic.gov/pubs/eea_96.htm - 27k - Cached - Similar pages

The Economic Espionage Act of 1996
... expect, a significant amount of foreign economic espionage occurs outside of the
United States. Under Section 1837 of the Act, a foreign corporation that sells ...
www.carolinapatents.com/ts_articles/trade_secret4.htm - 29k - Cached - Similar pages

Foreign Economic and Industrial Espionage Remains A Threat in ...
... employee. This case marks the first conviction of foreign individuals or a foreign
company that has gone to trial under the Economic Espionage Act of 1996. The ...
www.fas.org/irp/ops/ci/docs/fy99.htm - 8k - Cached - Similar pages

security resource net's intelligence community
... Held Companies; Uniform Trade Secrets Act; 1998 Annual Report to Congress on Foreign
Economic Collection and Industrial Espionage; 1997 Annual Report to Congress ...
nsi.org/Intelligence.html - 10k - Cached - Similar pages

Despite passage of the 1996 Economic Espionage Act, the FBI ...
... Despite passage of the 1996 Economic Espionage Act, the FBI says foreign spies have
stepped up their attacks on US-based companies, and a new national survey ...
www.infowar.com/class_2/class2_011498b.html-ssi - 13k - Cached - Similar pages

Article: The Economic Espionage Act of 1996
... 1839. Definitions. 1831. Economic Espionage (a) In General: Whoever ... foreign instrumentality,
or foreign agent, knowingly-- (1 ... persons do any act to effect the ...
www.brinkshofer.com/resources/eea_act.cfm - 10k - Cached - Similar pages

FindLaw: CyberSpace Law Center: Crimes: Economic Espionage Act
... for the record on allied foreign governments' economic espionage activities against
the United States. The Economic Espionage Act: Turning Fear into Compliance ...
cyber.lp.findlaw.com/criminal/econ_esp.html - 28k - Cached - Similar pages

----- Original Message -----
From: "Brian E Carpenter" <[email-masked]>
To: "Kwok-Ho Chan" <[email-masked]>
Cc: "Andrew Smith" <[email-masked]>; "Diff Serv" <[email-masked]>; "Bert Wijnen" <[email-masked]>; "Randy Bush"
<[email-masked]>
Sent: Thursday, December 13, 2001 8:15 AM
Subject: Re: [Diffserv] diffserv PIB: a question to the WG