Subject: RE: [Diffserv] diffserv PIB: a question to the WG

From: "Weiss, Walter" <[email-masked]>
Date: Thu, 13 Dec 2001 13:14:44 -0500

This request goes to the very core of the IETF standardization process and
the unwritten contract between ADs and the individual contributors that
develop the standards. Irrespective of the what or why, I am not aware of a
precedent for this request or as a justification for not moving a draft to
proposed standard. In my view, this dramatically increases the level of
control that ADs have over the standards process and undermines the
desirability for individuals to invest in Chartered work items.

There are already four checks for standards progression:
1. Is there sufficient interest the work to justify a chartered work item.
2. Is there consistent progress in the work item to justify keeping it on
the charter.
3. Is it technically sufficient to progress to proposed standard.
4. Are there a sufficient number of interoperable implementations to justify
progression to Draft Standard.

There are already sufficient checks and balances in the process. Let's not
add more and particularly not this arbitrary and politically charged one.

regards,

-Walter

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Thursday, December 13, 2001 9:15 AM
> To: Kwok-Ho Chan
> Cc: Andrew Smith; Diff Serv; Bert Wijnen; Randy Bush
> Subject: Re: [Diffserv] diffserv PIB: a question to the WG
> 
> 
> I think the notes from Bert and Randy have explained why they
> asked me to ask the question.
> 
> BTW, Kwok, your mail agent seems to think it is still September 13.
> 
>    Brian
> 
> Kwok-Ho Chan wrote:
> > 
> > DiffServ PIB just completed WG last call and sought only
> > "proposed standard" now.
> > When I asked this question in tonight's IESG Planary,
> > Scott Bradner, Transport Area (DiffServ's Area) Director 
> have confirmed
> > many implementations and proven interoperability is not 
> required at this point.
> > -- Kwok --
> > 
> > At 03:49 PM 12/12/01 +0100, Brian E Carpenter wrote:
> > >You'll have to ask the Ops & Mgt ADs that. As far as Draft Standard
> > >is concerned, the actual requirement is proven interoperability. We
> > >aren't there yet.
> > >
> > >   Brian
> > >
> > >Andrew Smith wrote:
> > > >
> > > > Brian,
> > > >
> > > > Seems odd that this formal request would come when it's 
> only "proposed
> > > > standard" that is being sought - have They changed the 
> rules? It used to be
> > > > that such implementation experience was only requested 
> when "draft
> > > standard"
> > > > status was sought.
> > > >
> > > > Andrew Smith
> > > >
> > > > -----Original Message-----
> > > > From: [email-masked] 
[mailto:[email-masked]]On Behalf
> > > Of Brian E Carpenter
> > > Sent: Monday, December 10, 2001 8:55 AM
> > > To: Lloyd Wood
> > > Cc: Diff Serv
> > > Subject: Re: [Diffserv] diffserv PIB: a question to the WG
> > >
> > > Lloyd,
> > >
> > > No, it belongs here because it is a formal request from two Area
Directors
> > > as part of the IESG's decision process.
> > >
> > >   Brian

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive:
http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.ht
ml

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 13 Dec 2001 19:33:02 +0100

Walter,

Personally I think you are reading too much into this - but if you 
have a process issue to raise, I think it should be raised directly 
with the IESG, since there is nothing the WG can decide about it. 

As soon as Kwok submits the updated PIB draft I intend to forward it
to the IESG for Proposed Standard processing.

   Brian

P.S. for the record, I was asked to make this enquiry some time ago,
but waited until after the WG Last Call had ended and the OPS-NM
BOF had taken place before doing so.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 13 Dec 2001 20:14:29 +0100

>>>>> Weiss, Walter writes:

Walter> There are already four checks for standards progression: 1. Is
Walter> there sufficient interest the work to justify a chartered work
Walter> item.

Was Bert not just trying to check the answer to this question?

I have seen similar questions in other WGs and usually people just
provide a suitable answer and move on.

/js