Subject: RE: [Diffserv] rowpointer and next free

From: Gai Nachum <[email-masked]>
Date: Mon, 22 Oct 2001 19:37:17 +0200

first i want to point out that the problem exist in the mib level and not in
the implementation level ,and 
while the sulotion u present is acceptable in implementation level , it is
not a mib compatble one, since there is no 
indication in the mib that says u can not delete an entry that is being
pointed to( or u would never reach a situation
were u point to a non exist entry ), further more no componnet in the mib
knows who or how many other components are 
pointing to it, so i guess am seeking a solution that is supported by the
mib .

thanks

gain
-----Original Message-----
From: Iren, Sami [mailto:[email-masked]]
Sent: Monday, October 22, 2001 7:19 PM
To: 'Gai Nachum'; [email-masked]
Subject: RE: [Diffserv] rowpointer and next free

Gain:
In your scenario, you should not delete the meter entry in the first place,
since it is used by an element entry. For this, you need to use
usage counters and unless this counter value is zero, you should
never delete a row.
Regards,
---
Sami Iren 
Marconi Networks
[email-masked] 

> -----Original Message-----
> From: Gai Nachum [mailto:[email-masked]]
> Sent: Sunday, October 21, 2001 1:01 PM
> To: [email-masked]
> Subject: [Diffserv] rowpointer and next free
> 
> 
> hi all
> 
> if we have a situation were we point let say from element to 
> meter , than we
> delete the meter , the next field in the element is to be 
> treated as if it
> hold 0.0 ,
> but should that meter index be returned to the next free list 
> of the meter(
> due to tha fact we deleted it ) ?
> if so we might create a new meter entry with the same index ( 
> taken from
> next free) wich in fact is being pointed to by the element !!! ,
> if this meter index should not be returned to the next free 
> list, how can we
> seperate it from a meter entry that is not being pointed to 
> and is deleted ?
> 
> gain
> 
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/diffserv
> Archive: 
> http://www2.ietf.org/mail-archive/working-groups/diffserv/curr
ent/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 22 Oct 2001 21:32:31 +0200

As far as I can tell, this isn't a problem of *this* MIB in particular;
it's the fact that MIBs in general don't include a mechanism for
avoiding dangling pointers. That's an implementation issue as far
as diffserv is concerned. If you want to handle the generic
problem, that is an issue for the IETF Operations and Management
area.

   Brian