Subject: [Diffserv] Forwarding entries in a Diffserv-capable router

From: [email-masked] (Goorah Shravan)
Date: Wed, 17 Oct 2001 15:09:35 +0400

Hello there,

        I am looking for a limit on the number of entries in the
Forwarding Information Base of a Diffserv-capable router to achieve some
performance.

        What is the relationship between the number of entries
(classification state) in the FIB and the feasible capacity (say, in
bps) for a particular PHB?

Shravan
--
Shravan Goorah
Lecturer, Department of Computer Science,
Faculty of Engineering, University of Mauritius
Tel. 454 1041   Fax.  465 71 44

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 17 Oct 2001 14:35:09 +0200

This is an implementation issue and will depend very much on the 
router technology. I suggest asking your question on the
diffserv implemenatation list
http://www.atnf.csiro.au/news/exploders/dsimplementation.html

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment at the IBM Zurich Laboratory, Switzerland
Board Chairman, Internet Society http://www.isoc.org

---

From: Fred Baker <[email-masked]>
Date: Mon, 22 Oct 2001 08:34:01 +0900

At 07:09 PM 10/17/2001, Goorah Shravan wrote:
>What is the relationship between the number of entries (classification 
>state) in the FIB and the feasible capacity (say, in bps) for a particular PHB?

I'm not certain that there is any, or that their should be. Diffserv 
classification is about session aggregates, while IP forwarding is about 
destination prefixes. While they could be put together, the resulting FIB 
size wouldn't really buy you anything; you want to think of diffserv 
classification as separate from and orthogonal to forwarding classification.