Subject: RE: [Diffserv] Typos in draft-ietf-diffserv-mib-13.txt

From: Shahram Davari <[email-masked]>
Date: Fri, 28 Sep 2001 14:56:46 -0700

Hi,

There might also be some typos in page 111 and 112 too:

1)In high speed interfaces if we are using High counters (64-bit), why do we still need 32-bit counters?

2) diffserMIBHCCounterGroup: Is the diffservAlgRandomDropHCPkts correct or should it be diffservAlgRandomDropPkts? Also shouldn't the diffservAlgRandomDropOctets be added?

3) Is he omission of AlgRandomdrop counters in diffserMIBVHCCounterGroup intentional?

4) Why the diffserMIBCounterGroup has diffservCountActionNextFree, but the other HC and VHC groups don't?

Yours,
-Shahram

> -----Original Message-----
> From: Denton Gentry [mailto:[email-masked]]
> Sent: Friday, September 28, 2001 5:26 PM
> To: [email-masked]
> Subject: [Diffserv] Typos in draft-ietf-diffserv-mib-13.txt
> 
> 
>   I hope I'm not about to make a fool out of myself, but I believe
> there are several typos in Section 3.4.4 of draft13 of the diffServ
> MIB. These are not substantive problems, merely editorial.
> The last sentence of the second paragraph in section 3.4.4 reads:
> 
> "The action inspects the diffServQEntry that diffSeervAlgQMeasure
> points to in to determine whether the packet should be dropped."
> 
> 1. I believe "diffSeervAlgQMeasure" should be 
> "diffServAlgDropQMeasure"
> 2. I believe "points to in to" should be "points to in order to"
> 
> --Denny
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/diffserv
> Archive: 
> http://www2.ietf.org/mail-archive/working-groups/diffserv/curr
ent/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Fred Baker <[email-masked]>
Date: Fri, 28 Sep 2001 15:54:42 -0700

You'll find the current markup (complete with the error mentioned a bit ago 
fixed) at 
ftp://ftpeng.cisco.com/fred/diffserv/draft-ietf-diffserv-mib-14.txt and 
ftp://ftpeng.cisco.com/fred/diffserv/marked.draft-ietf-diffserv-mib-14.txt

>we still need 32-bit counters?

the current markup lacks 32 bit counters.

>2) diffserMIBHCCounterGroup: Is the diffservAlgRandomDropHCPkts correct or 
>should it be diffservAlgRandomDropPkts? Also shouldn't the 
>diffservAlgRandomDropOctets be added?
>

The current markup has one group:

diffServMIBCounterGroup OBJECT-GROUP
     OBJECTS {
               diffServCountActOctets, diffServCountActPkts,
               diffServAlgDropOctets, diffServAlgDropPkts,
               diffServAlgRandomDropOctets, diffServAlgRandomDropPkts,
               diffServCountActStorage, diffServCountActStatus,
               diffServCountActNextFree
     }
     STATUS       current
     DESCRIPTION
        "A collection of objects providing information specific to
        packet-oriented network interfaces."
     ::= { diffServMIBGroups 9 }