Subject: [Diffserv] diffServActionInterface, diffServMIBCounterGroup

From: Harrie Hazewinkel <[email-masked]>
Date: Tue, 25 Sep 2001 08:42:04 -0700

Hi,

A)
I believe there is a minor problem with the diffServActionInterface.
The diffServActionInterface description says:

       ".....  If this is unspecified or unknown, the
       value is zero. ...."

It is unclear what the value will be when the entry belongs to multiple
interfaces. In other words, which value should the diffServActionInterface
get when the counter action is part of a datapath that is merged from
multiple interfaces.

I propose a small change that includes the assignment of the value
zero to the diffServActionInterface in this case. Changed text:

       ".....  If this is unspecified or unknown or the
       entry belongs to a datapath that is merged from multiple
       interfaces, the value is zero. ...."

B)
Do we still want to refer to 'high speed' for all the counters??
I suggest we delete "This object should be used on high-speed
interfaces." from the descriptions that go with the Counter64
typed objects.
Also the description of the diffServMIBCounterGroup??
I propose a DESCRIPTION for the diffServMIBCounterGroup like:
       "A collection of objects providing information specific to
       packet-oriented network interfaces."

C)
Minor minor nit:
- The functions in the description of of the 'rate-tables' go beyond
the line length. (Search for 'ifSpeed')
- The type Counter64 for the diffServCountActOctets and
diffServCountActPkts are not aligned in the entry definition.

Harrie

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Fred Baker <[email-masked]>
Date: Tue, 25 Sep 2001 11:12:19 -0700

At 08:42 AM 9/25/2001, Harrie Hazewinkel wrote:
>interfaces.

I'm not convinced that it can, really. The parameters, found in whatever 
diffServActionSpecific points to, could apply to multiple interfaces, but 
the action itself applies to a single interface - at least to my line of 
reasoning. How about:

        ".....  If this is indeterminate, the value is zero. ...."

Beyond that, care to check the current markup to see that I did what you 
said correctly?

---

From: Harrie Hazewinkel <[email-masked]>
Date: Tue, 25 Sep 2001 12:33:52 -0700

>       ".....  If this is indeterminate, the value is zero. ...."

Sounds good to me.

> Beyond that, care to check the current markup to see that I did what you

Just checked looks OK to me.

Harrie