Subject: RE: [Diffserv] IndexInteger vs. InstanceId

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 26 Sep 2001 18:13:23 +0200

Inline
> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]]
> Sent: woensdag 26 september 2001 17:22
> To: DIFFSERV WG
> Subject: [Diffserv] IndexInteger vs. InstanceId
> 
> The DiffServ MIB uses the IndexInteger TC which is an Unsigned32
> (1..2147483647) while the DiffServ PIB uses the SPPI InstanceId
> which is an Unsigned32 (1..4294967295).
> 
> This basically means that it is possible to create instances via
> COPS-PR which you can not monitor with SNMP without introducing a
> mapping between IndexInteger and InstanceId values.
> 
> Perhaps it is more useful to change IndexInteger to Unsigned32
> (1..4294967295) and IndexIntegerNextFree to just Unsigned32.
> 
I would cetainly want them to be in sync. Could also lower the
value in the PIB to get in sync with the MIB of course

Vut in my version of the MIB, they already are 
Unsigned32 (1..4294967295) Unsigned32 (0..4294967295) respectively.
Have you picked up the latest rev from Fred which he keeps up
to date with fixes on issues raised to the list?

Bert

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 26 Sep 2001 12:11:14 -0500

The statement by the PIB authors has always been that they will
align with the MIB, so I think that is what should happen here too.

  Brian