Subject: Re: [Diffserv] doubts on draft-ietf-differv-model-06.txt

From: Fred Baker <[email-masked]>
Date: Tue, 04 Sep 2001 15:14:22 -0700

At 11:04 PM 8/14/2001, Ashley Shi wrote:
>1) Is the token interval used the same as the token update interval?

As I understand things, there is a difference between specification and 
implementation. The specification is that:

         token rate == token burst size/token interval

The implementation may be, as you suggest and as I implemented in Cisco 
gear lo these many moons ago, that there is a much smaller burst and 
interval that are used for actually updating it, or alternatively that the 
bucket is refilled at irregular intervals, or a variety of other things.

In the text, I tried to describe the specification, not the implementation.

>2) The description for strict token bucket on page 50 doesn't match the
>mathematical model in A.4.

I'll leave that to the author of A.4

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 5 Sep 2001 16:03:15 +0200

And so does the MIB.
I would think it would be worthwhile to keep the doc as
and informational RFC. If current thinking has changed, you might
wriet something about that in the introduction. But certainly
we have used that document to form our current thinking of the
MIB (and PIB) have we not.

Bert 

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: woensdag 5 september 2001 0:04
> To: Fred Baker; Dan Grossman; Steve Blake; [email-masked];
> [email-masked]
> Subject: Re: [Diffserv] doubts on draft-ietf-differv-model-06.txt
> 
> 
> Answering my own thought... the PIB at least contains many, many
> (non-normative) references to the model draft. It would be a lot
> of work to remove them.
> 
> Since the model says it "is not intended as a
> guide to system implementation nor as a formal modelling description,"
> I believe we do not need to insist on every detail, and I 
> don't personally
> see a problem with the way Appendix A is now, but if Fred can tell us
> exactly what to delete, we can certainly do so.
> 
>    Brian
> 
> Brian E Carpenter wrote:
> > 
> > Fred raises an interesting thought. The informal model has, 
> I think, been
> > quite useful in developing the MIB and PIB, but it was 
> never intended
> > to describe any real implementation, and the MIB and PIB are the
> > standards-track items. There will be a WG Last Call fairly soon for
> > the MIB, PIB, and model - unless people think that the 
> model is indeed
> > OBE and should be retired with honour rather than becoming an RFC.
> > Opinions welcome.
> > 
> >    Brian
> > 
> > Fred Baker wrote:
> > >
> > > At 12:06 PM 9/4/2001, Dan Grossman wrote:
> > > >Perhaps Fred can clarify.
> > >
> > > there is an extensive discussion in the archives, as well 
> as in your and my
> > > private mailboxes.
> > >
> > > Since the model is now largely irrelevant (it describes 
> *a* way diffserv
> > > might be implemented, but is mostly OBE, and goes way too far into
> > > designing a router to be even remotely considered to be 
> the One True Way
> > > That All Of Us Will Rip Out Our Existing Code And 
> Hardware And Re-implement
> > > It), I'm personally willing to see the text you're 
> concerned about removed.
> 
> Archive: 
> http://www2.ietf.org/mail-archive/working-groups/diffserv/curr
ent/maillist.html