Subject: [Diffserv] diffserv mib rev 13 - do we need Counter32 objects

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 18 Sep 2001 16:06:37 +0200

Hi,
as you can all see, the MIB does have a set of Counter64
objects, and it also has a set of "shadow" counter32 objects
that in many cases contain the low order 32 bits of the
Counter64 objects.

Fred did this, because I pointed him to other mibs
(like IF-MIB) a year or more ago when I first saw the 
diffserv mib. 

It does however make the MIB bigger and a bit more complex
than needed. Lately, various other WGs have asked me if
we really MUST provide 32bit "shadow" counters for
MIBs where just plain 64-bit counters would make the most
sense. As a result, I have been checking our RFCs and
discussed this with the SMIv2 ediotors. It turns out that
we do NOT have any rules in any RFCs that say that you
must always have such "shadow" counter32 objects. So
that means that WGs can actually decide if they want/need
the 32-bit counters or not.

When discussing this with Fred, my understanding is that
he would also prefer to just eliminate the 32-bit counters
from the diffserv MIB. And I am fine with that.

So I hope that the WG chairs will entertain a bit of
discussion on this, or at least YESorNO emails to see
if we have consensus to remove the 32-bit counters.

Bert 

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Simon Leinen <[email-masked]>
Date: 18 Sep 2001 22:04:36 +0200

>>>>> "wb(" == Wijnen, Bert (Bert) <[email-masked]> writes:

Removing the 32-bit counters is fine with me (an operator :-).
-- 
Simon.