Subject: Re: [Diffserv] DiffServ MIB rev 12 review

From: Fred Baker <[email-masked]>
Date: Thu, 06 Sep 2001 15:12:32 -0700

At 05:08 AM 9/2/2001, Wijnen, Bert (Bert) wrote:
>13. You seem to have discontinuity timestamps (like the
>     diffServCountActDisconTime) per row. Is this really
>     what you want? I don't think I have ever seen it
>     implemented at the row level. I don't think that that
>     is what we intended discontinuity timers for either.
>     It seems to add an extra object to each row while I
>     wonder if discontinuity indeed
>     - happens often
>     - if it does happen, does it then only apply to
>       one row, or does it apply to multiple or possibly
>       all rows in the table.
>     A discontinuity timer per table or per MIB is what
>     we have seen more often.
>
>     This has been done in a few more tables, so it applies
>     to them as well.

Willing enough to move it to the table (right beside ...NextFree) or to the 
MIB level. It seems, though, that this makes an assumption about the 
operating system which is problematic. If the architecture of a single CPU 
which controls and manages a few devices - the usual low-end router design 
- fine. If you have a distributed system, in which you can pull out 
interface cards or add new ones, which themselves implement the forwarding, 
the diffserv processing, and by the way the counters, a discontinuity 
timestamp for the table or MIB seems to not serve.

before writing this, though, I did a bunch of research. What would you 
think of copying the 802.3 MIB's approach? From RFC 2665's 
dot3StatsAlignmentErrors:

       ...
       Discontinuities in the value of this counter can
       occur at re-initialization of the management
       system, and at other times as indicated by the
       value of ifCounterDiscontinuityTime."

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: "Andrew Smith" <[email-masked]>
Date: Thu, 6 Sep 2001 16:21:19 -0700

I thought that, when we originally discussed this, that we wanted to have
discontinuity indicators at the interface level, but I don't recall why we
decided not to do that.

I agree with Fred that per-MIB or per-table is not sufficient and I agree
with Bert that per-row seems like overkill. Another alternative might be to
tie this to the entity MIB e.g. with an OID-pointer - I remember discussing
that with some people at one of the early snmpconf meetings but the feeling
seemd to be that entity MIB was not implemented widely-enough for this to be
viable. Is this something for a new "Discontinuity Indicator MIB"?

Andrew

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Fred Baker
Sent: Thursday, September 06, 2001 3:13 PM
To: Wijnen, Bert (Bert)
Cc: [email-masked]
Subject: Re: [Diffserv] DiffServ MIB rev 12 review

       ...

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive:
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.h
tml