Subject: RE: [Diffserv] Dropper issues

From: "Weiss, Walter" <[email-masked]>
Date: Thu, 23 Aug 2001 17:14:36 -0400

Andrew,

> I'm slightly concerned that we chose not to cover the 
> measuring/smoothing in
> more detail in the Model and yet your proposal for the MIB 
> involves nailing
> down some of that detail - would that over-constrain us 
> moving forward? I
> guess that most of your proposal involves the "plumbing" as 
> opposed to the
> algorithmic details of measuring - could we make it more 
> generic perhaps?
> Your phrase "the set of queues that the dropper is deriving 
> the aggregate
> queue depth from" is what worries me most - do you think we 
> (the WG) have a
> clear enough idea of what "set of" and "deriving the 
> aggregate" mean, to
> translate this phrase into MIBisms? (thinking aloud here).
> 
I share your concern. As I mentioned, the use of the ID works well when
summing queue depths, irrespective of whether they are absolute or weighted.
However, the caculations of queue depths is more complicated then summing,
the current model is insufficient. While I konw of a number of shared
buffering schemes that use simple summing, I am not aware of any that
require more complexity. I don't feel we have painted ourselves into a
corner though. I have not been able to come up with a scenario that could
not be supported by extending this "plumbing" change, as you call it.

regards,

-Walter 

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 24 Aug 2001 12:23:02 -0500

It is still true that the model is not an implementation guide
and the MIB is not intended to be the union of all possible
implementations. I'm not getting a strong sense from the WG that
people want this addition. If you haven't spoken up yet, and
you think we should add this, please say so *now*.

   Brian 
   writing as WG cochair