Subject: RE: [Diffserv] Draft 11 MIB Edits

From: "Weiss, Walter" <[email-masked]>
Date: Mon, 20 Aug 2001 17:48:30 -0400

Brian,

In London, I spoke with Fred and provided him with a skelaton of the MIB
changes. The proposed changes affects 4 scheduler-related classes and add no
new classes. However, the relationships between these classes are changed
significantly. I would say that the complexity (while greater) is comparable
to that of the Classifier. However, these changes permit the configuration
for a broader set of deployed implementations (as indicated in my previous
note). Here is the skelaton I gave to Fred (* indicates additions):

DiffServQEntry ::= SEQUENCE  {
    diffServQId                      INTEGER,
*   diffServQNext                    RowPointer, (points to scheduler
servicing this queue)
    diffServQStatus                  RowStatus
}

DiffServSchedulerEntry ::= SEQUENCE  {
    diffServSchedulerId                   INTEGER,
*   diffServSchedulerNext                 RowPointer, (possibly points to
another scheduler)
*   diffServSchedulerFailNext             RowPointer, (points to another
scheduler for
                                                       which excess
bandwidth is available)
    diffServSchedulerMethod               OBJECT IDENTIFIER,
*   diffServSchedulerParamListId          INTEGER, (describes list of param
table entries
                                                    used by this scheduler)
    diffServSchedulerStatus               RowStatus
}

Scheduler Paramater tables:

DiffServAssuredRateEntry ::= SEQUENCE  {
    diffServAssuredRateId              INTEGER,
*   diffServAssuredRateParamListId     INTEGER, (a common value used by all
param instances
                                                 participating in the same
scheduler)
*   diffServAssuredRateQorSched        RowPointer, (points to the queue or
scheduler for
                                                    which these parameters
are being
                                                    specified)
    diffServAssuredRatePriority        Unsigned32,
    diffServAssuredRateAbs             Unsigned32,
    diffServAssuredRateRel             Unsigned32,
    diffServAssuredRateStatus          RowStatus
}

DiffServShapingRateEntry ::= SEQUENCE  {
    diffServShapingRateId              INTEGER,
*   diffServShapingRateParamListId     INTEGER, (a common value used by all
param instances
                                                 participating in the same
scheduler)
*   diffServShapingRateQorSched        RowPointer, (points to the queue or
scheduler for
                                                    which these parameters
are being
                                                    specified)
    diffServShapingRateLevel           INTEGER,
    diffServShapingRateAbs             Unsigned32,
    diffServShapingRateRel             Unsigned32,
    diffServShapingRateThreshold       BurstSize,
    diffServShapingRateStatus          RowStatus
}

regards,

-Walter

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Sunday, August 19, 2001 2:54 PM
> To: Fred Baker
> Cc: [email-masked]
> Subject: Re: [Diffserv] Draft 11 MIB Edits
> 
> 
> Walter did send some text to the list on August 9th with the
> subject field "Scheduler scenarios for the MIB", but indeed
> I have seen no comments. If you have an opinion about Walter's
> text, either positive or negative, please send it to the list
> so that we can see what people think.
> 
> Apart from that: thanks Fred!
> 
>   Brian
> 
> Fred Baker wrote:
> > 
> > I have, as you will note, asked Natalia to post
> > 
> ftp://ftpeng.cisco.com/fred/diffserv/draft-ietf-diffserv-mib-1
> 1.txt for
> > review. In the same location, you will find
> > 
ftp://ftpeng.cisco.com/fred/diffserv/marked.draft-ietf-diffserv-mib-11.txt,
> which is the result of a diffmk comparison to draft 10.
> 
> I believe that this contains all agreed edits; anyone who has had a
comment
> on the MIB should review it with their comments in mind, and reply to this
> email with any remaining comments.
> 
> In the working group meeting, Walter asked for two major revisions from
the
> mike. He has sent me some sketches of what he is asking for, but I don't
> see those proposals on the working group mailer, and I don't see any
> discussion of them. I would like for the chair to tell me there is
> consensus for the changes he wants made before I go make them. Not that
> they are horrible changes, mind you; I would just like to hear that there
> is consensus to support them.
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/diffserv
> Archive:
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.h
tml

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive:
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.h
tml

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 20 Aug 2001 17:55:57 -0500

Question to the WG: do we *want* this additional capability in the MIB?
(Never mind the details for the moment; this is a question of principle.)

    Brian

---

From: Dan Grossman <[email-masked]>
Date: Tue, 21 Aug 2001 10:28:05 -0400

Walter,
Maybe it's just that I'm dense, and maybe it's just that the morning caffine 
fix hasn't had a chance to soak in, but can you explain what these changes are 
supposed to accomplish?
Tnx
Dan