Subject: Re: [Diffserv] a question on edge-to-edge DiffServ flows

From: [email-masked]
Date: Tue, 7 Aug 2001 01:05:40 -0400

Jay, very interesting thought.  I am afraid, though, when the numbers of E's and
C's are large, like those in real life, it becomes almost intractable.  The min
and max throughputs are getting closer and closer to 0 and the min throughput of
(Ea2nearbyC and Eb2nearbyC) foreach Ea2Eb...

My humble 2 cents.

Yingchao
NetScout Systems

--- Jaeyoung Kim <[email-masked]> wrote:
>
>
>
>
>
> Hi, I have an idea on monitoring edge-to-edge
> DiffServ flows and would
> like to have some comments or related papers on
> this.
>
> When managing a DiffServ domain, it is important to
> have the network-wide
> traffic status of each QoS class in DiffServ
> network. Since each DiffServ
> router can monitor QoS (throughput, drop rate, etc.)
> of each DiffServ
> class it handles, I think it is possible to extract
> edge-to-edge traffic
> status by combining the QoS information monitored in
> each router and
> routing path from one edge router to another.
>
> In the following example network topology with four
> edge routers (E1-E4)
> and two core routers (C1-C2),
>
>  E1---           /---E3
>                 /
>        C1-------C2
>        /

>  E2---/           ---E4
>
> Let's assume there are four different edge-to-edge
> traffic of a DiffServ
> class, E1->E3, E1->E4, E2->E3, E2->E4. Thus, E1 and
> E2 perform source
> edge routers, and E3 and E4 perform sink edge
> routers.
>
> In this situation, I'd like to have traffic status
> of one Edge-to-Edge
> DiffServ flow. The problem here is that all the
> traffic of the same
> DiffServ class are aggregated and undistinguished in
> DiffServ domain.
> That is, the QoS information monitored at each
> router is not for each
> edge-to-edge flow, but for aggregated class overall.
> However, with simple
> rule, I think we can extract QoS of each E-to-E
> traffic.
>
> Let's assume that we are monitoring the throughput
> of a DiffServ class
> in each link within a certain time interval. The
> throughput is indicated
> in the following figure.
>
>  E1---         4/---E3
>                 /
>        C1-------C2
>        /   10

>  E2---/7         6---E4
>
> The throughput monitored in E1->C1 link is 3, E2->C1
> is 7. And the two
> traffic is aggregated in C1->C2 link and the amount
> is 10. Finally, in
> C2 router, the traffic is splitted to 4 for C2->E3,
> and 6 for C2->E4.
>
> >From this throughput information, I think the
> edge-to-edge QoS can be
> obtained like this,
>
> for E1->E3, the maximum throughput is 3 since the
> minimum link througput
> in the routing path from E1 to E3 is 3 at E1->C1
> link. And the minimum
> throughput is 0 when every traffic leaving E1 router
> transferred to
> E4 router.
>
> for E2->E3, the maximum throughput is 4 since the
> minimum link throughput
> in the routing path is 4 at C2->E3 link. And the
> minimum throughput is
> 1 when all the traffic at C2->E4 link is from the
> router E2.
>
> I found that the real throughput of every E-to-E
> traffic is bounded with
> this min/max value. And I'd like to use this metric
> to control DiffServ
> network.
>
> Is there anybody have similar interests and valuable
> comments on this idea?
> Thank you so much in advance.
>
> Sincerely,
> Jay Kim
> --
>
============================================================================
>  __/__ ** Remember Yesterday, Dream about Tomorrow,
> but ... LIVE TODAY !!!
>   / /
>
-------------------------------------------------------------------
>  /_/_ ** [email-masked]
> http://home.postech.ac.kr/~jay
>    /   ** Jaeyoung Kim      Computer Science &
> Engineering, POSTECH, KOREA
>
>
>
> _______________________________________________
> diffserv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/diffserv
> Archive:
>
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 07 Aug 2001 12:25:14 -0500

This discussion was redirected to the diffserv-interest list
http://www1.ietf.org/mailman/listinfo/diffserv-interest

   Brian