Subject: [Diffserv] Scheduler query!

From: "Akhilesh Kumar Sah" <[email-masked]>
Date: Fri, 24 Aug 2001 10:53:15 +0530

Hi ,

We have to implement a scheduler for Diffserv we are having few problems -In case of Diffserv we can have three types of queues i.e AF queue ,EF queue and Best Effort Queue. 

Can a single scheduler take care of forwarding packets from all these queues. 

As for as EF queues are concerned they are high prcannot tolerate delay  .

In case of AF bandwidth sharing can take place. So how are these  queues and taken care . Can the scheduler using WRR with 

priority(improvement over WRR taking care of Priority  also )take care of this one by assigning  high priority to EF and the lower priority to the AF queues .

Or do we need different Schedulers for AF ,EF and best effort queues working independenty.

Thanks and Regards,

Akhilesh

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 24 Aug 2001 12:20:11 -0500

I suggest you study the MIB quite carefully. You will notice that the schedulers
described by the MIB are quite neutral with respect to any particular PHB. Of course
you would expect to run multiple schedulers if you are supporting multiple PHBs,
but the basic scheduler logic is not dedicated to any PHB.

For this type of question, it is better to try the diffserv implementation list.
See http://www.atnf.csiro.au/news/exploders/dsimplementation.html

   Brian

> Akhilesh Kumar Sah wrote:
> 
> Hi ,
> 
> We have to implement a scheduler for Diffserv we are having few problems -In case of Diffserv we can have three types of
> queues i.e AF queue ,EF queue and Best Effort Queue.
> 
>                            Name: Wipro_Disclaimer.txt
>    Wipro_Disclaimer.txt    Type: Plain Text (text/plain)
>                        Encoding: 7bit

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Board Chairman, Internet Society http://www.isoc.org

"We shall need a number of efficient librarian types 
 to keep us in order." - Alan Turing, 1947.

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html