Subject: RE: [Diffserv] Token bucket meters

From: Shahram Davari <[email-masked]>
Date: Tue, 24 Jul 2001 07:02:23 -0700

Jayaram,

My understanding is that Appendix A.4 assumes that "t'" is the time that the last byte of the packet is received. This is called a strict token bucket. 

The draft also talks about a loose token bucket in which, you accept the packet without knowing its length, and after you receive the whole packet and you know the exact size of the packet, then you adjust the number of tokens, possibly to a negative value to account for packets that required more tokens that existed at the time of their arrival.

The Strict and Loose TB are the extreme ends of the possible TB implementation. Any other implementation is probably something in between. Therefore it is perfectly acceptable to assume "t'" being the time of arrival of the first byte of the packet if you know the length of the packet in advance (which may not be practical with variable length IP packets), or if you guess the size of the packet, etc.

So my answer is that the implementation is not a matter of standard, rather a matter of engineering compromise, practicality and taste.

Yours,
-Shahram  

> -----Original Message-----
> From: Jayaram Beladakere [mailto:[email-masked]]
> Sent: Tuesday, July 24, 2001 12:05 AM
> To: [email-masked]
> Subject: [Diffserv] Token bucket meters
> 
> 
> Referring to the discussions on token buckets in Diffserv Informal
> Management Model, Feb. 2001.  There is description of a 
> packet of length L
> arriving at time t' (Appendix A.4).  Is there any assumption 
> about when t'
> should be taken?  That is, is t' the time of arrival of the 
> first byte of
> the packet or the last byte of the packet?  Does this 
> selection of time
> matter for the operation of token bucket?  Is one selection 
> preferable?
> 
> Regards,
> Jayaram Beladakere
> Mahi Networks, Inc.
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive: 
> http://www2.ietf.org/mail-archive/working-groups/diffserv/curr
ent/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 24 Jul 2001 11:23:54 -0500

Correct. The model is *informal* and doesn't attempt to standardise this
with mathematical precision, since different vendors might prefer different
solutions.

   Brian