Subject: Re: [Diffserv] I-D ACTION:draft-bless-diffserv-mcast-routerext-00 .txt (fwd)

From: Roland Bless <[email-masked]>
Date: Tue, 24 Jul 2001 09:29:36 +0200

Albert,

> This I-D makes the case for allowing individual DS codepoints for each DS
> tunnel or physical interface used by a multicast router to distribute IP
> multicast packets.

Yes.

> You say in your I-D:
> 
>    A virtual interface means in this context,
>    that it is either a multicast tunnel or a real physical network
>    interface. So there may be several configured tunnels over one
>    physical interface present. The multicast routing table entry
>    contains usually information about the multicast group address
>    (destination address), source address and (virtual) outgoing
>    interfaces where packets should be copied to during packet
>    forwarding.
> 
> I believe that a "virtual interface" in the context of this I-D might
> potentially be defined as any combination of source and destination IP
> address, source and destination UDP port ID, incoming DS codepoint, _and_
> outgoing physical interface? (The Protocol field will always indicate UDP.)

Yes, the entry should basically identify the pair of tunnel endpoints.
Personally, I don't think it's a good idea to assume always UDP as 
protocol. We don't know what mcast-capable transport protocols will be 
used instead of UDP one day in future. 

> If you agree with this, perhaps the word "only" in the abstract:
> 
>    Only one additional DS
>    codepoint for each virtual interface in the multicast routing table
>    is required to open up a variety of different uses, ...
> 
> should be deleted. This could be a large number of additional codepoints, in
> principle.

I disagree here, because it really depends on how many tunnel endpoints
or branches you have. "Only" means the overhead compared to one
complete entry/row in the multicast routing table that describes a
virtual interface. So one additional byte for the DSCP in comparison to
your above list of source/dest IP addresses and ports (which are already
12 bytes for IPv4) is not that much... So if you have a large number of
additional codepoints you'll also have a large number of virtual 
interfaces anyway, and that's why the overhead is still small in relation
to the whole multicast routing table.

Regards,
 Roland

-- 
Roland Bless -- e-Mail: [email-masked]
Institute of Telematics, University of Karlsruhe, Germany  
Zirkel 2, D-76128 Karlsruhe -- Office: Bld. 20.20, 3rd floor, R 358
Phone: +49 721 608-6413 Fax: +49 721 388097

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Mon, 23 Jul 2001 10:15:36 -0400

Roland,

You say in your I-D:

   Only one additional DS

Bert

> -----Original Message-----
> From: Roland Bless [mailto:[email-masked]]
> Sent: Friday, July 20, 2001 12:37 PM
> To: Brian E Carpenter
> Cc: [email-masked]
> Subject: Re: [Diffserv] I-D
> ACTION:draft-bless-diffserv-mcast-routerext-00.txt (fwd)
> 
> 
> Brian,
> 
> > Have you discussed with the Routing ADs how to follow up on this? 
> > That is certainly something to do in London.
> 
> Yes, I followed Kathie's advice to contact them in order to
> get a hint for an appropriate WG for discussion of this issue.
> So we already contacted the Routing ADs by e-mail, but Rob wanted 
> to know something about the operational requirements for this work 
> (this was before we wrote the draft). Therefore, we'd like to get 
> feedback from the community. However, we are looking forward to 
> discuss about it in London.
> 
>  Roland
> 
> P.S.: Will the diffserv WG meet in London? I didn't see any
> agenda yet.
> 
> >    Brian
> > 
> > Roland Bless wrote:
> > > 
> > > Hi,
> > > 
> > > when looking back to 46th IETF meeting minutes, there are still
> > > some open multicast issues. This short proposal might be 
> of interest
> > > for some people here. It would be nice to get any 
> feedback from people
> > > here, especially manufacturers of routers.
> > > 
> > > Regards,
> > >  Roland
> > > 
> > > P.S.: Sorry, I currently don't know any other WG that is 
> more appropriate
> > > for discussion of this issue.
> > > 
> > > ------- Forwarded Message
> > > A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> > > 
> > >         Title           : A Router Extension to Support 
> Multicast in
> > >                           Differentiated Services Networks
> > >         Author(s)       : R. Bless, K. Wehrle
> > >         Filename        : 
> draft-bless-diffserv-mcast-routerext-00.txt
> > >         Pages           : 4
> > >         Date            : 16-Jul-01
> > > 
> > > This draft proposes an extension to the multicast routing table in
> > > routers in order to achieve better support for using multicast
> > > within Differentiated Services (DS) networks. Only one 
> additional DS
> > > is required to open up a variety of different uses, e.g., to solve
> > > resource provisioning problems or to support 
> heterogeneous DiffServ
> > > multicast groups.
> > > 
> > > A URL for this Internet-Draft is:
> > > 
> http://www.ietf.org/internet-drafts/draft-bless-diffserv-mcast
-routerext-00.txt

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive:
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.h
tml

_______________________________________________
diffserv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html