Subject: [Diffserv] Token bucket meters

From: Jayaram Beladakere <[email-masked]>
Date: Mon, 23 Jul 2001 21:04:48 -0700

Referring to the discussions on token buckets in Diffserv Informal
Management Model, Feb. 2001.  There is description of a packet of length L
arriving at time t' (Appendix A.4).  Is there any assumption about when t'
should be taken?  That is, is t' the time of arrival of the first byte of
the packet or the last byte of the packet?  Does this selection of time
matter for the operation of token bucket?  Is one selection preferable?

Regards,
Jayaram Beladakere
Mahi Networks, Inc.

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Steve Blake <[email-masked]>
Date: Tue, 24 Jul 2001 13:39:17 -0400

> matter for the operation of token bucket?  Is one selection preferable?

The equations should hold for either case, as long as you are consistent.

Regards,

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Steven L. Blake               <[email-masked]>
Ericsson IP Infrastructure                  (919)472-9913