Subject: RE: [Diffserv] Instantiations of EF PHB

From: Sasha Vainshtein <[email-masked]>
Date: Sun, 24 Jun 2001 19:08:55 +0200

Anna,
Thank you for a prompt response. 
It is somewhat difficult to see what does it mean having
two instances of EF PHB with the same values of Ea and Ep parameters,
because, if
you load your router with two flows -one from each such instance -
simultaneously,
your observed behavior is presumably the same as if there were only one EF
instance.
I admit that having multiple EF PHB instances with different Ea and Ep
parameters
is possible. (Whether anyone would ever need or support it is another
matter).

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Anna Charny [mailto:[email-masked]]
> Sent: Sunday, June 24, 2001 3:12 PM
> To: Sasha Vainshtein
> Cc: [email-masked]'; [email-masked]'; Alik Shimelmits; 
> Gonen Zilber; Elena Vinkler
> Subject: Re: [Diffserv] Instantiations of EF PHB
> 
> 
> Sasha,
> 
> At 10:02 AM 6/24/2001 +0200, Sasha Vainshtein wrote:
> >Bruce,
> >I have read <draft-ietf-diffserv-rfc2598bis-01.txt>
> >and I have the following question:
> >Is it possible for a DS router to instantiate more than one 
> instance of EF?
> 
> There appears to be no reason why a DS router cannot have 
> many instances of 
> EF PHB.
> 
> >If so, what exactly would it mean?
> 
> It would mean that each instance of EF PHB would be 
> characterized by the 
> two sets of equations in the rfc2598bis, each instance 
> potentially having 
> its own values of Ea and Ep  (although it could also be that 
> all instances 
> have the same values of these parameters).
> 
> >(Intuitively it looks like it is not.
> 
> What problem do you see with having multiple EF instances?
> 
> Best regards,
> Anna
> >  If so,
> >may be it should be explicitly stated in the text.)
> >With best regards,
> >                                    Sasha Vainshtein
> >email:     [email-masked]
> >tel:       +972-3-7659993 (office)
> >            +972-8-9254948 (res.)
> >            +972-58-674833 (cell.)
> >
> >_______________________________________________
> >diffserv mailing list
> >[email-masked]
> >http://www1.ietf.org/mailman/listinfo/diffserv
> >Archive: 
> >http://www2.ietf.org/mail-archive/working-groups/diffserv/cur
rent/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Anna Charny <[email-masked]>
Date: Sun, 24 Jun 2001 15:26:34 -0400

Sasha,

>your observed behavior is presumably the same as if there were only one EF

Actually, this is not necessarily so. Suppose you have a simple 
hierarchical scheduler
where there is a  high priority class, which is shared by two queues inside 
the class, one per a separate instance of EF,
served by some scheduler (doesn't matter which). Since both queues are 
served by the same hierarchical scheduler, they can both be characterized 
by the same Ea and Ep values. Yet, the per-packet behavior observed in the 
case where you feed the scheduler with two EF instances will be different 
than if you only had one EF instance.

It is of course all a matter of semantics - you could decide to call the 
same scenario as having one instance of EF PHB with per-subaggregate 
scheduling.

But the point is - in principle you can have as many EF instances as you 
are willing to spare codepoints for.

Anna

>http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 25 Jun 2001 11:24:09 -0500

Anna is correct, and this is in no way specific to EF- you can have multiple
instances of almost any PHB, with identical parameters, as long as they
are fed by distinct classifiers and have distinct DSCPs.

This is allowed by the diffserv architecture and is made explicit,
for example, in RFC 2597 with its reference to N independent AF classes.

The exception to this would be the Default PHB and the seven Class
Selector PHBs, since they are defined in RFC 2474 with non-mapped
code points.

As a general feature of the architecture, this doesn't need to be
mentioned in RFC 2598bis.

    Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Board Chairman, Internet Society http://www.isoc.org

---

From: demir <[email-masked]>
Date: Mon, 25 Jun 2001 17:18:15 -0700 (PDT)

Unfortunatelly, there is only one DSCP RECOMMENDED for EF PHB. I assume
the other instances be EF-alike PHBs which are experimental having their
PDBs defined for themselves.

Alper K. Demir

---

From: "Scott Brim" <[email-masked]>
Date: Mon, 25 Jun 2001 21:46:30 -0400

> PDBs defined for themselves.

Your first sentence is about PHB indication by DSCPs, and your second is
about the PHBs themselves.  There is only one recommended PHB-DSCP
mapping, true, but you can have multiple instances of EF indicated by
different DSCPs than the recommended one.

...Scott

---

From: demir <[email-masked]>
Date: Tue, 26 Jun 2001 02:59:18 -0700 (PDT)

> different DSCPs than the recommended one.

I thought there would be only one EF PHB instance in a DS domain; as a
result, only one corresponding PDB using EF PHB in a DS domain. An
experimental PHB (using an experimental DSCP) could be configured the same
as EF PHB (that's why I called EF-alike); as a result, a PDB using the
EF-alike experimental PHB; as a result another EF instance on a hop. Isnt'
taht right? 
/OR a DS domain might define one/many EF PHB(s) assigning different
DSCP(s) for each among the ones (DSCPs) that can be assigned; as a result,
corresponding PDB(s). If so, can one define a PDB using more than one EF
PHBs (i.e. to have priorities).

Alper K. Demir

---

From: "Scott Brim" <[email-masked]>
Date: Tue, 26 Jun 2001 09:17:04 -0400

On 26 Jun 2001 at 02:59 -0700, demir apparently wrote:
> result, only one corresponding PDB using EF PHB in a DS domain.

As Brian said Monday:

| Anna is correct, and this is in no way specific to EF- you can have
| multiple instances of almost any PHB, with identical parameters, as
| long as they are fed by distinct classifiers and have distinct DSCPs.

> PHBs (i.e. to have priorities).

I don't understand what priorities in a PDB based on EF would mean.
Maybe someone else does.

...Scott

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 26 Jun 2001 08:35:03 -0500

> EF-alike experimental PHB; as a result another EF instance on a hop. Isnt'

No. You have missed the point of the very fundamental choice in diffserv
that *all* codepoints are mapped to PHBs (except for Default and Class
Selectors). If you want to run 56 instances of EF in one domain that is
perfectly compatible with the architecture; i.e. you map all the code
points except xxx000 to distinct instances of EF. You would need 56
distinct classifiers at the ingress of course.

> corresponding PDB(s). 

Exactly.

> If so, can one define a PDB using more than one EF

I'm not sure why you would want to do that. Since EF assigns specific 
capacity to its PDB, there is no notion of priority - if you have two
independent EF PDBs, they are not competing for capacity.

   Brian

---

From: demir <[email-masked]>
Date: Tue, 26 Jun 2001 11:18:02 -0700 (PDT)

> Selectors). If you want to run 56 instances of EF in one domain that is

I am not sure how you concluded that I have missed the very fundamental
choice on mapping. I am very aware of it :)

> independent EF PDBs, they are not competing for capacity.

There is no notion of priority in EF PHB itself. This could provide "delay
variation" priority /or am I missing something?

Alper K. Demir

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 26 Jun 2001 15:16:50 -0500

> choice on mapping. I am very aware of it :)

I apologize for my choice of words.

   Brian

"We shall need a number of efficient librarian types 
 to keep us in order." - Alan Turing, 1947.