Subject: RE: [Diffserv] DSCP --> 802.1p

From: [email-masked]
Date: Fri, 18 May 2001 09:28:12 +0800

Hi,

Brian: Current switches are hardly L2, since a few incorporate sofisticated flow indentification and matching algorithms. This flow matching is incorporated to monitor flows/assign priority to flows etc. Even the low end switches have the capability of "atleast" checking the ToS IP field. In this case mismatch between L2 packet priority and L3->L2 mapped priority may arise.

Xiaoning: L3 devices must perform priority regeneration at the edge of an L2 network to assign a L2 priority consistant with the management policies of the L2 network and the service level expected by the packet (as per the DSCP field). Infact the Ethernet standard provided for such priority regenration. However if the edge L3 devives do not do this OR do this incorrectly then I agress with Xiaoning's suggestion that each switch must perform its own L3->L2 mapping i.e. L3 priority must be given precedence over L2 priority.

-Mubarak.

-----Original Message-----
From: Nie Xiaoning (CPD AA PP) 
Sent: Friday, May 18, 2001 1:07 AM
To: Shridhar Mubaraq Mishra (DC SIN COM); [email-masked]
Subject: AW: [Diffserv] DSCP --> 802.1p 

In a layer 3 processing you may have to map from your DSCP to L2 prio while the received l2 prio was assigned by the previous switch.
As DSCP semantics is defined per hop some policy mechnisms are required to ensure the consisteny of
the "mapping-chain".

-Xiaoning

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]]
Gesendet am: Donnerstag, 17. Mai 2001 09:41
An: [email-masked]
Betreff: Re: [Diffserv] DSCP --> 802.1p 

Brian,

The problem is not so much in mapping but in resolving the following situation-

When a switch receives a packet with a certain L2 priority and a different L2 priority is determined via the mapping process, which priority should be given preference ?

Regards,
Mubarak.

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 18 May 2001 11:38:09 -0500

But it's precisely so that switches don't need to commit layer violations that we
invented diffserv. If the traffic source has made an informed choice of hardware
priority on the basis of diffserv, the switch has no business changing it.

   Brian

N.B. I haven't switched this to the diffserv-interest list because that list
has temporarily gone away - as soon as it exists again I will inform this list.