Subject: [Diffserv] Un-recognized color in the color-aware marker

From: "Man Trinh" <[email-masked]>
Date: Fri, 25 May 2001 11:18:27 -0700

Hi,

In a color-aware srTCM or trTCM, how is the incoming data with an un-recognized color be treated.  Should it be treated as red?

Thanks,
-Man

---

From: "Jay Wang" <[email-masked]>
Date: Fri, 25 May 2001 12:58:10 -0700

Man,

That is the job of your meter/marker. Measure it and give it a color.

thanks,

- Jay
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Man Trinh
  Sent: Friday, May 25, 2001 11:18 AM
  To: [email-masked]
  Subject: [Diffserv] Un-recognized color in the color-aware marker

  Hi,

  In a color-aware srTCM or trTCM, how is the incoming data with an
un-recognized color be treated.  Should it be treated as red?

  Thanks,
  -Man

---

From: "Man Trinh" <[email-masked]>
Date: Fri, 25 May 2001 15:51:23 -0700

Hi Jay,

I am sorry, I didn't make the question clear.  In the color-aware marker, the metering/marking also takes the incoming color into account.  You don't want to promote a packet marked with color red to either yellow or green even if the packet is in-profile.  The question is what if the incoming color of the packet is neither red, yellow, or green, should the packet be treated as a red-color packet and should not be promote to yellow/green even if it is in-profile.

Thanks,
-Man

  ----- Original Message ----- 
  From: Jay Wang 
  To: Man Trinh ; [email-masked] 
  Sent: Friday, May 25, 2001 12:58 PM
  Subject: RE: [Diffserv] Un-recognized color in the color-aware marker

  Man,

  thanks,
   
  - Jay
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of Man Trinh
    Sent: Friday, May 25, 2001 11:18 AM
    To: [email-masked]
    Subject: [Diffserv] Un-recognized color in the color-aware marker

    Hi,

    Thanks,
    -Man

---

From: "Jay Wang" <[email-masked]>
Date: Fri, 25 May 2001 18:03:47 -0700

Hi Man,

I think this is a policy issue. The Diffserv policy setting for the box
really should
tell you what to do - meter and mark every single incoming packet, meter and
mark
only those without a known color, or perhaps even something else. For
example, if
I am providing VoIP services and VoIP packets are mapped to EF. Then I
probably
want to be very careful as to who gets the EF-GREEN status along the path.
For AF,
I may not be as strict. So the policy may even depend on the PHB groups.
This is
just my opinion. You may look into the DS PIB draft to see how it is
recommended
on this also. You also mentioned that an intermediate node should not
promote a packet.
Even that, I don't think this should be a fixed DS node behavior. Rather, it
should be
policy-configurable too and it is not difficult to come up with a reason why
this is
desirable too.

thanks,

- Jay

  -----Original Message-----
  From: Man Trinh [mailto:[email-masked]]
  Sent: Friday, May 25, 2001 3:51 PM
  To: Jay Wang; [email-masked]
  Subject: Re: [Diffserv] Un-recognized color in the color-aware marker

  Hi Jay,

  I am sorry, I didn't make the question clear.  In the color-aware marker,
the metering/marking also takes the incoming color into account.  You don't
want to promote a packet marked with color red to either yellow or green
even if the packet is in-profile.  The question is what if the incoming
color of the packet is neither red, yellow, or green, should the packet be
treated as a red-color packet and should not be promote to yellow/green even
if it is in-profile.

  Thanks,
  -Man

    ----- Original Message -----
    From: Jay Wang
    To: Man Trinh ; [email-masked]
    Sent: Friday, May 25, 2001 12:58 PM
    Subject: RE: [Diffserv] Un-recognized color in the color-aware marker

    Man,

    thanks,

    - Jay
      -----Original Message-----
      From: [email-masked] [mailto:[email-masked]]On
Behalf Of Man Trinh
      Sent: Friday, May 25, 2001 11:18 AM
      To: [email-masked]
      Subject: [Diffserv] Un-recognized color in the color-aware marker

      Hi,

      Thanks,
      -Man

---

From: "Andrew Smith" <[email-masked]>
Date: Fri, 25 May 2001 18:33:32 -0700

Not sure it's as complicated as that. Just define "red = NOT green AND NOT
yellow" or some other suitable dependency. We wrote several times in the DS
Model and MIB documents that classifiers had to be "complete" in that sense.
I guess that is a "policy".

Andrew

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Jay Wang
Sent: Friday, May 25, 2001 6:04 PM
To: Man Trinh; Jay Wang; [email-masked]
Subject: RE: [Diffserv] Un-recognized color in the color-aware marker

Hi Man,

thanks,

- Jay

-----Original Message-----
From: Man Trinh [mailto:[email-masked]]
Sent: Friday, May 25, 2001 3:51 PM
To: Jay Wang; [email-masked]
Subject: Re: [Diffserv] Un-recognized color in the color-aware marker

Hi Jay,

Thanks,
-Man

----- Original Message -----
From: Jay Wang
To: Man Trinh ; [email-masked]
Sent: Friday, May 25, 2001 12:58 PM
Subject: RE: [Diffserv] Un-recognized color in the color-aware marker

Man,

thanks,

- Jay
-----Original Message-----

Hi,

Thanks,
-Man

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html