Subject: [Diffserv] logical view of a PHB deployment in a multi-port router

From: "Sergio Andreozzi" <[email-masked]>
Date: Tue, 8 May 2001 18:18:53 +0300

A behaviour aggregate is defined as "a collection of packets with the same
codepoint crossing a link in a particular direction"

A PHB is defined as "a description of the externally observable forwarding
treatment applied at a differentiated services-compliant node to a behavior
aggregate".

Let us consider the following network topology with EF BAs crossing the edge
1 & 2 towards the core network.
In the core1 router I want to implement the EF PHB.

Q1: Which is the correct logical view of the EF PHB deployment in the core1
router?

Ex1. there are two EF PHBs, one for each egress interface. The related BA is
the outgoing EF BA.

            EF BA 1                    EF BA 3
    ------	--->		       	     --->    --------
    |edge1|-----------		      -------------|core2 | ----
    ------            \            /		 --------
                       \  EF PHB  /
                        \ ------ /
                         |core1 |
                        / ------\
             EF BA 2   /         \   EF BA 4
    ------      --->  /		    \   --->      -------
    |edge2|-----------		     -------------|core3 |------
    ------                                      -------

ingress interface (from edge1)                    egress interface (to
core2)
          +-------------+     +---------+     +-------------+
          | ingress:    |     |         |     | egress:     |
          |   classify, |     |         |     |   classify, |
      --->|   meter,    |---->|         |---->|   meter,    |--->
          |   action,   |     |         |     |   action,   |
          |   queueing  |     | routing |     |   queueing  |
          +-------------+     |  core 1 |     +-------------+
                              |         |
ingress interface (from edge2)|         |      egress interface (to core3)
          +-------------+     |         |     +-------------+
          | ingress:    |     |         |     | egress:     |
          |   classify, |     |         |     |   classify, |
      --->|   meter,    |---->|         |---->|   meter,    |--->
          |   action,   |     |         |     |   action,   |
          |   queueing  |     +---------+     |   queueing  |
          +-------------+                     +-------------+

Regards,

Sergio Andreozzi

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 09 May 2001 07:32:04 -0500

I think the general assumption is that you *must* perform tarffic conditioning
on every outbound interface, but some implementors may *also* perform traffic
conditioning at the inbound interface.

If you want an extended discussion I suggest taking it to the ds-implementation
list.

   Brian