Subject: Re: [Diffserv] DSCP --> 802.1p

From: [email-masked]
Date: Thu, 17 May 2001 15:41:09 +0800

Brian,

The problem is not so much in mapping but in resolving the following situation-

When a switch receives a packet with a certain L2 priority and a different L2 priority is determined via the mapping process, which priority should be given preference ?

Regards,
Mubarak.

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: [email-masked]
Date: Thu, 17 May 2001 19:07:21 +0200

In a layer 3 processing you may have to map from your DSCP to L2 prio while the received l2 prio was assigned by the previous switch.
As DSCP semantics is defined per hop some policy mechnisms are required to ensure the consisteny of
the "mapping-chain".

-Xiaoning

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]]
Gesendet am: Donnerstag, 17. Mai 2001 09:41
An: [email-masked]
Betreff: Re: [Diffserv] DSCP --> 802.1p 

Brian,

Regards,
Mubarak.

---

From: "Iliff, Tina" <[email-masked]>
Date: Fri, 18 May 2001 18:14:26 +0000

Thanks, I was trying to follow the discussion and use the same terminology
as used in the discussion...although it may have been incorrect.  I agree.
The issue is this:  the 802.1 priority policy is managed locally by an
enterprise, the DSCP Marking policy is controlled by the ISP based on the
SLA.  The ISP will need knowledge of the enterprise's 802.1 priority traffic
mapping in order to map their DSCP policy correctly.  Well, maybe routers
should not use 802-type classification.  Switches should use Layer 2
classification policy and routers should use Layer 3 classification policy.
Tina Iliff

		-----Original Message-----
		From:	Brian E Carpenter [mailto:[email-masked]]
		Sent:	Friday, May 18, 2001 12:55 PM
		To:	Iliff, Tina
		Cc:	[email-masked]; [email-masked];
[email-masked]
		Subject:	Re: [Diffserv] DSCP --> 802.1p

		Terminology alert. Diffserv classification is typically an
ingress 
		*router* function. A level 2 switch isn't a router. Of
course, if the
		router and switch functions happen to be in a single box,
that's fine,
		but it doesn't change the principle.

		The point is that it's a level 3 function, whether it's in a
host or
		an ingress router. A level 2 device shouldn't second-guess
the level
		3 decision.

		   Brian

		> "Iliff, Tina" wrote:
		> 
		> However, are you referring to the application host as the
traffic source?  The ISP may provision policy in switches which
		> follows SLAs and this priority policy may differ from
local policy on the hosts.  In this situation, the policy in the switch
		> should override the host marking of the packet.  However,
if the policy for the host is managed by the ISP, then this
		> situation should not occur.
		> 
		> Please let me know if I am misunderstanding the
discussion.
		> Regards,
		> Tina Iliff
		> 
		>           -----Original Message-----
		>           From:   Brian E Carpenter
[mailto:[email-masked]]
		>           Sent:   Friday, May 18, 2001 11:38 AM
		>           To:     [email-masked]
		>           Cc:     [email-masked];
[email-masked]
		>           Subject:        Re: [Diffserv] DSCP --> 802.1p
		> 
		>           But it's precisely so that switches don't need
to commit layer violations that we
		>           invented diffserv. If the traffic source has
made an informed choice of hardware
		>           priority on the basis of diffserv, the switch
has no business changing it.
		> 
		>              Brian
		> 
		>           N.B. I haven't switched this to the
diffserv-interest list because that list
		>           has temporarily gone away - as soon as it exists
again I will inform this list.
		> 
		>           [email-masked] wrote:
		>           >
		>           > Hi,
		>           >
		>           > Brian: Current switches are hardly L2, since a
few incorporate sofisticated flow indentification and matching
		>           algorithms. This flow matching is incorporated
to monitor flows/assign priority to flows etc. Even the low end
		>           switches have the capability of "atleast"
checking the ToS IP field. In this case mismatch between L2 packet
		>           priority and L3->L2 mapped priority may arise.
		> 
		>           >
		>           > Xiaoning: L3 devices must perform priority
regeneration at the edge of an L2 network to assign a L2 priority
		>           consistant with the management policies of the
L2 network and the service level expected by the packet (as per the
		>           DSCP field). Infact the Ethernet standard
provided for such priority regenration. However if the edge L3 devives do
		>           not do this OR do this incorrectly then I agress
with Xiaoning's suggestion that each switch must perform its own
		>           L3->L2 mapping i.e. L3 priority must be given
precedence over L2 priority.
		> 
		>           >
		>           > -Mubarak.
		>           >
		>           > -----Original Message-----
		>           > From: Nie Xiaoning (CPD AA PP)
		>           > Sent: Friday, May 18, 2001 1:07 AM
		>           > To: Shridhar Mubaraq Mishra (DC SIN COM);
[email-masked]
		>           > Subject: AW: [Diffserv] DSCP --> 802.1p
		>           >
		>           > In a layer 3 processing you may have to map
from your DSCP to L2 prio while the received l2 prio was assigned by
		>           the previous switch.
		> 
		>           > As DSCP semantics is defined per hop some
policy mechnisms are required to ensure the consisteny of
		>           > When a switch receives a packet with a certain
L2 priority and a different L2 priority is determined via the
		>           mapping process, which priority should be given
preference ?

---

From: [email-masked]
Date: Mon, 21 May 2001 12:03:23 +0200

Brian,

agree with your statement: the L2 device shouldnt second-guess the L3 decision
but moreover, the code mapping into L2 should help to keep the QoS semantics
accross a L2 bridged network as close as possible to the policy at L3.

-Xiaoning

-----Ursprüngliche Nachricht-----
Von: Brian E Carpenter [mailto:[email-masked]]
Gesendet am: Freitag, 18. Mai 2001 19:55
An: Iliff, Tina
Cc: [email-masked]; [email-masked]; [email-masked]
Betreff: Re: [Diffserv] DSCP --> 802.1p

Terminology alert. Diffserv classification is typically an ingress 
*router* function. A level 2 switch isn't a router. Of course, if the
router and switch functions happen to be in a single box, that's fine,
but it doesn't change the principle.

The point is that it's a level 3 function, whether it's in a host or
an ingress router. A level 2 device shouldn't second-guess the level
3 decision.

   Brian

> "Iliff, Tina" wrote:
> 
> However, are you referring to the application host as the traffic source?  The ISP may provision policy in switches which
> follows SLAs and this priority policy may differ from local policy on the hosts.  In this situation, the policy in the switch
> should override the host marking of the packet.  However, if the policy for the host is managed by the ISP, then this
> Please let me know if I am misunderstanding the discussion.
> Regards,
> Tina Iliff
> 
>           Cc:     [email-masked]; [email-masked]
>           But it's precisely so that switches don't need to commit layer violations that we
>           invented diffserv. If the traffic source has made an informed choice of hardware
>           priority on the basis of diffserv, the switch has no business changing it.
> 
>              Brian
> 
>           N.B. I haven't switched this to the diffserv-interest list because that list
>           has temporarily gone away - as soon as it exists again I will inform this list.
> 
>           > Brian: Current switches are hardly L2, since a few incorporate sofisticated flow indentification and matching
>           algorithms. This flow matching is incorporated to monitor flows/assign priority to flows etc. Even the low end
>           switches have the capability of "atleast" checking the ToS IP field. In this case mismatch between L2 packet
>           > Xiaoning: L3 devices must perform priority regeneration at the edge of an L2 network to assign a L2 priority
>           consistant with the management policies of the L2 network and the service level expected by the packet (as per the
>           DSCP field). Infact the Ethernet standard provided for such priority regenration. However if the edge L3 devives do
>           not do this OR do this incorrectly then I agress with Xiaoning's suggestion that each switch must perform its own
>           L3->L2 mapping i.e. L3 priority must be given precedence over L2 priority.
> 
>           >
>           > -Mubarak.
>           >
>           > To: Shridhar Mubaraq Mishra (DC SIN COM); [email-masked]
>           > When a switch receives a packet with a certain L2 priority and a different L2 priority is determined via the
>           mapping process, which priority should be given preference ?
> 
>           >
>           > Regards,
>           > Mubarak.
>

---

From: "Iliff, Tina" <[email-masked]>
Date: Wed, 23 May 2001 14:03:05 +0000

In my opinion, the L2 device would classify based on MAC address, etc and
mark the 802.1p priority based on its mapping policy.
Tina Iliff

		-----Original Message-----
		From:	Michiel van Everdingen
[mailto:[email-masked]]
		Sent:	Wednesday, May 23, 2001 5:00 AM
		To:	Diffserv
		Subject:	Re: [Diffserv] DSCP --> 802.1p

		Hello,

		Andrew Smith wrote:
		> ..<snip>..
		> 2. IEEE 802.1D
(http://standards.ieee.org/reading/ieee/std/lanman/802.1D-1998.pdf) clause 7
		> (see particularly Tables 7-1 and 7-2) contains rules for
what to do in this
		> case: 802.1 switch must "regenerate" a user_priority based
on a mapping
		> table; this table contains defaults which may be modified
by management (see
		> e.g. RFC 2674) or which handle the case where no incoming
priority is
		> available. There is no mention in IEEE 802.1D of using the
DSCPs.
		> ..<snip>..

		Consider the case in which an L3 device is connected to an
802.3 L2
		network (no priorities) and an L2 device bridges the packets
from
		this 802.3 network to an 802.1p network (with priorities).

		Questions:
		- Is the L2 device allowed to look into the DSCP to guess L2
		  priority to be used on the 802.1p network ?
		- If yes, should the mapping DSCP -> 802.1p be standardized
		  (looking at e.g. the mapping of mpls exp field as Juha
suggests) ?

		Thanks,

		Michiel

		-- 

+------------------------------------------------------------------+
		| Michiel van Everdingen
|
		| Lucent Technologies - Optical Networking Group - AONe
|
		| Botterstraat 45, 1271 XL       Phone : +31 35 687 4883
|
		| P.O. Box 18, 1270 AA           Fax   : +31 35 687 5976
|
		| Huizen, The Netherlands
mailto:[email-masked]  |
	
+------------------------------------------------------------------+

		_______________________________________________
		diffserv mailing list
		[email-masked]
		http://www1.ietf.org/mailman/listinfo/diffserv
		Archive:
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.h
tml