Subject: RE: [Diffserv] API for COPS

From: "Alexander Hagen" <[email-masked]>
Date: Tue, 8 May 2001 08:47:54 -0700

Personal Opinion:

Check out:
http://www.networkcomputing.com/1024/1024f1.html

A little dated but perhaps a good starting point.

For my two cents, Cisco (QPM-COPS), Nortel (Optivity) and Intel (COPS SDK)
all have COPS implementations worth looking at. Cisco and Nortels take
advantage of LDAP (W2K AD, NDS, Iplanet/Netscape) while Intels SDK offers
source code and Linux support.

Alexander Hagen
Senior Research Engineer: Development
DoCoMo Communications Laboratories USA, Inc. (DoCoMo USA Labs)
  181 Metro Drive, Suite 300, San Jose, CA 95110, USA
  TEL :+1-408-573-1050 (Main)     FAX : +1-408-573-1090 (Main)
  TEL: +1-408-451-4706 (Direct)
E-mail: [email-masked]
Web: <http://www.docomo-usa.com>

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Kwok-Ho Chan
Sent: Tuesday, May 08, 2001 6:14 AM
To: Vitor Roque
Cc: IETF DiffServ Mailing List; IETF Policy Mailing List;
diffserv-interest; [email-masked]
Subject: Re: [Diffserv] API for COPS

Thank you for your interest in using COPS.
Currently only the protocol aspects is been standardized.
Of course that most implementations use an API, but this
is not exposed since the environments in the PEPs have
real-time requirements, and the PDPs' user access is mostly
from a GUI and DataBase.
Some vendors may sell a developer's kit for COPS, but I will let
them respond to your E-Mail.
I think this E-Mail thread doesn't belong in the DiffServ list.
This is a topic belonging to the RAP working group E-Mail list.
I have added rap to the CC list above.
Please remove DiffServ from the CC list after this message,
else Brian will send you a message. :)
-- Kwok Ho Chan --

At 11:03 AM 5/8/01 +0100, Vitor Roque wrote:
>Dear Sirs,
>
>I'm a PhD student at University of Aveiro. I would like to know if there
are
>API's for COPS and where i can find it for testing.
>
>Thanks in advance
>Best Regards
>V.Roque
>
>---
>Vitor Manuel Gomes Roque
>
>Instituto Politecnico da Guarda    Tel. +351.271 222 634
>Departamento de Informatica        Fax. +351.271 220 150
>Av. Dr. Francisco Sa Carneiro, 50
>6300-559 Guarda - PORTUGAL         email: [email-masked]
>Home Page: http://www.ipg.pt/user/estg/~vroque
>
>
>_______________________________________________
>diffserv mailing list
>[email-masked]
>http://www1.ietf.org/mailman/listinfo/diffserv
>Archive:
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.h
tml

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Ibrahim Okumus <[email-masked]>
Date: Tue, 8 May 2001 13:10:27 -0400 (EDT)

IP Highway and Intel has open COPS SDKs. I couldn;t find the pointers but
you can find the files with a quick search throuh their websites.

 _______________________________
 Ibrahim Taner OKUMUS           
 Electrical&Computer Eng. Dept. 
 Syracuse University

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 09 May 2001 07:35:38 -0500

Please don't discuss vendor products, especially COPS which is nothing
to do with this WG, on the diffserv list.

Thanks
   Brian Carpenter
   diffserv co-chair

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 09 May 2001 07:33:53 -0500

Thanks
   Brian Carpenter
   diffserv co-chair