Subject: [Diffserv] packet marking - prioritzing

From: Ravikanth Samprathi <[email-masked]>
Date: Wed, 11 Apr 2001 10:36:27 -0700

Hi everybody,
i have three interfaces, eth0, eth1, eth2.
i need to do the following:-

INGRESS:
packets coming on any of these three interfaces,
with a particular range of source ip addresses,
or with a particular range of destination ip addresses,
have to be marked by setting the TOS bits to some value.

EGRESS:
packets leaving on any of these interfaces must
be prioritized into 2 queues - high priority and normal priority.
all packets whose TOS bits are marked go into high
priority and all other packets go into low priority.
low priority queue should be serviced only after high
priority queue.

please tell me which tool to use, to mark, prioritize, and
service these packets.  what are the commands. i tried
reading tc, but i did not understand how to use it for
my purpose.

thank you in advance for any help.
ravi
--------------------------------------------------->
Ravi Samprathi   work:(408)853-8038
Cisco Systems   res  :(408)988-2268
Empowering the  Internet Generation
<---------------------------------------------------

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Apr 2001 13:32:58 -0500

Implementation issues are not the topic of the
diffserv WG. Please use the diffserv implementation list at
http://www.atnf.csiro.au/news/exploders/dsimplementation.html

Regards
  Brian Carpenter
  diffserv co-chair