Subject: RE: [Diffserv] draft-ietf-diffserv-mib-09.txt MIB errors

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 13 Apr 2001 16:31:47 +0200

Inline

> ----------
> From: 	Tom Irwin[SMTP:[email-masked]]
> Sent: 	Thursday, April 12, 2001 11:12 PM
> To: 	[email-masked]
> Subject: 	[Diffserv] draft-ietf-diffserv-mib-09.txt MIB errors
> 
> Would someone please help me?
> 
> I compiled the "draft-ietf-diffserv-mib-09.txt" MIB and got the
> following errors and warnings:
> 
> Errors (IMPORT errors):
> - InetAddressPrefixLength not found in INET-ADDRESS-MIB
> - InetPortNumber not found in INET-ADDRESS-MIB
>      where INET-ADDRESS-MIB is defined in RFC 2851
> 
there is also a new draft  draft-ietf-ops-rfc2851-update-00.txt
which does inclide these new TCs. And a rev of that doc
is also in the pipeline

> Warnings:
> - Textual-convention "Dscp" defined but not referenced.
> - Textual-convention "DscpOrAny" defined but not referenced.
That is often (allways) the case for a TC-only module.
SMICng has a flag for it to turn off the wng. Other compilers
probably too (if they issue a wng at all)

> - Warning:  "zeroDotZero" imported but not used.
> 
Not sure why that one would be imported into a TC module

> Also, are there any significant changes anticipated for this MIB, or is
> this version close to the final cut?
> 
Brian answered this one.

Bert

> Thank you,
> Tom Irwin
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive:
> http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist
> .html
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Tom Irwin <[email-masked]>
Date: Fri, 13 Apr 2001 18:06:18 -0500

Thank you all for your gracious help.  I have compiled the draft
DiffServ MIB now using the Emissary MIB compiler that comes with the
Wind River (formerly Epilogue) Envoy SNMP package.  There are no errors
and just the 'Warning:  "zeroDotZero" imported but not used.'

Thanks,
Tom Irwin.

---

From: Harrie Hazewinkel <[email-masked]>
Date: Sat, 14 Apr 2001 11:45:16 +0200

> and just the 'Warning:  "zeroDotZero" imported but not used.'

interesting. For instance on page 36 (diffServClfrElementSpecific)
the value zeroDotZero  is used. Depending what you use it for
I would not make a problem out of it. The compiler seems not to
recognise DEFVAL-clauses.

Harrie
-- 
phone: +39-3474932300
http://www.lisanza.net/