Subject: [Diffserv] urgent help needed in iproute2+tc

From: Ravikanth Samprathi <[email-masked]>
Date: Tue, 10 Apr 2001 16:26:01 -0700

Hi all,
I am running linux-2.4.0 with
3 interfaces - eth0, eth1, and eth2.

eth0 is the outgoing WAN interface.
eth1 and eth2 are the internal LAN interfaces.
eth1 and eth2 belong to a bridge group br0.
eth1 is connected to a voice-over-ip phone.
eth2 is connected to a pc.

so, the setup is
                       ------------------------------
	            |                             |
voip-phone --->| eth1  --->               |
	            |	  br0   eth0 -|---WAN
lan-pc ---------->| eth2 ---->               |
                       ------------------------------

voip-phone can talk with lan-pc
through-the-bridge-group.
voip phone can also talk with any other
phone in the outside-world-through-the-WAN.

I need to setup QoS so that all packets
from voip-phone (that is destined to either
eth1, eth2 or to eth0) are provided with
high-priority-low-delay service.  voip-phone
can be on any lan-interface (eth1 or eth2).
The only thing that can be surely said
about the voip-phone is that it will
have only a particular set of ip addresses
ranging from 171.72.233.100 to 171.72.233.200.

To implement this, i downloaded the
iproute2+tc tool version
iproute2-2.2.4-now-ss991023.tar.gz
and went through the README files.

Can somebody please help me in
writing the commands?  That will
be of great help.

Thanking you in advance,
ravi
--------------------------------------------------->
Ravi Samprathi   work:(408)853-8038
Cisco Systems   res  :(408)988-2268
Empowering the  Internet Generation
<---------------------------------------------------

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Apr 2001 09:13:27 -0500

This isn't a topic for the diffserv WG. Please try the
diffserv implementation list at 
http://www.atnf.csiro.au/news/exploders/dsimplementation.html

Thanks
  Brian Carpenter
  diffserv co-chair

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Board Chairman, Internet Society http://www.isoc.org