Subject: [Diffserv] problems in diffserv...

From: Ravikanth Samprathi <[email-masked]>
Date: Wed, 11 Apr 2001 13:22:29 -0700

Hi everybody,
i have three interfaces, eth0, eth1, eth2.
i need to do the following:-

INGRESS:
packets coming on any of these three interfaces,
with a particular range of source ip addresses,
or with a particular range of destination ip addresses,
have to be marked by setting the TOS bits to some value.

EGRESS:
packets leaving on any of these interfaces must
be prioritized into 2 queues - high priority and normal priority.
all packets whose TOS bits are marked go into high
priority and all other packets go into low priority.
low priority queue should be serviced only after high
priority queue.

please tell me which tool to use, to mark, prioritize, and
service these packets.
I tried tc configuration commands.
But its giving me these errors:-

 > Unknown qdisc "dmark", hence option "indices" is unparsable
 > Error: Qdisc "dsmark" is classless
 > Unknown filter "tcindex", hence option "mask" is unparsable
 > RTNETLINK answers: No such file or directory
 > Unknown filter "tcindex", hence option "classid" is unparsable

thank you in advance for any help.
ravi
--------------------------------------------------->
Ravi Samprathi   work:(408)853-8038
Cisco Systems   res  :(408)988-2268
Empowering the  Internet Generation
<---------------------------------------------------

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Apr 2001 17:36:18 -0500

For the second time please take this discussion to
the correct list:

http://www.atnf.csiro.au/news/exploders/dsimplementation.html

Thanks

  Brian Carpenter
  diffserv co-chair

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Board Chairman, Internet Society http://www.isoc.org