Subject: Re: [Diffserv] TCP urgent DATA vs DIFFSERV EF DATA

From: Kathleen Nichols <[email-masked]>
Date: Mon, 02 Apr 2001 13:47:54 -0700

And, perhaps tangentially to the discussion below, but as far as
"expanding MF classification in a DS node to also include...", there
isn't any called out limit on how many (or how few) fields can get
called out in a multifield classifier. A particular implementation
may limit you. Now as to the wisdom of including any particular field,
that isn't addressed by diffserv.

	Kathie

Brian E Carpenter wrote:
> 
> That was what I expected, and that being so it does seem more
> like a topic for e2e-interest than this list.
> 
>     Brian
> 
> John Wroclawski wrote:
> >
> > At 12:42 PM -0500 3/30/01, Jeff Norman wrote:
> > >It may be outside the scope of this WG, since we might be dealing
> > >with implementation here, but does anyone see any problem or issues
> > >with expanding MF classification in a DS node to also include the TCP
> > >URG and ACK flags?
> > >
> > >Comments and opinions welcome.
> > >
> > >--Jeff
> >
> > Including URG would need careful thought. URG is not out of band
> > data, it's an indication that there's something urgent later on in
> > the in-band stream. So the goal would be to get the whole stream to
> > the receiver faster. Pulling URG-flagged packets into a different
> > PHB, and thus likely delivering them out of order, might make the
> > situation worse by triggering congestion control and retransmissions.
> >
> > --john
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: "Yacine El Mghazli" <[email-masked]>
Date: Tue, 3 Apr 2001 13:39:57 +0200

Hi,

In the PIB, the DataPath is linked to a role and  a role is linked to an
interface type (corresponding to a capability set).
In the MIB, the DataPath is linked to an IfIndex.

The question is :

When receiving a new Datapath Entry from the PDP, a PEP has to map it
towards several interfaces (each has an IfIndex), how the device (PEP) know
which interface belongs to a specific capability set ?
Where is this information ?
I had red about a Policy Auxiliary Mib for this mapping... what is it
exactly ?

Thanks

-- Yacine El Mghazli
----------------------------------------------------------------------
  Alcatel R&I
  Software and Services Strategic Program - VIPeR
  Marcoussis, France
  Tel  +33 1 69 63 41 87
  Fax  +33 1 69 63 11 69
  [email-masked]
----------------------------------------------------------------------

---

From: "Kwok-Ho Chan" <[email-masked]>
Date: Tue, 03 Apr 2001 08:22:58 -0400

Yacine:
Yes.  The PEP have the Interface to RoleCombo mapping based on the
Policy Auxiliary Mib.
-- Kwok --

At 01:39 PM 4/3/01 +0200, Yacine El Mghazli wrote:
>Archive:
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.h
tml