Subject: [Diffserv] TCP urgent DATA vs DIFFSERV EF DATA

From: Kamel Sadani <[email-masked]>
Date: Mon, 26 Mar 2001 17:57:05 +0200

I am currently comparing different methods of congestion notification,
especially ECN. In order to progress in this work I need to understand
the following  point.

If a host sends data via TCP using  the bit URG (urgent mode) , the packet
is 
then carried by IP along the path . My question, is how is the competition
between
this urgent packet and a packet that belongs to EF class ?

Is the urgent packet also encapsulated in EF class or is this urgent packet 
all the time out of band and first served ?

I believe the second is more logical but I must be sure and formal.

Please if someone can reply or suggest me some specific links about this.

Thanks 

Kamel

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Kamel Sadani <[email-masked]>
Date: Tue, 27 Mar 2001 11:43:42 +0200

Sami, I can explain  little bit more .

First, My mail was quite clear and I don't say that
TCP is other than  layer 4.  Then, I also know that routing is layer 
3 protocol. Perhaps it's a minimum people should know before sending 
a question in this maillist.

My question was not so naive, and since I am working with 
Douglas Comer TCP/IP book it's also possible that I know how 
Urgent TCP DATA work .

Out of this, in this same book (chapter that describes TCP), it is said that
"The program that receives urgent data, must receives them as fast as is
possible."

Now, you understand why I was wondering about the competition between urgent
data
encapsulated  in IP datagrams  and other data  signalled in EF class.

What is said by Brian seems to be  realistic and logical.

Thanks for your help

Kamel

> -----Message d'origine-----
> De:	Iren, Sami [SMTP:[email-masked]]
> Date:	lundi 26 mars 2001 18:41
> À:	'Kamel Sadani'; [email-masked]'
> Objet:	RE: [Diffserv] TCP urgent DATA vs DIFFSERV EF DATA
> 
> Kamel:
> TCP's urgent mode has nothing to do with how
> the packet is routed/treated along the way.
> TCP is layer 4 protocol and routers typically
> do not deal with layer 4 headers.
> The TCP urgent mode is used to notify the
> receiving TCP entity (transport receiver)that
> an urgent data has been placed into the data stream,
> and it is up to the transport receiver what to do
> with it (e.g., go and read the urgent data directly,
> skipping everything else in the stream). 
> It is most commonly used in Telnet/Rlogin
> (when the user types the interrupt key) and
> FTP (when the user aborts the transfer)applications.
> I hope this helps.
> 
> ---
> Sami Iren
> Marconi Communications
> Tel: (724) 742-6849
> Fax: (724) 742-4555
> Email: [email-masked]
> 
> 
> > -----Original Message-----
> > From: Kamel Sadani [mailto:[email-masked]]
> > Sent: Monday, March 26, 2001 10:57 AM
> > To: [email-masked]'
> > Subject: [Diffserv] TCP urgent DATA vs DIFFSERV EF DATA
> > 
> >

---

From: "Iren, Sami" <[email-masked]>
Date: Tue, 27 Mar 2001 15:46:34 -0500

Kamel:

I did not mean to offend you by describing the layers
and how TCP urgent data works. I was just trying to
clarify the issues. The following is quoted from
your original email:

   "My question, is how is the competition between this 
    urgent packet and a packet that belongs to EF class ?
    Is the urgent packet also encapsulated in EF class or is this 
    urgent packet all the time out of band and first served ?"

If you know that routers do not deal with layer 4 headers
how are they going to know whether the URG bit is set or not
so that they can serve these packets (by your definition)
"out of band and first"? You are talking about competition
between EF packets and packets with TCP URG bit set. How is
this possible? 

Once the packets are in the core, the only competition/differentiation
is between different PHBs/PSCs. At the edge of the network, a classifier
determines what packet is marked with what DSCP based on the 6-tuple
classifier which does not include the TCP URG bit (at least not today).
Therefore, if a TCP flow happens to be marked with EF, then all
the packets in that TCP stream will be marked EF including the ones
with URG bit set.

One more point, TCP's urgent mode should NOT be called out-of-band data.
If you need to send out-of-band data, you need to create a separate
TCP connection. For more information see:
TCP/IP Illustrated, Vol 1 by Richard Stevens, Section 20.8 (pp 292-293).

Regards,
--Sami

> Sent: Tuesday, March 27, 2001 4:44 AM
> To: 'Iren, Sami'; [email-masked]'
> Cc: 'Brian E Carpenter'
> Subject: RE: [Diffserv] TCP urgent DATA vs DIFFSERV EF DATA
> 
>