Subject: RE: [Diffserv] TCP urgent DATA vs DIFFSERV EF DATA

From: "Iren, Sami" <[email-masked]>
Date: Mon, 26 Mar 2001 11:40:39 -0500

Kamel:
TCP's urgent mode has nothing to do with how
the packet is routed/treated along the way.
TCP is layer 4 protocol and routers typically
do not deal with layer 4 headers.
The TCP urgent mode is used to notify the
receiving TCP entity (transport receiver)that
an urgent data has been placed into the data stream,
and it is up to the transport receiver what to do
with it (e.g., go and read the urgent data directly,
skipping everything else in the stream). 
It is most commonly used in Telnet/Rlogin
(when the user types the interrupt key) and
FTP (when the user aborts the transfer)applications.
I hope this helps.

---
Sami Iren
Marconi Communications
Tel: (724) 742-6849
Fax: (724) 742-4555
Email: [email-masked]

> -----Original Message-----
> From: Kamel Sadani [mailto:[email-masked]]
> Sent: Monday, March 26, 2001 10:57 AM
> To: [email-masked]'
> Subject: [Diffserv] TCP urgent DATA vs DIFFSERV EF DATA
> 
> 
> I am currently comparing different methods of congestion notification,
> especially ECN. In order to progress in this work I need to understand
> the following  point.
> 
> If a host sends data via TCP using  the bit URG (urgent mode) 
> , the packet
> is 
> then carried by IP along the path . My question, is how is 
> the competition
> between
> this urgent packet and a packet that belongs to EF class ?
> 
> Is the urgent packet also encapsulated in EF class or is this 
> urgent packet 
> all the time out of band and first served ?
> 
> I believe the second is more logical but I must be sure and formal.
> 
> Please if someone can reply or suggest me some specific links 
> about this.
> 
> Thanks 
> 
> Kamel
> 
> 
> 
> 
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive: 
> http://www2.ietf.org/mail-archive/working-groups/diffserv/curr
ent/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 26 Mar 2001 17:39:46 -0600

To be clear, a packet that happens to have the urgent bit set
will inherit *exactly* the same diffserv treatment as any other
packet that is selected by the same MF classifier. In practice
that means it will get the same treatment as any other packet in 
the same TCP session, since it will have the same addresses,
protocol tpe, and port numbers.

   Brian