Subject: Re: [Diffserv] TCP urgent DATA vs DIFFSERV EF DATA

From: "Jeff Norman" <[email-masked]>
Date: Fri, 30 Mar 2001 12:42:27 -0500 (EST)

It may be outside the scope of this WG, since we might be dealing
with implementation here, but does anyone see any problem or issues 
with expanding MF classification in a DS node to also include the TCP
URG and ACK flags?

Comments and opinions welcome.

--Jeff

In message "[Diffserv] TCP urgent DATA vs DIFFSERV EF DATA", Brian E Carpenter writes:

>To be clear, a packet that happens to have the urgent bit set
>will inherit *exactly* the same diffserv treatment as any other
>packet that is selected by the same MF classifier. In practice
>that means it will get the same treatment as any other packet in 
>the same TCP session, since it will have the same addresses,
>protocol tpe, and port numbers.
>
>   Brian
>
>"Iren, Sami" wrote:
>> 
>> Kamel:
>> TCP's urgent mode has nothing to do with how
>> the packet is routed/treated along the way.
>> TCP is layer 4 protocol and routers typically
>> do not deal with layer 4 headers.
>> The TCP urgent mode is used to notify the
>> receiving TCP entity (transport receiver)that
>> an urgent data has been placed into the data stream,
>> and it is up to the transport receiver what to do
>> with it (e.g., go and read the urgent data directly,
>> skipping everything else in the stream).
>> It is most commonly used in Telnet/Rlogin
>> (when the user types the interrupt key) and
>> FTP (when the user aborts the transfer)applications.
>> I hope this helps.
>> 
>> ---
>> Sami Iren
>> Marconi Communications
>> Tel: (724) 742-6849
>> Fax: (724) 742-4555
>> Email: [email-masked]
>> 
>> > -----Original Message-----
>> > From: Kamel Sadani [mailto:[email-masked]]
>> > Sent: Monday, March 26, 2001 10:57 AM
>> > To: [email-masked]'
>> > Subject: [Diffserv] TCP urgent DATA vs DIFFSERV EF DATA
>> >
>> >
>> > I am currently comparing different methods of congestion notification,
>> > especially ECN. In order to progress in this work I need to understand
>> > the following  point.
>> >
>> > If a host sends data via TCP using  the bit URG (urgent mode)
>> > , the packet
>> > is
>> > then carried by IP along the path . My question, is how is
>> > the competition
>> > between
>> > this urgent packet and a packet that belongs to EF class ?
>> >
>> > Is the urgent packet also encapsulated in EF class or is this
>> > urgent packet
>> > all the time out of band and first served ?
>> >
>> > I believe the second is more logical but I must be sure and formal.
>> >
>> > Please if someone can reply or suggest me some specific links
>> > about this.
>> >
>> > Thanks
>> >
>> > Kamel
>> >
>> >
>> >
>> >
>> >
>> > _______________________________________________
>> > diffserv mailing list
>> > [email-masked]
>> > http://www1.ietf.org/mailman/listinfo/diffserv
>> > Archive:
>> > http://www2.ietf.org/mail-archive/working-groups/diffserv/curr
>> ent/maillist.html
>> 
>> _______________________________________________
>> diffserv mailing list
>> [email-masked]
>> http://www1.ietf.org/mailman/listinfo/diffserv
>> Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
>
>_______________________________________________
>diffserv mailing list
>[email-masked]
>http://www1.ietf.org/mailman/listinfo/diffserv
>Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
>
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: John Wroclawski <[email-masked]>
Date: Fri, 30 Mar 2001 13:29:42 -0500

>Comments and opinions welcome.

Including URG would need careful thought. URG is not out of band 
data, it's an indication that there's something urgent later on in 
the in-band stream. So the goal would be to get the whole stream to 
the receiver faster. Pulling URG-flagged packets into a different 
PHB, and thus likely delivering them out of order, might make the 
situation worse by triggering congestion control and retransmissions.

--john

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 30 Mar 2001 13:21:38 -0600

That was what I expected, and that being so it does seem more
like a topic for e2e-interest than this list.

    Brian