Subject: RE: [Diffserv] A question on PHB-PDB relationship

From: Shahram Davari <[email-masked]>
Date: Fri, 2 Mar 2001 07:13:54 -0800

Hi,

> P.S. I still didn't receive any answer if "jitter" is part of services
> that EF might support.

The EF draft binds the delay inside a device. Binding of the jitter is a direct consequence of binding the delay:

If:
     Delay < B/R + E_p   
Then:
     Jitter < B/R + E_p      

As explained in the draft, jitter is the difference between minimum and maximum delay. Therefore when delay is bound by D, jitter is also bound by D. Off course this is not the tightest bound for jitter. If one wants to find a tighter bound,  he could use separate "E" components advertised by a device: 

If:
     E_p = E_fixed + E_variable
Then:
     Jitter < B/R + E_variable

In the latter formula Jitter has a tighter bound than the former formula.

Yours,
-Shahram 

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: demir <[email-masked]>
Date: Fri, 2 Mar 2001 15:50:13 -0800 (PST)

Actually,

> In the latter formula Jitter has a tighter bound than the former formula.

In the draft, jitter is defined as:
"jitter is defined as the variation between maximum and minimum delay."

I guess, what you mean by "variation" needs a further explanation. In
literature, variation IS NOT a simple difference. I assume VW PDB is based
on EF PHB because it is expected that VW behavior depends on overall
packet behavior where "jitter" is a well-known QoS parameters that can
be used in network literature so far  we know; not only one packet's
behavior. Of course, "jitter" gets bounded when "delay" gets bounded cause
... However, obviously, EF PHB is not capable of pushing the "limits" of
"jitter" that is "no/zero jitter" from mathematical point of view. I am
very confused with above definitions.

Alper K. Demir

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 04 Mar 2001 06:06:41 -0600

demir wrote:
>... I assume VW PDB is based
> on EF PHB...

The VW draft (which has expired) was based on RFC 2598, not on the
redefinition of EF.

  Brian