Subject: Re: [Diffserv] I-D ACTION:draft-brunner-diffserv-pdb-one2any-ar-00.txt

From: Albert Banchs <[email-masked]>
Date: Mon, 05 Mar 2001 11:54:57 +0100

Alper,
Find my comments inline,

> - To me, one2any AR is not much different than AR PDB that is also somehow
> stated in the draft, I guess.
> - I think, once you support one2any; one2one and one2few is supported by
> default cause they are subset of one2any where AR PDB already supports.

I agree. However, admission rules for one2any and one2one may differ significantly. This is
the reason why in our draft we decided to focus only on the one2any case.

> - Is this PDB based on a "stochastic model" where "stochastic admission
> rule" is used as a supporting mechanisms for assured rate for one2ay?

Yes. This is one of the differences with the AR PDB draft and ours.

> If so, I guess "probabilistic/stochastic AR name would be a better name that
> supports one2one, one2few and one2any.

Yes.

> If not, what do you think about
> using a "stochastic model" as a "admission rule" and claiming for "assured
> rate" in a real life? Does it really change the risk of having a (strong)
> "probabilistic assured rate"?

There is a tradeoff between the probability of not dropping one-to-any assured rate traffic
and network utilization: the higher this probability, the higher the network utilization by
assured rate traffic. If we make this probability small enough, we will have a kind of
"assured rate" in a real life.
However, in our draft we have left this probability as a configuration parameter of the
service to be configured based on the network operator's preferences.
In the future we plan to perform simulations to study this tradeoff.

> - I think the main challenge for one2any is that without under-utilizing
> the network how "provisioning problem" can be solved where assured rate is
> claimed for one2one, one2few and one2any. In that sense, AR PDB has the
> "well-provisioned" network assumtion. I guess the challenge is what are
> the mechanisms to achieve this assumtion.

I agree. Actually, the intention of our draft goes in this direction.

Albert

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: demir <[email-masked]>
Date: Mon, 5 Mar 2001 11:41:58 -0800 (PST)

Albert,
> the reason why in our draft we decided to focus only on the one2any case.

I agree. I made this comment because, I guess, the name led me
to. Current, AR PDB also claims one2any, too. They address the issue with
"assumptions". They don't give any specific mechanisms. However, I assume,
your approach gives a specific mechanisms with "admission rules" where it
is based on a stochastic model; as a result, assurance on rate is
stochastic. I am not sure if you are planning to integrate
"determinism" into your approach. In case of one2one, "deteminism" seems
possible without any sacrifice from "utilization". I guess, there is no
problem if the whole architecture is stochastic, for simplicity and
easy service understanding for later, either.

Alper K. Demir

---

From: Marcus Brunner <[email-masked]>
Date: Tue, 13 Mar 2001 16:49:12 +0100

--On Monday, March 05, 2001 11:41 AM -0800 demir <[email-masked]> wrote:

> Albert,
>> > - To me, one2any AR is not much different than AR PDB that is also
>> > somehow stated in the draft, I guess.
>> > - I think, once you support one2any; one2one and one2few is supported
>> > by default cause they are subset of one2any where AR PDB already
>> > supports.
>>
>> I agree. However, admission rules for one2any and one2one may differ
>> significantly. This is the reason why in our draft we decided to focus
>> only on the one2any case.
>

For the draft we do not plan to integrate determinism. Another PDB draft 
may be look into one2one deterministic guarantees.

Marcus

> Archive:
> http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillis
> t.html
>

--------------------------------------
Dr. Marcus Brunner
C&C Research Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.tik.ee.ethz.ch/~brunner

Adenauerplatz 6
D-69115 Heidelberg
Germany

Phone: +49 (0)6221/ 9051129
Fax:   +49 (0)6221/ 9051155