Subject: [Diffserv] Re: FW: MIB definition of mask length, port

From: Fred Baker <[email-masked]>
Date: Tue, 27 Feb 2001 09:54:42 -0800

Folks:

Juergen is recommending a slight change to our DscpOrAny Textual 
Convention. This is to make it more similar to other "...-or-anything" 
conventions around. Is there any concern with adopting his proposed text?

At 06:05 PM 2/27/2001 +0100, Juergen Schoenwaelder wrote:

> >>>>> Fred Baker writes:
>
> >> On the technical side, I think that DscpOrAny should be renamed
> >> and reworded to be DscpOrNone where the text in the description
> >> says that the usage of this TC must explain what the precise
> >> semantics of the value -1 are. Right now, the wordings in the
> >> DscpOrAny description make the TC targeted to filters and it would
> >> be problematic to use this TC e.g. in a routing table.
>
>Fred> Guess what - we designed it for filters.
>
>Fred> Give me words.
>
>Here is a first try. I have stolen the wordings from the
>InterfaceIndexOrZero TC definition.
>
>DscpOrNull ::= TEXTUAL-CONVENTION
>     DISPLAY-HINT "d"
>     STATUS   current
>     DESCRIPTION
>        "The IP header Diffserv Code-Point that may be used for
>         discriminating or marking a traffic stream. This textual
>         convention is an extension of the Dscp convention which
>         permits the special null value -1. The meaning of the null
>         value -1 is object-specific and must be defined as part of
>         the description of any object which uses this textual
>         convention. Examples of the usage of the null value -1
>         include situations where the value -1 indicates a wild
>         card in a filter or where the Diffserv Code-Point is
>         unknown or irrelevant."
>     REFERENCE
>         "RFC 2474, RFC 2780"
>     SYNTAX   Integer32 (-1 | 0..63)
>
>Does that make sense? Is the usage of the word "null" confusing?
>
>/js

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Andrew Smith <[email-masked]>
Date: Tue, 27 Feb 2001 11:39:13 -0800

I'm not sure that is an improvement.

For starters "DSCP or null" or "DSCP or none" implies that it is possible for 
there to be no DSCP. My preferences would be, in order, 1) DscpOrAny (i.e. no 
name change) b) DscpOrDontCare. I think these names reflect the usage and the 
semantics better than the proposal. If there were a concept of a "null DSCP" in 
diffserv then I might think differently but I hate to invent new concepts in 
MIBs that don't exist in the underlying technology standards.

Wording: the proposed text first states that "IP header Diffserv Code-Point that 
may be used for discriminating or marking". Later on it uses as an example 
"where the value -1 indicates a wild card in a filter or where the Diffserv 
Code-Point is unknown or irrelevant". The first clause covers the 
"discriminating" usage of DSCPs but I don't see what usage there might be for 
the "unknown or irrelevant" example (except for in a wildcard in a filter, in 
which case this is redundant). I'd suggest finding a better example for the 
marking usage of DSCPs e.g. for a Marker that doesn't touch the DSCP field (but 
we don't have any of those in the current diffserv architecture or MIB), or else 
dropping the second clause.

There doesn't seem to be much of a precedent for providing usage examples in the 
TC definition itself though - I'd suggest we just stick to definition.

My 2c, but if this change gets us closer to consensus then, OK, do it.

Andrew

Fred Baker wrote:

> Archive: 
> http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Feb 2001 15:09:16 -0600

I agree with Andrew. "or any" is the appropriate (i.e. wild card) 
semantic. There is no such thing as a null or absent DSCP;
there is a default value but that is a meaningful value. I vote for
no change in the DS MIB.

  Brian

---

From: Fred Baker <[email-masked]>
Date: Tue, 27 Feb 2001 17:35:47 -0800

At 03:09 PM 2/27/2001 -0600, Brian E Carpenter wrote:
>semantic.

Yes, sir (salute)

:^)