Subject: RE: [Diffserv] MIB-07: Counters in classifiers

From: Dan Romascanu <[email-masked]>
Date: Thu, 15 Feb 2001 09:46:59 +0200

> > Dan Romascanu wrote: 
> > > 
> > > > > I note that if you don't want to implement the counters they 
> > > > > will simply 
> > > > > fail to count even if defined in the MIB. 
> > > > > 
> > > > >   Brian 
> > > > 
> > >         [Dan]  Brian, 
> > > 
> > >         What do you mean by 'fail to count even if defined in the
> MIB'? 
> > > Implement the MIB objects in the agent  and return zero values? This
> is not 
> > > the recommended SNMP practice. 
> > > 
> > >         Regards, 
> > > 
> > >         Dan 
> 
> Dan, what IS the recommended practice? 
	[Dan]  No value should be returned. If queried by a GetRequest PDU
the agent should return instead an error code indicating noSuchObject. If
queried by a GetNext PDU, the object should be skipped.

	Regards,

	Dan

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 15 Feb 2001 06:34:03 -0600

Just to be clear, is it considered evil to return noSuchObject for
something that is not defined as optional in a standard MIB?

  Brian

---

From: Fred Baker <[email-masked]>
Date: Thu, 15 Feb 2001 09:17:37 -0800

>something that is not defined as optional in a standard MIB?

it's not eveil, it just means that you can't actually claim compliance to 
the MIB. There is a way to specify that you don't implement an object, so 
that an NMS can avoid that.