Subject: [Diffserv] MIB-07: Counters in classifiers

From: "Weiss, Walter" <[email-masked]>
Date: Tue, 13 Feb 2001 16:44:43 -0500

I am confused as to why counters are back in the classifiers. Here is my
recollection of events. At the meeting in San Diego the consensus was for
making the counters optional. After the meeting, Fred argued on the list for
making them required. Both Andrew and I objected on seperate grounds. Andrew
argued that diagnostic functionality should not be mandated by the MIB. I
argued that we don't have diagnostic experience across other elements and
that if we want to address diagnostics, it should be more general to
encompass the other elements like meters, schedulers, and droppers. There
may have been others opposed as well, but there was certainly not a
consensus for anything more than an optional attribute on the list.

regards,

-Walter

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 13 Feb 2001 21:53:28 -0600

Walter,

I think you missed Fred's eloquent argument that optional counters
are an implementation nightmare; they need to be in or out. Fred was
in another room when this was discussed in SD. Andrew may or may not
dissent still, but the 2:1 majority view among the authors seemed to be to
include the counters. 

I note that if you don't want to implement the counters they will simply
fail to count even if defined in the MIB.

  Brian

> "Weiss, Walter" wrote:
> 
> I am confused as to why counters are back in the classifiers. Here is my recollection of events. At the meeting in San Diego
> the consensus was for making the counters optional. After the meeting, Fred argued on the list for making them required. Both
> Andrew and I objected on seperate grounds. Andrew argued that diagnostic functionality should not be mandated by the MIB. I
> argued that we don't have diagnostic experience across other elements and that if we want to address diagnostics, it should be
> more general to encompass the other elements like meters, schedulers, and droppers. There may have been others opposed as
> well, but there was certainly not a consensus for anything more than an optional attribute on the list.
> 
> regards,
> 
> -Walter

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html