Subject: Re: [Diffserv] MIB-07 comments on Shapers

From: "Robert Moore" <[email-masked]>
Date: Wed, 14 Feb 2001 16:05:22 -0500

Brian,

>"managing" diffserv nodes doesn't (in the case of this MIB) mean
*configuring*
>them - that is either the PIB or SNMPCONF. So the mandate is a MIB that
>provides meaningful generic info about what a node is doing diffserv-wise.

This wasn't my understanding.  The SNMPCONF DiffServ Policy MIB
got very small in its most recent incarnation precisely because
most of the work of making DiffServ configurable via SNMP was
taken care of in the DiffServ MIB itself.  That's why almost all
of the accessible objects in the DiffServ MIB have MAX-ACCESS
read-create, and why almost all of the tables have RowStatus
objects.

If the DiffServ MIB really is only for monitoring and for
reporting on how DiffServ functions are currently configured,
then it's got a lot of unnecessary stuff in it.  I don't
think its role is this narrow, though, so I don't think the
elements I mentioned are unnecessary.

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 14 Feb 2001 20:49:43 -0600

OK, I haven't looked at the SNMPCONF MIB recently. I stand corrected.
But in terms of answering Dan, that is an even stronger reason for
completing this MIB.

  Brian

---

From: Dan Grossman <[email-masked]>
Date: Thu, 15 Feb 2001 11:35:23 -0500

> But in terms of answering Dan, that is an even stronger reason for
I **did not** say that we should not complete the MIB.  I would say such a thing only if it became clear that the MIB was merely a checkoff item, and had no value to implementors and network operators.  I do not believe this to be the case.

I ***did*** say that we need to articulate what the MIB is supposed to manage, and to draw a bright line between objects that we represent in the standard MIB and those that would be represented in enterprise MIBs.  Because it's clear from this discussion that the WG does not have a common understanding of these things.  If even the authors of the MIB can't agree among themselves what they're trying to do, what about the poor dweeb whose boss will inevitably drop it on his desk and say "here, comply with this"?