Subject: RE: [Diffserv] Congestion avoidance, Class-Of-Service etc.

From: Shahram Davari <[email-masked]>
Date: Mon, 26 Feb 2001 10:41:38 -0800

Hi,

My 2c:

> 1. WRED (Weighted Random Early Detection): 
>    In a multi-port chassis, is WRED used in egress alone? (or) 
>    Is WRED used in the ingress (prior to switch fabric) as well
>    as egress?

It can be used anywhere that you have a queue (ingress and egress).

> 
>    I understand, WRED can be used to color an IP packet (ex: by
>    setting DSCP to one of the AF code points) on the egress.

Wrong. WRED is not used to mark the DSCP. WRED will either drop a packet or mark the 2-bit currently named UU (Unused) following the DSCP.

>Do
>    folks also use WRED for congestion avoidance within the 
>    chassis, even as the packet is not colored as it exits the box? 
>

If you mean marking the packets if congestion is experienced, then NO. There is no point in marking the packet internally for the switch, because the switch is not the point that can take any corrective action such as reducing the transmission rate.
 
> 2. COS (Class Of Service): Would like to hear from folks on the 
>    consistent meaning of the term in the industry.
> 
>    I believe, Class-of-Service surely defines packet priority and drop
>    precedence. Now, Does Class-of-Service definition also include
>    bandwidth requirements (or) Is Class-Of-Service independent of
>    bandwidth, but may be associated with a bandwidth?
> 

In Diffserv terminology a CoS is the same as a PSC.

Yours,
-Shahram

> Thanks.
> 
> regards,
> suresh
> 
> __________________________________________________
> Do You Yahoo!?
> Get email at your own domain with Yahoo! Mail. 
> http://personal.mail.yahoo.com/
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive: 
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Ludovic Ferre <[email-masked]>
Date: Mon, 26 Feb 2001 18:49:41 -0000

Pyda,

Regarding your point 1, WRED can be implemented ingress or egress depending
of the platform. Usually, any Gigabit Switch Router or so called will use a
switch fabric to transfer packets between line cards. Packet are usually
placed on Virtual Output Queue (to limit Head of Line Blocking) before being
schedule across the switch fabric / crossbar (ingress that is). If the
scheduler cannot serve the output queue, packet would be dropped following
QoS configuration (WRED in this case). 

Regarding point 2, CoS do not define bandwidth requirement. Committed Access
Rate can be used to do the job (limiting the access rate to the bandwidth
level you want, and allowing certain level of burst as well). I know for a
fact that CAR and IP Precedence / type of Service can be mapped together in
cisco 7200/7500 routers, and I should expect it to be the same with other
vendor kit / platform.

Best Wishes
Ludovic Ferré, Senior Engineer
ABS Network Solutions, East Sussex, TN22 1AA
Tel: 01825 749015, Fax: 0870 439 895

DISCLAIMER: This e-mail contains proprietary information some or all of
which may be legally privileged. It is for the intended recipient only.
If an addressing or transmission error has misdirected this e-mail,
please notify the author by replying to this e-mail. If you are not the
intended recipient you must not use, disclose, distribute, copy, print,
or rely on this e-mail.

> -----Original Message-----
> From: Pyda Srisuresh [mailto:[email-masked]]
> Sent: Monday, February 26, 2001 17:28
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Diffserv] Congestion avoidance, Class-Of-Service etc.
> 
> 
> Folks,
> 
> I have a couple of questions on the terminology and usage of
> Quality-of-Service parameters. These are not necessarily
> diffserv related entirely. Would appreciate hearing from those
> of you knowledged in the area. Thanks.
> 
>    setting DSCP to one of the AF code points) on the egress. Do

________________________________________________________________________
This message has been checked for all known viruses, by Star Internet, 
delivered through the MessageLabs Virus Control Centre. 
For further information visit:
http://www.star.net.uk/stats.asp