Subject: RE: [Diffserv] MIB-07: Counters in classifiers

From: Justin Fletcher <[email-masked]>
Date: Wed, 14 Feb 2001 12:09:47 -0800

> Dan Romascanu wrote:
> > 
> > > > I note that if you don't want to implement the counters they
> > > > will simply
> > > > fail to count even if defined in the MIB.
> > > >
> > > >   Brian
> > >
> >         [Dan]  Brian,
> > 
> >         What do you mean by 'fail to count even if defined in the MIB'?
> > Implement the MIB objects in the agent  and return zero values? This is
not
> > the recommended SNMP practice.
> > 
> >         Regards,
> > 
> >         Dan

Dan, what IS the recommended practice?

Justin Fletcher
[email-masked]

---

From: "Weiss, Walter" <[email-masked]>
Date: Thu, 15 Feb 2001 08:58:11 -0500

You are correct.

regards,

-Walter

> -----Original Message-----
> From: Fred Baker [mailto:[email-masked]]
> Sent: Wednesday, February 14, 2001 5:24 PM
> To: Weiss, Walter
> Cc: [email-masked]
> Subject: RE: [Diffserv] MIB-07: Counters in classifiers
> 
> 
> At 04:50 PM 2/14/2001 -0500, Weiss, Walter wrote:
> 
> >My first preference is for not including them at all.
> 
> By "them", am I correct that you are referring to 
> diffServClfrElementPkts 
> and diffServClfrElementHCPkts?
> 
> > > Just to be clear, the ones we are talking about are
> > > diffServClfrElementPkts
> > > and diffServClfrElementHCPkts, right? Consider them history.
> > >
>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Thu, 15 Feb 2001 18:13:01 +0100

Inline

> ----------
> From: 	Brian E Carpenter[SMTP:[email-masked]]
> Sent: 	Thursday, February 15, 2001 1:34 PM
> To: 	Dan Romascanu
> Cc: 	'Justin Fletcher'; [email-masked]
> Subject: 	Re: [Diffserv] MIB-07: Counters in classifiers
> 
> Just to be clear, is it considered evil to return noSuchObject for
> something that is not defined as optional in a standard MIB?
> 
Basically yes... that is if we have it in the MODULE-COMPLIANCE
statement as required. 
But.... and agent can provide an AGENT-CAPABILITIES statement in
which it lists the deviations from the compliance requirements, that
is, with documentation as to why it choose to do so.

Bert

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html