Subject: RE: [Diffserv] MIB-07: Counters in classifiers

From: Dan Romascanu <[email-masked]>
Date: Thu, 15 Feb 2001 17:28:56 +0200

Hi Brian,

Did you mean to write 'this is defined' or 'this is not defined'?

Anyway, the answer is no. Returning noSuchObject is the non-evil behavior
for the agent. What will happen is that the vendor cannot claim conformance
if he does not support all mandatory objects in a MIB. 'Evil' is to return a
zero value if you do not support the counter, the reason being that a
management application cannot differentiate between such a response and a
correct implementation that counted zero such events.

Regards,

Dan

> -----Original Message-----
> From:	Brian E Carpenter [SMTP:[email-masked]]
> Sent:	Thu February 15 2001 14:34
> To:	Dan Romascanu
> Cc:	'Justin Fletcher'; [email-masked]
> Subject:	Re: [Diffserv] MIB-07: Counters in classifiers
> 
> Just to be clear, is it considered evil to return noSuchObject for
> something that is not defined as optional in a standard MIB?
> 
>   Brian
> 
> Dan Romascanu wrote:
> > 
> > > > Dan Romascanu wrote:
> > > > >
> > > > > > > I note that if you don't want to implement the counters they
> > > > > > > will simply
> > > > > > > fail to count even if defined in the MIB.
> > > > > > >
> > > > > > >   Brian
> > > > > >
> > > > >         [Dan]  Brian,
> > > > >
> > > > >         What do you mean by 'fail to count even if defined in the
> > > MIB'?
> > > > > Implement the MIB objects in the agent  and return zero values?
> This
> > > is not
> > > > > the recommended SNMP practice.
> > > > >
> > > > >         Regards,
> > > > >
> > > > >         Dan
> > >
> > > Dan, what IS the recommended practice?
> >         [Dan]  No value should be returned. If queried by a GetRequest
> PDU
> > the agent should return instead an error code indicating noSuchObject.
> If
> > queried by a GetNext PDU, the object should be skipped.
> > 
> >         Regards,
> > 
> >         Dan
> > >
> > 
> > _______________________________________________
> > diffserv mailing list
> > [email-masked]
> > http://www1.ietf.org/mailman/listinfo/diffserv
> > Archive:
> http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist
> .html
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive:
> http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist
> .html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 15 Feb 2001 10:25:21 -0600

Thanks. I meant what I wrote.

  Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Program Director, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Board Chairman, Internet Society http://www.isoc.org
Non-IBM email: [email-masked]