Subject: RE: [Diffserv] MIB-07 comments on Shapers

From: "Weiss, Walter" <[email-masked]>
Date: Thu, 15 Feb 2001 14:39:32 -0500

> At 11:27 AM 02/15/2001 -0500, Weiss, Walter wrote:
> >... The scenario we have all grown comfortable with is one where 
> >a bandwidth scheduler allows a conforming packet through but a 
> >subsequent priority scheduler rejects the packet. 
> >In this scenario, the first scheduler succeeded, but the second 
> >schduler failed.
> 
> We are not all comfortable with this concept of the scheduler.
> Cascading schedulers without queues between, in contrast to schedulers
> that might implement hierarchical scheduling directly, does not make
> sense to me.
> 
If you are not comfortable with this concept, you need to be more vocal.
This has been expressed for the past year in numerous instantiations of both
the informal model and the MIB. I certainly did not suggest, nor do I
endorse, the placement of queues in between schedulers. My previous text was
ment to suggest that while one scheduling dicipline may permit the
departure(transmission) of a packet, a subsequent scheduling function bound
to the same queue may deny the departure due to some criteria not considered
by the first scheduler.

> I agree with Fred that there is confusion between policing 
> and scheduling
> lurking in these discussions. Only MIB variables that do not depend on
> complex models of the mechanisms underlying diffserv operations should
> be included.
> 
From this statement I can't really tell what you are agreeing with Fred on.

> "Subsequent priority scheduler rejects the packet" makes no sense.
> 
Here is Fred's diagram from Feb. 2. What does not make sense?

        --->classifier -+->||-> S
                        |       c
                        +->||-> h
                        |       e
                        +->||-> d
                        |       u
                        +->||-> l
                        |       e------------> P
                        +->||-> r              r
                        |                      i
                        +---------------->||-> o
                        |                      r--> output
                        +---------------->||-> i
                        |                      t
                        +---------------->||-> y

regards,

-Walter

---

From: John Schnizlein <[email-masked]>
Date: Thu, 15 Feb 2001 15:27:06 -0500

Brian,
>specific recommendations for deletions from the MIB text? 

My intention was to oppose changing the MIB to include the
DiffServSchedulerFailNext that concerns Fred.

Walter,

As I understand Fred's point, there is no rejection of a packet 
in a scheduler, although there would be in a policer (meter-dropper). 
Schedulers choose from queues. 
Policers delete from (prevent insertion into) queues.

The diagram determines the order of servicing queues, with selection
weights and departure times in the left block, and only service when
all higher-priority queues are empty in the lower block. 
No packets are rejected, although they might be delayed.

This does not imply cascading schedulers, in general.
Wasn't Fred's response that cascading schedulers are too complex 
to deserve inclusion in the standard MIB?

John

At 02:39 PM 02/15/2001 -0500, Weiss, Walter wrote:
>> and scheduling lurking in these discussions. 
>> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html