Subject: Re: [Diffserv] DiffServ MIB: Whazzup with StaticRowPointer?

From: "Robert Moore" <[email-masked]>
Date: Fri, 9 Feb 2001 07:58:03 -0500

Fred,

I don't have any text to send you.  But just to be clear,
we're not talking simply about a style issue.  With Keith's
approach, there would be an additional columnar object in
each of the "Specific" tables, indicating that the
conceptual row containing it is available to be pointed to
by multiple data path elements.

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

Fred Baker <[email-masked]> on 02/08/2001 11:38:18 AM

To:   Robert Moore/Raleigh/IBM@IBMUS
cc:   <[email-masked]>
Subject:  Re: [Diffserv] DiffServ MIB:  Whazzup with StaticRowPointer?

At 12:26 PM 2/6/2001 -0500, Robert Moore wrote:
>a. The current version, with StaticRowPointer?
>b. A version that removes StaticRowPointer, and makes no
>    attempt to formalize the distinction between "Next"
>    pointers and "Specific" pointers?
>c. A version that formalizes the distinction between
>    "Next" rows (that's rows, not pointers) and "Specific"
>    rows along the lines that Keith has sketched?

I was detained by other duties at that particular point in the meeting, and
didn't hear Keith's comments. As I understood the matter, Kwok was there
and picked up the comments. He and I spent about four hours together over
Wednesday and Thursday applying comments. Sounds like we may have missed
one.

Personally, I don't see a strong difference between a use of a pointer
described in a DESCRIPTION in a variable and the same thing described in a
a DESCRIPTION in TC. I'll do it one way, or I'll do it in another. I use
TC's primarily to organize things that are similar, and perhaps this
qualifies. But I do believe that we're on a style issue, and at some point
we need to draw the line on style issues.

So here's the deal. Send me text, and I will edit it into draft -08.

At 12:26 PM 2/6/2001 -0500, Robert Moore wrote:
>(For you non-Americans, that's "What's up...," as depicted
>in an inescapable series of beer commercials currently
>showing on American sports telecasts.)  If I look in
>the -07 version of the DiffServ MIB, I find that the
>StaticRowPointer TC is still there.  This TC was introduced
>to formalize and generalize the distinction between the
>"Next" and "Specific" pointers in the DiffServ MIB.  In
>San Diego, however, Keith McCloghrie suggested that the
>StaticRowPointer TC is the wrong way to approach the
>problem it is trying to solve.  Instead, there needs to
>be a TC like RowStatus or StorageType, that applies to
>an object in the conceptual row being pointed to, rather
>than a TC like StaticRowPointer applied to the object
>doing the pointing.  Kwok and I both acknowledged that
>Keith's approach may very well be better than
>StaticRowPointer.
>
>Now we're about to go to WG last call on a DiffServ MIB
>that, through inertia, continues to rely on the
>StaticRowPointer TC that Keith has brought into question.
>So what should go forward as the DiffServ MIB:
>
>a. The current version, with StaticRowPointer?
>b. A version that removes StaticRowPointer, and makes no
>    attempt to formalize the distinction between "Next"
>    pointers and "Specific" pointers?
>c. A version that formalizes the distinction between
>    "Next" rows (that's rows, not pointers) and "Specific"
>    rows along the lines that Keith has sketched?
>
>(b) is the conservative choice here, but it requires
>additional work from the MIB editors.  (c) is an option
>only if someone (presumably Keith) provides a write-up of
>the alternative proposal.  (a) will happen by default
>unless somebody does something.
>
>Are the WG, and the SNMP community in general, comfortable
>enough with StaticRowPointer to let the MIB go down
>path (a)?  I'm not really comfortable with (a) myself,
>but I'll confess that I'm also not prepared to sign up for
>any of the work necessary to get us to (b) or (c).
>
>Regards,
>Bob
>
>Bob Moore
>IBM Networking Software
>+1-919-254-4436
>[email-masked]
>_______________________________________________
>diffserv mailing list
>[email-masked]
>http://www1.ietf.org/mailman/listinfo/diffserv
>Archive:
>http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Fred Baker <[email-masked]>
Date: Fri, 09 Feb 2001 10:18:40 -0800

>by multiple data path elements.

Absent text, and absent a mandate from the chair, I'm not doing it. I'm not 
going to shoot in the dark and hope I got it right. This doesn't sound much 
like "there is a consensus that a problem exists and something needs to be 
done", it sounds like "I like Keith's approach". Keith's approach is 
probably wonderful, but...

Tell me exactly what changes to make, or they are not happening.