Subject: [Diffserv] Help ?

From: "Hari Kishan (ECI)" <[email-masked]>
Date: Fri, 19 Jan 2001 00:10:24 +0800

Hi,
  I am new to this group and DS techonology.

  Can anybody write me the reason for allowing the DSCP value for a
standardized PHB to be
  configurable? It seems like forcing the recommended DSCP of a standardized
PHB to be a
  constant across DS domains helps in maintaing the end to end Qos in both
directions.
  Recommended DSCP values should not be assigned to non-standardized PHBs so
that they
  map to same PHB in all DS domains.

  It's good to have the IP packets requiring standard PHB to have
recommended DSCP while
  crossing the DS domains which  avoiding remarking in the next DS domain.

  What are the advantages/disadvantages  of the above schemes? Why did the
RFC2474 allow
  the recommended DSCP values to be reconfigurable to non standard PHBS.

Thanks,
Kishan

****************************************************************************
*************
Hari Kishan Desineni,		E-mail:   [email-masked]
*
Software engineer,	            		  [email-masked]
*
Embedded Routing Group,     			  [email-masked]
*
Ericsson Communications,	   	Phone:   +91-40-6575601  ( Home )
*
Hyderabad, INDIA  			              +91-40-3303289
extn:4023 ( Office )      *
					              +91-9849004215 (
mobile )                   * 
****************************************************************************
*************

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Jan 2001 13:15:20 -0600

This is because the ISPs who participated in the definition
of the diffserv model insisted on the ability to map DSCPs
flexibly within their own networks. Since ISPs will usually
want to re-classify traffic at the ingress, there really
is no performance penalty as a result. End to end consistency
depends on compatible SLAs at each ISP boundary anyway, so again
there is no real penalty.

   Brian

---

From: Bora Akyol <[email-masked]>
Date: Thu, 18 Jan 2001 11:54:52 -0800

Not to be anti or anything but I don't recall many ISPs
participating in Diffserv besides Juha.

I think this flexibility in Diffserv (referring to
remappibility) actually hurst both deployment of Diffserv as
well as making hardware for it more difficult. In particular, it
does require one to do yet another lookup on the egress
interface to see if one is crossing a domain boundary.

Oh well, I should stop now.

Bora

>>>>> "Brian" == Brian E Carpenter <[email-masked]> writes:

    Brian> This is because the ISPs who participated in the
    Brian> definition of the diffserv model insisted on the
    Brian> ability to map DSCPs flexibly within their own
    Brian> networks. Since ISPs will usually want to re-classify
    Brian> traffic at the ingress, there really is no
    Brian> performance penalty as a result. End to end
    Brian> consistency depends on compatible SLAs at each ISP
    Brian> boundary anyway, so again there is no real penalty.

    Brian>    Brian

    Brian> "Hari Kishan (ECI)" wrote:
    >>  Hi, I am new to this group and DS techonology.
    >> 
    >> Can anybody write me the reason for allowing the DSCP
    >> value for a standardized PHB to be configurable? It seems
    >> like forcing the recommended DSCP of a standardized PHB
    >> to be a constant across DS domains helps in maintaing the
    >> end to end Qos in both directions.  Recommended DSCP
    >> values should not be assigned to non-standardized PHBs so
    >> that they map to same PHB in all DS domains.
    >> 
    >> It's good to have the IP packets requiring standard PHB
    >> to have recommended DSCP while crossing the DS domains
    >> which avoiding remarking in the next DS domain.
    >> 
    >> What are the advantages/disadvantages of the above
    >> schemes? Why did the RFC2474 allow the recommended DSCP
    >> values to be reconfigurable to non standard PHBS.
    >> 
    >> Thanks, Kishan
    >> 
    >> ************* Hari Kishan Desineni, E-mail:
    >> [email-masked] * Software engineer,
    >> [email-masked] * Embedded Routing Group,
    >> [email-masked] * Ericsson Communications, Phone:
    >> +91-40-6575601 ( Home ) * Hyderabad, INDIA +91-40-3303289
    >> extn:4023 ( Office ) * +91-9849004215 ( mobile ) *
    >> _______________________________________________ diffserv
    >> mailing list [email-masked]
    >> http://www1.ietf.org/mailman/listinfo/diffserv Archive:
    >> http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

    Brian> _______________________________________________
    Brian> diffserv mailing list [email-masked]
    Brian> http://www1.ietf.org/mailman/listinfo/diffserv
    Brian> Archive:
    Brian> http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Jan 2001 16:45:51 -0600

Bora,

They were very present at the Boston interim meeting where this decision
was taken.

   Brian

---

From: Kathleen Nichols <[email-masked]>
Date: Thu, 18 Jan 2001 15:12:27 -0800

> participating in Diffserv besides Juha.

But this wasn't the case on the design team that led to the
first diffserv RFCs and in early diffserv WG meetings and
even on the mailing list. The flexibility of the DSCP came
from a comment/proposal by Jim Boyle in a design team meeting
and it passed consensus in the early diffserv WG when we had
more operational folks attending. At this point, the diffserv
WG has produced RFCs on the basics that service providers
were requesting and we hope to soon have a MIB. That's probably
not so interesting to a lot of people except that
they want there to *be* a MIB.

> interface to see if one is crossing a domain boundary.

I suppose this is one way to do things, but the usual model
is conformance testing at the ingress.

---

From: Dan Grossman <[email-masked]>
Date: Fri, 19 Jan 2001 09:58:36 -0500

> interface to see if one is crossing a domain boundary.

The issue of who wanted it aside (and I don't recall that RFC 2026 gives special deference to  participants  based on their employers' line-of-business), some things seem to be emerging from the murk that militate in favor of remapping.

We have a recurring theme in discussions surrounding PDBs.  It appears that a single DS-domain would have a number of reasons for supporting multiple _instances_ of a PDB _type_.  These _instances_ might have identical per-hop forwarding behaviors, but have different resources assigned to them.  For example, in the VW PDB, it turned out that one solution to the dissimilar rates problem was to:
  - have a different _instance_ of VW for each rate (or range of rates), 
  - assign a different _instance_ of the EF PHB _type_ to each PDB _instance_,
  - assign a DSCP which is unique within the DS-domain to each of these EF 
    _instances_, and
  - configure appropriate resources for each EF _instance_ in each DS-node in   
    the DS-domain so that all VW TCAs will be met.

Similarly, for the AR PDB, there was a desire to have different AR _instances_ for different customers served by the same DS-domain.

Problem is that we have 64 DSCPs, less the legacy class selectors.  If lots of PHBs of the same _type_ are needed to support different _instances_ that support different TCAs or different customers (or different whatever), then this speaks to scaling limits on the size of a DS-domain and/or the number of PDB instances that a DS-domain can support.  One way that this can be alleviated (somewhat) is to carefully map and remap DSCPs as they cross domain boundaries.  The objective is that if a PDB _instance_ does not transit a domain, then neither the PHB _instance_ that supports it, nor the DSCP that identifes that PHB _instance_ are needed in that domain.  Thus, the DSCP can be used for another PHB _instance_, possibly one not of the same _type_.

Routing implications of this are left as an exercise for the reader.

Does this make sense?

Sometime if I get around to it, I will do an I-D on type and instance in Diffserv.  Such a thing would clear up a lot of confusion.

Dan