Subject: RE: [Diffserv] Assured Rate PDB

From: Shahram Davari <[email-masked]>
Date: Tue, 9 Jan 2001 08:31:13 -0800

Hi Demir,

> 1) "Bandwidth" and "Assured Rate" are used as comparable parameters. I
> think "bandwidth" word  should not be used in the document at 
> all to be
> more clear.
> I assume the main intuition of AR PDB is:
>    "This PDB ensures that traffic conforming  to a committed 
> information
>    rate (CIR) will incur low drop probability."
> 2)
>    "The traffic aggregate will also have the opportunity
>    to obtain excess bandwidth beyond the assured rate."
> 
> This sentence is kind of confusing because excess bandwidth 
> and assured
> rate are related to each other. 

I don't see any relationship at all between excess BW and assured rate. You can have zero excess BW or very very large excess BW regardless of the assured rate. Why do you think they are related?

Result is "beyond the assured
> rate". "assured rate" is not a deterministic metric. It is CIR that is
> deterministic. 

I don't see any difference between these two.  Assured rate = CIR

> 
> 4) "The possibility of obtaining excess bandwidth allows  
> development  of
>    various  novel  SLA  models.  e.g.  Excess  bandwidth is 
> charged at a
>    higher rate than assured bandwidth; Excess bandwidth is 
> cheaper  than
>    assured  bandwidth;  Excess  bandwidth  is charged 
> proportionally etc.
>    Development and discussion of such service and  charging  
> models  are
>    beyond the scope of this document."
> 
> I assume it is not possible to talk about excess bandwidth 
> which might be
> varying. This paragraph is kind of confusing. I think "excess
> resources" would be a better choice. Excess bandwidth should 
> be something
> like "excess information rate" that is more than CIR (instead 
> of assured
> bandwidth).
> 

To the contrary I think excess BW is a correct term. The AR PDB is in fact talking about excess BW being the excess information rate (more than CIR) that is accepted at the ingress and is successfully delivered to the egress.

 8)  "A committed information rate (CIR) that is assured with high
>      probability."
> 
> Conforming packets are assured. Not CIR.

The sentence means: the network assures (with high probability) to deliver the AR PDB traffic that enters the network, which has a rate less than the CIR.  

> Alper K. Demir

Yours,
-Shahram

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: demir <[email-masked]>
Date: Tue, 9 Jan 2001 10:39:03 -0800 (PST)

Shahram,
> I don't see any relationship at all between excess BW and assured rate. You can have zero excess BW or very very large excess BW regardless of the assured rate. Why do you think they are related?

That's what I mean. I don't see any relationship. That's why "excess
bandwidth beyond assured rate" phrase doesn't make any sense to me.

> I don't see any difference between these two.  Assured rate = CIR

I am not sure if: assured rate = CIR. If it is, then I guess I'm wrong.

Alper K. Demir