Subject: RE: [Diffserv] Assured Rate PDB

From: Shahram Davari <[email-masked]>
Date: Tue, 9 Jan 2001 08:11:07 -0800

Demir,

I think you are confusing two different concepts here. We have two different rates:

1) Committed or assured rate (CIR)
2) Configured rate at each node (for AFx)

The first one is used for the policing/marking purpose, while the second one is used in each node's scheduler. In fact the second one most probably is larger than the first one and may be different in each node.

What you are quoting from the AF-PHB is talking about the excess resources that are used by an AFx in each node, such as excess BW beyond the AFx configured rate. While the AR PDB is talking about the excess rate or excess BW that an input traffic can have beyond the committed rate. These are two different concepts.

Yours,
-Shahram

> -----Original Message-----
> From: demir [mailto:[email-masked]]
> Sent: Friday, January 05, 2001 5:42 PM
> To: Nabil Seddigh
> Cc: [email-masked]; Biswajit Nandy; [email-masked]
> Subject: Re: [Diffserv] Assured Rate PDB
> 
> 
> Nabil,
> > 
> > >   "The traffic aggregate will also have the opportunity
> > >   to obtain excess bandwidth beyond the assured rate."
> > 
> > >This sentence is kind of confusing because excess bandwidth 
> > >and assured
> > >rate are related to each other. Result is "beyond the assured
> > >rate". "assured rate" is not a deterministic metric. It is 
> CIR that is
> > >deterministic. I think "excess resources" would be a better choice.
> > >
> > 
> > "excess" bw has been used extensively in previous work on 
> > the AF PHB. The AF RFC (2597) uses the word "excess" quite
> > a bit. In addition, many of the studies on AF-based 
> services use the 
> > term "excess".  If I recall, the early draft by Clark & Wroclawski
> > used the term excess. 
> 
> I didn't mean the word "excess". It means what it is. It is
> "resource" instead of "bandwidth". However, my main point 
> wasn't that. It
> was on the "excess bandwidth beyond the assured rate".
> i) To me, "bandwidth" word should not be used when it is compared or
> related to "assured rate". 
> ii) It is not "excess bandwidth" only. I'll get that point. If "excess
> bandwidth" is meant to be used than it is either "excess
> bandwidth" (I assume that's what you meant) or "excess 
> bandwidth beyond
> configured service rate/configured bandwidth". 
> iii) Here is a segment from AF PHB:
>   "An AF class MAY also be configurable to receive more forwarding 
>    resources than the minimum when excess resources are 
> available either
>    from other AF classes or from other PHB groups.  This memo does not
>    specify how the excess resources should be allocated, but
>    implementations MUST specify what algorithms are actually supported
>    and how they can be parameterized."
> 
> Forwarding resources are defined as:
>    "A DS node MUST allocate a configurable, minimum amount of 
> forwarding
>    resources (buffer space and bandwidth) to each implemented 
> AF class. 
>    Each class SHOULD be serviced in a manner to achieve the configured
>    service rate (bandwidth) over both small and large time scales."
> 
> Please note that "excess resource" is used (even it is not "excess
> forwarding resources". I am not sure if this is intentional 
> or not. To me,
> it makes sense).
> -----------------------
> 
> An Example PDB in AF PHB:
>    "In a typical application, a company uses the Internet
>    to interconnect its geographically distributed sites and wants an
>    assurance that IP packets within this intranet are forwarded with
>    high probability as long as the aggregate traffic from 
> each site does
>    not exceed the subscribed information rate (profile).  It is
>    desirable that a site may exceed the subscribed profile with the
>    understanding that the excess traffic is not delivered with as high
>    probability as the traffic that is within the profile."
> 
> I assume in AR PDB traffic aggregate is the total of the 
> aggregate traffic
> from each site and how to control aggregate traffic from each 
> site is an
> open issue?
> 
> > >3) "The  PDB is  applicable  for  a  one-to-one,  
> one-to-few as well as
> > >   one-to-any types of service."
> > >
> > >It is not clear what this sentence means. I assume these 
> are services
> > can
> > >be based on from ingress to egress?
> > >
> > 
> > You're correct. One-to-one means single ingress to single 
> > egress within a domain. One-to-any means single ingress to 
> > any egress within a domain. Do these terms need to be explicitly
> > defined in the document?
> 
> To me, they do. Cause, when I read at first, I was shocked :)
> 
> > >9) "In the case of one-to-any services, the PDB can be utilized to
> > assure
> > >   a  rate for a traffic aggregate that originates from one ingress
> > node
> > >   but whose individual five-tuple flows may exit the 
> domain at  any
> > of
> > >   the egress nodes."
> 
> Traffic Aggregate: a collection of packets with a codepoint that 
> maps to the same PHB, usually in a DS domain or some subset of  
> a DS domain.
> 
> From my understanding, "traffic aggregate" does not specify 
> anything about
> origin and direction of flows/microflows. By default, each flow in a
> "traffic aggregate" may exit the domain at any of the egress nodes. It
> seems, by your definition, "traffic aggregate" is from one 
> ingress to one
> egress only. am I missing something?
> 
> Alper K. Demir
> 
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive: 
> http://www2.ietf.org/mail-archive/working-groups/diffserv/curr
ent/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: demir <[email-masked]>
Date: Tue, 9 Jan 2001 10:31:52 -0800 (PST)

Shahram,
Nope. I am not confusing these two different concepts at all. They are
very easy and straightforward to understand. Here is a sentence from your
previous email:
"I think the AR PDB, is assuring that all the packets with an "INPUT" rate
of less than CIR will be delivered (with high probability)."
Q.1. What is "assurance"?
Q.2. What is "assured rate"?
Q.3. What is "excess bandwidth"?
Q.4. What is "excess bandwidth beyond assured rate"?

I hope this questions will clear what I mean. I don't have any problem
understanding the text. It is a little confusing. That's all.

Alper K. Demir