Subject: RE: [Diffserv] Assured Rate PDB

From: Shahram Davari <[email-masked]>
Date: Tue, 9 Jan 2001 12:14:12 -0800

Demir,

> "I think the AR PDB, is assuring that all the packets with an 
> "INPUT" rate
> of less than CIR will be delivered (with high probability)."
> Q.1. What is "assurance"?
> Q.2. What is "assured rate"?
> Q.3. What is "excess bandwidth"?
> Q.4. What is "excess bandwidth beyond assured rate"?

1) "Assurance" means guaranteeing something with a very high probability. In the AR PDB context it means guaranteeing delivery of green packets with very high probability.
2) "Assured rate" means the maximum rate that a customer can send AR PDB packets to the network and be sure that they will be delivered.
3, 4) "Excess bandwidth" and "excess bandwidth beyond assured rate" both mean the input traffic that is in excess of the assured rate (CIR) that is not guaranteed but can still make it to the egress of the network.

As an example assume an AR PDB that guarantees 99.99% delivery of packets, when the input rate is below 100Mbits/s (CIR). Now if a customer sends 200Mbits/s AR PDB traffic and the network delivers 150Mbits/sec of his/her traffic, then the extra 50Mbits/s (200-150) is called the excess bandwidth.

Yours,
-Shahram   

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: demir <[email-masked]>
Date: Tue, 9 Jan 2001 15:07:42 -0800 (PST)

Shahram,
It seems we are going on circles over and over. I will reply to this
last time. 

> 1) "Assurance" means guaranteeing something with a very high probability. 
> In the AR PDB context it means guaranteeing delivery of green packets
> with very high probability.
> 2) "Assured rate" means the maximum rate that a customer can send AR PDB
> packets to the network and be sure that they will be delivered.
> 3, 4) "Excess bandwidth" and "excess bandwidth beyond assured rate" both 
> mean the input traffic that is in excess of the assured rate (CIR) that
> is not guaranteed but can still make it to the egress of the network.

This is confusing, too. Acoording to the draft and your explanation,
"excess traffic [rate] beyond CIR" has same meaning with "excess bandwidth
beyond assured rate". If "assured rate" is CIR, I wonder what a "guarateed
rate" would be. Why the name is "assured rate" not "guaranteed rate" (I
don't accept the answer that it is matter of choice). From my point of
view, what "excess bandwidth" means is "excess rate as a result of
excess resources while the traffic is being transmitted from edge 
to edge". That's why I suggested to avoid using "bandwidth" when compared
to "rate". Anyway, this is a very minor detail and we are going on
circles.

Alper K. Demir