Subject: Re: [Diffserv] Token bucket suggestion in Diffserv Model draft

From: Andrew Smith <[email-masked]>
Date: Mon, 15 Jan 2001 17:35:24 -0800

Tom,

We'll certainly make the discussion in the -05 model draft less "biased". But 
I'm not sure that this draft should get into this discussion too deeply - it is 
trying to document existing solutions, rather than explain why they are used 
(most of the current material is "just an Appendix" after all). I wonder if we 
should be pruning rather than seeking to expand the discussion there.

Andrew
(model draft editor)

Lemaire, Tom wrote:

> hi Brian,
> 
> It's OK if the loose model is in the draft and
> also in widespread use.  I think it's great it's
> in the draft, it makes you think about it.
> But I am asking the authors to clarify the
> problem domain that loose buckets address, at least
> to the list.  If that text was included in the draft,
> that would seemingly only enhance the understanding
> of the reader of the draft.
> 
> As it stands, the draft does not explicitly say
> whether loose buckets are TCP friendly or not,
> though it touches on the subject of TCP.  If this
> is not yet known, that would also be a reasonable
> statement, that loose buckets interaction with TCP
> are a subject for further research.
> 
> There is a risk that the reader will infer that loose
> buckets are a specification for what underlies the
> TCP friendly mechanisms that are deployed in existing
> products.  I believe those implementations are more
> sophisticated than the negative count token bucket
> described in the draft.
> 
> Tom L
> 
> 
> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Wednesday, December 13, 2000 11:46 AM
> To: Lemaire, Tom
> Cc: [email-masked]'
> Subject: Re: [Diffserv] Token bucket suggestion in Diffserv Model draft
> 
> 
> Tom,
> 
> We've been round and round on this many times.
> Experienced implementors of IP routers tell us that
> the loose model is in widespread use (i.e. it is
> running code). That is enough to include it in the model
> and that's what the WG settled on a while back. We also agreed
> to include the strict model because other implementors
> want it. Since we are *months* late with this document,
> I think we should just go with what we have now.
> 
>   Brian
> 
> "Lemaire, Tom" wrote:
> 
>> I'd like it if the draft authors could clarify
>> the problems that negative count token buckets
>> are trying to solve.
>> 
>> A reader of the draft might infer they are
>> more TCP friendly, since the existing positive
>> count token buckets are not particularly
>> TCP friendly, and maybe someone wanted to address
>> that.  But in fact their perceived leniency does
>> not help TCP, since they still drop multiple
>> back-to-back packets in a TCP burst.  And as Shahram's
>> revised text of Monday points out, they are biased
>> against small packets, e.g. TCP ACKs, and that seems
>> TCP unfriendly.
>> 
>> But perhaps they are good for TCP in some ways, or
>> good for some other application.  It would be helpful
>> if the authors could give examples of where negative
>> count token buckets are an improvement over the positive
>> count.
>> 
>> Tom Lemaire
>> Unisphere Networks
>> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 16 Jan 2001 08:46:52 -0600

I agree. Less is better in this case; since we clearly have a
disagreement, we should document that fact and move on. This
isn't a protocol standard issue, where we would have to resolve the
disagreement.

  Brian