Subject: RE: [Diffserv] Help ?

From: Jay Wang <[email-masked]>
Date: Fri, 19 Jan 2001 11:58:00 -0800

Dan,

An instance of a PDB type with different bandwidth amount 
associated with it? To me, this is not "an instance" of PDB.  
This is a (logical) pipe that employs the PDB. I think DSCP 
is meant to indicate which service grade the packet should be 
associated with, not which flows. You are almost using DSCP 
like an MPLS label. If you can aggregrate two flows of the same 
PDB type and honor the SLS (e.g., bandwidth) requirement in your 
DS domain (and you should), why bother to assign them distinct 
DSCP's?  

- Jay

> -----Original Message-----
> From: Dan Grossman [mailto:[email-masked]]
> Sent: Friday, January 19, 2001 6:59 AM
> To: Bora Akyol
> Cc: Brian E Carpenter; Hari Kishan (ECI); [email-masked]
> Subject: Re: [Diffserv] Help ? 
> 
> 
> > 
> > I think this flexibility in Diffserv (referring to
> > remappibility) actually hurst both deployment of Diffserv as
> > well as making hardware for it more difficult. In particular, it
> > does require one to do yet another lookup on the egress
> > interface to see if one is crossing a domain boundary.
> 
> The issue of who wanted it aside (and I don't recall that RFC 
> 2026 gives special deference to  participants  based on their 
> employers' line-of-business), some things seem to be emerging 
> from the murk that militate in favor of remapping.
> 
> We have a recurring theme in discussions surrounding PDBs.  
> It appears that a single DS-domain would have a number of 
> reasons for supporting multiple _instances_ of a PDB _type_.  
> These _instances_ might have identical per-hop forwarding 
> behaviors, but have different resources assigned to them.  
> For example, in the VW PDB, it turned out that one solution 
> to the dissimilar rates problem was to:
>   - have a different _instance_ of VW for each rate (or range 
> of rates), 
>   - assign a different _instance_ of the EF PHB _type_ to 
> each PDB _instance_,
>   - assign a DSCP which is unique within the DS-domain to 
> each of these EF 
>     _instances_, and
>   - configure appropriate resources for each EF _instance_ in 
> each DS-node in   
>     the DS-domain so that all VW TCAs will be met.
> 
> Similarly, for the AR PDB, there was a desire to have 
> different AR _instances_ for different customers served by 
> the same DS-domain.
> 
> Problem is that we have 64 DSCPs, less the legacy class 
> selectors.  If lots of PHBs of the same _type_ are needed to 
> support different _instances_ that support different TCAs or 
> different customers (or different whatever), then this speaks 
> to scaling limits on the size of a DS-domain and/or the 
> number of PDB instances that a DS-domain can support.  One 
> way that this can be alleviated (somewhat) is to carefully 
> map and remap DSCPs as they cross domain boundaries.  The 
> objective is that if a PDB _instance_ does not transit a 
> domain, then neither the PHB _instance_ that supports it, nor 
> the DSCP that identifes that PHB _instance_ are needed in 
> that domain.  Thus, the DSCP can be used for another PHB 
> _instance_, possibly one not of the same _type_.
> 
> Routing implications of this are left as an exercise for the reader.
> 
> Does this make sense?
> 
> Sometime if I get around to it, I will do an I-D on type and 
> instance in Diffserv.  Such a thing would clear up a lot of confusion.
> 
> Dan
> 
> 
> 
> 
> 
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive: 
> http://www2.ietf.org/mail-archive/working-groups/diffserv/curr
ent/maillist.html

---

From: Dan Grossman <[email-masked]>
Date: Fri, 19 Jan 2001 15:30:44 -0500

> DS domain (and you should), why bother to assign them distinct 
Jay, 
You are talking about concepts ("logical pipes", "service grades") that do not exist in RFC 2474, RFC 2475, the terminology draft or the PDB definition draft.

DSCPs do NOT indicate anything about services.  They select the forwarding behavior that the packet will receive at each hop in the DS domain.  What we seem to be learning is that forwarding behaviors imply resources, and that for a variety of reasons, a DS domain wants to apply the same type of forwarding behavior with different resources to different BAs.

No, I'm not using a DSCP like a label.  A label identifies a flow (aggregated or otherwise).  A DSCP selects a PHB.

And the answer to your last question, check the archives of the list for the discussion of the past few weeks on AR (concerning reasons why an ISP might want multiple AR instances) and the last version of the VW draft (concerning VW behavior for BAs with different rates).

Dan

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html