Subject: Re: [Diffserv] I-D ACTION:draft-seddigh-pdb-ar-00.txt

From: [email-masked]
Date: Mon, 8 Jan 2001 14:22:17 -0500 (EST)

>
>Why do you need the 2nd MUST here:
>
>>   The green, yellow and red packets MUST be marked with  the  
>>   DSCP for AFx1,  AFx2 and AFx3 PHBs respectively, 
>>   where x MUST be any one value from 1 to 4.
>
>The limit of 4 AF classes is only a recommendation in RFC 2597-
>actually it speaks of N classes. It would be consistent with 
>2597 if you changed the 2nd MUST into a SHOULD. 
>
> Brian

Agreed. Some rework is required. 

One solution is to change the 2nd MUST into a SHOULD. Alternatively, the
2nd MUST can remain, the 4 can be changed to N and an extra line added
to explain that N is the number of AF classes supported by the routers
in the domain.

Which of the 2 approaches is preferable?

Nabil

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: andrew <[email-masked]>
Date: Mon, 08 Jan 2001 11:58:18 -0800

I'd suggest that neither approach is optimal:

There is no requirement that this draft mention specific DSCPs at all: you 
should keep the (valuable) indirection, built into the DS architecture, that 
PDBs are built out of PHBs and that, to get a certain PHB at a given node you 
have to mark traffic with a suitable DSCP somewhere upstream of that node: 
therefore, there is no reason for this sentence to mention specific DSCPs. A 
sufficient formulation might be something like:

"The green, yellow and red packets MUST be marked with a DSCP
that will cause the packets to obtain AFx1, AFx2 and AFx3 drop
precedences, respectively, within the same AF PHB class, all
along the path taken by these packets through the domain."

That way the use of locally-assigned DSCPs and of multiple sets of AF classes on 
a single link is not precluded, which I think is important.

[I tried sending this comment last week but it came out garbled in some 
HTML-like format - apologies to all for that]

Andrew Smith