Subject: [Diffserv] Re: I-D ACTION:draft-seddigh-pdb-ar-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Fri, 05 Jan 2001 15:28:06 -0600

Why do you need the 2nd MUST here:

>    The green, yellow and red packets MUST be marked with  the  DSCP  for
>    AFx1,  AFx2 and AFx3 PHBs respectively, where x MUST be any one value
>    from 1 to 4.

The limit of 4 AF classes is only a recommendation in RFC 2597- actually
it speaks of N classes. It would be consistent with 2597 if you changed 
the 2nd MUST into a SHOULD. 

  Brian

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: andrew <[email-masked]>
Date: Fri, 05 Jan 2001 22:01:37 -0800

So, to be completely accurate, there is no requirement
that this draft mention specific DSCPs at all: you should keep the (valuable)
indirection, built into the DS architecture, that PDBs are built out of PHBs
and that, to get a certain PHB at a given node you have to mark traffic with
a suitable DSCP somewhere upstream of that node: therefore, there is no reason
for this sentence to mention specific DSCPs. A sufficient formulation might
be something like:

"The green, yellow and red packets MUST be marked with a DSCP
that will cause the packets to obtain AFx1, AFx2 and AFx3 drop
precedences, respectively, within the same AF PHB class, all
along the path taken through the domain."

That way the use of locally-assigned DSCPs is not precluded which I think is important.

Andrew Smith

Brian E Carpenter wrote:

Brian