Subject: RE: [Diffserv] Dropping Strategy in AF PHB

From: Jay Wang <[email-masked]>
Date: Thu, 14 Dec 2000 14:38:10 -0800

I don't see the connection at all on both counts.  If I
allow highly bursty flows to have higher chances of being 
dropped than those perfectly smoothed, since they are placed
under the same PSC, when RED kicks in I drop packets marked
out-of-profile first. And those packets tend to be ones 
coming from the bursty flows.  It won't be tail-dropping.  
Also, giving smooth traffic better treatment does not 
necessarily mean I do or have to discount the past history either.  

thanks.

- Jay

> -----Original Message-----
> From: Nabil Seddigh [mailto:[email-masked]]
> Sent: Thursday, December 14, 2000 2:04 PM
> To: Jay Wang
> Cc: 'Brian E Carpenter'; [email-masked]
> Subject: re:[Diffserv] Dropping Strategy in AF PHB
> 
> 
> >"The dropping algorithm MUST be insensitive to the short-term 
> >traffic characteristics of the micro flows using AF class. 
> >That is, flows with different short-term burst but identical 
> >longer-term packets rates should have packets discarded with 
> >essentially equal probability." 
> >
> >For one thing, I don't know why the authors of the RFC wanted 
> >to mandate this. 
> 
> There was certainly a lot of attention paid to AF.
> 
> If I recall correctly, the intent of the quoted paragraph was 
> to  ensure
> 
> that drop-tail was not used for AF. It essentially mandates an AQM
> mechanism that takes past history into account when making its drop
> decisions. I don't think the intent of that paragraph was
> to require per-micro-flow drop decisions.
> 
> Best
> Nabil
>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 14 Dec 2000 17:03:51 -0600

I suggest you refer to the diffserv archive. We discussed all
this at great length before reaching consensus on the text
of RFC 2597. 

  Brian

> Jay Wang wrote:

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: John Wroclawski <[email-masked]>
Date: Tue, 19 Dec 2000 04:11:14 -0500

Jay,

At 2:38 PM -0800 12/14/00, Jay Wang wrote:

thanks.

- Jay

One intended use of AF is as a building block for services/situations 
that use dropped packets to indicate that a source currently needs to 
slow down (to stay within a numerical profile, or to get a relative 
share, or whatever). If the feedback signal (pkt drop) is not 
independent of the detailed shape of a flow's traffic it becomes hard 
to build systems that assure a flow some level of capacity or 
performance independent of the detailed shape of the traffic it is 
generating.

(It does occur to me that we might have been a little more concrete 
about what "short-term" means in this paragraph - it is talking about 
very short-term sub-congestion-control-response-time transient 
bursts, not some longer short term such as "a minute or two". Hope 
that is apparent from the context..)

There's no particular reason to think that bursty flows are more 
likely to have out-of-profile packets than CBR flows. One could, for 
example, run a CBR layered codec against a profile that gave you high 
assurance of the base layer getting through, but sent the higher 
layers opportunistically as out-of-profile packets.

Cheers
John

>  From: Nabil Seddigh 
>[<mailto:[email-masked]>mailto:[email-masked] 
>m]