Subject: RE: [Diffserv] Possible compromise between EFRESOLVE and draft-ch arny

From: [email-masked]
Date: Mon, 11 Dec 2000 16:43:00 -0800 (PST)

Jim,

> 
> And if the burstines of the aggregate leaving the
> router you consider is
> bounded, what about the burstiness of the particular
> EF pipes splitting out
> from that aggregate at the next router? And the
> burstiness of the output
> from that router? And so on? There is an exponential
> increase in burstiness.
> Except that the first router is probably the last
> router in the path of
> other aggregates so that it not even possible to
> make iterative
> calculations.
> 
> It really is not simple to understand how worst case
> burstiness propagates,
> even in the absence of non-EF traffic.
> 

I would like to believe that you are making the above
comments in the absence of a specification on how the
EF aggregate is formed.

Also, if micro flows are individually spaced at the
ingress then I would like to think that we can bound
the burstiness as a function of routers traversed
however the splitting and merging occurs provided that
the loading resulting at each output remains below the
input rate R.

Guven.

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Anna Charny <[email-masked]>
Date: Tue, 12 Dec 2000 01:13:37 -0500

Guven,

>the loading resulting at each output remains below the

To the best of my knowledge as of today it is not known how to 
deterministically limit burstiness even for ideally shaped microflows in a 
general network with aggregate scheduling (unless severe constraints on EF 
utilization, or complicated constraints of the rates and the number of 
merges and splits of different "ef flows" are imposed). Neither it is known 
(at least to me) how to describe a useful range of topologies for which 
such bound can be found.   Hence, I am afraid you may be overly optimistic 
in your statement.

However, if you are aware of any results that shed more light on this 
problem, I would be very interested in learning what they are.

Anna
>Archive: 
>http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---------------------------------------
Anna Charny
Cisco Systems, Inc
300 Apollo Drive
Chelmsford, MA  01824
Tel. (978)-244-8172
Fax (978)-244-8126