Subject: [Diffserv] diffserv-pib-02; qosIfClassificationCaps

From: "Iliff, Tina" <[email-masked]>
Date: Thu, 21 Dec 2000 18:48:54 +0000

All,

Comment regarding qosIfClassificationCapsSpec:
The inputIpClassification value is stated to indicate whether or not the PEP
supports classification on the ingress.  My concern is that the PIB draft
specifically states the following:  On a given interface, there must be a
complete  classifier  in  place  at  all  times in   the ingress direction.
This means that there will always
be one or more filters that match every possible pattern  that  could be
presented in an incoming packet.
       There is no such requirement in the egress direction."

Maybe the capability indication which the PEP can provide for the ingress
direction is whether or not it supports DiffServ QoS on ingress.

What are your thoughts?

Tina Iliff

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Dec 2000 15:46:05 -0600

Not quite sure why you see a problem. Classification on egress would be 
somewhat unusual, but if there is no classifier on input a node
cannot possibly be a diffserv node.  I would assume that all classifiers
will have a wild card match (a.k.a. an "else" clause) to catch packets
that aren't caught by any explicit filter. Presumably, these packets would
get default behavior.

   Brian

> "Iliff, Tina" wrote:
> The inputIpClassification value is stated to indicate whether or not the PEP supports classification on the ingress.  My
> concern is that the PIB draft specifically states the following:  On a given interface, there must be a complete  classifier
> in  place  at  all  times in   the ingress direction. This means that there will always
> 
> be one or more filters that match every possible pattern  that  could be presented in an incoming packet.
> Maybe the capability indication which the PEP can provide for the ingress direction is whether or not it supports DiffServ QoS
> on ingress.
> 
> What are your thoughts?
> 
> Tina Iliff

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html