Subject: RE: [Diffserv] Yesterday's EF discussion

From: Shahram Davari <[email-masked]>
Date: Thu, 14 Dec 2000 09:44:54 -0800

Demir,

> -----Original Message-----
> From: demir [mailto:[email-masked]]
> Sent: Thursday, December 14, 2000 1:29 PM
> To: Shahram Davari
> Cc: Nabil Seddigh; Brian E Carpenter; Diff Serv
> Subject: RE: [Diffserv] Yesterday's EF discussion
> 
> 
> Shahram,
> I am not sure if what you stated was the industry's 
> understanding. Let me
> quote something taken from "The `Virtual Wire' Per-Domain 
> Behavior" draft
> (you can see the same info at RFC 2598): 
> "[RFC2598] describes a diffserv PHB called expedited forwarding 
> (EF) intended for use in building a scalable, low loss, low 
> latency, low jitter, assured bandwidth, end-to-end service that 
> appears to the endpoints like an unshared, point-to-point 
> connection or
> `virtual wire.'"
> I assume, that was the "industry's understanding" of EF. What
> happened? It was claimed that this "rate-based" definition 
> was not enough
> to define such services in a "expedited" manner As a result, 
> there has
> been discussions: one "delay-oriented expedited" approach, 
> other "delay
> variance-oriented expedited" aproach. 

I am sorry, but I don't recall such a reason for changing RFC-2598. For your information it all started by me trying to check a number of schedulers that were mentioned in RFC-2598, for EF compliance. I found that for certain valid input traffic, I couldn't find any scheduler to satisfy the exact RFC-2598 definition. So I brought it up to the attention of the WG and many agreed that the EF definition as stated in RFC-2598 needed to be fixed. 

It was never the intend to redefine EF so that it could be used by any particular PDB. To do that there were better paths, such as defining a new PHB, or adding the additional restrictions to the PDB itself.

Yours,
-Shahram

What "expedited" meant is "low
> jitter" (RFC-2598). There is a tendency to "use" B. Davie and
> draft-charny's (and group's) this "delay-oriented" approach 
> cause it has
> roots to "rate".
> If this "delay-oriented" approach will have the "EF" name, it would be
> VERY VERY confusing (I know they are just names).
> My suggestion is: To keep EF for its "low-jitter" expedition. 
> Forget about
> old "rate-oriented" "EF" and all "rate" related names. Use a different
> name for the new one (my suggestion is: "Destined Forwarding").
> 
> P.S. "assured bandwidth"'s 'A' is not the same as "assured
> forwarding's" 'A'. It would be better to use another word for "assured
> bandwidth"'s 'A'.
> 
> Alper K. Demir
> 
>  
> 
> 
> 
> On Thu, 14 Dec 2000, Shahram Davari wrote:
> 
> > Demir,
> > 
> > I think the industry's understanding of EF is what is in 
> RFC-2598, which is a rate-based service in which the arrival 
> rate is less than departure rate in small intervals. Since 
> the language used in RFC-2598 was not very accurate, in the 
> sense that it didn't cover some valid scenarios, the work 
> group's intent was to lay a clear definition that covers 
> those valid scenarios, and  at the same time does not deviate 
> from the industry's understanding of EF. So the intent was to 
> keep the EF PHB behavior but to give a more accurate definition. 
> > 
> > Yours,
> > -Shahram 
> > 
> > > -----Original Message-----
> > > From: demir [mailto:[email-masked]]
> > > Sent: Thursday, December 14, 2000 12:44 PM
> > > To: Nabil Seddigh
> > > Cc: Brian E Carpenter; Diff Serv
> > > Subject: Re: [Diffserv] Yesterday's EF discussion
> > > 
> > > 
> > > Nabil,
> > > > However, there is another group of people to consider. I'm 
> > > thinking of
> > > > the multitudes of developers, product  managers, 
> network engineers,
> > > > sales, marketting folks etc  who are not on this list. It 
> > > has taken a
> > > > while to get terms like EF and AF socialized, understood 
> > > and adopted.
> > > > IMHO, adding a new name may cause more confusion than 
> clarification.
> > > 
> > > I agree with above statements. However, what is their 
> understanding of
> > > "EF"; yet, there is no "agreement" in Diffserv group on "EF"?
> > > 
> > > Alper K. Demir
> > > 
> > > 
> > > _______________________________________________
> > > diffserv mailing list
> > > [email-masked]
> > > http://www1.ietf.org/mailman/listinfo/diffserv
> > > Archive: 
> > > http://www2.ietf.org/mail-archive/working-groups/diffserv/curr
> > ent/maillist.html
> > 
> 
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive: 
> http://www2.ietf.org/mail-archive/working-groups/diffserv/curr
ent/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: demir <[email-masked]>
Date: Thu, 14 Dec 2000 10:01:58 -0800 (PST)

Shahram,
> I am sorry, but I don't recall such a reason for changing RFC-2598. For your information it all started by me trying to check a number of schedulers that were mentioned in RFC-2598, for EF complian…

I am sorry if what I wrote is giving a source or reasoning. I was
trying to "evaluate". Should I say "process/aim/result/?"? 

> It was never the intend to redefine EF so that it could be used by any particular PDB. To do that there were better paths, such as defining a new PHB, or adding the additional restrictions to the P…

I didn't say that it was intended for a particular PDB. I was trying to
write some words about "industry's understanding". I happen to copy the
quoted words from VW PDB. Same words are in RFC-2598 (I wrote this down,
too).

Alper K. Demir