Subject: Re: [Diffserv] Counters in the classifier

From: "Robert Moore" <[email-masked]>
Date: Thu, 14 Dec 2000 10:34:29 -0500

I don't know if my interpretation is correct, but here's
what I *think* Fred is proposing:

1. Add a packet counter, but not an octet counter, to each
   ClassifierElement in a Classifier.
2. Retain the Counter action element for counting packets
   and/or octets that pass by an arbitrary point in the
   data path, such as one of the outputs from a meter.

If this is in fact Fred's proposal, it's fine with me.

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

Andrew Smith <[email-masked]>@ietf.org on 12/13/2000 06:54:45
PM

Sent by:  [email-masked]

To:   Fred Baker <[email-masked]>
cc:   Kathleen Nichols <[email-masked]>, [email-masked]
Subject:  Re: [Diffserv] Counters in the classifier

This does, again, beg the question of having even more overlap with what
the
DSMON MIB (in the RMON WG) does.

I'm also a bit confused as to whether Fred's proposal *replaces* the
existing
"counter action" material in the MIB or is in addition to it. And is this
addition/change expected to be rolled back into the Model draft also?

Andrew

Kathleen Nichols wrote:

>
> Fred Baker wrote:
> ....
>
>> So this is my proposal. Kwok and I are editing the MIB this morning,
with a
>> view to this outcome, Andrew's comments, and some comments from Bert
>> relating to TCs (want to pull them together into a separate module and
do
>> some minor tweaks). We will put in a packet counter in the classifier,
and
>> the chairs can tell us we did it wrong.
>>
>> Your comments, please.
>>
>
>
> Fred, I think what you are saying reflects what we talked
> about before Monday's meeting: you have to set up a classifier
> if you want to count (a particular DSCP for example). If
> this is so, I certainly support that and thought we emerged
> from that meeting with out any real case made for anything
> else.
>
>    Kathie
>
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive:
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive:
http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Andrew Smith <[email-masked]>
Date: Thu, 14 Dec 2000 14:31:25 -0800

Fine with me too.

Andrew