Subject: [Diffserv] Degree of detail in the DiffServ MIB

From: "Robert Moore" <[email-masked]>
Date: Tue, 5 Dec 2000 15:04:19 -0500

Here is the DiffServ MIB's text describing the DSCP Mark Action Table:

3.4.1.  DSCP Mark Action Table

   This Action is applied to traffic in order to mark it with a Diffserv
   Codepoint (DSCP) value, specified in the diffServDscpMarkActTable. Other
   marking actions might be specified elsewhere - these are outside the
   scope of this MIB.

And here is the text from QDDIM describing the property in
a DSCP marker that holds the DSCP value:

4.4.16.1 The Property DSCPValue

  This property is an unsigned 8-bit integer, representing a value to be
  used for marking the DSCP within the DS field in an IPv4 or IPv6 packet
  header.  Since the DSCP consists of 6 bits, the values for this property
  are limited to the range 0..63.  When the DSCP is marked, the remaining
  two bit in the DS field are left unchanged.

Clearly there is an additional detail in the QDDIM version:
the statement that the remaining two bits are left unchanged.
(The range limitation 0..63 is handled in the MIB by the
Dscp Textual Convention (-1 | 0..63), combined with the
description text for the object, saying that the value -1
is not allowed.)  In the ordinary Policy Framework treatment
("ordinary" based on one partially completed example of PCIM
and PCLS, but never mind that:-), this level of detail would
be documented in the Information Model (QDDIM in this case),
and then incorporated by reference into the Data Models (the
MIB and the PIB) derived from it.  But in this case the Data
Models are much more mature, and thus closer to completion,
than the QDDIM.  The only remaining alternatives are either
not to have the detail at all in the MIB and PIB, or else to
copy the QDDIM text into them.  I vote for copying the text
in, because of past history of cases in which "everybody knows
what that means" being exposed as cases in which different
people "know" different things.

I don't have a complete list, but I'm sure this is not the
only instance where the QDDIM has more detail than the two
diffserv Data Models.

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 07 Dec 2000 10:12:11 -0600

I'd like opinions from diffservers whether the Policy WG is or is not
getting into too much detail in this case.

   Brian