Subject: [Diffserv] The DsCodePoint definition

From: Harrie Hazewinkel <[email-masked]>
Date: Mon, 11 Dec 2000 13:32:44 -0800

HI,

I was wondering why there is a difference between
2 definitions of the DiffServ CodePoint in different
MIB modules. The two different MIMB modules are
the DIFFSERV-MIB (of diffserv) and the DSMON-MIB (of RMON).

I beleive these 2 TCs should be the same and taken from the
DIFFSERV-MIB, because that is from the diffserv WG.

----------- From the DIFFSERV-MIB (draft 05) -----------------
Dscp ::= TEXTUAL-CONVENTION
    DISPLAY-HINT "d"
    STATUS   current
    DESCRIPTION
       "The IP header Diffserv Code-Point that may  be  used
       for  discriminating or marking a traffic stream.  The
       value  -1  ( 4294967295 for Integer32 )  is  used  to
       indicate a wildcard i.e. any value."
    SYNTAX   Integer32 (4294967295 | 0..63)
--------------------------------------------------------------

------------ From the DSMON-MIB (draft 03) -------------------
DsmonDSCodePoint ::= TEXTUAL-CONVENTION
    STATUS current
    DESCRIPTION
            "This TC describes an object which identifies the
            Differentiated Services Codepoint (DSCP) value found within
            the DS field in a network layer packet header (e.g., IPv4
            and IPv6)."
    REFERENCE
            "Definition of the Differentiated Services Field (DS Field)
            in the IPv4 and IPv6 Headers [RFC2474]."
    SYNTAX Integer32 (0..63)
--------------------------------------------------------------

OK, I will admit the definition of the DiffServ-MIB is currently
broken, but that will be fixed (this week at the IETF, I hope).

Harrie

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Andy Bierman <[email-masked]>
Date: Tue, 12 Dec 2000 11:52:10 -0800

> DIFFSERV-MIB, because that is from the diffserv WG.

But the TCs are obviously designed for different purposes.
The DSMON TC represents the actual values that the DSCP field 
may contain. There is no need for a value of -1, typecast
as the value 2G-1. The extra semantics would break the DSMON
MIB aggregation control tables.  

Andy

---

From: Andy Bierman <[email-masked]>
Date: Tue, 12 Dec 2000 12:07:48 -0800

>     SYNTAX   Integer32 (4294967295 | 0..63)

just noticed how broken this TC is...
 1) an Integer32 object cannot contain the value 4294967295
 2) missing REFERENCE clause
    (where exactly in 2474 is the 'wildcard' DSCP value discussed?)

Andy

---

From: Harrie Hazewinkel <[email-masked]>
Date: Tue, 12 Dec 2000 05:18:48 -0800

>     (where exactly in 2474 is the 'wildcard' DSCP value discussed?)

Correct, it is broken and already mentioned on the diffserv mailinglist.
That is also why I added the folling below (I quote here);
"OK, I will admit the definition of the DiffServ-MIB is currently
 broken, but that will be fixed (this week at the IETF, I hope)."

Harrie
 
> RMONMIB mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/rmonmib

---

From: Harrie Hazewinkel <[email-masked]>
Date: Tue, 12 Dec 2000 05:16:44 -0800

> MIB aggregation control tables.

I know RMON does not need this -1 value, but it is my understanding
one can still use the TC with the (-1 | 0..63) range of values.
In RMON then you may use the TC and subtype it towards (0..63)
which solves this problem.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 12 Dec 2000 16:29:34 -0600

> Andy Bierman wrote:
...
> >     (where exactly in 2474 is the 'wildcard' DSCP value discussed?)

It isn't and I can't see any reason why it would need to be. It's something
needed in the management of diffserv, so it is nothing to do with the
basic model.

  Brian