Subject: RE: [Diffserv] some info

From: "Iliff, Tina" <[email-masked]>
Date: Wed, 13 Dec 2000 22:51:43 +0000

Matteo,
 
I have attached a URL for a paper on Microsoft and QoS Support.  I hope it
helps!  Also, to try to answer your question..It is my understanding that a
PHB will not modify either data or headers.  It just defines how a router
will treat the packet w.r.t. queueing, dropping, shaping etc.  DiffServ uses
DSCP in IP headers to tell the router which PHB is appropriate for the
packet.
 
http://www.microsoft.com/hwdev/devdes/qos.htm
<http://www.microsoft.com/hwdev/devdes/qos.htm> 
 
Tina

-----Original Message-----
From: Matteo Pelati [mailto:[email-masked]]
Sent: Wednesday, December 13, 2000 4:35 PM
To: [email-masked]
Subject: [Diffserv] some info

Hi everybody,
 
I'm an undergraduate student interested in QoS, recently learning about
DiffServ and working on a university project.
 
I wondered if anybody knows about which support is offered by Windows 2000
QoS components. Reading RFCs and drafts I felt a bit lost since everything
seems to be a continuous work-in-progress, and Ms documentatuion says
Differentiated Services are actually supported by W2K. So, I wondered what
is exactly supported...
 
In DiffServ specs, a PHB is allowed to modify data (not headers) contained
in a packet ?
 
Thanks
 
-Matteo

---

From: "Matteo Pelati" <[email-masked]>
Date: Thu, 14 Dec 2000 00:56:43 +0100

Thanks! I was a bit unclear when asking for actions taken by PHBs. What I meant was if a packet (marked with a specific DSCP), can, under certain circumstances, be altered by an intermediate router. DSCP is the only data a DiffServ router is allowed to modify?

Thanks
-Matteo
  ----- Original Message ----- 
  From: Iliff, Tina 
  To: 'Matteo Pelati' ; [email-masked] 
  Sent: Wednesday, December 13, 2000 11:51 PM
  Subject: RE: [Diffserv] some info

  Matteo,
   
  I have attached a URL for a paper on Microsoft and QoS Support.  I hope it helps!  Also, to try to answer your question..It is my understanding that a PHB will not modify either data or headers.  It just defines how a router will treat the packet w.r.t. queueing, dropping, shaping etc.  DiffServ uses DSCP in IP headers to tell the router which PHB is appropriate for the packet.

  Tina

    -----Original Message-----
    From: Matteo Pelati [mailto:[email-masked]]
    Sent: Wednesday, December 13, 2000 4:35 PM
    To: [email-masked]
    Subject: [Diffserv] some info

    Hi everybody,

    I'm an undergraduate student interested in QoS, recently learning about DiffServ and working on a university project.
     
    I wondered if anybody knows about which support is offered by Windows 2000 QoS components. Reading RFCs and drafts I felt a bit lost since everything seems to be a continuous work-in-progress, and Ms documentatuion says Differentiated Services are actually supported by W2K. So, I wondered what is exactly supported...

    In DiffServ specs, a PHB is allowed to modify data (not headers) contained in a packet ?

    Thanks

    -Matteo

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 13 Dec 2000 18:43:10 -0600

The only field that diffserv "owns" is the DSCP, so clearly
that is the only field that diffserv can modify.

   Brian

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html