Subject: RE: [Diffserv] DiffServ MIB -06: statistics

From: Dan Romascanu <[email-masked]>
Date: Sun, 3 Dec 2000 15:59:33 +0200

> Andrew has sent me off in another direction on this question:
> to the RMON WG's DiffServ Monitoring MIB.  Since DSCPs are
> visible in the packet headers, a probe-based approach is
> certainly possible for determining the distribution of DSCPs
> sent to or from a particular device via a particular
> interface.
> 
> I think that we will probably end up putting a table of the
> form I suggested into our hosts.  But I can understand that
> router vendors might prefer to have the performance penalty
> of what will ordinarily be an extra 64-way classification
> fall onto a probe rather than onto their router interfaces.
> 
	Bob,

	There is no need to invent something new. This is exactly what the
dssonStatsTable counters in the DS-MON MIB do, and they apply to the device
interfaces via the RMON dataSource mechanism. In this case 'the probe is the
diffserv host', or better say 'the probe is embedded within the diffserv
host'.

	Regards,

	Dan

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Andrew Smith <[email-masked]>
Date: Sun, 03 Dec 2000 21:14:34 -0800

Of course, that does beg the question as to why we are not using "dataSource" 
instead of "ifIndex" to index the diffserv MIB tables ...

BTW, I assume that the diffserv WG will also run a last-call of the DSMON MIB 
since the "subject-matter experts" are supposedly on that list.

Andrew

---

From: Keith McCloghrie <[email-masked]>
Date: Sun, 3 Dec 2000 22:24:49 -0800 (PST)

> since the "subject-matter experts" are supposedly on that list.
 
I doubt it:

1. the DSMON MIB is intended for a (logical) probe, rather than for a
(logical) router.  (That's not to say that an actual router can't
perform both functions, but that's true of most RMON MIBs).

2. the DSMON MIB was submitted to the RMON WG only after the DiffServ WG
chair said that it wasn't wanted in the DiffServ WG.

3. the DiffServ MIB already contains a (complicated) set of DiffServ
counters for a router to implement, many of which are not appropriate
for a (physical) probe to implement.

Keith.

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 04 Dec 2000 11:53:26 -0600

Well, the IESG has developed a nasty habit of asking for cross-checks
between WGs with overlapping interests. Can you give us the draft name for
the DSMON MIB so that diffservers can check it out right away?

Thanks

  Brian

---

From: Keith McCloghrie <[email-masked]>
Date: Mon, 4 Dec 2000 14:04:20 -0800 (PST)

> the DSMON MIB so that diffservers can check it out right away?
 
draft-ietf-rmonmib-dsmon-mib-03.txt

Keith.