Subject: RE: [Diffserv] Token bucket suggestion in Diffserv Model draft

From: "Lemaire, Tom" <[email-masked]>
Date: Wed, 13 Dec 2000 08:23:14 -0500

I'd like it if the draft authors could clarify
the problems that negative count token buckets
are trying to solve.

A reader of the draft might infer they are
more TCP friendly, since the existing positive
count token buckets are not particularly
TCP friendly, and maybe someone wanted to address
that.  But in fact their perceived leniency does
not help TCP, since they still drop multiple
back-to-back packets in a TCP burst.  And as Shahram's
revised text of Monday points out, they are biased
against small packets, e.g. TCP ACKs, and that seems
TCP unfriendly.

But perhaps they are good for TCP in some ways, or
good for some other application.  It would be helpful
if the authors could give examples of where negative
count token buckets are an improvement over the positive
count.

Tom Lemaire
Unisphere Networks

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www2.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 13 Dec 2000 10:46:19 -0600

Tom,

We've been round and round on this many times.
Experienced implementors of IP routers tell us that
the loose model is in widespread use (i.e. it is
running code). That is enough to include it in the model
and that's what the WG settled on a while back. We also agreed
to include the strict model because other implementors
want it. Since we are *months* late with this document,
I think we should just go with what we have now.

  Brian

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 13 Dec 2000 19:38:41 +0200 (EET)

Brian E Carpenter writes:

 > running code).

brian, could you tell me me whose router allows me to choose between
positive and negative leaky buckets?  so far i haven't seen any.  i
don't think that it a service to the router vendors or those who need to
configure the boxes to introduce yet another option.

-- juha

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 13 Dec 2000 12:27:26 -0600

That's not what I said. Some claim to do it one way and
some claim to do it the other way. In an informal model
why can't we simply recognise this fact of life?

  Brian

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 13 Dec 2000 21:23:46 +0200 (EET)

> why can't we simply recognise this fact of life?

tell me then which vendor implement token bucket using the negative
definition?

-- juha

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 13 Dec 2000 15:17:26 -0600

I'm not going to speak for any vendor. But at least one person you
know has said "we have been using the loose model for years"
in the WG.

  Brian