Subject: [Diffserv] DiffServ PIB

From: "Iliff, Tina" <[email-masked]>
Date: Tue, 17 Oct 2000 15:57:27 +0000

All,

I have a comment on the DiffServ PIB:
Specifically, on pg. 10, the qosIfClassificationCaps attribute definition:
1.	Recommend changing the attribute to qosIfClassificationCapsDefn or
qosIfClassificationCapsSpec
2.	The definition is not in line with the frwkBaseFilterTable and its
extends in the Framework PIB I-D; i.e. one of the extends is the
frwk802FilterTable which allows for the provisioning of 802-based filter
configuration data.  I recommend that more bits be added to the SYNTAX
definition of the qosIfClassificationCaps attribute.  This will allow for
PDP discrimination in regards to including the 802-based attributes in the
provisioning message instead of receiving an error from the PEP due to it
being unable to support 802-based filtering.  It will minimize bandwidth,
connection losses due to inability to process/corruption due to processing
problems, and configuration time.

Tina Iliff
MCIWorldCom ENSD
(972)729-1620

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 18 Oct 2000 03:22:15 -0500

Tina,

In my opinion the diffserv PIB needs to be blind to lower layer issues,
i.e. should in no circumstances refer to 802 or any other lower layer
technology. Mapping to lower layers should be handled by a separate
PIB or MIB.

   Brian

> "Iliff, Tina" wrote:
>   1. Recommend changing the attribute to qosIfClassificationCapsDefn or qosIfClassificationCapsSpec
>   2. The definition is not in line with the frwkBaseFilterTable and its extends in the Framework PIB I-D; i.e. one of the
>      extends is the frwk802FilterTable which allows for the provisioning of 802-based filter configuration data.  I recommend
>      that more bits be added to the SYNTAX definition of the qosIfClassificationCaps attribute.  This will allow for PDP
>      discrimination in regards to including the 802-based attributes in the provisioning message instead of receiving an error
>      from the PEP due to it being unable to support 802-based filtering.  It will minimize bandwidth, connection losses due to
>      inability to process/corruption due to processing problems, and configuration time.
> 
> Tina Iliff
> MCIWorldCom ENSD
> (972)729-1620

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/