Subject: [Diffserv] Physical Queues and Virtual Queues

From: Vinod Jeyachandran <[email-masked]>
Date: Mon, 30 Oct 2000 07:50:09 -0500

I am trying to understand how Virutal queues are mapped onto physical 
memory on the routers. The questions below could give a better picture of 
what I am trying to understand.

1) Can there be more than one Queue set along the Data Path of a packet. I 
am thinking more along the lines of the "shaper" and "scheduler" components 
? If yes do each of these components work with/on different virtual queues. 
The shaper has to be queue to packets somewhere if it needs to shape and so 
does the scheduler.

(2) How are these virtual queues related to the physical queues (or 
physical memory) on the routers ? In terms of memory limits and so on.

Any pointers would be greatly appreciated.

Thanks
Vinod

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: "Iliff, Tina" <[email-masked]>
Date: Mon, 30 Oct 2000 14:46:35 +0000

Vinod,

I would like to point you in the direction of the Diffserv PIB for your
second question.  Specifically, take a look at queuesize parameter in the
qosIfQueue table.  This may be a starting point.

Tina
		-----Original Message-----
		From:	Vinod Jeyachandran [mailto:[email-masked]]
		Sent:	Monday, October 30, 2000 6:50 AM
		To:	[email-masked]
		Subject:	[Diffserv] Physical Queues and Virtual
Queues

		I am trying to understand how Virutal queues are mapped onto
physical 
		memory on the routers. The questions below could give a
better picture of 
		what I am trying to understand.

		1) Can there be more than one Queue set along the Data Path
of a packet. I 
		am thinking more along the lines of the "shaper" and
"scheduler" components 
		? If yes do each of these components work with/on different
virtual queues. 
		The shaper has to be queue to packets somewhere if it needs
to shape and so 
		does the scheduler.

		(2) How are these virtual queues related to the physical
queues (or 
		physical memory) on the routers ? In terms of memory limits
and so on.

		Thanks
		Vinod

---

From: "Peter Pieda" <[email-masked]>
Date: Mon, 30 Oct 2000 08:59:49 -0600

Hello,

A Virtual Queue is the collection of packets on a physical queue with a
particular Diffserv 
Code Point (DSCP) marking. 

For example, in the Assured Forwarding PHB, a physical queue can have 3
virtual 
queues: AF11, AF12, and AF13.  Meaning that at any given time, there may be
packets in 
the physical queue with DSCP markings corresponding to AF11,AF12, or AF13
Classes.

To answer your questions:
1. This depends on your implementation, but yes there can be more than one
queue 
along the data path. Virtual Queues appear most often in the physical queues
of scheduler Components.
Most likely your shaper component would use a physical queue.

2. Virtual queues are contained within the physical queues.

We developed and released a Diffserv Model for NS-2 that utilized virtual
queues.
You can check it and some of our related papers out at:
http:www7.nortel.com:8080/CTL/

Thanks

Peter

Peter Pieda
613-765-3999
Nortel Networks

> From:	Vinod Jeyachandran [SMTP:[email-masked]]
> Sent:	Monday, October 30, 2000 7:50 AM
> To:	[email-masked]
> Subject:	[Diffserv] Physical Queues and Virtual Queues
> 
>