Subject: [Diffserv] AF class question

From: "Wang, Cliff " <[email-masked]>
Date: Thu, 12 Oct 2000 22:01:20 -0000

I am a new comer to this list and appolagize if this question has been
discussed before:

If I am designing a proprietary AF PHB, do I have to define more than 1 AF
class?

The current AF RFC specify 4 classes and I really don't see many benefits of
defining that many classes.
Maybe 1 or 2 classes are quite enough? Any insight to this will be greatly
appreciated.

Cliff Wang
SmartPipes Inc.
614 923 6241

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Jay Wang <[email-masked]>
Date: Thu, 12 Oct 2000 16:10:46 -0700

Although the RFC (you referred to 2597?) recommends
four AF classes it does not mean that every vendor
must have four distinct behavior aggregates.  You need 
to make sure that you can handle up to four AF classes,
as far as the DSCP is concerned, but there is nothing in
Diffserv specs that prevents you from mapping more than 
one AF classes from upstream into one in your domain. 

- Jay

> -----Original Message-----
> From: Wang, Cliff [mailto:[email-masked]]
> Sent: Thursday, October 12, 2000 3:01 PM
> To: [email-masked]'
> Subject: [Diffserv] AF class question
> 
>

---

From: Jayaram Beladakere <[email-masked]>
Date: Thu, 12 Oct 2000 18:15:56 -0700

I am also new to this group, and would appreciate clarifications on this
subject.
 
Here is a paragraph from RFC 2597:
"A DS node SHOULD implement all four general use AF classes.  Packets
in one AF class MUST be forwarded independently from packets in
another AF class, i.e., a DS node MUST NOT aggregate two or more AF
classes together."
 
Does the above expressly prohibit implementations that support fewer than
four distinct PHBs and map more than one AF class to these PHBs?  Or, is it
okay to support, say, one PHB and map the four classes to these?  What does
'forwarded independently' mean in implementation?  Does it allow any level
of resource sharing among classes at all?
 
To be compliant with the RFC when supporting only two AF PHBs (say), is it
also necessary to limit the acceptable DSCPs to two sets (out of four)?
 
Regards, Jayaram

-----Original Message-----
From: Jay Wang [mailto:[email-masked]]
Sent: Thursday, October 12, 2000 4:11 PM
To: 'Wang, Cliff '; [email-masked]'
Subject: RE: [Diffserv] AF class question

- Jay 

> From: Wang, Cliff [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Maybe 1 or 2 classes are quite enough? Any insight to this 
<http://www1.ietf.org/mailman/listinfo/diffserv>  
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
<http://www-nrg.ee.lbl.gov/diff-serv-arch/>

---

From: [email-masked]
Date: Fri, 13 Oct 2000 15:23:56 -0400

Much longer answer, with details ...

subject.
> Does the above expressly prohibit implementations that support fewer than
four distinct
> PHBs and map more than one AF class to these PHBs?

Yes, this is expressly prohibited at interior nodes.  It is ok for an edge
node to remark
traffic so that fewer than 4 distinct AF classes are used inside the domain.
Note that
"AF class" as used here refers to PHBs, not DSCPs.

> Or, is it okay to support, say, one PHB and map the four classes to these?

Not in an interior node.  An edge node could remark traffic (e.g., so that
inbound
traffic in four classes exits in one class), but then there would only be
one AF
class used in the interior of the domain.

> What does 'forwarded independently' mean in implementation? 
> Does it allow any level of resource sharing among classes at all?

The RFC says:

   A DS node MUST allocate a configurable, minimum amount of forwarding
   resources (buffer space and bandwidth) to each implemented AF class.
   Each class SHOULD be serviced in a manner to achieve the configured
   service rate (bandwidth) over both small and large time scales.

It's ok for one class to consume resources available to, but unused
by another class for example.  It is not ok to put two classes in the
same queue where they completely share forwarding resources.

> To be compliant with the RFC when supporting only two AF PHBs (say), is
> it also necessary to limit the acceptable DSCPs to two sets (out of four)?

It's not strictly "necessary" -- RFC 2474 makes this a (lower-case) "should"
for the default
configuration:

   With some exceptions noted below, the mapping of codepoints to PHBs
   MUST be configurable.  A DS-compliant node MUST support the logical
   equivalent of a configurable mapping table from codepoints to PHBs.
   PHB specifications MUST include a recommended default codepoint,
   which MUST be unique for codepoints in the standard space (see Sec.
   6).  Implementations should support the recommended codepoint-to-PHB
   mappings in their default configuration.  Operators may choose to use
   different codepoints for a PHB, either in addition to or in place of
   the recommended default.  Note that if operators do so choose, re-
   marking of DS fields may be necessary at administrative boundaries
   even if the same PHBs are implemented on both sides of the boundary.

So, mapping of the recommended codepoints for one AF class onto another
AF class is allowed, but should not be done by default, as that would
diverge
from the guidance in RFC 2474.

--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------