Subject: RE: [Diffserv] QUESTION on draft-ietf-diffserv-model-04.txt

From: Shahram Davari <[email-masked]>
Date: Thu, 7 Sep 2000 10:39:12 -0700

Michele,

The Diffserv model draft tries to model the behavior of a router from the
Diffserv perspective. The TTL, chekcsum and other processing is assumed to
be done somewhere in the router. 

Regards,
-Shahram

-----Original Message-----
From: Michele Fontana [mailto:[email-masked]]
Sent: Thursday, September 07, 2000 12:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Diffserv] QUESTION on draft-ietf-diffserv-model-04.txt

Hi,

I have a doubt about the draft draft-ietf-diffserv-model-04.txt, where
it is said that a generalised TCB might consist of the following stages:

- classification stage
- metering stage
- action stage
- algorithmic dropping stage
- queueing stage
- scheduling stage

As each router (e.g. each hop) has to decrement the TTL and verify the
header checksum of every packet, I was wondering where these "stages"
take place in the case of a Diff-Serv edge router.

Is it correct to assume that the header checksum have to be verified
BEFORE the meter stage? in this case the packets with corrupted header
will not be metered.

Is it correct to assume that the TTL decrement (and consequent dropping
action due to expired TTL) has to take place AFTER the meter-action
stage.

Is there any other suggestion?

Thanks.

Michele

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: "Iliff, Tina" <[email-masked]>
Date: Thu, 07 Sep 2000 17:49:31 +0000

I believe Michele has some very good points.  However, I also agree with
Shahram stating that these router aspects do not belong in a DiffServ
framework model.  Is this a good suggestion:  Michele's points should be
included in some sort of management extension or accounting extension?

-----Original Message-----
From: Shahram Davari [mailto:[email-masked]]
Sent: Thursday, September 07, 2000 12:39 PM
To: 'Michele Fontana'; [email-masked]
Subject: RE: [Diffserv] QUESTION on draft-ietf-diffserv-model-04.txt

Michele,

Regards,
-Shahram

-----Original Message-----
From: Michele Fontana [mailto:[email-masked]]
Sent: Thursday, September 07, 2000 12:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Diffserv] QUESTION on draft-ietf-diffserv-model-04.txt

Hi,

- classification stage
- metering stage
- action stage

Thanks.

Michele