Subject: Re: [Diffserv] DiffServ MIB

From: [email-masked]
Date: Tue, 1 Aug 2000 13:15:09 -0400

Joel,

I'm missing something very basic here.   Suppose you have
a device with four network interfaces, each of which has
an IN direction and an OUT direction.  Won't there be 8
(or more) TCBs here, two on each interface?  How will a
two-row table identify these 8 TCBs?

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

"Joel M. Halpern" <[email-masked]>@ietf.org on 07/31/2000 08:29:48 PM

Sent by:  [email-masked]

To:   Geoff Huston <[email-masked]>
cc:   [email-masked]
Subject:  Re: [Diffserv] DiffServ MIB

There are indeed only two directions, and therefore only two rows in the
table I am proposing.

As for determining which direction a TCB works in, I am not sure that is a
useful question.  Given a TCB somewhere in the middle of a chain (not the
beginning), asking "what direction does this work on" is generally less
important than "what subset of the traffic will get handed to this".  If
you have enough information to answer that question, you can determine
easily what direction that is in.  One could view this (IfDirection in each
table) as a simpler way to answer that question.  But we usually have an
approach that tries to make sure that we really have use for attributes
before throwing them in to simplify a question we might want to ask.
(By the way, the current structure makes it very hard for a human reader to
figure out what the "first" think done to a packet in each direction
is.  It can be determined, but it is not simple.)

Yours,
Joel M. Halpern

At 10:18 AM 8/1/00 +1000, Geoff Huston wrote:

>At 07:55 PM 7/31/00 -0400, Joel M. Halpern wrote:
>>[Rephrasing what I suggested in the room to get wider review.]
>>
>>I would like to suggest that IfDirection be removed from all of the
>>tables where it now appears.
>>Instead, have a single table indexed by IfDirection.  The only attribute
>>in this table would be a RowPointer to the row describing the first thing
>>to do to packets traveling in that direction.  In the case where the
>>RowPointer points to the classifier table, it implicitly points to all
>>classifier entries in the same TCB as the Row that is pointed to.
>>
>>This effectively factors out the IfDirection from all the tables to allow
>>it to be used effectively for its intended purpose.
>>I believe that a side effect of this would be to remove any concern in
>>the processing path about the falues used to identify different TCBs.
>
>
>Does this proposal adequately allow a query agent to establish which
direction
>of traffic is operated upon by a TCB?
>
>Do you really mean "indexed by IF direction"? Surely there are only
>two values in this index, IN and OUT.
>
>regards,
>
>    Geoff Huston
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 01 Aug 2000 14:13:53 -0400

Thank you for the correction. Clearly the "direction" table would need to 
have IfIndex as its primary index, and therefore the actual table is bigger 
than two entries.
Yours,
Joel

---

From: Geoff Huston <[email-masked]>
Date: Thu, 03 Aug 2000 00:03:29 +1000

That was the point of my original question, where I thought
Joel really wanted the index is some way of referencing the
TCB and the value is the direction.

   thanks,

   Geoff

At 02:13 PM 8/1/00 -0400, Joel M. Halpern wrote:
>have IfIndex as its primary index, and therefore the actual table is 
>bigger than two entries.
>Yours,
>Joel
>