Subject: RE: [Diffserv] The EF definition

From: Shahram Davari <[email-masked]>
Date: Thu, 27 Jul 2000 14:47:22 -0700

Hi,

>-----Original Message-----
>From: Grenville Armitage [mailto:[email-masked]]
>Sent: Thursday, July 27, 2000 5:44 PM
>To: Shahram Davari
>Cc: [email-masked]'; 'Diff Serv'
>Subject: Re: [Diffserv] The EF definition
>
>
>
>
>Shahram Davari wrote:
>
>> >From: Brijesh Kumar [mailto:[email-masked]]
>	[..]
>> >The EF traffic  should receive the rate at which it arrived when
>> >measured over any period of duration T provided the rate of 
>arrival is
>                                          ^^^^^^^^
>> >less than or equal to the configured rate R.
>   ^^^^^^^^^^^^^^^^^^^^^
>
>	[..]
>> Assume the EF flow is nicely shaped except for the 2nd 
>packet which has a
>> jitter of T=MTU/C	[..]
>
>> As you can see your measured output rate is MTU/(20T) which 
>is half of your
>> measured input rate of 2MTU/(20T) during this interval. Any 
>more arguments?
>
>Seems like Brijesh's first sentence says it only applies during those
>periods where the ingress rate is <= R. So the interval you chose
>is automatically excluded.  

I knew somebody may ask this (but I thought it should be easy to figure it
out). For the record the ingress rate during the period that I chose is
exactly 2MTU/(20T)= 2MTU/(20MTU/C) = C/10 which is exactly equal to my
configured rate R=C/10.

Any other comment?

-Shahram

(Note too that the choice of T is
>basically a choice of jitter tolerance. Using only a multiple of 2
>creates a low jitter tolerance. Higher multiples of MTU/C would
>result in correspondingly higher tolerance of jitter when calculating
>the running average in/out rates. This is an operator configurable
>parameter.)
>
>cheers,
>gja
>_______________________________________________________________
>_________
>Grenville Armitage                    
>http://members.home.net/garmitage/
>Bell Labs Research Silicon Valley
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Grenville Armitage <[email-masked]>
Date: Thu, 27 Jul 2000 14:57:12 -0700

Shahram Davari wrote:
	[..]
> For the record the ingress rate during the period that I chose is

D'oh!  I'll just stick my head in an oven.

gja