Subject: RE: [Diffserv] Part 2: FWD: response to comments todraft-charny -ef-definition-00

From: Shahram Davari <[email-masked]>
Date: Wed, 26 Jul 2000 10:33:32 -0700

Hi Brian,

>-----Original Message-----
>From: Brian E Carpenter [mailto:[email-masked]]
>Sent: Wednesday, July 26, 2000 12:57 PM
>To: Shahram Davari
>Cc: Anna Charny; Kathleen Nichols; [email-masked]
>Subject: Re: [Diffserv] Part 2: FWD: response to comments
>todraft-charny-ef-definition-00
>
>
>Shahram Davari wrote:
>> 
>> Hi Brian,
>> 
>> You certainly can use PQ without any difficulty and assign 
>EF to the highest
>> priority. And I am sure it complies to the intent of EF-PHB. 
>However, it
>> seems impossible to perfectly comply to the formal 
>conformance definitions
>> of RFC-2598, which says:  "you SHOULD get at least the 
>configured rate over
>> any time interval greater than MTU/R (R is the configured rate)".
>> 
>> In the simplest form if the arrival rate of EF is always 
>smaller than the
>> configured rate, how can you get at least the configured 
>rate over any such
>> interval?
>
>Well, this is a problem I would be glad to have. We could always add
>"unless the offered load is less than the configured rate" to 
>the sentence
>you quote, if you think the obvious needs stating. 
>

I don't think that would help. Because RFC-2598 says:

"The EF PHB is defined as a forwarding treatment for a particular
 diffserv aggregate where the departure rate of the aggregate's
 packets from any diffserv node must equal or exceed a configurable
rate".

And as Kathy has proven in her mathematics, the arrival rate is always less
than or equal the departure rate. Therefore the conclusion is that EF PHB is
specifically defined for scenarios where the offered rate is less than or
equal the configured rate. 

So your proposed statement: "unless the offered load is less than the
configured rate". does not hold, because the offered load MUST be less than
the configured rate in order to get the EF behavior.

Regards,
-Shahram

>> 
>> So when somebody says they have implemented EF without 
>difficulty, what they
>> mean is that they are using PQ.
>
>Maybe. Let's hear from them. I know of people who are running 
>CBWFQ in support
>of EF.
>
>   Brian
>> 
>> Regards,
>> -Shahram
>> 
>> >-----Original Message-----
>> >From: Brian E Carpenter [mailto:[email-masked]]
>> >Sent: Wednesday, July 26, 2000 10:41 AM
>> >To: Anna Charny
>> >Cc: Kathleen Nichols; [email-masked]
>> >Subject: Re: [Diffserv] Part 2: FWD: response to comments
>> >todraft-charny-ef-definition-00
>> >
>> >
>> >Anna Charny wrote:
>> >...
>> >> > >Finally, we request that interested parties *read* RFC2598. The
>> >> > >body of the RFC (without the appendix) is not terribly long or
>> >> > >difficult reading. Similarly, with draft-ietf-diffserv-vw-pdb.
>> >> >
>> >> >
>> >> >Since certainly all of the authors of this draft spent long
>> >hours studying
>> >> >RFC 2598 we are assuming this comment is addressed to the
>> >rest of the
>> >> >mailing list?
>> >
>> >Anna, I think the point here is that the proponents of what I
>> >am calling
>> >EF-Jacobson believe that the proponents of what I am calling
>> >EF-Charny have a fundamental misunderstanding of EF-Jacobson, rather
>> >than that you have literally not read the RFC. We need to get to
>> >the bottom of this mutual misunderstanding, and we haven't 
>done so yet.
>> >So far you are talking across each other.
>> >
>> >There are certainly people who claim to have implemented RFC 2598
>> >without any particular difficulty, so this is not a 
>one-sided debate.
>> >I would actually like some of those implementors to speak up.
>> >
>> >    Brian
>> >
>> >_______________________________________________
>> >diffserv mailing list
>> >[email-masked]
>> >http://www1.ietf.org/mailman/listinfo/diffserv
>> >Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>> >
>
>-- 
>- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
>Brian E Carpenter 
>Program Director, Internet Standards & Technology, IBM 
>On assignment for IBM at http://www.iCAIR.org 
>Internet Society: http://www.isoc.org
>Non-IBM email: [email-masked]
>
>_______________________________________________
>diffserv mailing list
>[email-masked]
>http://www1.ietf.org/mailman/listinfo/diffserv
>Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 27 Jul 2000 10:36:33 -0500

> the configured rate in order to get the EF behavior.

I really can't believe we're arguing about this; this isn't a class
in syllogisms. How could any implementor be thrown into doubt by this?

Try replacing "departure rate" by "attainable departure rate".

   Brian