Subject: Re: [Diffserv] Fwd: response to comments on draft-charny-ef-definition-00

From: Anna Charny <[email-masked]>
Date: Wed, 26 Jul 2000 09:17:08 -0400

>
>In Principle I agree with the statement of Kathleen Nichols
>
>"It is certainly reasonable for the
>document's co-authors to define a different PHB and  the PDB(s) i
>n which they believe it will be useful, .."
>
>As I understand, draft-charny-ef-definition-00 states that there is
>no WORK-Conserving Scheduler which is compliant to RFC 2598. But it is not
>saying that there is NO NON-Work-Conserving Scheduler satisfying RFC 2598.

Quite so - we did not make a claim that it is not possible to implement EF 
with any non-work-conserving scheduler.  However, we actually do not know 
of one that does.
  The statement in our draft means, however, that you cannot implement EF 
with PQ, WFQ or any of the other schedulers listed in the RFC as 
compliant  since those are in fact work-conserving.

>I see another cause for the discussion is the statement about the time of 
>measurement
>in RFC 2598 "it SHOULD average at least the configured rate when measured 
>over any
>time interval equal to or longer than ..." where especially "over any time 
>interval"
>is problematic in my view. It would be no problem if it is mentioned that 
>"there is
>at least one start time in every MTU interval" which gives the required 
>average rate.

Start time of transmission? MTU interval *at the configured rate*?  You may 
not be able to achieve that in many of the examples we give in our draft.

Regards,
Anna

>Xiaoning Nie
>
>Infineon Technolgies
>Advanced Algorithms
>Balanstr. 55
>81541 Munich, Germany
>
>_______________________________________________
>diffserv mailing list
>[email-masked]
>http://www1.ietf.org/mailman/listinfo/diffserv
>Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>

---------------------------------------
Anna Charny
Cisco Systems, Inc
300 Apollo Drive
Chelmsford, MA  01824
Tel. (978)-244-8172
Fax (978)-244-8126

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 26 Jul 2000 11:49:26 -0500

I note that from the very beginning of diffserv, we have known that
certain scenarios cannot be satisfied by work-conserving schedulers,
and there is no presumption that a diffserv box must use work-conserving
schedulers.

To clarify one point, isn't your actual point that there is no
work-conserving scheduler that satisfies RFC 2598 for an arbitarily
large utilisation by EF traffic (rather than for a bounded utilisation)?

   Brian