Subject: RE: [Diffserv] Intuitive EF ?

From: Shahram Davari <[email-masked]>
Date: Wed, 26 Jul 2000 11:19:01 -0700

I have answered this to Brian and Brijesh. The EF-PHB can only be applied to
a traffic in which the offered load is less than the configured rate. If you
exclude this from the EF definition then you can't find any other traffic to
comply the RFC-2598 definition.

-Shahram 

>-----Original Message-----
>From: Grenville Armitage [mailto:[email-masked]]
>Sent: Wednesday, July 26, 2000 2:15 PM
>To: Shahram Davari
>Cc: DiffServ
>Subject: Re: [Diffserv] Intuitive EF ?
>
>
>
>Since your observed conformance failure is of the form "the EF packets
>are coming out slower than the configured rate", and I firmly believe
>most router designers know packets can't come out that haven't
>already gone in, I take this scenario as intuitively part of
>the existing RFC2598 definition, and therefore conformant.
>
>There's a saying that you only need QoS architectures when there's
>contention. Perhaps we need more explicit text in RFC2598 reflecting
>that truth. It would certainly appear to remove the supposed 
>conformance
>failure in 1.2.2.
>
>cheers,
>gja
>
>Shahram Davari wrote:
>> 
>> Grenville,
>> 
>> I think you misunderstood my comment. What I am trying to say is that
>> example 1.2.2 wants to show an output stream which is intuitively EF
>> conformant (as you and I both agree) but does not fulfill 
>the conformance
>> definitions of RFC-2598 as mentioned in my email. I never 
>said there is a
>> problem with this behavior. I just pointed out that 
>according to RFC-2598
>> this flow is not EF conformant, while it should be.
>> 
>> Regards,
>> -Shahram
>	[..]
>_______________________________________________________________
>_________
>Grenville Armitage                    
>http://members.home.net/garmitage/
>Bell Labs Research Silicon Valley
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Grenville Armitage <[email-masked]>
Date: Wed, 26 Jul 2000 12:05:35 -0700

Shahram,

> comply the RFC-2598 definition.

Nobody is excluding that case. But it is clearly equally trite to
observe that if there are no excess packets causing contention
for an outbound link, there's no need for diffserv. But that gets
us nowhere useful, because burstiness does cause localized excess
and thus localized violation of the "offered is less than configured"
rule. And that's when an EF stream ought to see "at least" the configured
rate available to it, and the "average" ought be measured across
actually transmitted EF packets.

My last sentence above always seemed (intuitively) the context
within which the RFC2598 text was to be interpreted. Assuming we
add it this intuition as explicit text, would the WG finally have
an observably testable definition for EF?  (This is roughly similar
to the point Brijesh has been making.)

cheers,
gja
________________________________________________________________________
Grenville Armitage                    http://members.home.net/garmitage/
Bell Labs Research Silicon Valley