Subject: RE: [Diffserv] Intuitive EF ?

From: Shahram Davari <[email-masked]>
Date: Wed, 26 Jul 2000 12:39:11 -0700

Hi,

I think you didn't get it. There are only 2 possibilities:

1) Arrival rate is greater than configured rate.
2) Arrival rate is less than configured rate.

The first case is already precluded from EF-PHB, according to RFC-2598, in
other words if arrival rate is greater than the configured rate you can't
provide EF behavior. The second case was suggested by Brian to be precluded
as well (in order to solve one of the examples). So that leaves no other
traffic. Does it?

-Shahram

>-----Original Message-----
>From: Rajesh Talpade [mailto:[email-masked]]
>Sent: Wednesday, July 26, 2000 3:20 PM
>To: [email-masked]
>Cc: [email-masked]; [email-masked];
>[email-masked]; [email-masked]
>Subject: Re: [Diffserv] Intuitive EF ?
>
>
>> >As the draft points out, the underlying reason for this problem is
>> >that the scheduler cannot forward EF traffic faster than it arrives.
>> >However, it can be easily seen that the existence of internal delay
>> >causes one packet to be inside the router at all times.
>> >
>> >While the addition of the condition that EF aggregate must 
>receive its
>> >configured rate only when the EF aggregate is backlogged may not
>> >suffice in this case, but  adding a more explicit condition that the
>> >configured rate is only achievable when EF aggregate arrival rate
>> >exceeds (or equal to (?)) the configured rate should remove the
>> >problem described in the 1.2.2. Let us see what you have 
>against these
>> >two simple conditions.
>> >
>> 
>> Although your proposed statement removes the problem of 1.2.2, but it
>> creates another problem. And that is RFC-2598 conformance 
>definition then
>> can't be applied to any flow at all. Because:
>> 
>> 1) IF the arrival rate is greater than the configured rate 
>then you can't
>> deliver EF-PHB, because you will have packet loss in the router.
>> 
>
>huh ?? if the arrival rate of EF traffic at a router
>exceeds the configured rate over a sustained period, packet loss will 
>result no matter what definition one uses for EF-PHB.
>
>i don't see the EF-PHB definition in rfc2598 precluding packet loss
>under such circumstances.
>
>it is more a matter of appropriate policing by the network operator
>to ensure that such conditions are not induced.
>
>
>
>rajesh.
>
>
>-- 
>Rajesh R. Talpade [email-masked] 973 829-4261
>Telcordia Technologies 
>
>_______________________________________________
>diffserv mailing list
>[email-masked]
>http://www1.ietf.org/mailman/listinfo/diffserv
>Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Rajesh Talpade <[email-masked]>
Date: Wed, 26 Jul 2000 15:47:11 -0400 (EDT)

> provide EF behavior. 

and what i commented was that if arrival rate is indeed greater than
configured rate over a sustained period, you can't really provide
any behavior, can u ? apart from packet loss, of course ? :-)

rajesh.