Subject: [Diffserv] AF Classes standardization

From: Radhakrishna <[email-masked]>
Date: Mon, 10 Jul 2000 15:02:17 +0530

There is no relation defined between AF classes and hence is left to
provider of the DS domain. This will lead to in-consistence use of
AF classes where in two domains might use different classes (and
codepoints) to provide the same service (for example, domain 1
uses AF1 and domain 2 uses AF4 for Olympic gold service).
Although, remarking could be used between the domains, it is basically
taking away from consistence usage of AF classes and their codepoints.
Especially, when a customer is subscribed to more than one service
provider and uses host pre-marking, he needs complex mechanisms
to get the desired service.

In the absence of standard relationship between AF classes, their usage
is similar to local usage PHBs except that there is some relation between
PHBs within an AF class.

Is there any effort going on to standardize the relation between AF classes
?

Following what I propose to be good relation, keeping in mind the various
applications.

     AF1 >= AF2 >= AF3 >= AF4 in terms of low delay, and
     AF4 >= AF3 >= AF2 >= AF1 in terms of high throughput.

With above relationship, AF1/AF2 could be always associated with delay
sensitive
low volume applications like voice, telnet, etc., while AF3/AF4 could be
associated
with throughput sensitive applications like FTP, HTTP, etc.

Regards,
......RK
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Radhakrishna <[email-masked]>
Date: Mon, 10 Jul 2000 16:16:31 +0530

I din't mean any direction. What I meant with the proposed
relationship is AF3/AF4 will provide relatively higher throughput
while AF1/AF2 will provide relatively lower delay. You could use
in any direction and in this case, you can have AF3/AF4 for
the data coming in reverse path.

Regards,
......RK

> -----Original Message-----
> From:	Ronaldo Salles [SMTP:[email-masked]]
> Sent:	Monday, July 10, 2000 4:21 PM
> To:	Radhakrishna
> Cc:	[email-masked]
> Subject:	Re: [Diffserv] AF Classes  standardization
> 
> Hi,
> 
> it is not clear for me, maybe I'm missing the point, why would you use
> AF3/AF4 to "throughput sensitive applications like FTP, HTTP" since you
> would be requiring a service in the direct path and most of the data would
> be comning in the reverse path.
> 
> regards,
> rms.
> 
> 
> ----- Original Message -----
> From: Radhakrishna <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, July 10, 2000 10:01 AM
> Subject: [Diffserv] AF Classes standardization
> 
>