Subject: RE: [Diffserv] Part 2: FWD: response to comments todraft-charny- ef-definition-00

From: Shahram Davari <[email-masked]>
Date: Wed, 26 Jul 2000 08:28:01 -0700

Hi Brian,

You certainly can use PQ without any difficulty and assign EF to the highest
priority. And I am sure it complies to the intent of EF-PHB. However, it
seems impossible to perfectly comply to the formal conformance definitions
of RFC-2598, which says:  "you SHOULD get at least the configured rate over
any time interval greater than MTU/R (R is the configured rate)".

In the simplest form if the arrival rate of EF is always smaller than the
configured rate, how can you get at least the configured rate over any such
interval?

So when somebody says they have implemented EF without difficulty, what they
mean is that they are using PQ.

Regards,
-Shahram 

>-----Original Message-----
>From: Brian E Carpenter [mailto:[email-masked]]
>Sent: Wednesday, July 26, 2000 10:41 AM
>To: Anna Charny
>Cc: Kathleen Nichols; [email-masked]
>Subject: Re: [Diffserv] Part 2: FWD: response to comments
>todraft-charny-ef-definition-00
>
>
>Anna Charny wrote:
>...
>> > >Finally, we request that interested parties *read* RFC2598. The
>> > >body of the RFC (without the appendix) is not terribly long or
>> > >difficult reading. Similarly, with draft-ietf-diffserv-vw-pdb.
>> >
>> >
>> >Since certainly all of the authors of this draft spent long 
>hours studying
>> >RFC 2598 we are assuming this comment is addressed to the 
>rest of the
>> >mailing list?
>
>Anna, I think the point here is that the proponents of what I 
>am calling
>EF-Jacobson believe that the proponents of what I am calling
>EF-Charny have a fundamental misunderstanding of EF-Jacobson, rather
>than that you have literally not read the RFC. We need to get to
>the bottom of this mutual misunderstanding, and we haven't done so yet.
>So far you are talking across each other.
>
>There are certainly people who claim to have implemented RFC 2598
>without any particular difficulty, so this is not a one-sided debate.
>I would actually like some of those implementors to speak up.
>
>    Brian
>
>_______________________________________________
>diffserv mailing list
>[email-masked]
>http://www1.ietf.org/mailman/listinfo/diffserv
>Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 26 Jul 2000 11:57:00 -0500

> configured rate, how can you get at least the configured rate over any such

Well, this is a problem I would be glad to have. We could always add
"unless the offered load is less than the configured rate" to the sentence
you quote, if you think the obvious needs stating. 

> mean is that they are using PQ.

Maybe. Let's hear from them. I know of people who are running CBWFQ in support
of EF.

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Program Director, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Internet Society: http://www.isoc.org
Non-IBM email: [email-masked]

---

From: Grenville Armitage <[email-masked]>
Date: Wed, 26 Jul 2000 10:53:25 -0700

Shahram Davari wrote:
	[..]
> configured rate, how can you get at least the configured rate over any such

For all the talk about "intuition" in draft-charny-ef-definition-00.txt
whatever happened to the intuitive understanding that a packet cannot
go out if it hasn't arrived?  Does that need to be stated explicitly
in RFC2598 (for people who dont subconciously assume this to be true)?

I see two constant themes in the complaints:

	- '"..over any time interval.." should mean any start/stop
	  times, but if it does then the formal definition fails'
		- I think this is at least partially resolved by
		  locking the start times to some EF packet in the
		  EF stream.
	- 'the egress rate cannot be "at least" the configured rate if
	   the EF packets are arriving at a regular, slower rate'
		- I take is as implied (intuitive, if you will) that
		  the EF PHB applies when there's contention for
		  egress resources. If there's no contention, chill.

cheers,
gja
________________________________________________________________________
Grenville Armitage                    http://members.home.net/garmitage/
Bell Labs Research Silicon Valley

---

From: "Brijesh Kumar" <[email-masked]>
Date: Wed, 26 Jul 2000 14:02:22 -0400

> From: [email-masked]
> [mailto:[email-masked]]On Behalf
> Of Brian E Carpenter
> Shahram Davari wrote:

> Maybe. Let's hear from them. I know of people who are running

I don't think it is such a insurmountable problem.

Yes, there is a problem in the definition of EF PHB draft which means
that none of the implementations may "precisely" fulfill the
definition as written in the draft. Assume, if the original draft was
written with added clarification so that there was no ambiguity about
"any time interval" in the statement - "you SHOULD get at least the
configured rate over any time interval greater than MTU/R (R is the
configured rate)" and also there was added condition that this is only
true when EF aggregate arrival rate exceeds the configured rate. I
wonder if this would have made any difference to how most vendors have
implemented this PHB in their boxes? Let us see the answers from
people who are proposing the new draft. Please don't give complex
mathematical derivations (as most have already admitted the problems
in the basic draft) - just give us plain text explanation that will
differentiate implementations in two cases.

Cheers,

--brijesh
Ennovate Networks Inc..