Subject: RE: [Diffserv] Proposal for Diffserv MIB - droppers

From: Andrew Smith <[email-masked]>
Date: Thu, 1 Jun 2000 16:28:01 -0700

I agree with you about the layer-violation. But I think you are then saying
that an algorithmic dropper cannot distinguish between stuff that is/was
marked as, say, AF12 and stuff that was marked as AF13, if they were fed
through the same meter before being queued. Is that too restrictive?

Andrew

> -----Original Message-----
> From: Fred Baker [mailto:[email-masked]]
> Sent: Thursday, June 01, 2000 4:01 PM
> To: Andrew Smith
> Cc: [email-masked]
> Subject: RE: [Diffserv] Proposal for Diffserv MIB - droppers
> 
> 
> At 02:59 PM 6/1/00 -0700, Andrew Smith wrote:
> >The issue is that we want to re-use the do_commonstuff() 
> building blocks and
> >that needs a "go to" because we do not have procedure calls 
> in the model (or
> >MIB syntax).
> 
> I have to say that this doesn't have a very strong image 
> match with my 
> model of how the MIB works. It seems to me that some combination of 
> classifiers and meters selects a set of actions and a queue, neatly 
> described in some kind of table, and at that point there is 
> no need to know 
> how you arrived at the table - you mere need to know the 
> contents of the 
> table. My queuing code doesn't even know that IP called it, 
> or that it is 
> queuing an IP datagram, much less that the code was worried 
> about the fact 
> that the DSCP contained the number 67. It knows that it has 
> been given a 
> message and a set of parameters, and that it is putting the 
> message into a 
> queue. It doesn't know anything else, and it doesn't need to 
> know anything 
> else.
> 
> I'll ask the question I have asked a number of times 
> concerning the model - 
> why do I have this layer violation here? Why can I not put 
> IPX traffic, 
> which has no DSCP, into the same queuing system if the 
> network operator 
> configures IPX routing?
> 
> Seems like a phenomenally poor architectural decision to make 
> the queues 
> and actions know anything about the classification or the meters. 
> Classification is separate because it is another question entirely, 
> something that good implementation design separates completely away.
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Fred Baker <[email-masked]>
Date: Thu, 01 Jun 2000 18:19:14 -0700

>through the same meter before being queued. Is that too restrictive?

I'm saying that someone that could decided what parameters to give to the 
dropper. The entire process knows, and because the layer 3 classifier is 
part of that process, the layer 2 dropper has no need to know.