Subject: RE: [Diffserv] Re: Proposal for Diffserv MIB - droppers

From: Andrew Smith <[email-masked]>
Date: Thu, 1 Jun 2000 14:34:22 -0700

See below - a couple of things that I don't quite understand.

> -----Original Message-----
> From: Fred Baker [mailto:[email-masked]]
> Sent: Thursday, June 01, 2000 11:21 AM
> To: Nabil Seddigh
> Cc: [email-masked]
> Subject: [Diffserv] Re: Proposal for Diffserv MIB - droppers

<Much good stuff about packet loss somewhere near Pismo Beach deleted>

> > > diffServRandomDropMaxThreshold OBJECT-TYPE
> >Another rewording suggestion for the DESCRIPTION:
> >
> >DESCRIPTION:
> >    "The threshold that provides primary notification of
> >     a severe congestion level. If the average queue depth
> >     exceeds this amount, the current rate of random dropping
> >     has not been successful in reducing congestion.
> >     Beyond this threshold, either 100% of packets are
> >     dropped or the packet drop probability is increased
> >     at a faster rate"
> 
> s/. Beyond this threshold/; therefore/
> 
> otherwise, fine.

[Andrew] Not sure about the "either" here: that raises a red flag in my
mind. The second option is somewhat vague - can we not just say "100%"? What
does it mean to "increase the probability at a faster rate"? Rate w.r.t.
what?

> 
> >diffServRandomDropWeight OBJECT-TYPE
> >     SYNTAX       Unsigned32
> >     MAX-ACCESS   read-create
> >     STATUS       current
> >     DESCRIPTION
> >        "The weighting of past history in affecting the
> >         calculation of the current queue average. This
> >         value is an exponent, the inverse of which can
> >         be used to calculate the actual weighting factor"
> >     ::= { diffServRandomDropEntry ? }
> 
> is it the inverse of the exponent, or the inverse of the 
> exponentiated 
> exponent? I think it would be better to read
> 
> "The weighting of past history in affecting the calculation 
> of the current 
> queue average using  an exponentially weighted moving 
> average. This value 
> is an exponent of two; the factor for the new information is 
> 1/(2^diffServRandomDropWeight), and the factor for the 
> history term is 
> 1-1/(2^diffServRandomDropWeight)."
> 
> Does that work?

[Andrew] Is it a valid assumption that the averaging is an EWMA function?
We've been careful not to mention the specifics of the smoothing algorithm
up to now - this would be the first time in the {Model/MIB} set that this
were mentioned as "the" way to do it.

... 
> Are we precessing in a useful direction?

[Andrew] Somewhat. But there's a deafening silence from some who were quite
vocal on these topics in the past.

Andrew

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Fred Baker <[email-masked]>
Date: Thu, 01 Jun 2000 16:08:31 -0700

At 02:34 PM 6/1/00 -0700, Andrew Smith wrote:
>mind. The second option is somewhat vague - can we not just say "100%"?

I'd rather see "drop 100%", personally.

>[Andrew] Is it a valid assumption that the averaging is an EWMA function?

It's what RED93 calls for. I tried to describe it more generally and got 
blasted.

>were mentioned as "the" way to do it.

Semi-agreed, but it seems that several have called for some description of 
the "weight" used in smoothing. I can tell you that customers like to be 
able to control this. Can you suggest a more general way to do this?

>vocal on these topics in the past.

You'll notice that there is normally a deafening silence from me. I find 
this list pretty noisy, and so dive in when I perceive that there is a 
discussion that I need to contribute to. I suspect that might be the 
viewpoint of one or more other people as well.