Subject: RE: [Diffserv] Token bucket burst size

From: Shahram Davari <[email-masked]>
Date: Tue, 13 Jun 2000 13:44:11 -0700

Roch,

What I am trying to say is that when RFC-2697 says that:
"A packet is marked green if it doesn't exceed the CBS.", it means that when
a packet exceeds the CBS it is not marked as green. However, I proved that
if the size of the TB is CBS (which is the case in RFC-2697), then it is
possible to have packets marked green while they exceed CBS.

Don't you see any contradiction?

-Shahram

>-----Original Message-----
>From: Roch Guerin [mailto:[email-masked]]
>Sent: Tuesday, June 13, 2000 4:38 PM
>To: Shahram Davari
>Cc: [email-masked]'; [email-masked]'
>Subject: Re: [Diffserv] Token bucket burst size
>
>
>Shahram,
>
>I'm still not sure I follow you.
>
>> RFC-2697 says:
>> 
>> "The maximum size of the token bucket C is CBS."
>> "A packet is marked green if it doesn't exceed the CBS."
>> 
>> I think you agree that CBS can not present both the bucket 
>size and the
>> allowable burst size. So we have to use two different 
>parameters in these
>> two statements. Right? If so then the RFC needs a change.
>
>to me, this is just a rule that specifies the 
>conformance checking for packets.  it uses a
>standard terminology, which I think you are 
>saying may be confusing because it appears
>to imply that bucket depth = maximum feasible burst size.
>i hadn't really thought that this was a likely
>source of confusion, as this is a pretty well
>documented issue, but if you think it is, the
>best way to fix this in my mind it to put a
>warning statement as a preamble to warn
>people not to make such an assumption.
>
>is this what you have in mind by "change"?
>
>Roch
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Roch Guerin <[email-masked]>
Date: Tue, 13 Jun 2000 17:06:09 -0400

Shahram Davari wrote:
Shahram,
I'm about to go off-line for a few hours, and
so may not respond immediately to subsequent 
emails, but no I do not see a contradiction.

This is mainly because I never assumed that 
sentence to refer to an actual transmitted burst
size, and instead refer to the max bucket sizes that
are described later, i.e., a packet is marked
green/yellow if its token deficit does not 
exceed CBS/EBS.  Again, the terminology used
was consistent with past usages, e.g., FR and
ATM, and we had not really thought it would
create confusion.  But if it does, we can certainly
amend it, say, as follows:

"A packet is marked green if its token deficit (see
below) doesn't exceed the CBS.  Note that as shown
in refs[ATM TM 4.0, etc.], the worst case burst
size that can be sent in the network can exceed CBS."

is this the issue you had?

Roch