Subject: RE: [Diffserv] Comments on the -03 draft of the Diffserv MIB

From: Andrew Smith <[email-masked]>
Date: Fri, 2 Jun 2000 15:26:20 -0700

I did not include the full description there - sorry. The variable would be
updated *at least as often as* sysUpTime: i.e. whenever sysUpTime were
changed and also when the plumbing were changed - that was Bob's complete
suggestion.

Andrew

> -----Original Message-----
> From: Fred Baker [mailto:[email-masked]]
> Sent: Friday, June 02, 2000 3:10 PM
> To: Andrew Smith
> Cc: 'Keith McCloghrie'; [email-masked]
> Subject: RE: [Diffserv] Comments on the -03 draft of the Diffserv MIB
> 
> 
> At 03:01 PM 6/2/00 -0700, Andrew Smith wrote:
> >[Andrew] So I think you are saying that, if we define our 
> own discontinuity
> >time, we should just mandate in the DESCRIPTION that it be 
> explicitly set to
> >sysUpTime whenever sysUpTime is changed.
> 
> in that case, it is sysUpTime in another variable, which 
> seems a little 
> pointless. I'm missing something here (as usual). The benefit 
> of having a 
> separate discontinuity time is what again?
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Andrew Smith <[email-masked]>
Date: Fri, 2 Jun 2000 16:50:57 -0700

Right, that's what I meant.

Andrew

> From: Keith McCloghrie [mailto:[email-masked]]
> Sent: Friday, June 02, 2000 4:44 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Diffserv] Comments on the -03 draft of the Diffserv MIB
...
> I don't think you mean that.  sysUpTime changes every one hundredth of
> a second :-), and Fred would be right.
> 
> Let me try again - the counters related to any discontinuity 
> indicator,
> xxxDiscontinuityTime (i.e., not just those for 
> ifCounterDiscontinuityTime)
> need to be defined as:
> 
>                Discontinuities in the value of this counter can occur
>                at re-initialization of the management system, and at
>                other times as indicated by the value of 
>                xxxDiscontinuityTime.
> 
> or to use your syntax:
> 
>    sysUpTime was reset OR xxxDiscontinuityTime changed
> 
> The reason is that the value of ifCounterDiscontinuityTime is not
> necessarily changed on a sysUpTime reset.  For example, if no counter
> discontinuities occur between two successive reboots, then the value
> of xxxDiscontinuityTime:
> 
> - before the 2nd reboot is zero, and
> - after the 2nd reboot is also zero.
> 
> So if you only look for changes in the value of xxxDiscontinuityTime,
> you will miss the discontinuity that occurs due to the 2nd reboot.
> 
> Keith.
>