Subject: re:[Diffserv] Second proposal for Diffserv MIB - Droppers

From: "Nabil Seddigh" <[email-masked]>
Date: Mon, 5 Jun 2000 00:12:35 -0400 (EDT)

Fred,

I think this looks pretty good - few comments
below. Agree with you that we need further discussion
on the key remaining issue (connection 'tween classifier/action
and the dropper table).

"" <[email-masked]> writes:

[...stuff deleted....]

>
>diffServRandomDropTable OBJECT-TYPE
>    SYNTAX       SEQUENCE OF DiffServRandomDropEntry
>    MAX-ACCESS   not-accessible
>    STATUS       current
>    DESCRIPTION
>       "The random drop table augments the algorithmic drop table. 
>       It contains entries describing a process that drops packets
>       randomly. It is pointed to by diffServAlgDropSpecific in such
>       cases."
>    REFERENCE
>        "[MODEL] section 7.1.3"
>    ::= { diffServTables ? }
>

Do we now have a diffServAlgDropType value for RED (4?)
or do we still use the value "other" (1) for RED?
My suggestion is to use the former.

>diffServRandomDropEntry OBJECT-TYPE
>    SYNTAX       DiffServRandomDropEntry
>    MAX-ACCESS   not-accessible
>    STATUS       current
>    DESCRIPTION
>       "An entry describes a process that drops packets according to
>       a random Algorithm."
>    INDEX { ifIndex, diffServAlgDropIfDirection,
>            diffServAlgDropId }
>    ::= { diffServRandomDropTable 1 }
>

Do we want to add a line saying that for each 
diffServAlgDropEntry we can only have one
corresponding diffServRandomDropEntry?

>DiffServRandomDropEntry ::= SEQUENCE  {
>    diffServRandomDropMinThreshold      Unsigned32,
>    diffServRandomDropMaxThreshold      Unsigned32,
>    diffServRandomDropInvWeight         Unsigned32,
>    diffServRandomDropInvMaxProbability Unsigned32
>}
>
>diffServRandomDropMinThreshold OBJECT-TYPE
>    SYNTAX       Unsigned32
>    UNITS        "packets"
>    MAX-ACCESS   read-create
>    STATUS       current
>    DESCRIPTION
>       "The average queue depth beyond which traffic has a
>	non-zero probability of being dropped or marked." 
>    ::= { diffServRandomDropEntry 1 }
>

Fine. One question pointed out by my colleague 
Bis Nandy: do we want the units in "pkts" or
"bytes"?

>diffServRandomDropMaxThreshold OBJECT-TYPE
>    SYNTAX       Unsigned32
>    UNITS        "packets"
>    MAX-ACCESS   read-create
>    STATUS       current
>    DESCRIPTION
>       "The average queue depth beyond which traffic has a
>	100% probability of being dropped or marked. Note that this
>	differs from the physical queue limit, which is stored in
>	diffServAlgDropQThreshold."
>    ::= { diffServRandomDropEntry 2 }
>

Fine. Same question as above re: "pkts" vs "bytes"?

>diffServRandomDropInvWeight OBJECT-TYPE
>    SYNTAX       Unsigned32
>    MAX-ACCESS   read-create
>    STATUS       current
>    DESCRIPTION
>	"The weighting of past history in affecting the calculation of
>	the current queue average.  The moving average of the queue
>	depth uses the inverse of this value as the factor for the new
>	queue depth, and one minus that inverse as the factor for the
>	historical average.
>
>	Implementations may choose to limit the acceptable set of
>	values to a specified set, such as powers of 2."
>   ::= { diffServRandomDropEntry 3 }
>

Fine.

>diffServRandomDropInvMaxProbability OBJECT-TYPE
>    SYNTAX       Unsigned32
>    MAX-ACCESS   read-create
>    STATUS       current
>    DESCRIPTION
>	"The inverse of the worst case random drop probability.  If
>	every packet may be dropped in the worst case (100%=1/1), this
>	is therefore one, and if in the worst case one percent of
>	traffic (1%=1/100) may be dropped, it is 100."
>   ::= { diffServRandomDropEntry 4 }
>

Fine.

Best,
---
Nabil Seddigh
[email-masked]

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Fred Baker <[email-masked]>
Date: Mon, 05 Jun 2000 23:48:43 +0800

>Do we now have a diffServAlgDropType value for RED (4?)

I had suggested sketching one in; I assume we do.

>corresponding diffServRandomDropEntry?

I'm not sure we're capable of having more than one, as the "Specific" 
variable can only point to one, and the indices between the two tables are 
identical.

>Bis Nandy: do we want the units in "pkts" or

good question. We want packets for sure; I think Sally would argue for 
bytes, and I would not argue against her on it. Are you proposing both 
objects, and use one-or-the-other in configuration?

---

From: Andrew Smith <[email-masked]>
Date: Mon, 5 Jun 2000 15:22:13 -0700

I missed that "UNITS packets" thing first time - I agree with Nabil that
those should be in bytes. But we should do a straw poll of current
implementations as to what units they use for thresholds.

Andrew

> -----Original Message-----
> From:	Nabil Seddigh [SMTP:[email-masked]]
> Sent:	Sunday, June 04, 2000 9:13 PM
> To:	[email-masked]
> Cc:	[email-masked]
> Subject:	re:[Diffserv] Second proposal for Diffserv MIB - Droppers
> 
> Fred,
>