Subject: [Diffserv] COUNTER ACTION - updated draft and open issues

From: "Nabil Seddigh" <[email-masked]>
Date: Thu, 8 Jun 2000 20:35:57 -0400 (EDT)

Sorry if I missed it but was there any resolution on 
the open issue re: explicit vs implicit counters as
stated below in Andrew's email? If there was then
ignore the rest of this email :)

I'm in agreement with an earlier poster (Brijesh?)
who argued that counting is something done implicitly 
and thus no need for the manager to explicitly 
configure a counter action.

Is anyone on this list aware of or involved in building
a box with explicitly configurable counters?

>
>3.2.  Still Open Issues
>
>(16) How should the creation of counter actions be under the control of
>     manager or agent: should a diffServActionEntry and
>     diffServCountActEntry appear by magic (the device surely knows
what
>     counters it can and cannot maintain on a given interface)? (assume
>     no) If not, should diffServCountActEntry appear magically when a
>     diffServAction element is created which points at the
>     diffServCountActTable (then would be no need for
>     diffServCountActStatus)? (assume no)
>

---
Nabil Seddigh
[email-masked]

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Andrew Smith <[email-masked]>
Date: Fri, 9 Jun 2000 11:34:10 -0700

I didn't see any other comment on this.

I do know of at least one box that has such configurable groups of counters
in the hardware. But I'm not sure the net manager will want to bother
configuring them - possibly. However, I do think it valuable to have
information regarding what counters are there, and in what elements,
reported back through the MIB. As I argued before on this list, I do think
that the incremental implementation cost of such counters is high enough to
justify making their inclusion optional.

Summary: I do think they should be represented as explicit actions in the
MIB. I am less sure that they need to be explicitly creatable through SNMP.

Andrew

> -----Original Message-----
> From:	Nabil Seddigh [SMTP:[email-masked]]
> Sent:	Thursday, June 08, 2000 5:36 PM
> To:	Andrew Smith
> Cc:	Diffserv (E-mail)
> Subject:	COUNTER ACTION - updated draft and open issues
>