Subject: RE: [Diffserv] Second proposal for Diffserv MIB - Droppers

From: Andrew Smith <[email-masked]>
Date: Fri, 2 Jun 2000 14:42:43 -0700

No I didn't mean real numbers. I guess I meant one of the 2 alternatives you
mention (a) a percent number, scaled to make it useful or (b) an exponent
base 2. 

I'd push for (b) if possible - I think that would give the best compromise
between utility for the standards'-based manager (based on how widely
implemented it would be) and ease-of-implementation for agents on binary
machines.

Andrew

> -----Original Message-----
> From: Fred Baker [mailto:[email-masked]]
> Sent: Friday, June 02, 2000 1:49 PM
> To: Andrew Smith
> Cc: [email-masked]
> Subject: RE: [Diffserv] Second proposal for Diffserv MIB - Droppers
> 
> 
> At 01:13 PM 6/2/00 -0700, Andrew Smith wrote:
> >I'd also prefer to have
> >diffServRandomDropInvWeight inverted
> 
> not sure what you mean by that. Given that there is religious 
> opposition to 
> supporting real numbers in SNMP, and the inverse is between 
> zero and one, 
> the alternative would be something like 
> diffServRandomDropWeightPercent 
> (represent it as some number of discrete units of size 
> smaller than one and 
> greater than zero) or to represent the integer exponent of 2 
> in the case.
> 
> The issue with real numbers has historically been something 
> about having 
> six different formats in ASN.1 and wouldn't we have to pick 
> one and by the 
> way there is no valid utility for real numbers in datagram 
> networking, 
> things like this and like Integrated Services being 
> completely beside the 
> point. But that's another rant.
> 
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Fred Baker <[email-masked]>
Date: Fri, 02 Jun 2000 15:06:52 -0700

>implemented it would be) and ease-of-implementation for agents on binary

I'll happily go there. Nabil didn't care for it, and my tech writers 
blanched, didn't use the text I provided them, and have engendered any 
number of "what the heck is that" questions from customers who couldn't 
figure out what in the world the English majors were trying to describe. But
if you want to say instead...

diffServRandomDropWeight OBJECT-TYPE
     SYNTAX       Unsigned32
     MAX-ACCESS   read-create
     STATUS       current
     DESCRIPTION
         "The weighting of past history in affecting the calculation of
         the current queue average using  an exponentially weighted
         moving average. This value is an exponent of two; the factor
         for the new information is 1/(2^diffServRandomDropWeight), and
         the factor for the history term is 1-1/(2^diffServRandomDropWeight)."
    ::= { diffServRandomDropEntry 3 }

I'm all for it. That was my suggestion to Nabil on this, and he was looking 
for
something more general.