Subject: RE: [Diffserv] draft-kanada-diffserv-qospifmib-00.txt

From: Andrew Smith <[email-masked]>
Date: Wed, 14 Jun 2000 11:18:14 -0700

I would not be comfortable with restricting queue depth units to "packets".
Is there any research that points to this being the only sensible unit? 

Bits, bytes or "buffering units" seems to be more appropriate to me: the
congestion that we are trying to manage is due to lack of available
bit-transmission capacity, not lack of packet slots, at least in most of the
common MAC layers.

Andrew

> -----Original Message-----
> From: Yasusi Kanada [mailto:[email-masked]]
> Sent: Tuesday, June 13, 2000 11:25 PM
> To: Fred Baker; [email-masked]
> Subject: Re: [Diffserv] draft-kanada-diffserv-qospifmib-00.txt
...
> BTW, Kwok allowed "kB" for the unit of queue depth, but you want to
> restrict this to "packets".  I think this is OK.
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Kathleen Nichols <[email-masked]>
Date: Wed, 14 Jun 2000 15:00:16 -0700

> Is there any research that points to this being the only sensible unit?

We're still "messing around" with this, but our research
would seem to be to the contrary; that is, if you can
get queue depth in one of the units you mention, it
is a good thing, though it's possible to work with
just packets.

---

From: Fred Baker <[email-masked]>
Date: Wed, 14 Jun 2000 16:28:55 -0700

At 11:18 AM 6/14/00 -0700, Andrew Smith wrote:
>Bits, bytes or "buffering units" seems to be more appropriate to me:

OK, Andrew, let's assume the existence of a consensus to:

         start with my "second proposal"

         support bandwidth and priority for schedulers by cloning
         the objects already present for queues

         add octet-count min-threshold and max-threshold objects;
         there should be supporting text that says one would not configure
         *both* packet depth and octet depth thresholds (unless someone
         thinks doing that is rational).

         make max drop rate be in drops per thousand packets, seeing as
         one cannot drop in units of octets, but an entire packet at a time.

Can you post an updated draft for WG review?