Subject: Re: [Diffserv] Token bucket burst size

From: Chatur sharp <[email-masked]>
Date: Tue, 13 Jun 2000 13:15:29 -0700 (PDT)

Brijesh is right when he says that in any given
interval T, you can send no more than T*R bytes.

I think one of the assumption being made by you
[Shahram] that bucket can accomadate packets to
begin with(initially) is incorrect. You have to 
wait for time T1 such 
              T1*b = B 

for bucket to empty up. 

Let us say at time T= T0 the bucket was completely
empty. And you send a packet of Size B at this point
in time. Then after an interval T(i) you could
send another packet of size T(i)*B but really what
you have done is that you have sent:
T(i)*B + B bytes in time T1 + Ti which is OK. 

And doesn not change the definition of burst at all.

Since there was a break of time T(i) before you 
sent more data. And consequently they do not fall
in the same burst.

One assumption made everywhere in traffic management
algorithms is continuity of time-(timer events
occuring all the time in time dimension) and we all
know how correct/incorrect this assumption is. And 
a lot of what we are discussion is to do with that.

Shahram you are correct in observing that if R = S
than burst size is effectively infinite. However, that
is not to say much. Since if you have one flow
which is allowed to send data with line rate than it
can occupy the link all the time and the burst size 
can be arbitrary large(infinite). In essence you have
provisioned this link for this single application as
you cannot drop any packet from this flow ( to meet 
SLA).

Alternatively you can think of this case as when the
burst size is zero. As you do not really need to 
accomodate anything in your bucket, you just let it
through. 

I think the issue is more theoretical than of
practical
utility.

> 
> 
> -----Original Message-----
> From: Shahram Davari
> [mailto:[email-masked]]
> Sent: Tuesday, June 13, 2000 1:34 PM
> To: [email-masked]'
> Cc: [email-masked]'
> Subject: [Diffserv] Token bucket burst size
> 
> 
> Hi,
> 
> Recently I have been working on TB, and I have found
> the following problem:
> 
> If we assume a TB (B, R), in which the TB counts can
> not go negative, then
> the Maximum burst size which can pass through this
> TB can be computed as
> following:
> 
> B: TB size
> R: TB rate
> S: input line rate
> T: Time required to exhaust the TB ( includes the
> Tokens already inside TB
> and the tokens that are accumulated in this period)
> MBS: Maximum Burst Size
> 
> 
> MBS = T * S = T * R + B 
> T = B / (S-R)
> MBS = B * S / (S-R)  ---> B = MBS * (S-R) / S
> 
> As you can see contrary to the general belief the
> MBS is not equal to the TB
> size "B". Unless S >>R.
> Example1:  if S = 2R --> MBS = 2B
> Example2: S = R --> MBS = infinite
> 
> However, in RFC-2697 and RFC-2698 the TB parameters
> are set as following:
> 
> Tc (size) = CBS
> Te (size) = EBS
> Tp (size) = PBS
> 
> While it should be set as following:
> 
> Tc (size) = CBS * (S-R) /S
> Te (size) = EBS * (S-R) /S
> Tp (size) = PBS * (S-R) /S
> 
> 
> Do you think this should be corrected?
> 
> 
> Shahram Davari
> Systems Engineer
> Product Research
> PMC-Sierra, Inc. (Ottawa) 
> 555 Legget drive,
> Suit 834, Tower B,
> Ottawa, ON K2K 2X3, Canada
> Phone: +1 (613) 271-4018
> Fax  : +1 (613) 271-7007
>     
> 
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

=====
I am willing to learn,  if you care to teach.
I am willing to teach, if you care to learn.

__________________________________________________
Do You Yahoo!?
Yahoo! Photos -- now, 100 FREE prints!
http://photos.yahoo.com

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Mark Stewart <[email-masked]>
Date: Tue, 13 Jun 2000 21:39:34 -0400

> interval T, you can send no more than T*R bytes.

I'm afraid not Chatur, the token buckets ( and the derivatives we are
discussing ) were explicitly designed to get around the fact that in
order to obtain an average rate R, which is less than the line rate,
over a large time interval in a packet based network it is necessary to
exceed the average rate R for short intervals.

Mark Stewart

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 13 Jun 2000 23:33:23 -0500

OK, here is the policeman again: this really is way off track for
any of the WG's current deliverables.

  Brian
  diffserv co-chair

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Program Director, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Attend INET 2000: http://www.isoc.org/inet2000
Non-IBM email: [email-masked]