Subject: [Diffserv] Model Draft TB?

From: Shahram Davari <[email-masked]>
Date: Thu, 15 Jun 2000 09:08:21 -0700

Hi,

Could the authors of Model draft please explain the following:

The Diffserv Model draft proposes a Simple TB model, in which, the Token
count can go negative up to "- MTU", and won't accept any packet while the
token count is negative. 

As far as I can see the only difference that this model has compared to a
Normal TB (i.e., the one that can't go negative) is that in a Normal TB,
large packets are punished after a set of small packets consume the tokens.
While in the Simple TB, small packets are punished after a large packet
consumes the tokens and causing negative token count.

If we consider the fact that the majority of the Internet traffic consists
of small packets (40% are ~40 byte, specially TCP control packets). I would
say that the Normal TB is the preferred one. On the other hand RFCs
2697,2698, 2211, 2212 , ATM and FR policers all are implemented using Normal
TB. 

So if there no strong reason, I highly recommend changing the Simple TB to a
Normal TB to be consistent with other IETF RFCs and ATM and FR and most
probably ITU.

Regards,

Shahram Davari
Systems Engineer
Product Research
PMC-Sierra, Inc. (Ottawa) 
555 Legget drive,
Suit 834, Tower B,
Ottawa, ON K2K 2X3, Canada
Phone: +1 (613) 271-4018
Fax  : +1 (613) 271-7007

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: "Brijesh Kumar" <[email-masked]>
Date: Thu, 15 Jun 2000 13:18:47 -0400

Hi Sharam,

I think you have a very valid point. Having said that, it is important
to note that  the real behaviour of TB depends on how one implements
it - no matter how the model draft defines it. I too couldn't figure
out why the model defined it differently, but it is not a big thing
for us. To me, the major critical factor is the granularity at which
the TB is implemented. But, you did raise a good question.

Cheers,

--brijesh
Ennovate Networks Inc.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf
> Of Shahram Davari
> Sent: Thursday, June 15, 2000 12:08 PM
> To: [email-masked]'
> Subject: [Diffserv] Model Draft TB?
>
>
> Hi,
>