Subject: RE: [Diffserv] draft-kanada-diffserv-qospifmib-00.txt

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 15 Jun 2000 13:14:46 -0400

> -----Original Message-----
> From: Andrew Smith [mailto:[email-masked]]

> As an aside, I don't think we've discussed this here (and it 
> has nothing to
> do with this consensus stuff) but I wonder how a RED dropper 
> that factors in
> the size of the packet when determining its drop probability 
> would behave -
> do any of the studies discuss this?

Interesting notion. Just words here:

If the strategy were to give small packets a higher drop probability, then
TCP become slow but remain successful. Any small packets would be dropped,
so the TCP source would soon be generating mostly large packets.

At the same time, UDP streams using small packets would show lots of
dropouts.

If the opposite strategy were implemented, then if things got congested and
TCP sessions became backup up, TCP would soon quit completely. On the other
hand, UDP flows would be very good, low jitter, low latency.

Bert
[email-masked]

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 15 Jun 2000 18:49:14 +0100 (BST)

> so the TCP source would soon be generating mostly large packets.

I don't follow this.

TCP acks are small, so they're at a disadvantage here.

telnet packets will suffer, packets at the path MTU size can't be made
any larger, and where's the algorithm in TCP that says 'I'm
experiencing congestion, so I'll try sending larger packets to get
around it'? We already have path MTU discovery to reduce the number of
packets from the start.

L.

> [email-masked]

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

---

From: Kathleen Nichols <[email-masked]>
Date: Thu, 15 Jun 2000 12:08:30 -0700

I'm with Lloyd here: there's no reason to assume that
small packets are inherently evil and should be dropped.
(Just as this is also true of UDP packets.)
And some experimentation has us believing it's best
to to just "count packets" regardless of size when it
comes to implementing drop probabilities.