Subject: RE: [Diffserv] Some comments on Diff-Serve Conceptual Model Draf t 3

From: Andrew Smith <[email-masked]>
Date: Fri, 2 Jun 2000 13:44:40 -0700

Is the following a more helpful (and correct) picture than the one in the
current figure 5? The intent is to show that the drop could be either from
the head or the tail of the FIFO.

                 +--------------------------------------+
                 | +------------+        +-----------+  |Algorithmic
                 | | smoothing  |    n   |trigger &  |  |Dropper
                 | | function(s)|---/--->|discard    |  |
                 | | (optional) |        |calc.      |  |
                 | +------------+        +-----------+  |
                 |            ^     TailDrop| |HeadDrop |
                 +------------|-------------|-|---------+
                              |             | |
                          +---|-------------+ |
                          |   |               |
                          v   |Depth          v  
    Input                ----------------------+     to Scheduler
  -----------------------------> |x|x|x|x|x|x|x|------------------>
                         ----------------------+        
                           FIFO     |     
                                    |
                                  | | |
                                  | v | bit-bucket
                                  +---+
 
      Figure 5. Algorithmic Dropper + Queue

If people agree, then I would propose replacing the picture in the draft
with this one.

Andrew

> -----Original Message-----
> From: Mark Stewart [mailto:[email-masked]]
> Sent: Friday, June 02, 2000 7:59 AM
> To: Andrew Smith
> Subject: Re: [Diffserv] Some comments on Diff-Serve Conceptual Model
> Draft 3
...
> > > Figure 5 Section 7.1.3 seems to preclude actions
> > > other than tail drop ( e.g. head drop )
> >
> > Thanks - that wasn't the intent: I drew that picture 
> thinking that the
> > algorithmic dropper could be placed either ahead of or 
> behind the FIFO
> > element: the words or picture need to be clearer that head drop is
> > explicitly permitted. One question still in my mind is 
> whether the choice is
> > between {headDrop, tailDrop, randomDrop} or whether {head, 
> tail} was one
> > choice and {deterministic, random} was an orthogonal 
> choice. Am I getting
> > confused about what the "randomness" applies to (is it 
> w.r.t. *this packet*
> > or is the choice of which packet to drop actually random?) 
> Any opinions?
> 
> It does sound like you just confused yourself. There are 
> certainly two randoms
> in play here.
> * a random decision which determines do I drop or not, and
> * a random decision of which packet do I drop.
> 
> The first fits easily into the queueing block model 
> described, but the second
> does not seem so easy to me.

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Mark Stewart <[email-masked]>
Date: Sun, 04 Jun 2000 13:02:24 -0400

I favor the retention of the current diagram over this revision.
Whilst the revision does remove any ambiguity about Head drop being an
option, it makes it harder to decipher the role of the algorithmic dropper.

Mark Stewart