Subject: RE: [Diffserv] Token bucket burst size

From: Shahram Davari <[email-masked]>
Date: Tue, 13 Jun 2000 12:55:01 -0700

Roch,

RFC-2697 says:

"The maximum size of the token bucket C is CBS."
"A packet is marked green if it doesn't exceed the CBS."

I think you agree that CBS can not present both the bucket size and the
allowable burst size. So we have to use two different parameters in these
two statements. Right? If so then the RFC needs a change.

Cheers
-Shahram

>-----Original Message-----
>From: Roch Guerin [mailto:[email-masked]]
>Sent: Tuesday, June 13, 2000 3:21 PM
>To: Shahram Davari
>Cc: [email-masked]'; [email-masked]'
>Subject: Re: [Diffserv] Token bucket burst size
>
>
>Shahram,
>
>Not sure why you say 
>
>> As you can see contrary to the general belief the MBS is not 
>equal to the TB
>> size "B".
>
>The relation between bucket size and actual
>burst size has been documented in several settings,
>including ATM and the GS RFC (indirectly there through
>the buffer requirements computation).
>The ATM Traf. Mgt. doc actually spends quite
>a bit of time detailing the relation as a
>function of various parameters, to the point
>that (in my opinion) it becomes highly confusing.
>
>The one parameter that is easy to specify is
>the bucket depth, and it does determine, at
>least partly, the ensuing burst size, so that
>I guess people have become accustomed to the
>abuse of notation.  It may be worthwhile pointing
>this out again, but i am not sure it calls for a
>change in nomenclature.  
>
>As side comment, you don't really need to allow
>the TB count to go negative to get the expression, 
>only to have arbitrarily small packets.  If you 
>allow TB to go negative, you actually need to add
>L (an MTU size packet) to the burst size you get.
>Also, when S=R, then you don't really have "bursts",
>at least not in the way I usually understand bursts.
>So the fact that the "burst" size can go to infinity
>is not really an issue.  But it is true that the
>burst size can get relatively large if S and R are close.
>
>Roch
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Roch Guerin <[email-masked]>
Date: Tue, 13 Jun 2000 16:37:31 -0400

Shahram,

I'm still not sure I follow you.

> two statements. Right? If so then the RFC needs a change.

to me, this is just a rule that specifies the 
conformance checking for packets.  it uses a
standard terminology, which I think you are 
saying may be confusing because it appears
to imply that bucket depth = maximum feasible burst size.
i hadn't really thought that this was a likely
source of confusion, as this is a pretty well
documented issue, but if you think it is, the
best way to fix this in my mind it to put a
warning statement as a preamble to warn
people not to make such an assumption.

is this what you have in mind by "change"?

Roch