Subject: RE: [Diffserv] Token bucket burst size

From: Shahram Davari <[email-masked]>
Date: Tue, 13 Jun 2000 13:36:16 -0700

Mark,

Yes. When RFC-2697 says:

"A packet is marked green if it doesn't exceed the CBS, yellow if it does
exceed the CBS, but not the EBS, and red otherwise."

This statement says that a packet is marked green if it sends bursts smaller
than CBS and non-green if it sends bursts greater than CBS. To me this is
identical to saying that CBS is the allowable burst size.

Don't you think so?

-Shahram

>-----Original Message-----
>From: Mark Stewart [mailto:[email-masked]]
>Sent: Tuesday, June 13, 2000 4:25 PM
>To: Shahram Davari
>Cc: [email-masked]'; [email-masked]'
>Subject: Re: [Diffserv] Token bucket burst size
>
>
>Hi Shahram
>
>I agree that should CBS should not represent two things, but 
>other than an
>unfortunate choice of name I see nothing to indicate that CBS is the
>"allowable burst size". Do you see a piece of text indicating 
>that CBS is the
>allowable burst size.
>
>Ta
>
>Mark Stewart
>
>Shahram Davari wrote:
>
>> Mark,
>>
>> Yes. Please check my earlier email:
>>
>> FC-2697 says:
>>
>> "The maximum size of the token bucket C is CBS."
>> "A packet is marked green if it doesn't exceed the CBS."
>>
>> I think you agree that CBS can not present both the bucket 
>size and the
>> allowable burst size. So we have to use two different 
>parameters in these
>> two statements. Right? If so then the RFC needs a change."
>>
>> -Shahram
>>
>> >-----Original Message-----
>> >From: Mark Stewart [mailto:[email-masked]]
>> >Sent: Tuesday, June 13, 2000 4:05 PM
>> >To: Shahram Davari
>> >Cc: [email-masked]'; [email-masked]'
>> >Subject: Re: [Diffserv] Token bucket burst size
>> >
>> >
>> >Hi Shahram
>> >
>> >Do you have any reason for beleiving that [CEP]BS should 
>have the same
>> >interpretation as the MBS? It appears to me that they are
>> >merely tolerances
>> >used by the token buckets.
>> >
>> >c u
>> >
>> >Mark Stewart
>> >
>> >Shahram Davari wrote:
>> >
>> >> Hi,
>> >>
>> >> Recently I have been working on TB, and I have found the
>> >following problem:
>> >>
>> >> If we assume a TB (B, R), in which the TB counts can not go
>> >negative, then
>> >> the Maximum burst size which can pass through this TB can be
>> >computed as
>> >> following:
>> >>
>> >> B: TB size
>> >> R: TB rate
>> >> S: input line rate
>> >> T: Time required to exhaust the TB ( includes the Tokens
>> >already inside TB
>> >> and the tokens that are accumulated in this period)
>> >> MBS: Maximum Burst Size
>> >>
>> >> MBS = T * S = T * R + B
>> >> T = B / (S-R)
>> >> MBS = B * S / (S-R)  ---> B = MBS * (S-R) / S
>> >>
>> >> As you can see contrary to the general belief the MBS is not
>> >equal to the TB
>> >> size "B". Unless S >>R.
>> >> Example1:  if S = 2R --> MBS = 2B
>> >> Example2: S = R --> MBS = infinite
>> >>
>> >> However, in RFC-2697 and RFC-2698 the TB parameters are set
>> >as following:
>> >>
>> >> Tc (size) = CBS
>> >> Te (size) = EBS
>> >> Tp (size) = PBS
>> >>
>> >> While it should be set as following:
>> >>
>> >> Tc (size) = CBS * (S-R) /S
>> >> Te (size) = EBS * (S-R) /S
>> >> Tp (size) = PBS * (S-R) /S
>> >>
>> >> Do you think this should be corrected?
>> >>
>> >> Shahram Davari
>> >> Systems Engineer
>> >> Product Research
>> >> PMC-Sierra, Inc. (Ottawa)
>> >> 555 Legget drive,
>> >> Suit 834, Tower B,
>> >> Ottawa, ON K2K 2X3, Canada
>> >> Phone: +1 (613) 271-4018
>> >> Fax  : +1 (613) 271-7007
>> >>
>> >>
>> >> _______________________________________________
>> >> diffserv mailing list
>> >> [email-masked]
>> >> http://www1.ietf.org/mailman/listinfo/diffserv
>> >> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>> >
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Mark Stewart <[email-masked]>
Date: Tue, 13 Jun 2000 21:21:26 -0400

Hi Shahram

No I don't interpret that text in that light, but partly because I've
spent so long with conformance definitions for ATM. It's just another
example of really ugly text trying to oversimplify token buckets, which
ends up confusing people.

The statement actualy says that the size of the packet ( in isolation to
any concept of rate ) determines the packets marking. As this is obviously
not the intent, lets see if we can come up with some better text. Something
of the nature

A data stream of packets is marked green if it does not exceed the CIR.
CBS defines an additional volume of data by which packets may exceed
the CIR and still be marked as green. EBS defines a further volume of data
by which the CIR may be exceeded, with these packets being marked
as yellow. Any additional packets will be marked as red.

*ponder* Thats possibly worse than what is there allready! somebody else
please have a stab at it.

c u

Mark Stewart