Subject: RE: [Diffserv] Token bucket burst size

From: Shahram Davari <[email-masked]>
Date: Tue, 13 Jun 2000 12:53:51 -0700

Kumar,

I did not claim that you could send MBS= T *R + B packets back to back in a
stream. I know that the average rate that comes out of TB is still R.  What
I wanted to prove was that it is possible to find a period "T" in which a
burst of size greater than B can pass through the TB, which I think I did.

Regards,
-Shahram

>-----Original Message-----
>From: Brijesh Kumar [mailto:[email-masked]]
>Sent: Tuesday, June 13, 2000 3:38 PM
>To: 'Shahram Davari'; [email-masked]
>Cc: [email-masked]
>Subject: RE: [Diffserv] Token bucket burst size
>
>
>Hi Shahram,
>
>> Why is the T*R + B limited by B? I know that we can't
>> generate token while
>> the bucket is full, but if you consider the worst case:
>>
>> A packet of size B arrives when the bucket is full, this
>> causes the Token
>> counts to get to zero. Now assume at the end of the T period
>> another packet
>> of size T*R arrives, that packet will also get through
>> (because there are
>> now T*R tokens accumulated in the TB). So the worst case maximum
>burst
>> passed during the T period is:
>>
>> Worst MBS =B + T * S
>
>You are right, but only partially. It is because you are shifting the
>time reference point. Even with your example, you need to wait for
>time T to send a packet of size T*R (remember, you can only start
>generating tokens AFTER the last event has completed and there is a
>space in the bucket to accumulate new tokens.). If that packet had
>come at (T-1) instant that would have not been allowed to go. No
>matter how you model, over a time period T, you are not allowed to
>send more than T*R where T*R <=B.
>
>Cheers,
>
>--brijesh
>Ennovate Networks Inc.
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: "Brijesh Kumar" <[email-masked]>
Date: Tue, 13 Jun 2000 16:17:57 -0400

Hi Shahram,
 
> burst of size greater than B can pass through the TB, which I 

You are right on this as many have already confirmed.   

Cheers,

--brijesh
Ennovate Networks Inc.