Subject: [Diffserv] Model's draft TB formula

From: Shahram Davari <[email-masked]>
Date: Wed, 14 Jun 2000 09:55:06 -0700

Hi,

Section 5 of the model draft says:

"A data stream is said to conform to a simple token bucket if the switch
receives at most the "burst_size" of data in any time interval of length
"interval", in which,  interval = burst_size/rate."
"Multi-rate token buckets (token buckets with both a peak and a mean rate
and sometimes more rates) are commonly used. In this case, the burst size
for the baseline traffic is conventionally referred to as the "committed
burst" and the time interval is as specified by interval =
committed_burst/mean_rate"
In these formulas "rate and mean_rate" should mean the "max. burst rate" or
in other words the "line rate" not the TB Rate. I think this needs to be
clarified/corrected. Therefore in summary:
interval =T
burst_size = MBS
rate = line rate = max. burst rate = S
TB rate = R 
T = MBS / S

Regards,

Shahram Davari
Systems Engineer
Product Research
PMC-Sierra, Inc. (Ottawa) 
555 Legget drive,
Suit 834, Tower B,
Ottawa, ON K2K 2X3, Canada
Phone: +1 (613) 271-4018
Fax  : +1 (613) 271-7007

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Andrew Smith <[email-masked]>
Date: Wed, 14 Jun 2000 10:46:24 -0700

Again, please supply detailed edits.

Andrew

> -----Original Message-----
> From: Shahram Davari [mailto:[email-masked]]
> Sent: Wednesday, June 14, 2000 9:55 AM
> To: [email-masked]'
> Subject: [Diffserv] Model's draft TB formula
> 
> 
> Hi,
>