Subject: RE: [Diffserv] Token bucket burst size

From: Shahram Davari <[email-masked]>
Date: Tue, 13 Jun 2000 14:30:26 -0700

Roch,

Let's forget about the English meaning of CBS.

Do you agree that if we have a TB of size X, then it is possible for a
packet to pass the TB test, even if it causes the burst to exceed X? (this
is what I proved earlier).

If you agree with the above statement, then this is what is written in
RFC-2697 (I just substituted CBS with X):

"The maximum size of the token bucket C is X " 
"A packet is marked green if it doesn't exceed X " (Yellow or Red if it does
exceed X)

In one hand I proved that it is possible to pass the TB test if a packet
causes the burst to exceed X, on the other hand RFC-2697 says it is not
possible to pass the TB test if a packet causes the burst to exceed X. To me
these are conflicting.

Regards,
-Shahram

PS- I am taking off for today, I will reply your messages tomorrow.

>-----Original Message-----
>From: Roch Guerin [mailto:[email-masked]]
>Sent: Tuesday, June 13, 2000 5:06 PM
>To: Shahram Davari
>Cc: [email-masked]'
>Subject: Re: [Diffserv] Token bucket burst size
>
>
>Shahram Davari wrote:
>Shahram,
>I'm about to go off-line for a few hours, and
>so may not respond immediately to subsequent 
>emails, but no I do not see a contradiction.
>
>This is mainly because I never assumed that 
>sentence to refer to an actual transmitted burst
>size, and instead refer to the max bucket sizes that
>are described later, i.e., a packet is marked
>green/yellow if its token deficit does not 
>exceed CBS/EBS.  Again, the terminology used
>was consistent with past usages, e.g., FR and
>ATM, and we had not really thought it would
>create confusion.  But if it does, we can certainly
>amend it, say, as follows:
>
>"A packet is marked green if its token deficit (see
>below) doesn't exceed the CBS.  Note that as shown
>in refs[ATM TM 4.0, etc.], the worst case burst
>size that can be sent in the network can exceed CBS."
>
>is this the issue you had?
>
>Roch
>
>> What I am trying to say is that when RFC-2697 says that:
>> "A packet is marked green if it doesn't exceed the CBS.", it 
>means that when
>> a packet exceeds the CBS it is not marked as green. However, 
>I proved that
>> if the size of the TB is CBS (which is the case in 
>RFC-2697), then it is
>> possible to have packets marked green while they exceed CBS.
>> 
>> Don't you see any contradiction?
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Roch Guerin <[email-masked]>
Date: Tue, 13 Jun 2000 17:40:56 -0400

Shahram,

> is what I proved earlier).

Sure, but this has been established in tons of different
ways and in different configs before.  This is why I was
taking this as a given.  especially, in light of the extensive
discussion on this in the ATM TM doc and several other places.

> possible to pass the TB test if a packet causes the burst to exceed X. To me

Again, this is for me more of an English issue, and actually,
if you want to take the sentence "literally" it has other
flaws as well ;-)  For example, it would appear to imply that
if a packet (size) does not exceed X, then it would always be marked
green.  But obviously this is not what was intended, and the
statement you took is in an introductory paragraph that made
not claim at being rigourous.  The more rigorous definition 
is provided later and this is what needs to be precise, and I
think it is.

Now, as I said before, we can certainly envision to add language
to make sure people understand that the quantities CBS and EBS
should not be taken as giving the actual max burst size possible
and provide pointers to places where this is discussed extensively.
If people feel this would be worthwhile to avoid future confusions,
this is probably the right thing to do.

Roch