Subject: RE: [Diffserv] Diffserv MIB - droppers

From: "Nabil Seddigh" <[email-masked]>
Date: Tue, 30 May 2000 16:37:52 -0400 (EDT)

>Sounds like a circular argument to me - it's useful because 
>it's useful. Can you try to be a little more forthcoming 
> in your uses?
>

Circular? I guess I thought the reasons for having
average Q sizes was obvious. My apologies!!

We have done extensive work with the AF PHB as 
incarnated by various MRED schemes: WRED, RIO 
& RIO-decoupled. In all cases, access to the queue 
averages greatly assisted in trouble shooting and "traffic 
engineering".

Without this information, in many cases we would
have been unable to tell whether end-customer achieved
traffic characteristics was due to faulty configuration or
algorithm specifics.

Another reason for exporting the avg Q sizes are
the emergence of Diffserv tools for network management. 
Offline traffic engineering and SLA tools 
require access to algorithm specific information.
For the MRED algorithms, avg Q size is key
to achieved performance - not only delay but
also achieved bandwidth. 

Best,
---
Nabil Seddigh
[email-masked]

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 30 May 2000 16:46:44 -0500

I have to say that I still don't understand. I can see how percentiles
might be useful (95th percentile of queue length for example) but I don't
see what diagnostic information the mean queue length conveys.

  Brian