Subject: RE: [Diffserv] Diffserv MIB - droppers

From: "Nabil Seddigh" <[email-masked]>
Date: Tue, 30 May 2000 14:29:36 -0400 (EDT)

Andrew,

>
>That's quite a leap - just because a device uses this 
>deep down in the implementation doesn't mean that it is 
>easy to extract and report back,
>particularly for a silicon implementation. 
>

Agreed! But then where do you draw the line?
Using this line of thinking, one could argue that it
is difficult for ASICs to report anything! 

>The criteria to use on evaluating a MIB variable for 
>inclusion in a standards'-track MIB must be primarily 
>based on the utility to a SNMP manager for the 
>management of commonly-agreed functionality. If it passes
>that test, then we can look at whether it is too 
>"expensive" to implement generally.
>

So, if our first step (or "test") is to agree on the usefulness of the
information, I would suggest that having a measure of
the instantaneous and avg Q sizes is most definitely 
useful in a Diffserv-world.

Best,

---
Nabil Seddigh
[email-masked]

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: "Brijesh Kumar" <[email-masked]>
Date: Tue, 30 May 2000 15:48:11 -0400

Nabil Seddigh writes:
> From: [email-masked]

> useful in a Diffserv-world.

Why would you need that.

On the high speed interfaces, it is hard to capture per queue data with any
accuracy. For example,  on a OC48 interface operating at 2.5 Giga bits per
second avg queue size and instantaneous queue size may vary from 0 to buffer
full in a second. Not only, it is hard to establish meaningful time period
for such a measurement on high speed interfaces, such queue data conveys no
meaningful information to the network manager.

Cheers,

--brijesh
Ennovate Networks Inc.