Subject: [Diffserv] WG poll on choice of terminology

From: Brian E Carpenter <[email-masked]>
Date: Wed, 03 May 2000 08:34:14 -0500

Diffservers,

The use of the term "behavior aggregate" to recurse to
cover an entire DS domain has been a matter of controversy
at the Adelaide IETF and on the mailing list. Sifting
through public and private emails on this, we've found that
the intent of draft-ietf-diffserv-ba-def-01.txt is nicely covered 
by either of two terms. We'd like to see what the WG consensus choice
is so that we can use this in the next document revision.

The proposed terms are:

 1) per-domain behavior (PDB)
or 
 2) intra-domain service (IDS)

These are intended to be defined upon a specific DS domain (as
defined in RFCs 2474 & 2475), though of course, any particular
definition may impose further constraints on the topology or
technology of DS domain for which it is useful.

Please indicate your choice of terminology in a one line
reply with one choice - PDB or IDS - to [email-masked]
(not to the whole list please!!!) by May 10 at the latest. 
We'll total the results and declare a winner.

If you want to discuss/debate further please do this on the
list with a different subject header.

Thanks

   Brian + Kathie
   diffserv co-chairs

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Dan Grossman <[email-masked]>
Date: Wed, 03 May 2000 10:10:53 -0400

Before answering the chairs' poll, it would be a good idea to review the 
definitions in RFC 2475, especially of 'service' and 'per-hop behavior'.  If, 
after review and consideration, you believe that the thing defined in the BA 
draft is a generalization of a per-hop behavior, then vote for PDB.  If you 
think it quacks like a service, then vote for IDS.

Dan

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 11 May 2000 14:14:38 -0500

Hi,

The poll ended yesterday. After removing one or two duplicates, the result was
23 people who preferred Per-Domain Behavior versus 16 who preferred
Intra-Domain Service. This is a fairly rough consensus, but clear enough
for a terminology choice. So Per-Domain Behavior it is, and the next version
of the ""BA"" draft will reflect this.

   Brian + Kathie