Subject: RE: FW: [Diffserv] EF question !!!

From: Shahram Davari <[email-masked]>
Date: Fri, 7 Apr 2000 08:06:04 -0700

Hi Carlo,

I don't understand what you mean by "the time interval should be independent
from its position in time?". Do you mean that I should slide the time
interval and average it over all the time scale? That doesn't make sense
because by doing so you will get your configured rate whether you use EF or
not!

This example may be solved by requiring a "multiple" of the time that it
takes to send an MTU size packet (as you and Siamak also have mentioned).
But here is another example where the "multiple" requirement won't help
either: 

Assume "2" EF flow each having a rate of "R" and one BE flow having a rate
of "8R". Assume that the output link rate is "10R" to accommodate these
flows. Further assume that all packets are of MTU size and the EF flows are
shaped and exactly identical. Now using priority queuing (as suggested by
RFC-2598) and looking at the time scale, we will have:

<--------------------------- time increase ----------------

BE-BE-BE-BE-BE-BE-BE-BE-EF-EF-BE-BE-BE-BE-BE-BE-BE-BE-EF-EF
<---------------------><---->
         8T              2T

The interval of each packet in output link is T=MTU/10R. The time that it
takes to send an MTU size packet at the EF configured rate is MTU/2R = 4T.
Since the interval 8T shown in the picture is greater than 4T, according to
RFC-2598 we should get at least the EF configured rate. But as you can see
there is no EF packet in this interval!!! (also note that 8T is a multiple
of 4T).

Regards,

-Shahram

>-----Original Message-----
>From: Carlo Matarasso [mailto:[email-masked]]
>Sent: Friday, April 07, 2000 3:36 AM
>To: Shahram Davari
>Cc: [email-masked]'
>Subject: Re: FW: [Diffserv] EF question !!!
>
>
>Shahram,
>
>when you calculate average values in steady state, the time 
>interval you
>consider has to be independent from its position on the time 
>axis. Yours is not:
>if you take the 3T interval right after yours, you' ll have 2 
>EF MTU and 1 BE,
>that will even up the previous average.
>In you example you have to consider an interval that contains 
>an evan amount of
>Ts.
>
>If you consider int. = 6T, in this interval the EF rate is 
>3MTU/6T = MTU/2T = R
>
>Carlo
>
>Shahram Davari wrote:
>
>> "The figure was messed up in previous email. Please use this one:"
>>
>> Hi,
>>
>> RFC-2598 says:
>> "EF SHOULD average at least the configured rate when 
>measured over any time
>> interval equal to or longer than the time it takes to send 
>an output link
>> MTU sized packet at the configured rate"
>>
>> Lets assume 2 PHB queues: an EF and a BE each of rate R (both nicely
>> shaped). Let's assume the output link rate is 2R so that 50% 
>of the link BW
>> (=R) is assigned to EF and 50% (=R) to BE. Let's also assume 
>that packet
>> sizes are all MTU size. Now on the output link we will have EF and BE
>> packets one after another as following:
>>
>>
>> ----------------------------------------------------------
>> |  BE   |  EF   |  BE  |  EF  | BE  |  EF  |   .....       |
>> ----------------------------------------------------------
>>
>>                 <------------------->
>>                          3T
>>
>> The duration of each packet at the output link is T= MTU/2R. 
>Now assume the
>> time from the beginning of a BE packet to the end of another 
>BE packet; this
>> time = 3T (notice that there is only one EF packet in this 
>interval). Also
>> the time to send an MTU size packet at EF configured rate is 
>MTU/R = 2T.
>>
>> Since 3T  > 2T then according to RFC-2598 we should average 
>the configured
>> rate in the 3T interval. But as you can see the average EF 
>rate in the 3T
>> interval is MTU/3T = 2R/3 which is 2/3 of the EF configured rate R.
>>
>> Either I am missing something or there is a problem with the 
>RFC-2598.
>>
>> Any comments?
>>
>>
>> Shahram Davari
>> Systems Engineer, Product Research
>> PMC-Sierra Inc.
>> 555 Legget drive,
>> Suit 834, Tower B,
>> Ottawa, ON K2K 2X3, Canada
>> Phone: +1 (613) 271-4018
>> Fax  : +1 (613) 271-7007
>>
>>
>> _______________________________________________
>> diffserv mailing list
>> [email-masked]
>> http://www1.ietf.org/mailman/listinfo/diffserv
>> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>>
>> _______________________________________________
>> diffserv mailing list
>> [email-masked]
>> http://www1.ietf.org/mailman/listinfo/diffserv
>> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>
>--
>---------------------------------------------------------------
>----------------------------
>
>DOTT. ING. CARLO MATARASSO
>
>[email-masked]
>TEL. +49 8153 28 2848
>FAX  +49 8153 28 2844
>
>DLR - DEUTSCHES ZENTRUM FUER LUFT UND RAUMFAHRT
>GERMAN AEROSPACE CENTER
>www.dlr.de
>POSTFACH 1116
>D - 82230   WESSLING - GERMANY
>
>---------------------------------------------------------------
>----------------------------
>
>
>
>
>_______________________________________________
>diffserv mailing list
>[email-masked]
>http://www1.ietf.org/mailman/listinfo/diffserv
>Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Qin Zheng <[email-masked]>
Date: Fri, 07 Apr 2000 12:15:20 -0400

How about adding that the time interval to measure an EF flow throughput should
alway start at a time when a packet of the EF flow is sent?

Qin

---

From: Carlo Matarasso <[email-masked]>
Date: Fri, 07 Apr 2000 18:27:28 +0200

Shahram,
my observation is that the output signal is periodic with period = 2T. Averages
should be made on time intervals that are integer multiple of its period
(2T,4T,6T.....).

regarding your second example, again you have a periodic signal with period =
10T, so correct time intervals are, in my opinion, 10T, 20T.....
Let me also point out that in your second example you write

"The interval of each packet in output link is T=MTU/10R"

then you write

"MTU/2R = 4T"

but if T=MTU/10R then MTU/2R = 5T

but if you consider 5T you violate the Nyquist principle and you get aliasing in
your result.

again I think that only 10T, 20T...... give significant results.

please correct me if I'm wrong !

have a nice weekend

Carlo

--
-------------------------------------------------------------------------------------------

[email-masked]
TEL. +49 8153 28 2848
FAX  +49 8153 28 2844

-------------------------------------------------------------------------------------------