Subject: [Diffserv] problems with Virtual Wire and RFC2598

From: Jean-Yves Le Boudec <[email-masked]>
Date: Mon, 27 Mar 2000 19:29:28 +0200

I have some problems understanding RFC2598 and draft-ietf-diffserv-ba-vw-00

a) RFC2598 requires that the service given to an aggregate flow guarantees a
rate down to a small time scale and further gives as example
"A simple priority queue will give the appropriate behavior as long as there is
no higher priority queue that could preempt the EF for more than a packet time
at the configured rate. "

I have the impression that this statement ignores the phenomenon of jitter
accumulation due to aggregate multiplexing. When several flows share their fate
in a multiplex, then there is accumulation of jitter from network node to
network node, well beyond the bounds given in this internet draft. The fact
that flows are shaped at the network input does not guarantee a bound on jitter
after several hops. Some bounds do exist, but they are not straightforward, and
it is not even clear whether finite bounds exist in all cases where the maximum
network utilization factor is less than 1. In the particular case where the
network topology is a ring, the answer is yes, however, in general, it is
unknown (as far as I know). See for example the references below.

It seems to me that the only way to guarantee the requirement described in
RFC2598 is to shape every aggregate at the output of *every* network node, a
solution that requires per aggregate information which is not compatible with
diffserv.

b) I don't understand why we would need to bound the network jitter to the
interval called "jitter window" in draft-ietf-diffserv-ba-vw-00.  It is
possible to guarantee a VW behaviour even if the jitter is larger. It is well
known that if the delay jitter is bounded by D, then a buffer of size 2RD is
able to recreate a periodic flow with 0 jitter.

JY

-----------------------------------

References:

A. Charny's work at

ftp://ftpeng.cisco.com/ftp/acharny/aggregate_delay_v4.ps

or mine at

http://dscwww.epfl.ch./EN/publications/ps_files/tr00_002.ps

or 

J. Wroclawski and A. Charny's internet-draft:

http://ana.lcs.mit.edu/ISSLL/drafts/draft-ietf-issll-ds-map-00.txt

---

From: Kathleen Nichols <[email-masked]>
Date: Mon, 27 Mar 2000 17:13:41 -0800

Jean-Yves Le Boudec wrote:
> a) RFC2598 requires that the service given to an aggregate flow
> guarantees a rate down to a small time scale and further gives as
> example
> "A simple priority queue will give the appropriate behavior as long as
> there is no higher priority queue that could preempt the EF for more
> than a packet time at the configured rate. "
> 
> I have the impression that this statement ignores the phenomenon of
> jitter accumulation due to aggregate multiplexing. When several flows
> share their fate in a multiplex, then there is accumulation of jitter
> from network node to network node, well beyond the bounds given in
> this internet draft. The fact that flows are shaped at the network
> input does not guarantee a bound on jitter after several hops. Some
> bounds do exist, but they are not straightforward, and it is not even
> clear whether finite bounds exist in all cases where the maximum
> network utilization factor is less than 1. In the particular case
> where the network topology is a ring, the answer is yes, however, in
> general, it is unknown (as far as I know). See for example the
> references below.
> 

So this is what a lot of the discussion in the vw draft is
attempting to address. We've tried to spell out what
the assumptions are and how they get used. I'm hoping
that in today's meeting we can figure out what is
missing in the explanation so the next roll can make
this clearer. Anna Charney's work uses a different set
of assumptions.

There are some university folks who believe they can work
out the analysis under the assumptions we work under. 
Hopefully, they'll get something worked out and made
publically available.

> It seems to me that the only way to guarantee the requirement
> described in RFC2598 is to shape every aggregate at the output of
> *every* network node, a solution that requires per aggregate
> information which is not compatible with diffserv.

This comes out under Charney's assumptions since they are
no more restrictive than the rules we assume for individual
domains. Thus this is like the rules for shaping at the
edge of every domain.

	Kathie

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Anna Charny <[email-masked]>
Date: Mon, 27 Mar 2000 20:43:02 -0800

Kathie,

>this clearer. Anna Charney's work uses a different set

I am not sure how  assumptions of my work differ from the assumptions in 
the draft.  Can you please be more specific ?

Thanks,
Anna Charny

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 27 Mar 2000 22:03:01 -0600

...
> 
> It seems to me that the only way to guarantee the requirement described 
> in RFC2598 is to shape every aggregate at the output
> of *every* network node, a solution that requires per 
> aggregate information which is not compatible with diffserv.

Let's assume for a moment that it is necessary to perform traffic conditioning
at every hop. No, this does not require any information that is not available.
An EF router needs to know the EF rate and nothing else.

However, I can't see why such re-conditioning is needed. The EF jitter bound
doesn't require intermediate reshaping as far as I can see.

  Brian