Subject: [Diffserv] SNA over DiffServ

From: Fayçal Bennani <[email-masked]>
Date: Wed, 19 Jan 2000 00:07:22 +0100

Hi,

Any work / recommendation on which DiffServ PHB / CoS should be used for legacy non native IP traffic, such as SNA and X25 ?
 
Fayçal Bennani

---

From: "Harry Silverstone" <[email-masked]>
Date: Thu, 20 Jan 2000 08:31:24 -0500

Hi,

	I think that the TOS precedence mapping being referred to applies
only 
to the SNA Enterprise Extender architecture that was introduced within the 
past couple of years. Using this, one can set the COS for the SNA over IP
traffic.

	With DLSw, there is nothing in the standard with respect to setting
the
TOS precedence bits. It only provides a means to prioritize its own data.
However 
there is nothing stopping a DLSw implementation from setting the TOS field
as 
needed, similar to any other IP application.

~harry

-----Original Message-----
From: Ping Pan [mailto:[email-masked]]
Sent: Thursday, January 20, 2000 12:20 AM
To: [email-masked]
Cc: Faycal Bennani; [email-masked]
Subject: Re: [Diffserv] SNA over DiffServ

Adam,

You're right. I recall that IBM had defined a special TOS precedence bit
combination to carry "important" SNA packets, and zero precedence value
to carry regular SNA data. It's mapped into the old TOS byte format,
where the precedence filed has a mask of 0xE0. It had all sort of fancy
precedence levels. ;-) But it won't work with the new DS byte mapping
anymore.

- Ping

Adam Dunstan wrote:
> 
> If my memory serves me correctly, DLSw puts SNA into TCP sessions, I think
> that DLSw v2 allowed difference COS into difference TCP sessions but I am
> probably wrong, the DLSw WG (if it still exists) is probably a good place
> for this question.
>

Faycal Bennani wrote:
>
> Hi,
>
> Any work / recommendation on which DiffServ PHB / CoS should be used for
> legacy non native IP traffic, such as SNA and X25 ?
>
> Faycal Bennani
>

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: [email-masked]
Date: Thu, 20 Jan 2000 10:12:32 -0500

This isn't quite right.  While the architecture for HPR over IP
was initially defined in terms of the 3 TOS Precedence bits, it
was revised to reflect the new definition of the DS codepoint.
The architecture continues to work just as it did before.

Anyone interested in more details on the architecture for HPR
over IP can get them at

http://www.raleigh.ibm.com:80/cgi-bin/bookmgr/BOOKS/D50H6003/2.5.5

Note that both IBM and Cisco have implemented the HPR over IP
architecture under the brand name "Enterprise Extender".

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

Ping Pan <[email-masked]>@ietf.org on 01/20/2000 12:20:29
AM

Sent by:  [email-masked]

To:   [email-masked]
cc:   Faycal Bennani <[email-masked]>, [email-masked]
Subject:  Re: [Diffserv] SNA over DiffServ

Adam,

- Ping