Subject: RE: [Diffserv] TCB's in diffserv router model.

From: Thomas Eklund <[email-masked]>
Date: Mon, 24 Jan 2000 09:55:22 +0100

No but my point was perhaps it might be a good thing to write a conceptual
model draft for diffserv in different hardware arhitecthures like crossbar,
shared memory, bus oriented... 

It could be written like a Informational RFC as well or BCP for HW...

And I understand that the IETF are not designing HW but today there are many
companies that offers integrated L2, L3 functionality in HW... 

Have there been any effort in defining that before?

/Thomas

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Friday, January 21, 2000 11:49 PM
> To: Thomas Eklund
> Cc: [email-masked]'; [email-masked]';
> [email-masked]'; [email-masked]'
> Subject: Re: [Diffserv] TCB's in diffserv router model.
> 
> 
> Thomas,
> 
> We aren't designing hardware; this is only a conceptual model.
> 
> The current functional decomposition has been debated for quite
> a while. Any choice of decomposition is arbitrary, and this is
> the one that got consensus.
> 
> As soon as we get the draft revised according to the discussion
> in Washington, we will be going for Informational RFC.
> 
> Regards
> 
>   Brian Carpenter
>   diffserv co-chair
> 
> 
> Thomas Eklund wrote:
> > 
> > Oops I forgot the forwarder block FOB... But that was 
> obviuos but I did not
> > see that in the draft.
> > 
> > Then you would have three buliding blocks; Forwarding 
> block, filter block
> > and traffic conditioning block...
> > 
> > This would be very good to fit the different models i HW 
> (shared memory
> > design, crossbar, shared bus etc...)...
> > 
> > I dont know if this should be included in the draft or a new one..?
> > Any Comments?
> > 
> > /Thomas
> > > -----Original Message-----
> > > From: Thomas Eklund [mailto:[email-masked]]
> > > Sent: Thursday, January 20, 2000 5:58 PM
> > > To: [email-masked]'
> > > Cc: [email-masked]'; [email-masked]';
> > > [email-masked]'
> > > Subject: [Diffserv] TCB's in diffserv router model.
> > >
> > >
> > > Hi,
> > > I have some questions about the 
> draft-ietf-diffserv-model-01.txt...
> > >
> > > I wonder why TCB (Traffic Conditioning Block) is specified to
> > > include the
> > > classifier stage??
> > >
> > > I would like to see something like
> > > Filter Block (BA, MF filtering)
> > > Traffic Conditioning Block (Metering, Marking, Shaping, Dropping,
> > > Queuing/Scheduling)
> > >
> > > So that you set the ingress and egress filtering rules in the
> > > FB and applies
> > > a TCB for every FB.
> > >
> > > So the FB is in, out, in/out (flow).
> > >
> > > Then I would also like to see a paper on how ipsec in 
> tunnel mode over
> > > diffserv should be handled at the same time in FB. Or is
> > > there any work
> > > already done on this?
> > >
> > > So the model would become:
> > > FB + TCB = (filtering block for both security filters and qos
> > > classification) + (and a traffic conditioning block that
> > > apply the traffic
> > > behaviour) = What treatment and how a packet is forwarded
> > >
> > > Any comments?
> > >
> > > Best Regards Thomas
> > >
> > > Thomas Eklund
> > > System Design, MSc
> > > SwitchCore i Stockholm AB
> > > Positionen 153, Hangövägen 19
> > > SE-115 74 Stockholm, Sweden
> > > phone +46 8 5630 5815
> > > fax +46 8 5630 5801
> > > mobile +46 709 952910
> > > [email-masked]
> > > visit our web page at http://www.switchcore.com
> > >
> > >
> > >
> > > _______________________________________________
> > > diffserv mailing list
> > > [email-masked]
> > > http://www.ietf.org/mailman/listinfo/diffserv
> > > Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
> > >
> > 
> > _______________________________________________
> > diffserv mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/diffserv
> > Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 24 Jan 2000 12:12:20 -0600

Thomas,

The document is specifically positioned to be independent of the
hardware architecture. That is the limit of what we are going to
do in the WG.

  Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter (IAB Chair)
Program Director, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Attend INET 2000: http://www.isoc.org/inet2000
Non-IBM email: [email-masked]