Subject: RE: [Diffserv] Model - queues (second draft)

From: Andrew Smith <[email-masked]>
Date: Thu, 6 Jan 2000 14:14:20 -0800

And I think that, in both cases, this is not worth pointing out in a
management model. What are you as a network manager going to do differently
in configurating and monitoring your network if you know about such
implementation nits? We already have too many hooks for such hypothetical
nits in this model.

Andrew

> -----Original Message-----
> From: Grenville Armitage [mailto:[email-masked]]
> Sent: Thursday, January 06, 2000 1:57 PM
> To: Andrew Smith
> Cc: [email-masked]
> Subject: Re: [Diffserv] Model - queues (second draft)
...
> I'm stating that _IF_ the packets arriving from different
> classifiers are known to have non-overlapping arrival times
> into a particular FIFO's buffer stage, then the notion of
> a multiple input FIFO is probably not worth pointing out.
> It is a simple queue-less merge, which I dont believe is a
> notable attribute of a FIFO stage per se.
> 
> There's an alternative hypothetical case which I take to be
> what triggered Shahram's observation: Consider if a router's
> architecture allowed packets from multiple parallel
> classifiers (heading into the FIFO's buffer) to have concurrent
> or overlapping arrival times. Iff this second (more general) case
> is allowed, then there has to be some element that (at least
> notionally) decides which packet gets into the buffer 'first'.
> Thats a scheduler.
> 
> cheers,
> gja
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Grenville Armitage <[email-masked]>
Date: Thu, 06 Jan 2000 14:26:31 -0800

if you allow concurrent packet arrivals to the FIFO's
input, presumably you must allow a management hook to configure
the element that arbitrates between which packet gets to
go in first. perhaps that's relevant.

but if one assumes packets never arrive concurrently, nothing
needs to be said _at all_ about multiple inputs to the FIFO.
so the management model can be simplified to only describe
the FIFO as a single input element. in this case, like i said,
the 'multiple inputs' is nothing more than a queue-less merge
preceding the FIFO element. why mention it if its might
create ambiguous interpretations later.

cheers,
gja