Subject: RE: [Diffserv] AF shaping for interior routers

From: Shahram Davari <[email-masked]>
Date: Wed, 5 Jan 2000 06:29:29 -0800

Hi,

As far as I understand, shaping should be done for EF & AF before the
ingress of the edge router to comply with the SLA. Diffserv documents don't
enforce shaping of EF & AF at the interior routers. However, some
conclusions can be drawn implicitly. 

For example to be able to comply with the EF requirement of "it should
average the configured rate measured over any time interval equal or greater
than the time it takes to send an output link MTU sized packet at configured
rate" you need to shape EF at almost every egress port of interior nodes. 

Also to be able to benefit from the statistical multiplexing you may want
not to shape AF at the interior nodes.

Hope that helps,

Shahram Davari
Systems Engineer, Product Research
PMC-Sierra Inc. 
555 Legget drive,
Suit 834, Tower B,
Ottawa, ON K2K 2X3, Canada
Phone: +1 (613) 271-4018
Fax  : +1 (613) 271-7007

> -----Original Message-----
> From: ksreeni [mailto:[email-masked]]
> Sent: Tuesday, January 04, 2000 11:47 PM
> To: IETF
> Subject: [Diffserv] AF shaping for interior routers
> 
> 
> Hi,
>      I have one  basic question  regarding shaping in the case of  AF.
> 
>      I think shaping is needed at ingress interface for Edge routers,
> correct me if I am wrong.
>      Do we need shaping at ingress interface for interior routers?
> 
> 
> Sreeni.
> 
> 
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: ksreeni <[email-masked]>
Date: Fri, 07 Jan 2000 19:16:49 +0530

Sharam,
              If we are doing shaping for EF at interior nodes, means we are
doing policing also at egress port. This is exactly opposite to ,what RFC2598
says in the introduction chapter. Correct me if I am wrong.

             Do we need  any policing for AF traffic at interior nodes? I got
this doubt because , RFC2597 mentioned  traffic conditioning actions for only DS
domain edge routers.

Sreeni

---

From: Stefano Salsano <[email-masked]>
Date: Fri, 07 Jan 2000 16:37:38 +0100

ksreeni wrote:
> doing policing also at egress port. This is exactly opposite to ,what 
> RFC2598 says in the introduction chapter. Correct me if I am wrong.
> Sreeni

I agree, NO shaping is needed at interior nodes (see below).

> > ingress of the edge router to comply with the SLA. Diffserv documents 
> > don't enforce shaping of EF & AF at the interior routers. However, 
> > some conclusions can be drawn implicitly.
> > average the configured rate measured over any time interval equal or
> > greater than the time it takes to send an output link MTU sized 
> > packet at configured rate" you need to shape EF at almost every 
> > egress port of interior nodes.

No, this does not mean you have to shape... you must only be able to 
provide AT LEAST that rate. As described in RFC 2598, you can use
priority queueing to support EF (which means no shaping...)

Stefano

-- 
*******************************************************************
Stefano Salsano
CoRiTeL - Consorzio di Ricerca sulle Telecomunicazioni
                  
E-mail  : [email-masked]      URL     : http://www.coritel.it
Tel.    : +39 06 20410029         Address : Via di Tor Vergata, 135     
Fax.    : +39 06 20410037                   00133 Roma - ITALY          
*******************************************************************

---

From: "Scott W Brim" <[email-masked]>
Date: Fri, 07 Jan 2000 14:53:01 -0500

Networks induce burstiness which is not present in the traffic provided 
by the source.  In order to avoid penalizing customers for a problem 
which is your fault, not theirs, a little bit of shaping of EF traffic, 
in the aggregate, seems reasonable.  However, that's not a protocol issue.

...Scott

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 07 Jan 2000 14:02:43 -0600

Exactly. We're still planning to get a "deployment" list going for
discussion of such points.

  Brian