Subject: [Diffserv] Question regarding shaper in the "Model"

From: [email-masked] (Longsong Lin)
Date: Wed, 8 Dec 1999 14:22:58 -0800

Hi, Yoram,
In your model draft sec 6.3
 
6.3  Shaper

   Shapers are used to shape traffic streams to a certain temporal
   profile.  For example, a shaper can be used to smooth traffic
   arriving in bursts.  In [DSARCH] a shaper is described as a
   queueing element controlled by a meter which defines its temporal
   profile.  This model of a shaper differs substantially from typical
   shaper implementations.  Further, with the inclusion of queueing
   elements in the model a separate shaping element becomes confusing.
   Therefore, the function of a shaper is embedded in a queue and is
   covered in Sec. 7.

The paragraph infers from the DSARCH that 
shaper needs to be coupled with queue element.
Won't the queueing element be just for packet scheduling 
for bandwidth usage rather than including TC function?
Would you mind explaining why it must to embed the shaping into scheduling?
What if one wants to implement a shaper component outside the scheduling element, e.g., a shaper that regulates the packets in an input queue 
before they are enqueued to an output queue for scheduling.
It seems to me that your model excludes the possibility.

Thanks,

llin 

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Shahram Davari <[email-masked]>
Date: Wed, 8 Dec 1999 15:00:10 -0800

Hi,

I think the answer to your question is that, the effect of the shaper will
be substantially diminished if there is a queuing element after it. In other
words after you have shaped a burst (clump), the packets may get queued and
form the clump again. So I think it is logical to have the shaping as part
of the scheduling, in which a queue is serviced at regular intervals
depending on its required rate.

Regards,
Shahram

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, December 08, 1999 2:23 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Diffserv] Question regarding shaper in the "Model"
> 
> 
> 
> Hi, Yoram,
> What if one wants to implement a shaper component outside the 
> scheduling element, e.g., a shaper that regulates the packets 
> in an input queue

---

From: Shahram Davari <[email-masked]>
Date: Wed, 8 Dec 1999 16:10:02 -0800

Hi Yoram,
 
I didn't say that there is no reason to shape before scheduling queues. I
just wanted to mention that if the shaping is done for the purpose of
smoothing the traffic for the downstream node, then doing it before
scheduler is almost useless. While there are some scenarios that you may
want to shape before scheduler, but for other reasons such as ingress
policing before egress scheduling.
 
-Shahram

-----Original Message-----
From: Yoram Bernet (Exchange) [mailto:[email-masked]]
Sent: Wednesday, December 08, 1999 3:52 PM
To: Shahram Davari; [email-masked]'; [email-masked]
Cc: Yoram Bernet (Exchange)
Subject: RE: [Diffserv] Question regarding shaper in the "Model"

I disagree. There are many reasons that you may want to shape either before
or after a different type of scheduling queue. generality should allow the
two to exist separately. just recognize that a shaper is a
non-work-conserving queue servicer. output scheduling typically uses work
conserving queue servicers (but not necessarily). the model affords the
freedom of putting either wherever you want them.

y 

> From: Shahram Davari [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Wednesday, December 08, 1999 3:00 PM 
> To: [email-masked]'; [email-masked] 
> Subject: RE: [Diffserv] Question regarding shaper in the "Model" 
> 
> 
> Hi, 
> 
> > From: [email-masked] [ mailto:[email-masked] <mailto:[email-masked]>
] 
> > It seems to me that your model excludes the possibility. 
<http://www.ietf.org/mailman/listinfo/diffserv>  
> > Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
<http://www-nrg.ee.lbl.gov/diff-serv-arch/>

---

From: "Yoram Bernet (Exchange)" <[email-masked]>
Date: Wed, 8 Dec 1999 15:52:19 -0800

y

> From: Shahram Davari [mailto:[email-masked]]

---

From: "Yoram Bernet (Exchange)" <[email-masked]>
Date: Wed, 8 Dec 1999 15:48:38 -0800

my model initially did call for a shaper to be treated separately. it was
noted however, that a shaper inevitably forms a queue of packets waiting to
be shaped (otherwise why have a shaper) and that therefore, a shaper and a
queue always exist together. in that case, a shaper can be considered in the
context of a type of queue. if you recognize that the shaper queue does not
have to be the same queue that you use on your egress but can instead be a
separate queue that exists at your ingress, solely for the purpose of
pre-shaping a traffic flow, then i think your goal is accommodated...

y

> Subject: Question regarding shaper in the "Model"
> 
> 
> 
> Hi, Yoram,

---

From: [email-masked] (Longsong Lin)
Date: Wed, 8 Dec 1999 16:54:35 -0800

Thank you Shahram, but...

If the shaper can shape the traffic well fitting to the profiled rate, there
should be no packet queued in the output buffer.
Clumping can be absorted by shaping but not scheduling without altering
the relative weights among the queues being scheduled. Once you change the weights, you change the bandwidth allocation, which means you need to re-allocate
the profiled rate at TC again.

I thought shaper and scheduler should serve for different purposes.
A shaper is for regulating traffic pattern whereas a scheduler is for
apportioning bandwidth.
If, in case I am wrong, our conclusion is a shaper can be replaced
by a scheduler, are we going to as well exclude it out of the context?
If not, why?

Thanks,

llin

> From [email-masked] Wed Dec  8 15:46 PST 1999
> From: Shahram Davari <[email-masked]>
> To: "[email-masked]'" <[email-masked]>, [email-masked]
> Date: Wed, 8 Dec 1999 15:00:10 -0800 
> MIME-Version: 1.0
> X-Mailman-Version: 1.0
> List-Id:  <diffserv.ietf.org>
> X-BeenThere: [email-masked]
> 
> Hi,
>