Subject: Re: [Diffserv] Model - queues - replacement text

From: [email-masked] (Longsong Lin)
Date: Tue, 14 Dec 1999 15:23:36 -0800

Hi, Dan,
A few minor points..., 

> 
> 7.  Queues
> Queues order the transmission of packets belonging to the different traffic
> streams, possibly storing them temporarily or discarding them. Packets are
> usually stored either because there is a resource constraint (e.g.,
> available bandwidth) which prevents immediate forwarding, or because the
> queue is being used to alter the temporal properties of a traffic stream.....
>
> 
> 7.1  Model
> Queuing is a function a which lends itself to innovation.  It must be
> modelled to allow a broad range of possible implementations to be
> represented using common structures and parameters.  This model uses
> functional decomposition as a tool to permit the needed lattitude.  
> 
> Queues perform three distinct, but related, functions:  they store packets,
> they modulate the departure of packets belonging to various traffic streams
> and they selectively discard packets.  This model decomposes queues into the
> component elements that perform each of these functions.  These elements
> which may be connected together either dynamically or statically to
> construct queueing subsystems.  A queue is thus composed of of one or more
> FIFO, one or more scheduler, and one or more discarder.  See figure TBA for
> an example of a queue.  
> 

I don't quite catch the meaning of the word "order" in the first sentence.
It seems to me that the Queues per se are just buffers.
It is the queueing functions that can "order" (or modulate as said in 7.1) the transmission of packets while enqueueing the packets. 
It reads much as if queues are the same as queueing functions. 

But, it again reads:
> construct queueing subsystems.  A queue is thus composed of of one or more
> FIFO, one or more scheduler, and one or more discarder.  See figure TBA for
> an example of a queue.  
> 
meaning the queues are "FIFO-ordered buffer" subject to discarding and scheduling.
Shouldn't a queueing system include a set buffers(queues) and queueing disciplines such as FIFO, a mean of storingpackets, Scheduler, of transmitting packets, and discarder, of dropping packets.
..Maybe I misunderstood.

> (i.e., shaping).  Packets are discarded either because of buffering
> limitations or as a feedback control signal to reactive control protocols
> such as TCP.

Also, shouldn't packets be discarded if they either are out of (by metering) or cannot be shaped into (shaping fails) the specific temporal properties of a traffic stream, in addition tobuffering limitations and feedback controls.

Thanks,
llin

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Dan Grossman <[email-masked]>
Date: Wed, 15 Dec 1999 18:10:51 -0500

Linsong 
> It seems to me that the Queues per se are just buffers.
This gets to Grenville's issue.  Maybe queueing system is better.
> Also, shouldn't packets be discarded if they either are out of (by metering) or cannot be shaped into (shaping fails) the specific temporal properties of a traffic stream, in addition tobuffering l…
That's a specific case of a buffering limitation, but an important one. I'll 
call it out separately.

Dan