Subject: Re: [Diffserv] Model - queues - replacement text

From: Grenville Armitage <[email-masked]>
Date: Wed, 15 Dec 1999 11:08:29 -0800

Longsong Lin wrote:
	[..]
> There, queues are a set of buffers and queueing discipline is a rule set the
> servers use to drain the packets out of the queues.
> Once the packets are in the queues you could exercise the packets with
> any queue management functions before they packets are drained out by the server(scheduler).
> So, the complete system includes three elements:
> 1. "ordered data stores" (buffers) +
> 2. queue management functions (discarding, re-ordering, thresholding...) +
> 3. scheduler (service discipline).
> Thus, Grenville's view is accommodated and Dan's points are covered.
> Do I lose any point?

Pretty much right. I dont disagree with 90% of the words
Dan wrote, except that he's defining "queue" to be what
is really a "queuing system". Most of the responses on this
thread have (consciously or unconciously) used phrases like
"queuing system" and "queue management" to describe the
elements surround the actions that may be effected on the
queue itself. I just want to see a queue clearly articulated
as a storage entity, with its temporal or discard characteristics
impose by surrounding elements (aka queue management and
scheduler).

cheers,
gja

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: [email-masked] (Longsong Lin)
Date: Wed, 15 Dec 1999 10:53:04 -0800

Hi, all,

I thought the issue here is simply a terminology problem belonging
to elementary or classic queueing theory.
Reciting any queueing theory book, I deems this pretty clear.
I don't think we are trying to invect any new thing different from 
the basic structure on which all the past theorems are based, are we?

Regards,
Longsong

> From [email-masked] Wed Dec 15 09:38 PST 1999
> From: "Albert Manfredi" <[email-masked]>
> To: "Andrew Smith" <[email-masked]>
> Cc: <[email-masked]>
> Subject: RE: [Diffserv] Model - queues - replacement text
> Date: Wed, 15 Dec 1999 10:37:12 -0500
> MIME-Version: 1.0
> Content-Transfer-Encoding: 7bit
> X-Priority: 3 (Normal)
> X-MSMail-Priority: Normal
> X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3155.0
> Importance: Normal
> Content-Transfer-Encoding: 7bit
> X-Mailman-Version: 1.0
> List-Id:  <diffserv.ietf.org>
> X-BeenThere: [email-masked]
> 
> Andrew Smith wrote:
> 
> > Grenville,
> >
> > There's no point in forming a queue for a bus if there's
> > no scheduling
> > algorithm implied for when the bus comes along. Or are
> > Ozzie bus queues like
> > French ski-resort cable-car queues: form a nice neatly
> > ordered queue and
> > then have a mad random-access scramble when the vehicle
> > arrives. :-)
> 
> Actually, there is. The queue is used for buffering only. I suppose
> you can call that "scheduling," but it really isn't. Buffering means
> you're holding something until the next stage is ready. Scheduling
> means you're holding something for transmitting at some
> predetermined time.
> 
> Thinking back at queueing theory courses, I also remember what Dan
> mentioned, but I think that things like service and arrival times
> can be considered to be outside influences _on_ the queue, which
> affect the behavior _of_ the queue, rather than effects caused by
> the queue itself.
> 
> Semantics, semantics. I am sort of agreeing with Grenville here.
> 
> Bert
> [email-masked]
> 
>

---

From: Lloyd Wood <[email-masked]>
Date: Wed, 15 Dec 1999 20:37:10 +0000 (GMT)

> impose by surrounding elements (aka queue management and

Personally, I just want to see a queue clearly articulated as an
ordered structure providing references to various entities in storage;
actions affecting the queue do not necessarily affect the storage. The
storage and its relationship to the entities themselves need to be
much more clearly stated.

L.

oh, and we need a definition of 'entity' too. Hope Grenville's up to it.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

---

From: Grenville Armitage <[email-masked]>
Date: Wed, 15 Dec 1999 13:43:11 -0800

Lloyd Wood wrote:
	[..]
> oh, and we need a definition of 'entity' too. Hope Grenville's up to it.

Its a thing, made up of distinct blobs, each defined by a
particular formation of stuff.

There. Clear as mud :)

cheers,
gja

---

From: Dan Grossman <[email-masked]>
Date: Wed, 15 Dec 1999 17:01:25 -0500

So in order to meet Grenville's concerns, it looks like we have a couple of 
options:

we can globally replace "queue" with "queueing system" or, more precisely 
"queueing subsystem"

or

we can put words in place to the effect that the word "queue" should be taken 
to mean "queueing system.

I have no issue with either of them,

Grenville, will either or both of these resolve your issue?

Dan [who is still on Jury duty :-( but able to get back to the office after 
court hours]

---

From: Grenville Armitage <[email-masked]>
Date: Wed, 15 Dec 1999 14:39:48 -0800

dan,

i'd prefer the descriptive text say that a "queuing subsystem
consists of...." (list, and then go on to describe, the three
main components - one of which is the queue/buffer itself)

cheers,
gja