Subject: RE: [Diffserv] Model - queues - replacement text

From: Andrew Smith <[email-masked]>
Date: Tue, 14 Dec 1999 16:45:15 -0800

Grenville, 

There's no point in forming a queue for a bus if there's no scheduling
algorithm implied for when the bus comes along. Or are Ozzie bus queues like
French ski-resort cable-car queues: form a nice neatly ordered queue and
then have a mad random-access scramble when the vehicle arrives. :-)

Andrew

> -----Original Message-----
> From: Grenville Armitage [mailto:[email-masked]]
> Sent: Tuesday, December 14, 1999 3:58 PM
> To: Dan Grossman
> Cc: [email-masked]
> Subject: Re: [Diffserv] Model - queues - replacement text
> 
> 
> Dan,
> 
> 	[..]
> > I have a very nice two-volume set in my office called 
> "Queueing Systems".
> > It's full of math and graphs that describe the dynamics of 
> queues.  There's
> > material on priority queueing and queueing disciplines and 
> work conservation
> > and loss formulas and.... a lot more than the 20-odd pages 
> on stacks and
> > queues in my (nondescript) Data Structures reference text.
> > 
> > I think that if I'm stretching the definition of a queue, 
> others have gotten
> > there first. :-)
> 
> I suspect the books talk about the behaviors of queuing systems,
> with "systems" implied and thereby including the components that
> add/discard/schedule-removal.
> 
> (Interesting side-note, the term "queue" is used in non-technical
> circles to refer to an ordered data store - e.g. people queue up
> to board a bus, or to order tickets, or to purchase food... but
> I'm aware such usage isn't common in the US, being more of a
> british-ism. Perhaps my british-influenced background is demanding
> purity here :-)
> 
> > > (When I wrote code to hold data elements in a queue, the 'queue'
> > > itself never modulated departure of data elements. Why should the
> > > defn be changed for routers?)
> > >
> > I think that this is another case of a word that's gotten 
> overloaded.   And
> > the broader context is appropriate here.
> > 
> > Unless you have another word that would 'drop in'?
> 
> "Queuing systems perform three distinct, but related...."
> 
> cheers,
> gja
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Grenville Armitage <[email-masked]>
Date: Tue, 14 Dec 1999 17:02:29 -0800

Andrew,

Yes :-)

And as you so nicely demonstrate in your example, the
queueing system is "queue plus scheduling". A queue
provides the 'place to wait', scheduling provides
the 'when to leave'. (And I supposed discard can be
considered the 'leave via the secret trap door in
the floor' :-)

cheers,
gja

---

From: "Albert Manfredi" <[email-masked]>
Date: Wed, 15 Dec 1999 10:37:12 -0500

> then have a mad random-access scramble when the vehicle

Actually, there is. The queue is used for buffering only. I suppose
you can call that "scheduling," but it really isn't. Buffering means
you're holding something until the next stage is ready. Scheduling
means you're holding something for transmitting at some
predetermined time.

Thinking back at queueing theory courses, I also remember what Dan
mentioned, but I think that things like service and arrival times
can be considered to be outside influences _on_ the queue, which
affect the behavior _of_ the queue, rather than effects caused by
the queue itself.

Semantics, semantics. I am sort of agreeing with Grenville here.

Bert
[email-masked]

---

From: Dan Grossman <[email-masked]>
Date: Wed, 15 Dec 1999 17:23:57 -0500

> considered the 'leave via the secret trap door in
Actually, it's the secret police, who are instructed to either:
a) shoot everybody standing behind a line on the floor
b)  when, on average, people get backed up behind a line on the floor, start 
shooting people at random, in the expectation that they won't have children 
who will ultimately also stand in line
c) same, except start shooting people who already have large families when the 
queue is short, and start shooting everybody else when the queue is longer
d) when people get backed up behind a line on the floor, shoot people at the 
head of the queue.
e) shoot people according to some other algorithm which is proprietary to the 
local dictator.

:-)

(yeah, I know, I've oversimplified RED and RIO.  But the metaphor is apt.)