Subject: RE: [Diffserv] Model - queues - replacement text

From: Andrew Smith <[email-masked]>
Date: Wed, 15 Dec 1999 10:48:00 -0800

That's fine for specific PHBs but we are talking here about the generic
model of a queueing thing for all current PHBs and as many future PHBs as
possible. Not sure I understand the relevance of MF-classifier based ASICs
to this.

Andrew

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Wednesday, December 15, 1999 7:46 AM
> To: Andrew Smith
> Cc: 'Dan Grossman'; [email-masked]
> Subject: Re: [Diffserv] Model - queues - replacement text
> 
> 
> Andrew Smith wrote:
> ...
> > > structure that remove or examine packets (e.g., for use by
> > > discarders), as
> > > long as no operation reorder packets belonging to the 
> same microflow.
> > 
> > [Andrew] Suggest we not get into re-ordering issues here to 
> any granularity
> > less than "per-queue": I think it suffices to say here 
> "this does not
> > preclude implementions which support operations on the FIFO 
> data structure
> > that remove or examine packets e.g. for use by discarders. The only
> > constraint on such operations is that they not add packets 
> back into the
> > FIFO in a different order."
> 
> Well, some months back we had implementors *insisting* on the 
> per-microflow
> language rather than per-queue, so that the diffserv model would
> be compatible with MF-classifier based ASICs. I think that was for the
> specific case of AF, but I suspect the argument is generic.
> 
>    Brian
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 Dec 1999 15:17:42 -0600

Well, never mind the ASICs then. RFC 2474 says

>    It is RECOMMENDED that PHB implementations do
>    not introduce any packet re-ordering within a microflow. 

The text in the model must be consistent with this.

  Brian