Subject: RE: [Diffserv] EF with Drop ?

From: Shahram Davari <[email-masked]>
Date: Wed, 17 Nov 1999 15:43:24 -0800

Hi John,

I think what Juha is proposing is that to reduce the delay, you could for
example assign 90% of the link BW to an AF class, but you don't want to
actually use that BW (because if you do other classes will get starved).
Let's say for example you want to use only 50% of the BW. Due to this
artificially available BW, there will be no queue buildup, and therefore you
can't use normal RED (which decides based on queue depth) to control the BW
usage. So you have to control the injection rate of high drop-precedence
traffic to the queue.

Regards,
Shahram

> -----Original Message-----
> From: John Wroclawski [mailto:[email-masked]]
> Sent: Wednesday, November 17, 1999 3:29 PM
> To: Juha Heinanen; Joerg Diederich
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Diffserv] EF with Drop ?
> 
> 
> At 9:33 PM +0200 11/16/99, Juha Heinanen wrote:
> 
> >  > I agree with you, but since we assume that EF is used 
> (or should be
> >  > used) to built low-delay services which rely on avoidance of
> >  > congestion by traffic conditioning (see above), AF seems 
> to be not the
> >  > right way to implement a low-delay service which allows 
> dropping but
> >  > does not allow congestion.
> >
> >see above for an implementation that uses an af class with red and
> >results in a low delay service with drop.  is there 
> something wrong with
> >it?  what else you would need?
> >
> >-- juha
> 
> Juha,
> 
> I suspect I'm missing your point here, but this doesn't make 
> sense to me:
> 
> - if there is sufficient b/w available to the AF class to carry the 
> traffic, it will go & there isn't much reason to drop it.
> 
> - if there is insufficient b/w to carry the traffic for whatever 
> reason, it will queue, and if you would rather drop it than queue it 
> you should be able to accomplish this by setting the AF parameters 
> appropriately (small q size, short averaging interval.
> 
> So I'm not quite sure what is to be gained by specifically watching 
> rate rather than q size.
> 
> (I believe this is pretty much what Grenville said in this thread 
> some msgs ago..)
> 
> -john
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: demir <[email-masked]>
Date: Wed, 17 Nov 1999 18:07:42 -0800 (PST)

> usage. So you have to control the injection rate of high drop-precedence
Hi,
Why do you assing 90% of the link BW to an AF class though you want to use
only 50% of the BW for that class? 
I am assuming that by "you can't use RED" mean, RED is used with
controlling the injection rate of high-drop precedence AF traffic to the
queue. why do we need to control the injection rate to the queue instead
of scheduling so that we use 50% of the BW?

Alper K. Demir

---

From: Juha Heinanen <[email-masked]>
Date: Thu, 18 Nov 1999 08:43:46 +0200 (EET)

> usage. So you have to control the injection rate of high drop-precedence

thanks shahram, this is what i tried to say.  i would control the total
arrival rate and then start gradually dropping yellows when a given rate
threshold is exceeded.

-- juha