Subject: [Diffserv] MPLS vs Diff-Serv

From: "Haci A. Mantar" <[email-masked]>
Date: Mon, 15 Nov 1999 00:31:58 -0500 (EST)

Hi

Are MPLS and Diff-Serv totally independent technologies? I mean does MPLS
uses Diff-Serv for some requirment, or Diff-Serv uses MPLS for anything.
For example: MPLS uses extended RSVP for reservation, Is there any this
kind of related or depended functions between Diff-Serv and MPLS.

Thanks

HACI ALI MANTAR

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Alex Zinin <[email-masked]>
Date: Mon, 15 Nov 1999 19:38:58 +0300

Haci,

In a word---yes, they are independent technologies.
This is to say that MPLS does not need DiffServ and
DiffServ doesn't need MPLS. However, we do have
several proposals on combining MPLS with DiffServ.

The fact that LSPs can be established by RSVP in
MPLS doesn't make MPLS an IntServ-aware technology
(RSVP is IntServ- rather than DiffServ-related)

You may want to explore the homepages and documents
of the corresponding WGs for more info.

Alex.

>kind of related or depended functions between Diff-Serv and MPLS.
------------------------------------------------------------------
Alex D. Zinin, Consultant
CCSI #98966
CCIE #4015

---

From: "Yoram Bernet (Exchange)" <[email-masked]>
Date: Mon, 15 Nov 1999 10:27:52 -0800

The two are both related and yet - independent. For example - diffserv
assumes a network which can offer certain services to its customers. In
order to offer these seervices, the diffserv network must be provisioned
(either dynamically or statically). MPLS can be used to do the traffic
engineering necessary to provision a diffserv network. MPLS might use a
certain form of RSVP for this. Completely independently, RSVP might be used
from hosts ot gain admision to the diffserv services. 

There are other examples of how diffserv, MPLS and RSVP technologies work
together. I think that none of them *replace* any of the others. They just
have different roles in the grand scheme.
 
Yoram

> -----Original Message-----
> From: Haci A. Mantar [mailto:[email-masked]]
> Sent: Sunday, November 14, 1999 8:57 PM
> To: Haci A. Mantar
> Cc: [email-masked]
> Subject: [Diffserv] MPLS vs Diff-Serv
> 
> 
> Hi
>