Subject: RE: [Diffserv] MPLS vs Diff-Serv

From: [email-masked]
Date: Tue, 16 Nov 1999 17:26:47 +0200

MPLS and Diff-Serv are totally independent technologies.
They work in somewhat different network layers. Diff-Serv
is layer 3 protocol which works on IP layer. 

MPLS works on a lower layer, somewhere between network layer
(layer 2) and IP layer (layer 3). In some sense you could call
MPLS as a layer 2.5 on the network stack, because it is not
clearly layer 2 or layer 3 technology, but something in between.

As far as I know MPLS as such doesen't require Diff-Serv to work.
To build a working network using MPLS will quite propably
require some kind of traffic control mechanism at layer 3,
for example Diff-Serv.

Diff-Serv doesen't need MPLS for anything. You can build
Diff-Serv network entirely without knowing anything about MPLS
or using it. If you are building an all IP network (IP over fiber etc.)
this might be the wisest choice.

If you happen to use some layer 2 network techology which provides
some network connections like functionality then using MPLS on such
system might be beneficial. So if you have an ATM or Frame Relay
based core network, MPLS might be useful in utilizing what that
network offers efficently. On ATM based network, it might be sensible
to use both Diffserv and MPLS on the same network.

The views shown at this article are my personal views on 
MPLS and Diff-Serv.

Tomi Engdahl
Nokia Research Center

> -----Original Message-----
> From: EXT Haci A. Mantar [mailto:[email-masked]]
> Sent: 15. November 1999 6:57
> To: Haci A. Mantar
> Cc: [email-masked]
> Subject: [Diffserv] MPLS vs Diff-Serv
> 
> 
> Hi
> 
> Are MPLS and Diff-Serv totally independent technologies? I 
> mean does MPLS
> uses Diff-Serv for some requirment, or Diff-Serv uses MPLS 
> for anything.
> For example: MPLS uses extended RSVP for reservation, Is 
> there any this
> kind of related or depended functions between Diff-Serv and MPLS.
> 
> Thanks
> 
> 
> HACI ALI MANTAR
> 
> 
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
> 

_______________________________________________
diffserv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/diffserv
Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/

---

From: Jon Crowcroft <[email-masked]>
Date: Tue, 16 Nov 1999 16:09:00 +0000

>>MPLS and Diff-Serv are totally independent technologies.

however, if you believe the hype, mpls enables traffic engineering -
one reason for traffic engineering is to provide better control of
services, including meeting some sort of SLAs (at least within an ISPs
boundaries), and Diff Serve is aimed at (eventually) allowing some
sort of derivation of services from PHB behaviours, together with
source models, traffic matrix and the providers knowledge of their
provisioning, and topology

so they could be inextricalby intertwined in some people's minds and
implmenetations....i guess a switch router might even map DSCP +
egress to labels if one wants to cut to the chase...

of course, the fact tha you can do traffic engineering (and flow
aggregation) without mpls, and the fact that you can do provisioning
without diffserv is entirely orthogonal :-)

j.
my employer pays me to have opinions - so this must be the official
position, or they are wasting their money:-)