Subject: RE: [Diffserv] EF RFC and loss

From: Shahram Davari <[email-masked]>
Date: Thu, 28 Oct 1999 18:21:42 -0700

Hi Kathy,

Please see below.

Regards,
Shahram

> -----Original Message-----
> From: Kathleen Nichols [mailto:[email-masked]]
> Sent: Thursday, October 28, 1999 6:03 PM
> Cc: [email-masked]
> Subject: Re: [Diffserv] EF RFC and loss
> 
> 
> 
> 
> Shahram Davari wrote:
> > 
> ... the result is a big
> > burst at the egress port. Now if you don't do shaping at 
> the egress port of
> > interior routers, this burst can potentially get very big.
> > 
> > As an example consider two consecutive routers A and B 
> directly connected
> > via a single link, each having 32 ports. If all the EF 
> traffic of all the
> > ports of routers A and B are directed toward one of the 
> egress ports of
> > router B, potentially you could have a burst size of 
> 32*32=1024 packets.
> > Although your egress port may be configured with an EF-BW 
> which is larger
> > than the addition of all incoming EF rates of all 32+32=64 
> ports. Notice
> > that this kind of burst generation could be exponential in 
> the worst case.
> 
> So if you could configure that it would mean that your network
> could have 1023 separate components of the EF aggregate. So
> you have 1024*rate_i < 0.5 * BW, where BW is the bandwidth of
> that single egress link. Then that means, to prevent loss,
> you have to buffer 1024*packet_size*8/BW (in time) 
> which is <= 1024*packet_size*8/(2048*rate_i) or one-half
> the time it takes to send a packet at rate_i. Would this be
> a huge burst?
>

We have only 64 separate components of EF traffic, because there are only 64
ports. So 64*rate_i < 0.5 * BW and therefore
Burst=1024*packet_size*8/(128*rate_i), which is equal to 8 packet time it
takes to send a packet at rate_i. I think this is a huge burst considering
only two routers.

> > 
> > The way to solve this problem is by shaping at each egress 
> port of interior
> > routers. Although shaping at the interior nodes is not 
> mentioned in EF
> > draft, but if not done you may exceed the buffer size of 
> downstream node
> > without violating the EF rate/BW rule, which is what the 
> question was about.
> > 
> > My opinion is that by shaping at interior nodes,  packet loss = 0 is
> > possible for EF.
> > 
> 
> You could certainly do this to reduce the buffering demands, but
> one ought to check the necessity first.
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>

---

From: Kathleen Nichols <[email-masked]>
Date: Thu, 28 Oct 1999 22:36:48 -0700

> takes to send a packet at rate_i. I think this is a huge burst considering

No, that doesn't work. You can't burst 1024 packets if there are
only 64 EF components.