Subject: EF RFC and loss

From: [email-masked]
Date: Thu, 28 Oct 1999 10:07:20 +0200

Folks,

The EF PHB RFC 2598 states at the end of section 3 on Security considerations:

"Similarly, since the aggregate EF traffic rate is constrained at
every interior node, the EF queue should never overflow so if it
does the drops SHOULD be noted as possible attacks or serious misconfiguration."

Does this mean that the EF PHB specifically requires "absolute zero" packet loss due to buffer overflow?
I  was under the impression that a statistical packet queueing process always entailed a loss probability,
that can however  be engineered to a low but non-zero value.

Thanks in advance for any clarifiaction,

manu

---

From: Anurag <[email-masked]>
Date: Thu, 28 Oct 1999 17:11:44 +0800 (HKT)

> Thanks in advance for any clarifiaction,
To my understanding loss of packets in EF is an exceptional condition.
Scheduling schemes (PQ, WRR or CBQ) used to implement EF do provide the
behaviour as defined in EF rfc. 

Description of EF says: 
   "The EF PHB is defined as a forwarding treatment for a particular
   diffserv aggregate where the departure rate of the aggregate's
   packets from any diffserv node must equal or exceed a configurable
   rate.  The EF traffic SHOULD receive this rate independent of the
   intensity of any other traffic attempting to transit the node."
   (RFC2598)

Hence I see no reason for packets to be droped due to buffer overflow 
under normal operating conditions (including congestion). 

with Regards
Anurag,
---------------------------------------------
Computer Science Department, HKUST, Hong Kong
Lab. # 4204, Phone: + (852) 2358 8832 (Lab.)
             FAX  : + (852) 2358 1477 (Dept. off.)
> 
> 
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
> 
>

---

From: Grenville Armitage <[email-masked]>
Date: Thu, 28 Oct 1999 07:35:35 -0700

[email-masked] wrote:
	[..]
> I  was under the impression that a statistical packet queueing
> process always entailed a loss probability,

EF imposes requirements that the queue serving rate is
not dependent on random traffic characteristics in other queues, and
is always larger than (within a small delta) the queue arrival rate.
Therefore it is expected that a buffer big enough to hold a couple
of EF packets should not overflow under proper operating conditions.

cheers,
gja
________________________________________________________________________
Grenville Armitage                            http://mh005.infi.net/~gja
Bell Labs Research, Lucent Technologies