Subject: RE: [Diffserv] Terminology draft

From: "Ray, Bhaskar" <[email-masked]>
Date: Fri, 8 Oct 1999 09:35:24 -0400

Brian E Carpenter wrote:
> 
> AF classes are independent and there is no ordering constraint
> across AF classes. The ordering constraint is clearly required across
> drop precedences within an AF class.
> 
> If an AF flow happens to go through a traffic conditioner that
> remarks it from one AF DSCP to another AF DSCP, that really has
> nothing to do with the terminology issue; it's simply business as
> usual at a network/network boundary.

Kathleen Nichols wrote:

>So I'm not sure what that diversion was about, but since Brian
>was making it, there has to have been a point. :)

Yes, that is the way I have understood it. My implementation treats class
AF1x, AF2x, AF3x and AF4x as
different PHB groups. There is no ordering constraints or any relationship
between them.
However ordering constraints apply to flows/microflows assigned to a
particular class, though
they may have different drop preferences. This implies that traffic
conditioner should not 
remark/demote a packet belonging to a microflow to a different class, only
the drop preference
gets changed.
Please let me know if I am wrong.

Thanks

Bhaskar

---

From: Kathleen Nichols <[email-masked]>
Date: Fri, 08 Oct 1999 09:19:58 -0700

You are not wrong. My saying it was a "diversion" was just that
I thought that part of AF (the drop precedence relationship
within an AF "class") was well-explained in RFC2597 and was
well-understood in the WG (although the implementation of it
may still be a matter for experimentation). I thought the current
"issue" was whether the AF "classes" were a PHB Group and what
IS a PHB Group.

"Ray, Bhaskar" wrote:
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/