Subject: RE: [Diffserv] EF RFC and loss

From: Shahram Davari <[email-masked]>
Date: Fri, 29 Oct 1999 09:45:18 -0700

Hi Kathy,

Sorry my mistake. But I think you had a mistake too:

"So if you could configure that it would mean that your network
could have 1023 separate components of the EF aggregate. So
you have 1024*rate_i < 0.5 * BW, where BW is the bandwidth of
that single egress link. Then that means, to prevent loss,
you have to buffer 1024*packet_size*8/BW (in time) 
which is <= 1024*packet_size*8/(2048*rate_i) or one-half
the time it takes to send a packet at rate_i. Would this be
a huge burst?"

Since in your equation you are substituting the BW with a smaller number
therefore: The time is >= 1/2 packet size ( not <= ). So for example if you
have 1024*rate_i < 0.1 * BW, then the time >= 10 packets time. I think this
is big, Right?

Regards,
Shahram

                            _\\|//_
                            ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
          Shahram Davari
          Systems Engineer, Product Research
          PMC-Sierra Inc. 
          105-8555 Baxter Place
          Burnaby, BC V5A 4V7, Canada
          Phone: +1 (604) 415-6000, Ext. 2428
          Fax  : +1 (604) 415-6206
                         oooO
   ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                          \ (    (   )
                           \_)    ) /
                                 (_/

> -----Original Message-----
> From: Kathleen Nichols [mailto:[email-masked]]
> Sent: Thursday, October 28, 1999 10:37 PM
> To: Shahram Davari
> Cc: [email-masked]
> Subject: Re: [Diffserv] EF RFC and loss
> 
> 
> 
> 
> Shahram Davari wrote:
> 
> > 
> > We have only 64 separate components of EF traffic, because 
> there are only 64
> > ports. So 64*rate_i < 0.5 * BW and therefore
> > Burst=1024*packet_size*8/(128*rate_i), which is equal to 8 
> packet time it
> > takes to send a packet at rate_i. I think this is a huge 
> burst considering
> > only two routers.
> 
> No, that doesn't work. You can't burst 1024 packets if there are
> only 64 EF components.
>

---

From: Kathleen Nichols <[email-masked]>
Date: Fri, 29 Oct 1999 10:08:01 -0700

..wondering if this should go to diffserv-interest, but...

> have 1024*rate_i < 0.1 * BW, then the time >= 10 packets time. I think this

If the amount allocated to EF is smaller than half the BW, for
example, 0.1 *BW, then BW = 10 * 1024 * rate_i, right? So this
rate_i is one fifth of the one you'd use for allocating 50% of BW.
BW doesn't get any smaller, rate_i does. So now the buffer in
time is 0.8 * the time to send a packet at rate_i. Except that
is five times as long as the value above. Or maybe I need to
finish my second cup of coffee?