Subject: Re: [Diffserv] EF RFC and loss

From: [email-masked]
Date: Thu, 28 Oct 1999 11:23:37 +0200

>On Thu, 28 Oct 1999 [email-masked] wrote:

>
>
> Folks,
>
> The EF PHB RFC 2598 states at the end of section 3 on Security considerations:
>
> "Similarly, since the aggregate EF traffic rate is constrained at
> every interior node, the EF queue should never overflow so if it
> does the drops SHOULD be noted as possible attacks or serious misconfiguration."
>
> Does this mean that the EF PHB specifically requires "absolute zero" packet loss due to buffer overflow?
> I  was under the impression that a statistical packet queueing process always entailed a loss probability,
> that can however  be engineered to a low but non-zero value.
>
> Thanks in advance for any clarifiaction,
>
> manu
>
To my understanding loss of packets in EF is an exceptional condition.
Scheduling schemes (PQ, WRR or CBQ) used to implement EF do provide the
behaviour as defined in EF rfc.

[manu] But you admit that they genuinely occur be it rarely/occasionaly.
So why should this be seen as a potential "attack or serious misconfiguration"?

<snip>

with Regards

[manu] And mine,

Anurag,

manu
---------------------------------------------
Computer Science Department, HKUST, Hong Kong
Lab. # 4204, Phone: + (852) 2358 8832 (Lab.)
             FAX  : + (852) 2358 1477 (Dept. off.)
>
>
> _______________________________________________
> diffserv mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/diffserv
> Archive: http://www-nrg.ee.lbl.gov/diff-serv-arch/
>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 28 Oct 1999 09:07:31 -0500

You are certainly correct that any queuing system has a
finite probability that the queue size exceeds the buffer
size; the point of EF is that a correctly engineered premium
service will reduce this probability to a negligible level.

However, there is one fundamental point that applications
designers must not overlook: differentiated services change
the statistics, but they do not change the fact that every 
IP packet has a finite probability of being dropped.

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter (IAB Chair)
Program Director, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Non-IBM email: [email-masked]