Subject: [Diffserv-interest] QoS in diffserv network

From: "Feng Y" <[email-masked]>
Date: Thu, 06 Nov 2003 11:29:01 -0500

>> 
>> It is up to the carrier to monitor congestion
periodically to prevent
>> lowest-priority traffic from being too congested. EF
should ALWAYS get
>> through on-time, and AF CIR should always get through,
if somewhat delayed
>> and jittery. The cases when this is NOT true should be
rare and bizarre
>> (earthquakes, major network outages, etc.) unless the
carrier is not doing
>> their job... Which is simply to make sure they engineer
total network
>> bandwidth above the level of peak CIR.
>
>Exactly. Each traffic class (i.e. each queue) needs to be
provisioned for
>the expected load with appropriate over- or
under-provisioning. The new
>thing is that you can over-provision for some traffic and
under-provision
>for other traffic. (New to IP, that is. It's hardly a new
concept.)

Can we always assume that a higher service class provides
the same or a better service than any lower service class
in AF? Can the following scenario happen in Diffserv
network?
The gold service was allocated x percent of a link’s
bandwidth and silver service was allocated x/2 percent of
the link’s bandwidth, but the traffic intensity of gold
packets was 10 times higher than that of silver packets.

Should the ISP assure that there are not so many gold
packets in service? 

Thanks

Yang 

_______________________________________________
Diffserv-interest mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv-interest

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 09 Nov 2003 19:26:48 +0100

below...

Feng Y wrote:
> in AF? 

No. There is no "higher" or "lower" built into AF. There
is simply the option of having one or more mutually
independent AF service classes, with an arbitrary number
of four service classes being named AF1, AF2, AF3, AF4
if you choose to use the recommended code points.

If you happen to give each of these classes equal weights
in a WFQ scheme they are all offering the same level of service.

If you happen to give AF2 a higher weight than AF3, you are
choosing to offer more service to AF2 traffic.

> Can the following scenario happen in Diffserv
> network?

That can certainly happen, if you mean that the offered
load to the gold service is ten times greater than the
offered load to the silver service.

> Should the ISP assure that there are not so many gold

It depends what the SLA for gold and silver say, doesn't
it? There is no rule. It's the ISP's business decision.

My assumption and what I would recommend to an ISP is:

If the offered load on silver equals the bandwidth assigned
to silver, then it should all be transmitted, unless the SLA says
otherwise. And the excess traffic offered to the gold service 
will be at high risk of being dropped, depending on the utilization
of the remaining (100-x-x/2)% of the line.

   Brian

---

From: [email-masked]
Date: Mon, 10 Nov 2003 09:21:15 +0100

Brian, Feng,

That would be the case when the relative load in those classes was
equal as well. But, since some

classes can be more loaded than others, the service seen in different
classes does not

relate to the index of the AF class. Unless, of course, the scheduler
was strict priority, which does

not conform to the requirements in RFC2597 (minimum bandwidth).

Regards,

Zoltan

<snip>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 10 Nov 2003 16:55:17 +0100

> [email-masked] wrote:
> 
> Brian, Feng,
> 
> That would be the case when the relative load in those classes was equal as well. But, since some
> classes can be more loaded than others, the service seen in different classes does not
> relate to the index of the AF class. 

Zoltan,

There is no such thing as an index; the digit in AF3 is just part of the name.

If two AF classes have equal WFQ weights but different offered loads, they will 
experience different loss and jitter rates, but the service *offered* is the same.
The service *delivered* will vary, but that is a different matter. The two SLAs may 
be different, by allowing different levels of overbooking, but that is why the diffserv 
documents distinguish between the SLA and the SLS [service level specification].

I think we are in agreement, but I want to be precise.

> Unless, of course, the scheduler was strict priority, which does

True.

   Brian