Subject: [Diffserv-interest] Re: Diffserv-interest digest, Vol 1 #113 - 3 msgs

From: "John H. Shuler" <[email-masked]>
Date: Mon, 10 Nov 2003 11:12:02 -0800

Brian,

I don't believe there is a mandate for SPs to use WFQ within the AF class,
so either WFQ or strict priority queuing is an option. As well, the nature
and degree of priority -- in fact, the entire policy equation -- seems to be
left open, except that there is an implication that AF4 is given some higher
quality/priority than AF1, whether in a weighted or strict sense.

It is my contention, however, that there should be some kind of specific
guidelines provided for this class, especially, since it is in AF where a
lot of the subtlety -- and confusion, and cross-carrier screwups -- can
reside. This is where I believe the proposed draft can have its biggest
impact. That is, not only in delineating further the treatment of AF within
class, but also the rules in assigning traffic types to different classes.

The whole idea is that, without some kind of standardization, multi-service
IP will not take off as it should, because there is no way for a customer to
know that the video (for example) he hands to his regional SP will make it
to the other end in a consistent and reliable way.

j

> From: [email-masked]
> Reply-To: [email-masked]
> Date: Mon, 10 Nov 2003 12:00:03 -0500
> To: [email-masked]
> Subject: Diffserv-interest digest, Vol 1 #113 - 3 msgs
> 
> Send Diffserv-interest mailing list submissions to
> [email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> https://www1.ietf.org/mailman/listinfo/diffserv-interest
> or, via email, send a message with subject or body 'help' to
> [email-masked]
> 
> You can reach the person managing the list at
> [email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Diffserv-interest digest..."
> 
> 
> Today's Topics:
> 
>  1. Re: QoS in diffserv network (Brian E Carpenter)
>  2. Re: QoS in diffserv network ([email-masked])
>  3. Re: QoS in diffserv network (Brian E Carpenter)
> 
> --__--__--
> 
> Message: 1
> Date: Sun, 09 Nov 2003 19:26:48 +0100
> From: Brian E Carpenter <[email-masked]>
> Organization: IBM
> To: Feng Y <[email-masked]>
> CC: [email-masked]
> Subject: Re: [Diffserv-interest] QoS in diffserv network
> 
> below...
> 
> Feng Y wrote:
>> =
> 
>>>> 
>>>> It is up to the carrier to monitor congestion
>> periodically to prevent
>>>> lowest-priority traffic from being too congested. EF
>> should ALWAYS get
>>>> through on-time, and AF CIR should always get through,
>> if somewhat delayed
>>>> and jittery. The cases when this is NOT true should be
>> rare and bizarre
>>>> (earthquakes, major network outages, etc.) unless the
>> carrier is not doing
>>>> their job... Which is simply to make sure they engineer
>> total network
>>>> bandwidth above the level of peak CIR.
>>> 
>>> Exactly. Each traffic class (i.e. each queue) needs to be
>> provisioned for
>>> the expected load with appropriate over- or
>> under-provisioning. The new
>>> thing is that you can over-provision for some traffic and
>> under-provision
>>> for other traffic. (New to IP, that is. It's hardly a new
>> concept.)
>>> 
>> =
> 
>> Can we always assume that a higher service class provides
>> the same or a better service than any lower service class
>> in AF? =
> 
> 
> No. There is no "higher" or "lower" built into AF. There
> is simply the option of having one or more mutually
> independent AF service classes, with an arbitrary number
> of four service classes being named AF1, AF2, AF3, AF4
> if you choose to use the recommended code points.
> 
> If you happen to give each of these classes equal weights
> in a WFQ scheme they are all offering the same level of service.
> 
> If you happen to give AF2 a higher weight than AF3, you are
> choosing to offer more service to AF2 traffic.
> 
> 
>> Can the following scenario happen in Diffserv
>> network?
>> The gold service was allocated x percent of a link=92s
>> bandwidth and silver service was allocated x/2 percent of
>> the link=92s bandwidth, but the traffic intensity of gold
>> packets was 10 times higher than that of silver packets.
> 
> That can certainly happen, if you mean that the offered
> load to the gold service is ten times greater than the
> offered load to the silver service.
> 
>> =
> 
>> Should the ISP assure that there are not so many gold
>> packets in service?
> 
> It depends what the SLA for gold and silver say, doesn't
> it? There is no rule. It's the ISP's business decision.
> 
> My assumption and what I would recommend to an ISP is:
> 
> If the offered load on silver equals the bandwidth assigned
> to silver, then it should all be transmitted, unless the SLA says
> otherwise. And the excess traffic offered to the gold service =
> 
> will be at high risk of being dropped, depending on the utilization
> of the remaining (100-x-x/2)% of the line.
> 
>  Brian
> 
> 
> --__--__--
> 
> Message: 2
> Date: Mon, 10 Nov 2003 09:21:15 +0100
> From: [email-masked]
> Organization: Alcatel,
> To: Brian E Carpenter <[email-masked]>
> Cc: Feng Y <[email-masked]>, [email-masked]
> Subject: Re: [Diffserv-interest] QoS in diffserv network
> 
> <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
> <html>
> <head>
> <meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1">
> <title></title>
> </head>
> <body text="#000000" bgcolor="#ffffff">
> Brian, Feng,<br>
> <blockquote type="cite" cite="[email-masked]">
> <blockquote type="cite">
>   <pre wrap="">Can we always assume that a higher service class provides
> the same or a better service than any lower service class
> in AF? 
>   </pre>
> </blockquote>
> <pre wrap=""><!---->
> No. There is no "higher" or "lower" built into AF. There
> is simply the option of having one or more mutually
> independent AF service classes, with an arbitrary number
> of four service classes being named AF1, AF2, AF3, AF4
> if you choose to use the recommended code points.
> 
> If you happen to give each of these classes equal weights
> in a WFQ scheme they are all offering the same level of service.</pre>
> </blockquote>
> That would be the case when the relative load in those classes was
> equal as well. But, since some<br>
> classes can be more loaded than others, the service seen in different
> classes does not <br>
> relate to the index of the AF class. Unless, of course, the scheduler
> was strict priority, which does<br>
> not conform to the requirements in RFC2597 (minimum bandwidth).<br>
> <br>
> <br>
> Regards,<br>
> Zoltan<br>
> <br>
> &lt;snip&gt;<br>
> </body>
> </html>
> 
> 
> 
> --__--__--
> 
> Message: 3
> Date: Mon, 10 Nov 2003 16:55:17 +0100
> From: Brian E Carpenter <[email-masked]>
> Organization: IBM
> To: [email-masked]
> CC: Feng Y <[email-masked]>, [email-masked]
> Subject: Re: [Diffserv-interest] QoS in diffserv network
> 
>> [email-masked] wrote:
>> 
>> Brian, Feng,
>> 
>>>> Can we always assume that a higher service class provides
>>>> the same or a better service than any lower service class
>>>> in AF?
>>>> 
>>>> 
>>> No. There is no "higher" or "lower" built into AF. There
>>> is simply the option of having one or more mutually
>>> independent AF service classes, with an arbitrary number
>>> of four service classes being named AF1, AF2, AF3, AF4
>>> if you choose to use the recommended code points.
>>> 
>>> If you happen to give each of these classes equal weights
>>> in a WFQ scheme they are all offering the same level of service.
>>> 
>> That would be the case when the relative load in those classes was equal as
>> well. But, since some
>> classes can be more loaded than others, the service seen in different classes
>> does not
>> relate to the index of the AF class.
> 
> Zoltan,
> 
> There is no such thing as an index; the digit in AF3 is just part of the name.
> 
> If two AF classes have equal WFQ weights but different offered loads, they
> will 
> experience different loss and jitter rates, but the service *offered* is the
> same.
> The service *delivered* will vary, but that is a different matter. The two
> SLAs may 
> be different, by allowing different levels of overbooking, but that is why the
> diffserv 
> documents distinguish between the SLA and the SLS [service level
> specification].
> 
> I think we are in agreement, but I want to be precise.
> 
>> Unless, of course, the scheduler was strict priority, which does
>> not conform to the requirements in RFC2597 (minimum bandwidth).
> 
> True.
> 
>  Brian
> 
> 
> 
> --__--__--
> 
> _______________________________________________
> Diffserv-interest mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/diffserv-interest
> 
> 
> End of Diffserv-interest Digest

_______________________________________________
Diffserv-interest mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv-interest

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 10 Nov 2003 20:49:58 +0100

Yes, WFQ is an example solution of course, but it's a relatively easy one to think
about.

I do agree we need a best practices document; we're only arguing about its
richness in service classes, I think.

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 

NEW ADDRESS <[email-masked]> PLEASE UPDATE ADDRESS BOOK

---

From: "John H. Shuler" <[email-masked]>
Date: Mon, 10 Nov 2003 11:55:12 -0800

Brian,

I agree. My suggestion would be to keep it simple so as to be easily
implemented as a common denominator standard that works, then refine it over
time after experience demonstrates a need. If it starts out too complicated,
it will be too expensive to implement and therefore usurp the purpose.

j

> Date: Mon, 10 Nov 2003 20:49:58 +0100
> To: "John H. Shuler" <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Diffserv-interest] Re: Diffserv-interest digest, Vol 1 #113 - 3
> msgs
> 
>>>> classes

---

From: Jing Shen <[email-masked]>
Date: Fri, 14 Nov 2003 20:14:16 +0800 (CST)

I'm not so clear with "overbooking" in DiffServ
network. To my understanding, there will be no
end-to-end explicit bandwidth allocation in DiffServ
Networks. At that of current IP network, ISP just
provides internet access to customers and core network
is overprovisioned to guarantee service quality.  So,
to my expection "logical Golden Service Network" in
DiffServ will not has explict e2e tunnel at all. Where
comes overbooking? 

 --- "John H. Shuler" <[email-masked]> 的正文：>
Brian,
> it will be too expensive to implement and therefore

=====
Jing Shen

Data Communication Center
HangZhou TeleCom 
HangZhou ZJ 310027
P.R.China

' spamcontrol '

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 14 Nov 2003 14:43:08 +0100

Whether a service class is over provisioned or under provisioned
(i.e. overbooked) is just an operational choice by the ISP.
For a PDB built using the EF PHB, it would be bizarre to
under-provision, but for the class selector PHBs, the default
PHB, or an AF class, under-provisioning would be a possible
choice. In fact, in a diffserv deployment, I would expect the
default PDB to be under-provisioned - otehrwise, there would
be little reason to offer "better than default" PDBs.

   Brian

Jing Shen wrote:
>  --- "John H. Shuler" <[email-masked]> µÄÕýÎÄ£º>
> Brian,
> >

---

From: "John H. Shuler" <[email-masked]>
Date: Fri, 14 Nov 2003 10:58:39 -0800

You don't need to worry about overbooking if you properly engineer bandwidth
and take advantage of DiffServ mechanisms. Although you will never get
absolute, deterministic guarantees, you can get statistical guarantees that
approach determinism while avoiding the huge cost implications of a
signaled, per-flow reservation network.

> From: Jing Shen <[email-masked]>
> Date: Fri, 14 Nov 2003 20:14:16 +0800 (CST)
> To: "John H. Shuler" <[email-masked]>, Brian E Carpenter
> <[email-masked]>