Subject: [Diffserv-interest] Re: Diffserv-interest digest, Vol 1 #104 - 2 msgs

From: "John H. Shuler" <[email-masked]>
Date: Thu, 30 Oct 2003 09:37:55 -0800

It is my understanding that DiffServ does not attempt to prevent congestion
at all, but only to ensure the the best chance for services to get the
treatment they need (vs. Want) by making choices about queuing priorities.

It is up to the carrier to monitor congestion periodically to prevent
lowest-priority traffic from being too congested. EF should ALWAYS get
through on-time, and AF CIR should always get through, if somewhat delayed
and jittery. The cases when this is NOT true should be rare and bizarre
(earthquakes, major network outages, etc.) unless the carrier is not doing
their job... Which is simply to make sure they engineer total network
bandwidth above the level of peak CIR.

The only alternative to this -- admission control -- imposes a signaling
requirement that just adds to the total network burden and is not responsive
enough to deal with the unpredictable burstiness of the internet.

Am I off-base, here?

j

> From: [email-masked]
> Reply-To: [email-masked]
> Date: Wed, 29 Oct 2003 12:00:04 -0500
> To: [email-masked]
> Subject: Diffserv-interest digest, Vol 1 #104 - 2 msgs
> 
> Send Diffserv-interest mailing list submissions to
> [email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> https://www1.ietf.org/mailman/listinfo/diffserv-interest
> or, via email, send a message with subject or body 'help' to
> [email-masked]
> 
> You can reach the person managing the list at
> [email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Diffserv-interest digest..."
> 
> 
> Today's Topics:
> 
>  1. Re: congestion in diffserv network (John Schnizlein)
>  2. Re: congestion in diffserv network (Brian E Carpenter)
> 
> --__--__--
> 
> Message: 1
> Date: Tue, 28 Oct 2003 12:30:55 -0500
> To: "Feng Y" <[email-masked]>
> From: John Schnizlein <[email-masked]>
> Subject: Re: [Diffserv-interest] congestion in diffserv network
> Cc: [email-masked]
> 
> The simple reason that congestion can occur is that the TCA
> need not limit incoming traffic sufficiently to avoid it.
> The TCA for expedited forwarding is the only one, of many=20
> traffic classes, that seeks to eliminate potential congestion,=20
> in order to minimize delay and jitter.
> 
> The parameters of other class definitions, assured forwarding
> for example, are intended to mark traffic at different ingress
> rates for different treatment when congestion occurs. Note
> that this anticipates that congestion will occur.
> 
> Please recall that the high link utilization in an IP network
> is obtained in large measure because traffic loads are high
> enough to produce occasional congestion. Cooperative management
> of this congestion is the responsibility of transport-layer
> protocols.
> 
> John
> 
> At 10:43 AM 10/28/2003, Feng Y wrote:
>> ... I wonder why the
>> overloading or even congestion occurs in diffserv network.
>> In diffserv architecture, the =93DS ingress node is
>> responsible for ensuring that the traffic entering the DS
>> domain conforms to any traffic conditioning agreement (TCA)
>> between it and the other domain to which the ingress node
>> is connected=94 [RFC 2475]. Moreover,   =93Traffic conditioning
>> performs metering, shaping, policing and/or re-marking to
>> ensure that the traffic entering the DS domain conforms to
>> the rules specified in the TCA, in accordance with the
>> domain's service provisioning policy=94. So what causes the
>> overloading or congestion in diffserv? Does anyone explain
>> it for me or give me some references. Thanks in advance.
> 
> 
> 
> --__--__--
> 
> Message: 2
> Date: Wed, 29 Oct 2003 12:07:02 +0100
> From: Brian E Carpenter <[email-masked]>
> Organization: IBM
> To: John Schnizlein <[email-masked]>
> CC: Feng Y <[email-masked]>, [email-masked]
> Subject: Re: [Diffserv-interest] congestion in diffserv network
> 
> Another way to look at it is that what diffserv does is split the network=
> 
> into several separate networks, but each of them retains the statistical
> properties of a single Internet.
> 
>  Brian
> 
> John Schnizlein wrote:
>> =
> 
>> The simple reason that congestion can occur is that the TCA
>> need not limit incoming traffic sufficiently to avoid it.
>> The TCA for expedited forwarding is the only one, of many
>> traffic classes, that seeks to eliminate potential congestion,
>> in order to minimize delay and jitter.
>> =
> 
>> The parameters of other class definitions, assured forwarding
>> for example, are intended to mark traffic at different ingress
>> rates for different treatment when congestion occurs. Note
>> that this anticipates that congestion will occur.
>> =
> 
>> Please recall that the high link utilization in an IP network
>> is obtained in large measure because traffic loads are high
>> enough to produce occasional congestion. Cooperative management
>> of this congestion is the responsibility of transport-layer
>> protocols.
>> =
> 
>> John
>> =
> 
>> At 10:43 AM 10/28/2003, Feng Y wrote:
>>> ... I wonder why the
>>> overloading or even congestion occurs in diffserv network.
>>> In diffserv architecture, the =93DS ingress node is
>>> responsible for ensuring that the traffic entering the DS
>>> domain conforms to any traffic conditioning agreement (TCA)
>>> between it and the other domain to which the ingress node
>>> is connected=94 [RFC 2475]. Moreover,   =93Traffic conditioning
>>> performs metering, shaping, policing and/or re-marking to
>>> ensure that the traffic entering the DS domain conforms to
>>> the rules specified in the TCA, in accordance with the
>>> domain's service provisioning policy=94. So what causes the
>>> overloading or congestion in diffserv? Does anyone explain
>>> it for me or give me some references. Thanks in advance.
>> =
> 
>> _______________________________________________
>> Diffserv-interest mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/diffserv-interest
> 
> -- =
> 
> - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
> Brian E Carpenter =
> 
> Distinguished Engineer, Internet Standards & Technology, IBM =
> 
> 
> NEW ADDRESS <[email-masked]> PLEASE UPDATE ADDRESS BOOK
> 
> 
> 
> --__--__--
> 
> _______________________________________________
> Diffserv-interest mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/diffserv-interest
> 
> 
> End of Diffserv-interest Digest

_______________________________________________
Diffserv-interest mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv-interest

---

From: "John H. Shuler" <[email-masked]>
Date: Thu, 30 Oct 2003 22:35:56 -0800

Why make a distinction between "Standard Service Class" and "Low Priority
Data"?

In fact, it seems the most useful outcome of this paper is to help service
providers standardize across and between their networks as to service class
treatment for different service types. For this reason, it seems the best
thing to do is, rather than to create these semi-artificial classes and
sub-classes, to get quite specific about how to mark each specific service,
e.g. IP telephony, SNA, HTTP, FTP, unidirectional video, interactive
multimedia, etc. You have gone part of the way to this goal, but have put
what seems to be an artificial middle step into the process... These service
classes. I can see why you would do this in an attempt to consolidate the
classes for ease of management, but by the time you are done, you have so
many classes and variations that you have defeated this purpose anyway. And
the net goal of standardizing treatment across the network is still not
achieved because of the multiple options for several of the services.

Just some thoughts on a single, careful reading.

Also, there is some dumb editorial stuff:
(1) Do a lookup for the word "respectfully" and make sure you don't really
mean "respectively".
(2) Look up "sufficed" and replace with "sufficient".
(3) You also have a tendency to use "which" instead of "that"
(4) There is an instance of using "then" instead of "than".

Sorry I'm too lazy to be specific about where (it's late).

j
-- 
Jay Shuler
President
Beyond Category Consulting
4020 Halkins Drive
San Jose, CA 95124
(408) 582-3682
[email-masked]
www.BeyondCategory.US

---

From: Jing Shen <[email-masked]>
Date: Fri, 31 Oct 2003 17:41:09 +0800 (CST)

IMHO, diffserv is just to define some basic rules to
be followed by ISPS who will negotiate real SLA
parameters. These parameters are to be 'implemented'
in their network and supported by routers around.
So, a coarse defination like EF, AF is enough.

Anyway, as pointed out by other people here, DiffServ
just make up logical network in physical network. This
means there will be congestion in every logical
networks.

jing shen

' spamcontrol '

 --- "John H. Shuler" <[email-masked]> 的正文：>
Why make a distinction between "Standard Service
> Class" and "Low Priority
> >> rates for different treatment when congestion
> occurs. 
=== message truncated === 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 31 Oct 2003 10:42:54 +0100

John, I guess your comment refers to the draft so I changed the subject.

If you want to be sure the authors see your comments, you might want to
write to them directly. My reactions inserted below.

   Brian

> Why make a distinction between "Standard Service Class" and "Low Priority

There is a kitchen sink aspect to this draft that worries me. Rather than
starting simple, with three or four generic service classes, the authors
have chosen to present the union of a number of diffserv deployment models.
I think that risks confusing operators by giving them too much complexity
to choose from.

> achieved because of the multiple options for several of the services.

Exactly.
> Sorry I'm too lazy to be specific about where (it's late).

<snip>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 31 Oct 2003 10:51:58 +0100

> treatment they need (vs. Want) by making choices about queuing priorities.

That's what I meant about it creating several separate Internets - you put
the traffic into the Internet that has the most appropriate queue handling
for your traffic, but ultimately (even for EF behavior) the result is still
statistical. Queueing theory doesn't go away just because it has unpleasant
consequences.

> bandwidth above the level of peak CIR.

Exactly. Each traffic class (i.e. each queue) needs to be provisioned for
the expected load with appropriate over- or under-provisioning. The new
thing is that you can over-provision for some traffic and under-provision
for other traffic. (New to IP, that is. It's hardly a new concept.)

> enough to deal with the unpredictable burstiness of the internet.

I think that's correct. But there are people in the VoIP world who really do
want to provision individual calls, which means adding signalling and admission
control. That's fine if they can make it scale, but it isn't part of the diffserv
model. 

> Am I off-base, here?

No.

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM

---

From: "John H. Shuler" <[email-masked]>
Date: Fri, 31 Oct 2003 08:46:29 -0800

I guess my point is that admission control is an application-specific
phenomenon. The DiffServ network simply sees control traffic between the
client and VoIP server and treats it appropriately, then when/if the server
tells the client to go ahead, the DS network then sees voice traffic and
treats it appropriately. It is not up to the DS network to admit or not.

Same concept as with TCP and congestion control. Not up to DS to do this,
but up to TCP. DS only sets limits on total BE traffic and bursts.

j

> Date: Fri, 31 Oct 2003 10:51:58 +0100
> To: "John H. Shuler" <[email-masked]>