Subject: [Diffserv-interest] [OFFLIST] MPLS+Diffserv(mapping DSCP to EXP)

From: Aaron Striegel <[email-masked]>
Date: Tue, 4 Feb 2003 09:20:14 -0500

This message has been forwarded to the DiffServ-interest
mailing group.

Aaron

Begin forwarded message:

> From: nerdboy <[email-masked]>
> Date: Tue Feb 4, 2003  1:20:01  AM America/Indianapolis
> To: [email-masked]
> Subject: [Diffserv] [OFFLIST] MPLS+Diffserv(mapping DSCP to EXP)
> Reply-To: [email-masked]
>
> Hi,
>
> i know this is offtopic but i didnt know where else to ask.
>
> i understand that the EXP bits in MPLS are used to provide DSCP
> functionality(Diffserv) for EXp inferred LSP's in MPLS.
>
> 1. i want to know how the DSCP bits are mapped to the EXP bits ?
>
> 2. Further, since the DSCP  ( pow(2,8) = 256 combinations ) is 8 bits  
> and
> provides 22 different PHB's(or roughly 7 different classes),
>      and the EXP is just 3 bits and therefore can provide only upto 8
> different classes, wouldnt there be loss of info while mapping  
> DSCP->EXP ?
>
> any help would be greatly appreciated.
>
> Warm Regards
> nerd
> _______________________________________________
> diffserv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/diffserv
> Archive:  
> http://www.ietf.org/mail-archive/working-groups/diffserv/current/ 
> maillist.html

_______________________________________________
Diffserv-interest mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/diffserv-interest

---

From: Shahram Davari <[email-masked]>
Date: Wed, 5 Feb 2003 07:22:46 -0800

Jeff,

No, I am actually referring to E-LSPs. Each signaled E-LSP can support
up to 8 PHBs. To support 64 PHBs you need 8 parallel LSPs.

In case of L-LSP, since each L-LSP can support a max of 3 PHBs,
you would need ~21 parallel LSPs to support the 64 PHBs.

Yours,
-Shahram

> -----Original Message-----
> From: Jeff Norman [mailto:[email-masked]]
> Sent: Tuesday, February 04, 2003 5:05 PM
> To: Shahram Davari
> Cc: 'Mark Duffy'; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [Diffserv] [OFFLIST] MPLS+Diffserv(mapping DSCP to EXP)
> 
> 
> Shahram,
>   You are referring to L-LSPs where a one-to-one mapping can
> be done, where as E-LSPs there isn't, which is what I believe
> nerdboy is asking about.
> 
> Best Regards,
> --Jeff
> 
> In message "[Diffserv] [OFFLIST] MPLS+Diffserv(mapping DSCP 
> to EXP)", Shahram Davari writes:
> 
> >> -----Original Message-----
> >> From: Mark Duffy [mailto:[email-masked]]
> >> Sent: Tuesday, February 04, 2003 7:29 AM
> >> To: [email-masked]; [email-masked]
> >
> >> >2. Further, since the DSCP  ( pow(2,8) = 256 combinations ) 
> >> is 8 bits and
> >> >different classes, wouldnt there be loss of info while 
> >> mapping DSCP->EXP ?
> >> >
> >
> >No because in MPLS we do DSCP=> PHB translation and PHB=> 
> EXP+Label encoding. The label gives you the context info, so 
> each label can support up to 8 PHBs. To support all 64 PHBs 
> (which are not defined yet) you need 8 parallel LSPs.
> >
> >
> >-Shahram
> http://www.ietf.org/mail-archive/working-groups/diffserv/curre
nt/maillist.html

---

From: "Jeff Norman" <[email-masked]>
Date: Wed, 5 Feb 2003 12:06:17 -0500 (EST)

Shahram,
  You are correct.... i.e. you can use "signalled" E-LSPs
--Jeff