Subject: [Diffserv-interest] size of a DiffServ domain

From: Jaeyoung Kim <[email-masked]>
Date: Mon, 13 Aug 2001 14:56:12 +0900

Hi, I have an practical question on DiffServ networks.
If DiffServ technology is deployed in most of backbone networks,
what is the proper network size of a single DiffServ domain?
How many edge routers and core routers?

Since I'm studying in monitoring DiffServ networks and I don't have
experienced with the big backbone networks, I'd like to ask you out
there about this information.

I think I've heard some backbone networks have already deployed
DiffServ technology. How big is your network size in terms of number
of edge/core routers?

Thanks in advance.

Sincerely,
Jay Kim

-- 
============================================================================
 __/\__ ** Remember Yesterday, Dream about Tomorrow, but ... LIVE TODAY !!!
 \ /\ / -------------------------------------------------------------------
 /_\/_\ ** [email-masked]                 http://home.postech.ac.kr/~jay
   \/   ** Jaeyoung Kim      Computer Science & Engineering, POSTECH, KOREA

_______________________________________________
Diffserv-interest mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/diffserv-interest

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 14 Aug 2001 10:23:54 -0500

I don't see why there would be a "proper" size. Diffserv is designed
to be scaleable, and I don't see any reason that deploying diffserv
would cause you to make an administrative domain bigger or smaller.

   Brian

---

From: Marcus Brunner <[email-masked]>
Date: Mon, 27 Aug 2001 12:47:15 +0200

Yes, DiffServ itself is scalable, however, don't forget the 
management/control systems (e.g., bandwidth bokers etc.). Depending on the 
architecture, the services you want to provide, and the number of customers 
you want to service, the mgt systems might be a bottleneck.

Marcus

--On Tuesday, August 14, 2001 10:23 AM -0500 Brian E Carpenter 
<[email-masked]> wrote:

>> ========================================================================
>> ==== __/\__ ** Remember Yesterday, Dream about Tomorrow, but ... LIVE
>>  TODAY !!! \ /\ /
>>  -------------------------------------------------------------------
>>  /_\/_\ ** [email-masked]
>>  http://home.postech.ac.kr/~jay \/   ** Jaeyoung Kim      Computer
>>    Science & Engineering, POSTECH, KOREA
>>
>

--------------------------------------
Dr. Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.brubers.org

Adenauerplatz 6
D-69115 Heidelberg
Germany

Phone: +49 (0)6221/ 9051129
Fax:   +49 (0)6221/ 9051155

---

From: Aaron D Striegel <[email-masked]>
Date: Mon, 27 Aug 2001 09:10:12 -0500

I think Jaeyoung might have meant to inquire what a typical size was as opposed to a proper size in order to have a practical foundation for simulations.

Aaron  

At 12:47 PM 8/27/2001 +0200, Marcus Brunner wrote:
>Yes, DiffServ itself is scalable, however, don't forget the management/control systems (e.g., bandwidth bokers etc.). Depending on the architecture, the services you want to provide, and the number of customers you want to service, the mgt systems might be a bottleneck.
>
>Marcus
>
>--On Tuesday, August 14, 2001 10:23 AM -0500 Brian E Carpenter <[email-masked]> wrote:
>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 27 Aug 2001 10:00:22 -0500

If that is the question, I think the answer will be "as large as possible". 
I haven't seen any simulations yet that seemed to be large enough to 
capture the edge-to-edge behaviour of a real network (tens or hundreds
of border routers and thousands of clients).

   Brian

---

From: Jaeyoung Kim <[email-masked]>
Date: Tue, 28 Aug 2001 01:21:26 +0900

On Mon, Aug 27, 2001 at 09:10:12AM -0500, Aaron D Striegel wrote:
> I think Jaeyoung might have meant to inquire what a typical size was 
> as opposed to a proper size in order to have a practical foundation for 
> simulations.
> 
> Aaron  
> 

Thank you, Aaron and Marcus, for clarifying what I meant in my previous
question. Theoretically, Mr. Carpenter's comment is correct. Absolutely
I agree on that DiffServ is scalable.

However, when it comes to managing DiffServ networks, it is good to have
information in advance on how big the network of concern is. Although
there is no theoretical limitation on the size of DiffServ domain, my
intuition is saying that a practical size of one DiffServ domain will not
be over a size of 50 routers. Besides, the number of edge routers might
be less than 10 or 15.

This estimation is important when devising simulation scenarios which
are as realistic as possible.

I think it is helpful if I know the actual size of network domains of
some big backbone network providers. Anybody?

Anyway, thank you for your valuable comments.

Sincerely,
Jay Kim

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 27 Aug 2001 11:49:10 -0500

> be over a size of 50 routers. Besides, the number of edge routers might

These numbers seem low to me. 50 routers is not even a large sized campus
network, let alone a backbone.

> are as realistic as possible.

Indeed. It would be very interesting to know the size-dependency
as well - do the statistics look different as the network gets bigger?

   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Board Chairman, Internet Society http://www.isoc.org

"We shall need a number of efficient librarian types 
 to keep us in order." - Alan Turing, 1947.