Subject: [Crypto-panel] Request for review: draft-ribose-openpgp-oscca-01

From: Alexey Melnikov <[email-masked]>
Date: Tue, 28 Nov 2017 14:02:38 +0000

Dear Crypto Panel,

SAAG’s SECDISPATCH chairs have requested review of
<https://datatracker.ietf.org/doc/draft-ribose-openpgp-oscca/>
before the document fate will be decided (it is likely to end up in the 
CURDLE WG).

Can we have some volunteer(s) please?

The draft Abstract is:

    This document enables OpenPGP (RFC4880) usage in an compliant manner
    with OSCCA (Office of State Commercial Cipher Administration)
    regulations for use within China.

    Specifically, it extends OpenPGP to support the usage of SM2, SM3 and
    SM4 algorithms, and provides the OSCCA-compliant OpenPGP profile
    "OSCCA-SM234".

Thank you,
Alexey

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Tue, 28 Nov 2017 18:21:51 +0300

Dear Alexey,

I'll be happy to do this.

Will it be OK, if I provide a review by the 20th of December?

Best regards,

Stanislav

2017-11-28 17:02 GMT+03:00 Alexey Melnikov <[email-masked]>:

> _______________________________________________
> Crypto-panel mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/crypto-panel
>

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 28 Nov 2017 15:23:52 +0000

Dear Stanislav,

> Will it be OK, if I provide a review by the 20th of December?
That would be great. Thank you!

Best Regards,
Alexey

> Best regards,
>
> Stanislav
>
>
>
> 2017-11-28 17:02 GMT+03:00 Alexey Melnikov <[email-masked] 
> <mailto:[email-masked]>>:
>
>     Dear Crypto Panel,
>
>     <https://datatracker.ietf.org/doc/draft-ribose-openpgp-oscca/
>     <https://datatracker.ietf.org/doc/draft-ribose-openpgp-oscca/>>
>     before the document fate will be decided (it is likely to end up
>     in the CURDLE WG).
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.irtf.org/mailman/listinfo/crypto-panel>
>
>

---

From: Ronald Tse <[email-masked]>
Date: Tue, 28 Nov 2017 15:46:27 +0000

Dear Alexey,

Thank you very much for helping us request the reviews. We look forward improving the draft according to feedback!

Kind regards,
Ron

_____________________________________

Ronald Tse
Ribose Inc.

On Nov 28, 2017, at 10:02 PM, Alexey Melnikov <[email-masked]<mailto:[email-masked]>> wrote:

Dear Crypto Panel,

SAAG’s SECDISPATCH chairs have requested review of
<https://datatracker.ietf.org/doc/draft-ribose-openpgp-oscca/>
before the document fate will be decided (it is likely to end up in the CURDLE WG).

The draft Abstract is:

Thank you,
Alexey

---

From: Ronald Tse <[email-masked]>
Date: Tue, 28 Nov 2017 15:47:31 +0000

Dear Stanislav,

Thank you very much for performing the review. Look forward to it!

Kind regards,
Ron

Ronald Tse
Ribose Inc.

On Nov 28, 2017, at 11:21 PM, Stanislav V. Smyshlyaev <[email-masked]<mailto:[email-masked]>> wrote:

Dear Alexey,

Best regards,

Stanislav

2017-11-28 17:02 GMT+03:00 Alexey Melnikov <[email-masked]<mailto:[email-masked]>>:
Dear Crypto Panel,

The draft Abstract is:

Thank you,
Alexey

_______________________________________________
Crypto-panel mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/crypto-panel

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Tue, 28 Nov 2017 19:08:02 +0300

Dear Ronald,

Since the document is dedicated to the algorithms and elliptic curve
parameters, it would be very helpful if you could point at papers with
their analysis in English, if some of them are not publicly available (or
could not be easily found via public resources). Also, it will be extremely
important if you could provide some materials with design rationale of the
algorithms and parameters presented in the I-D.

Of course, full cryptanalysis from a scratch is impossible to be made as a
part of review, so all known results/attacks/notes on design
rationale/results of evaluation of curve parameters will be very important
for making the review(s) as objective as possible.

Best regards,
Stanislav Smyshlyaev, Ph.D.
Head of Information Security Department,
CryptoPro LLC

2017-11-28 18:47 GMT+03:00 Ronald Tse <[email-masked]>:

> On Nov 28, 2017, at 11:21 PM, Stanislav V. Smyshlyaev <[email-masked]>
> wrote:
>
> Dear Alexey,
>

---

From: Ronald Tse <[email-masked]>
Date: Tue, 28 Nov 2017 16:28:39 +0000

Dear Stanislav,

You are absolutely right. Here are the IETF drafts of SM2, SM3 and SM4 (they are referred to within this draft, too):

SM2: https://tools.ietf.org/html/draft-shen-sm2-ecdsa-02
SM3: https://tools.ietf.org/html/draft-oscca-cfrg-sm3-02
SM4: https://tools.ietf.org/html/draft-ribose-cfrg-sm4-05

The SM3 and SM4 drafts contain both a design rationale and a cryptanalysis section. Specifically, the cryptanalysis section contain bibliography references with links to research publications of the latest cryptanalysis results (English + Chinese). Most of these results are freely available in English (Google Scholar).

As a matter of fact, we are currently updating the SM2 draft to provide the same level of detail as the other two.

I’d just like to clarify that the current review is purely on the OpenPGP side of things. That said, we have previously requested a CFRG review of the SM4 draft too, so if you have some time to review that draft, it would be even more awesome :-)

Hope this helps!

Kind regards,
Ron

Ronald Tse
Ribose Inc.

> On Nov 29, 2017, at 12:08 AM, Stanislav V. Smyshlyaev <[email-masked]> wrote:
> 
> Dear Ronald,
> 
> Since the document is dedicated to the algorithms and elliptic curve parameters, it would be very helpful if you could point at papers with their analysis in English, if some of them are not publicly available (or could not be easily found via public resources). Also, it will be extremely important if you could provide some materials with design rationale of the algorithms and parameters presented in the I-D.
> 
> Of course, full cryptanalysis from a scratch is impossible to be made as a part of review, so all known results/attacks/notes on design rationale/results of evaluation of curve parameters will be very important for making the review(s) as objective as possible.
> 
> Best regards,
> 2017-11-28 18:47 GMT+03:00 Ronald Tse <[email-masked] <mailto:[email-masked]>>:
> Dear Stanislav,
> 
>> On Nov 28, 2017, at 11:21 PM, Stanislav V. Smyshlyaev <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear Alexey,
>> 
>> 2017-11-28 17:02 GMT+03:00 Alexey Melnikov <[email-masked] <mailto:[email-masked]>>:
>> Dear Crypto Panel,
>> 
>> <https://datatracker.ietf.org/doc/draft-ribose-openpgp-oscca/ <https://datatracker.ietf.org/doc/draft-ribose-openpgp-oscca/>>
>> https://www.irtf.org/mailman/listinfo/crypto-panel <https://www.irtf.org/mailman/listinfo/crypto-panel>
>> 
> 
>

---

From: Russ Housley <[email-masked]>
Date: Tue, 28 Nov 2017 11:42:09 -0500

Sorry, but I cannot do this one.

Russ

> On Nov 28, 2017, at 9:02 AM, Alexey Melnikov <[email-masked]> wrote:
> 
> Dear Crypto Panel,
>

---

From: Bjoern Tackmann <[email-masked]>
Date: Tue, 28 Nov 2017 18:18:59 +0100

Hi Alexey,

I'll also join here.

I'll aim at a similar deadline as Stanislav, maybe a day or two later, if
that's ok.

Cheers,
Björn

---

From: Ronald Tse <[email-masked]>
Date: Wed, 29 Nov 2017 02:13:52 +0000

Hi Bjoern,

Thank you very much — your help is much appreciated!

Kind regards,
Ron

Ronald Tse
Ribose Inc.

+=========================================================+
This message may contain confidential and/or privileged
information.  If you are not the addressee or authorized to
receive this for the addressee, you must not use, copy,
disclose or take any action based on this message or any
information herein.  If you have received this message in
error, please advise the sender immediately by reply e-mail
and delete this message.  Thank you for your cooperation.
+=========================================================+

> On Nov 29, 2017, at 1:18 AM, Bjoern Tackmann <[email-masked]> wrote:
> 
> Hi Alexey,
> 
> I'll also join here.
> 
> I'll aim at a similar deadline as Stanislav, maybe a day or two later, if that's ok.
> 
> Cheers,
> Björn
> 
> 
> 
> On Tue, Nov 28, 2017 at 4:21 PM, Stanislav V. Smyshlyaev <[email-masked] <mailto:[email-masked]>> wrote:
> Dear Alexey,
>

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Wed, 29 Nov 2017 16:23:40 +0300

Dear Ronald,

Thank you very much for the links!
The review is conducted by Crypto Review Panel, thus the analysis is being
done more from the cryptographic perspective, and the current state of the
analysis of the proposed mechanisms is taken into account.

Best regards,
Stanislav

2017-11-28 19:28 GMT+03:00 Ronald Tse <[email-masked]>:

> Dear Stanislav,
>
> You are absolutely right. Here are the IETF drafts of SM2, SM3 and SM4
> (they are referred to within this draft, too):
>
> The SM3 and SM4 drafts contain both a design rationale and a cryptanalysis
> section. Specifically, the cryptanalysis section contain bibliography
> references with links to research publications of the latest cryptanalysis
> results (English + Chinese). Most of these results are freely available in
> English (Google Scholar).
>
> As a matter of fact, we are currently updating the SM2 draft to provide
> the same level of detail as the other two.
>
> I’d just like to clarify that the current review is purely on the OpenPGP
> side of things. That said, we have previously requested a CFRG review of
> the SM4 draft too, so if you have some time to review that draft, it would
> be even more awesome :-)
>
> Hope this helps!
>
> Kind regards,
> Ron
>

---

From: Ronald Tse <[email-masked]>
Date: Wed, 29 Nov 2017 18:24:30 +0000

Hi Stanislav,

Fully understand. Thank you again for your help!

Ron

Ronald Tse
Ribose Inc.

> On Nov 29, 2017, at 9:23 PM, Stanislav V. Smyshlyaev <[email-masked]> wrote:
> 
> Dear Ronald,
> 
> The review is conducted by Crypto Review Panel, thus the analysis is being done more from the cryptographic perspective, and the current state of the analysis of the proposed mechanisms is taken into account.
> 
> Best regards,
> Stanislav
> 
> 
> 2017-11-28 19:28 GMT+03:00 Ronald Tse <[email-masked] <mailto:[email-masked]>>:
> Dear Stanislav,
> 
> SM2: https://tools.ietf.org/html/draft-shen-sm2-ecdsa-02 <https://tools.ietf.org/html/draft-shen-sm2-ecdsa-02>
> SM3: https://tools.ietf.org/html/draft-oscca-cfrg-sm3-02 <https://tools.ietf.org/html/draft-oscca-cfrg-sm3-02>
> SM4: https://tools.ietf.org/html/draft-ribose-cfrg-sm4-05 <https://tools.ietf.org/html/draft-ribose-cfrg-sm4-05>
> 
>> On Nov 29, 2017, at 12:08 AM, Stanislav V. Smyshlyaev <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear Ronald,
>>