Subject: [core] Combining Proxy-Uri with Uri-*

From: Carsten Bormann <[email-masked]>
Date: Thu, 6 Dec 2012 17:44:47 +0100

One comment that we never properly ticketized was this from Cullen Jennings:

> When I am using a proxy and sending it a COAP URL, I find it totally lame that I have to send it in a totally different option than if I was not using a proxy. I think we should change this unless there is some really good reasons for doing it. Even when using a HTTP URI, I'd rather just add a scheme than use proxy-URI.

[http://www.ietf.org/mail-archive/web/core/current/msg03072.html]

I completely agree that "lame" is the correct technical term here.

I have checked in a proposed solution (added at the end of 5.10.2 Proxy-Uri):

   As a special case to simplify some proxy clients, the absolute-URI
   can be constructed from the Uri-* options.  When the Proxy-Uri Option
   only contains a scheme name followed by a colon, the absolute-URI is
   constructed as follows: A CoAP URI is constructed from the Uri-*
   options as defined in Section 6.5.  In the resulting URI, the initial
   scheme and the following colon are then replaced by the content of
   the Proxy-Uri Option.

Those who actually do forward proxies: would that work for you?

(Variants of this have been discussed on many hallways.  Going the whole way and defining the interactions of any subset of the Uri-* options with Proxy-Uri is leading to lots of unneeded complexity.  This seems to be the best way to keep clients simple.  Very little additional work for proxies.)

Grüße, Carsten

---

From: Zach Shelby <[email-masked]>
Date: Thu, 6 Dec 2012 21:07:00 +0200

> Those who actually do forward proxies: would that work for you?

I have no problems with making this less "lame", but we can't have several ways of doing this. Let's do this in only one way (your new proposed way):

Rename Proxy-Uri to Proxy-Scheme, which contains the scheme of the request URI. The Uri-* options are then always used to encode the rest of the request URI. 

Zach 

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com @SensinodeIoT
Mobile: +358 40 7796297
Twitter: @zach_shelby
LinkedIn: http://fi.linkedin.com/in/zachshelby
6LoWPAN Book: http://6lowpan.net

---

From: "Dijk, Esko" <[email-masked]>
Date: Tue, 11 Dec 2012 06:55:50 +0000

> I have no problems with making this less "lame", but we can't have several ways of doing this. Let's do this in only one way (your new proposed way):
+1 for having one way to do this instead of two.

Unless there are reasons to keep a single option Proxy-URI - are there any?

regards,
Esko

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Zach Shelby
Sent: Thursday 6 December 2012 20:07
To: Carsten Bormann
Cc: [email-masked] WG
Subject: Re: [core] Combining Proxy-Uri with Uri-*

Zach

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.