Subject: Re: [core] Comments on Observer-02

From: "Dijk, Esko" <[email-masked]>
Date: Fri, 1 Apr 2011 10:32:41 +0200

Dear Angelo, Guido,

I think that Observe-02 already defines the "obs" attribute (6.3), that should be enough to check whether a server supports it? Better to keep the Observe Option elective in that case.

best regards,
Esko

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Angelo P. Castellani
Sent: Monday 28 March 2011 15:45
To: Guido Moritz
Cc: core
Subject: Re: [core] Comments on Observer-02

+1

Probably to solve this could be better to have Observe option critical.

Best,
Angelo

On Mon, Mar 28, 2011 at 11:38, Guido Moritz <[email-masked]> wrote:
> Section 3.1.: If the server ignores the subscription, is there a response
> code or any other indication for the client why this happened? It might be a
> nice feature to indicate whether the server does not support observe at all
> or if the client might retry it again later.
>
> Guido
>
>
>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Likepeng <[email-masked]>
Date: Fri, 01 Apr 2011 09:46:33 +0000

> I think that Observe-02 already defines the "obs" attribute (6.3), that should be enough to check whether a server supports it?

Not really. "Obs" is for one Resource URI, it is not for the whole server. So, we have two different cases: (1) the server does not support the observation feature; (2) this resource can't be observed, but other resource can be observed on this server. This kind of information can't be indicated by the "obs" attribute. 

> Better to keep the Observe Option elective in that case.

If it is elective, there is no way to differentiate the two cases above. According to the current Observe draft, if the server does not support Observe, it turns to a basic Get, and server will return 2.05 "Content". But if we change it to Criticial, the server has to return 4.02 "Bad Option". Then the client will send another Get request without Observe Option.

So, in my opinion, Criticial will be better.

I just have another proposal, does it reasonable to define a mechanism to discover the server capability? For example, whether or not the server supports Block, Observation, Compression, etc.

In 6lowpan, Casten has a draft to indicate whether or not the neighbors implement the compression:
http://datatracker.ietf.org/doc/draft-bormann-6lowpan-ghc/

So I am wondering if we can borrow this kind of mechanism in CoAP.

Kind Regards
Kepeng
________________________________________
发件人: [email-masked] [[email-masked]] 代表 Dijk, Esko [[email-masked]]
发送时间: 2011年4月1日 16:32
到: Angelo P. Castellani; Guido Moritz
Cc: core
主题: Re: [core] Comments on Observer-02

Dear Angelo, Guido,

best regards,
Esko

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Angelo P. Castellani
Sent: Monday 28 March 2011 15:45
To: Guido Moritz
Cc: core
Subject: Re: [core] Comments on Observer-02

+1

Best,
Angelo

---

From: "Dijk, Esko" <[email-masked]>
Date: Fri, 1 Apr 2011 11:58:27 +0200

Dear Kepeng,

you're right that there is no way to check currently whether the server intrinsically supports observation. My current thinking is that for a client, interested to observe a specific resource, this may not be relevant - the client only may need to know whether the resource of interest is observable or not.

If possible could you share a use case where the client needs to know that a server supports observation?

Thanks
Esko

-----Original Message-----
From: Likepeng [mailto:[email-masked]]
Sent: Friday 1 April 2011 11:47
To: Dijk, Esko; Angelo P. Castellani; Guido Moritz
Cc: core
Subject: Re: [core] Comments on Observer-02

Kind Regards
Kepeng

Dear Angelo, Guido,

best regards,
Esko

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Angelo P. Castellani
Sent: Monday 28 March 2011 15:45
To: Guido Moritz
Cc: core
Subject: Re: [core] Comments on Observer-02

+1

Best,
Angelo

---

From: Zach Shelby <[email-masked]>
Date: Fri, 1 Apr 2011 14:27:56 +0300

> you're right that there is no way to check currently whether the server intrinsically supports observation. My current thinking is that for a client, interested to observe a specific resource, this…

+1, in my opinion what we have is already sufficient. 

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297