Subject: Re: [core] Help me with CoAP Demo

From: "Angelo P. Castellani" <[email-masked]>
Date: Tue, 18 Jan 2011 10:44:47 +0100

Markus,
if you are interested in another TinyOS implementation, we have
published our implementation named CoAPC:
https://telecom.dei.unipd.it/pages/read/59/

Our work has some limitations however can be a good starting point.

Best,
Angelo

On Mon, Nov 22, 2010 at 10:05, Markus Becker <[email-masked]> wrote:
>> Dear evey one,
>>
>> now i am starting with CoAP and have to make a demo.
>>
>> do you know where i should start ? and does it have any demo is available
>> for CoAP (in tinyos or contiki).
>>
>> could you give me some guide for CoAP Demo?
>
> Probably you would want to start with Olaf's C implementation libcoap [1] or
> Peter's Python implementation coappy [2] on a usual computer and not start
> directly on WSN nodes.
>
> [1] http://sourceforge.net/projects/libcoap/
> [2] http://coapy.sourceforge.net/
>
> We are currently working on a port of libcoap to TinyOS.
>
> Markus
>
>> thank you very much,
>>
>>
>>         Ngoc Thanh
> ------------------------------------------------
> | Dipl.-Ing. Markus Becker
> | Communication Networks
> | Mobile Research Center
> | TZI - Center for Computing Technologies
> | University Bremen
> | Germany
> ------------------------------------------------
> | web: http://www.comnets.uni-bremen.de/~mab/
> | mailto: [email-masked]
> | telephone: +49 421 218 62379
> | building: NW1 room: N2260
> ------------------------------------------------
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Markus Becker <[email-masked]>
Date: Tue, 18 Jan 2011 11:41:46 +0100

Hi Angelo,

our port of libcoap is now rather far as well. There is a client and a server 
component, which adapts Olaf's libcoap to TinyOS based on blip-1.0. 

Available at:
http://www.comnets.uni-bremen.de/~mab/git/tinyos-main.git/ (via git)

Some limitations as well, of course ...

Markus

> >> do you know where i should start ? and does it have any demo is
> >> available for CoAP (in tinyos or contiki).
> >> 
> > Probably you would want to start with Olaf's C implementation libcoap [1]
> > or Peter's Python implementation coappy [2] on a usual computer and not
> > start directly on WSN nodes.
> >