Subject: [core] Allowed methods in link format

From: Guido Moritz <[email-masked]>
Date: Thu, 27 Jan 2011 09:58:58 +0100

Dear WG,

I was wondering if it wouldn't be helpful to add a new extension in the CoRE
link format, which describes the methods allowed on the resource. If there
is no clear description, I would have to go through an iterative request
process and have to receive a "Method Not Allowed" as indication for not
permitted methods. 

To relax this, the extension is of course optional and must have a default
value if not carried inline (e.g. GET is allowed by default). 

Best,
Guido

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 27 Jan 2011 10:02:30 +0100

On Jan 27, 2011, at 09:58, Guido Moritz wrote:

> describes the methods allowed

There are two ways to do this:

1) write it up right in the link format
2) reference a description (e.g., WADL).

You can supply more detail in 2.
Is what we would do right within 1 useful without 2?
If we need 2 anyway to derive something useful I wouldn't do 1.

Gruesse, Carsten

---

From: Zach Shelby <[email-masked]>
Date: Thu, 27 Jan 2011 11:16:56 +0200

Hi Guido,

> process and have to receive a "Method Not Allowed" as indication for not

This is the purpose of the interface description parameter. In REST between machines only knowing what methods are allowed is not really sufficient, you need to know input and output, query string parameters etc. The d= attribute is meant to include a pre-defined name that represents a defined interface to that resource, or e.g. reference a WADL description.  

What I foresee happening is that different industries (e.g. building automation) will eventually define standard interface types. In the SENSEI project this is what was done, a standard interface type was defined for Sensor, Actuator and Parameter resource types. Those are referenced in the link description with URNs which correspond to WADL descriptions.

urn:sensei:sensor
urn:sensei:actuator
urn:sensei:parameter

Someone in CoRE could write a draft specifying some very simple interface descriptions for doing generic things. I am not sure how useful it is do define an interface type "Get" or "GetPostPut" for real applications. But why not try and see if people find it useful.

Zach

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297