Subject: Re: [core-parameters] FW: NEW RESOURCE TYPE - oma.lwm2m

From: Christian Groves <[email-masked]>
Date: Mon, 9 Jan 2017 15:43:11 +1100

Hello John,

With regards to the description. Would you be OK with slightly rewording 
the definition so that the style is similar to the existing registrations?

i.e. Description: OMA LWM2M Resource. This Resource type indicates that 
the resource and all of its sub-resources support the OMA Lightweight 
M2M protocol, i.e. contain OMA LWM2M objects and resources.

If you are OK with the change i'll ask IANA to register the value.

Regards, Christian

On 4/01/2017 1:57 AM, John Mudge wrote:
> Hi Christian,
>
> I understand that you are the primary expert for the sub-registry Resource Type (rt=) Link Target Attribute Values, within the Constrained RESTful Environments (CoRE) Parameters registry.
>
> What are the next steps regarding this registration request?
>
> Thank you and kind regards,
>
> John
>
> ----------------------------------------
> John Mudge
> Open Mobile Alliance
> Cell: (+44) (0)75 91 53 17 47
> Email: [email-masked]
> ----------------------------------------
>
> -----Original Message-----
> From: John Mudge
> Sent: 13 December 2016 10:34
> To: 'Dijk, Esko' <[email-masked]>; [email-masked]' <[email-masked]>
> Subject: RE: NEW RESOURCE TYPE - oma.lwm2m
>
> Hi,
>
> As there seem to be no more comments, what are the next steps regarding this registration request?
>
> The updated registration information is:
>
>     o  Attribute Value: oma.lwm2m
>
>     o  Description: Indicates this resource and all its sub-resources support the OMA Lightweight M2M protocol, i.e. contain OMA LWM2M objects and resources.
>
>     o  Reference: "Lightweight Machine to Machine Technical Specification", OMA-TS-LightweightM2M-V1_0, especially subsection 5.3.1,
>        http://www.openmobilealliance.org/tech/extref/OMA-TS-LightweightM2M-V1_0.zip
>
>     o  Notes: N/A
>
> Thank you and kind regards,
>
> John
>
> -----Original Message-----
> From: John Mudge
> Sent: 22 November 2016 16:09
> To: 'Dijk, Esko' <[email-masked]>; [email-masked]
> Subject: RE: NEW RESOURCE TYPE - oma.lwm2m
>
> Dear Esko,
>
> Thank you, your revised description is fine.
>
> Kind regards,
>
> John
>
> -----Original Message-----
> From: Dijk, Esko [mailto:[email-masked]]
> Sent: 16 November 2016 12:14
> To: John Mudge <[email-masked]>; [email-masked]
> Subject: RE: NEW RESOURCE TYPE - oma.lwm2m
>
> Dear John,
>
> Thanks; I still think this description could be clarified a bit more. Though the current text would also work, since the LWM2M spec reference defines it properly anyhow.
>
> The Lightweight M2M 1.0 spec states that the resource type 'oma.lwm2m' is used only for the resource that is acting as the top-level parent (i.e. ancestor) for all the OMA Lightweight M2M Objects and Resources. So this rt cannot be used itself for tagging say a LWM2M Resource or an Object Instance. It can only be used to identify a top-level entry point for the LWM2M resource structure.
>
> So what about:
>
>     o  Description: Indicates this resource and all its sub-resources support the OMA Lightweight M2M protocol, i.e. contain OMA LWM2M objects and resources.
>
> regards
> Esko
>
> -----Original Message-----
> From: John Mudge [mailto:[email-masked]]
> Sent: Tuesday, November 15, 2016 17:31
> To: Dijk, Esko <[email-masked]>; [email-masked]
> Subject: RE: NEW RESOURCE TYPE - oma.lwm2m
>
> Thank you Esko for your comment and suggestion.
>
> The OMA DM working group have endeavoured to clarify the description and have proposed the following alternative text:
>
>     o  Description: Indicates the URI contents is for the OMA LwM2M protocol e.g. OMA LwM2M objects and resources.
>
> Would this revised text be satisfactory?
>
> Thank you and kind regards,
>
> John
>
> -----Original Message-----
> From: Dijk, Esko [mailto:[email-masked]]
> Sent: 10 November 2016 20:19
> To: John Mudge <[email-masked]>; [email-masked]
> Subject: RE: NEW RESOURCE TYPE - oma.lwm2m
>
> Hello,
>
> perhaps the description could be clarified a bit to e.g.:
>
>    o  Description: The OMA Lightweight M2M entry-point resource in the LWM2M client (CoAP server).
>
> To clarify the term 'client' more.
>
> regards
> Esko Dijk
>
> -----Original Message-----
> From: core-parameters [mailto:[email-masked]] On Behalf Of John Mudge
> Sent: Thursday, November 10, 2016 18:52
> To: [email-masked]
> Subject: [core-parameters] NEW RESOURCE TYPE - oma.lwm2m
>
> Hi,
>
> This registration request proposes to add the value oma.lwm2m to the sub-registry Resource Type (rt=) Link Target Attribute Values, within the Constrained RESTful Environments (CoRE) Parameters registry.
>
> The completed registration template is as follows:
>
>     o  Attribute Value: oma.lwm2m
>
>     o  Description: This value denotes the OMA LightweightM2M application in the client.
>
>     o  Reference: "Lightweight Machine to Machine Technical Specification", OMA-TS-LightweightM2M-V1_0, especially subsection 5.3.1,
>        http://www.openmobilealliance.org/tech/extref/OMA-TS-LightweightM2M-V1_0.zip
>
>     o  Notes: N/A
>
>
> Please let me know if you have any comments or questions.
>
> Thank you and kind regards,
>
> John
>
> ----------------------------------------
> John Mudge
> Open Mobile Alliance
> Cell: (+44) (0)75 91 53 17 47
> Email: [email-masked]
> ----------------------------------------
>
> _______________________________________________
> core-parameters mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core-parameters
>
> ________________________________
> The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.
>

---

From: John Mudge <[email-masked]>
Date: Thu, 12 Jan 2017 06:05:41 -0800

Hello Christian,

Thank you for the rewording that is OK.

It has also been suggested to change both occurrences of "LWM2M" to "LwM2M".

The text then becomes:

Description: OMA LwM2M Resource. This Resource type indicates that 
the resource and all of its sub-resources support the OMA Lightweight 
M2M protocol, i.e. contain OMA LwM2M objects and resources.

Please proceed and ask IANA to register the value.

John

-----Original Message-----
From: Christian Groves [mailto:[email-masked]] 
Sent: 09 January 2017 04:43
To: John Mudge <[email-masked]>
Cc: [email-masked]
Subject: Re: FW: NEW RESOURCE TYPE - oma.lwm2m

Hello John,

Regards, Christian