Subject: [Coma] Store, Carry and Forward (SCF) Technologies for Management of Constrained Networks and Devices

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Wed, 11 Jul 2012 08:13:22 -0500

Hello,
I became aware of this list recently and perused the archives.  I am posting with two motives:

(1)  To see if this group sees a need for store, carry and forward (SCF) technologies. One of the areas we see such technology helping in is updated software to systems in challenged (Constrained) networks.

(2)  Our approach to bounding the SCF problem and generating requirements may be useful to COMA. After reading the threads, it appears that documenting your scenarios and creating a bounded problem statement may help move discussion along. As is, the problem space appears unbounded or, at least overly large.
The following Internet Drafts have recently been posted:
http://www.ietf.org/id/draft-ivancic-scf-problem-statement-00.txt
http://www.ietf.org/id/draft-ivancic-scf-requirements-expectations-00.txt

http://www.ietf.org/id/draft-ivancic-scf-testing-requirements-00.txt

There is also a recent presentation that might help regarding the philosophical approach to the problem.
http://roland.grc.nasa.gov/~ivancic/papers_presentations/2012/RobustNetworkingWorkshop062612.pdf

Summarized below:
=================
1. KISS (Keep it Simple Stupid)
2. Options make interoperability hard.
3. Options are often used as a placeholder for fixing a bad design.
4. Think about terminology. – “Words make a difference. They affect how we thing about something. The terms chosen to describe a concept are a crucial part of any model. The right concepts with terms that give the wrong connotation can make a problem much more difficult. The right terms can make it much easier. Adopting the mindset of the terms may allow you to see thing you might not otherwise see.” - John Day, Patterns in Network Architect

5. Don’t overload the protocol.
6. "In anything at all, perfection if finally attained, not when there is no longer anything to add, but when there is no longer anything to take away..." - Antonie de Saint Exupery
7. "A good engineer is a lazy degenerate. He prefers degenerate cases to special cases and will sit around (thinking) until he finds a simple solution, rather that immediately launch into a brute force approach. In other words, the goal of a architect is to use the tools he has to make things simple. (Anyone can make things more complicated)!” - John Day, Patterns in Network Architect
- Will

******************************
William D. Ivancic
http://roland.grc.nasa.gov/~ivancic

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 16 Jul 2012 14:57:45 +0200

Dear Will,

thank you for the information. SCF might be a useful solution e.g. for
SW distribution in constrained networks. 

However, our main interest is to collect use cases and to define
requirements for the management of the networks of constrained devices.

BR, 
Mehmet 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Ivancic, William D. (GRC-RHN0)
Sent: Wednesday, July 11, 2012 3:13 PM
To: [email-masked]
Cc: Wesley Eddy
Subject: [Coma] Store, Carry and Forward (SCF) Technologies for
Management of Constrained Networks and Devices

Hello,

I became aware of this list recently and perused the archives.  I am
posting with two motives:

(1)  To see if this group sees a need for store, carry and forward (SCF)
technologies. One of the areas we see such technology helping in is
updated software to systems in challenged (Constrained) networks.  

(2)  Our approach to bounding the SCF problem and generating
requirements may be useful to COMA. After reading the threads, it
appears that documenting your scenarios and creating a bounded problem
statement may help move discussion along. As is, the problem space
appears unbounded or, at least overly large.

http://www.ietf.org/id/draft-ivancic-scf-requirements-expectations-00.tx
t

There is also a recent presentation that might help regarding the
philosophical approach to the problem.  

http://roland.grc.nasa.gov/~ivancic/papers_presentations/2012/RobustNetw
orkingWorkshop062612.pdf

Summarized below:

=================

4. Think about terminology. - "Words make a difference. They affect how
we thing about something. The terms chosen to describe a concept are a
crucial part of any model. The right concepts with terms that give the
wrong connotation can make a problem much more difficult. The right
terms can make it much easier. Adopting the mindset of the terms may
allow you to see thing you might not otherwise see." - John Day,
Patterns in Network Architect

5. Don't overload the protocol. 

6. "In anything at all, perfection if finally attained, not when there
is no longer anything to add, but when there is no longer anything to
take away..." - Antonie de Saint Exupery

7. "A good engineer is a lazy degenerate. He prefers degenerate cases to
special cases and will sit around (thinking) until he finds a simple
solution, rather that immediately launch into a brute force approach. In
other words, the goal of a architect is to use the tools he has to make
things simple. (Anyone can make things more complicated)!" - John Day,
Patterns in Network Architect

- Will

---

From: Michael Richardson <[email-masked]>
Date: Mon, 16 Jul 2012 10:03:05 -0400

I agree that SCF is out of scope for COMA.
It's an exciting protocol though.

If there was sufficient multi-vendor excitement, a WG and/or IRTF WG
might be appropriate.  If not, I strongly suggest individual submission
Informational.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Mon, 16 Jul 2012 12:46:00 -0500

You might take a look at the Network Management slides here:

http://www.dtnrg.org/wiki/DtnBone/JanNetManMeeting

Irrespective of disconnection, the idea of sort of compressing network management information and requests (preconfigured requests and such) is probably useful.

Unfortunately, there is not much newer information that I am aware of.

- Will

On Jul 16, 2012, at 8:57 AM, Ersue, Mehmet (NSN - DE/Munich) wrote:

Dear Will,

thank you for the information. SCF might be a useful solution e.g. for SW distribution in constrained networks.
However, our main interest is to collect use cases and to define requirements for the management of the networks of constrained devices.

BR,
Mehmet