Subject: Re: [Coma] New Maillist for the discussion on the Management of Constrained Networks and Devices

From: Benoit Claise <[email-masked]>
Date: Fri, 01 Jun 2012 16:21:31 +0200

Dear all,

[reducing the mailing lists to coma only]

I believe it is time to think on what is needed for the management of 
constrained devices and how the OPS area could address the requirements.

What would be nice is a  "constrained devices management: problem 
statement" draft so that
1. the requirements are clearly written down
2. the OPS area could, if required, work on the protocol/data model 
language/data model modules/encoding mapping

IMHO,
1. we should NOT put the proposed solutions in that draft, i.e. "if you 
want to do X, then use Y". My fear is that the requirements will be 
tweaked if people don't like the protocol/data model language.
2. the feedback must come from the constrained device experts. OPS 
should not be building a solution for a problem that we, OPS, think that 
the constrained devices experts have.

Regards, Benoit.

> Hi All,
>
> as noted in the maillist announcement of IETF secretary "coma" maillist
> is for the discussion on the management of constrained networks and
> devices. The mailing list will discuss and identify the issues and
> requirements and objectives for the management of devices in such an
> environment with a special focus on and differentiation of device
> classes.
>
> The idea and trigger for the maillist creation came from a discussion in
> the OPS directorate during IETF #82. As
> draft-ietf-opsawg-management-stds-07 states IETF so far has not
> developed specific technologies for the management of constrained
> networks. OPS directorate members stated in IETF #82 that there is a
> need to understand the requirements and the necessary solutions for the
> management of such a constrained network and its devices. The assumption
> people had was that we need a comprehensive management approach to be
> able to address the diverse needs of different device classes.
>
> Although the OPS area was doing already standardization work for network
> management, the Core WG is one of the essential WGs at IETF interested
> in the management of constrained devices.
>
> Following are some of the questions which have been raised in the OPS
> directorate meeting, which are for sure subject to extend from Core WG
> pov.:
>
> *	Do we need a new development for IoT management (i.e.
> constrained devices) at all?
> -	If yes, what is really needed as standard and what is an
> overkill?
> *	What type of devices can we support?
> *	How are the classes 0-2 for constrained devices defined in
> detail?
> *	Is some simple configuration management already sufficient?
> -	Or do we need also a simple fault management and monitoring?
> *	What type of data model modules do we need to standardize?
> -	Just a few core models like ip-cfg, interface?
> -	or also other specific models for monitoring?
> *	Can we use available management standards and data models as a
> starting point and simplify them?
> *	Concerning the encoding (JSON, XML, or binary) we seem to be
> flexible with tools.
> -	Concerning a normative data modeling language, we need to choose
> a suitable language capable to prepare structured models.
> -	Is JSON sufficient for this purpose, or should YANG or any other
> modeling language be used?
> *	What is appropriate as message transport?
> -	CoAP over UDP with soft-transactions?
> -	Netconf-Light over TCP?
>
> Obviously the list of the questions above is not exhaustive.
>
> Carsten kindfully provided already in the Prague meeting the definition
> of device classes 0-2
> (http://www.ietf.org/proceedings/80/slides/core-0.pdf). I think it would
> be useful to start a discussion first on the detailed definition of
> these device classes 0-2 in constrained networks and based on their
> capabilities which functionality they will be able to support. This can
> be then used as a guideline for further discussion on the requirements
> or objectives for management of such devices.
>
> As noted in the announcement the result of the coma discussion can lead
> to a taxonomy document and a problem statement highlighting the need for
> new work.
>
> Please send your opinions/comments to the coma maillist ([email-masked]).
> To subscribe pls go to: https://www.ietf.org/mailman/listinfo/coma
>
> Cheers,
> Mehmet
>
>
> BTW: Coma has been chosen as the maillist name following the definition
> below:
>
> Coma \Co"ma\, n. [L., hair, fr. Gr. ko`mh.]
>     1. (Astron.) The envelope of a comet; a nebulous covering,
>        which surrounds the nucleus or body of a comet.
>        [1913 Webster]
>
>
>

---

From: Zach Shelby <[email-masked]>
Date: Fri, 1 Jun 2012 17:24:36 +0300

Hi,

(constrained guy hat on)

Sounds like a reasonable way forward to me. 

Zach

On Jun 1, 2012, at 5:21 PM, Benoit Claise wrote:

> I believe it is time to think on what is needed for the management of constrained devices and how the OPS area could address the requirements.
> 
> What would be nice is a  "constrained devices management: problem statement" draft so that
> 2. the OPS area could, if required, work on the protocol/data model language/data model modules/encoding mapping
> 
> 
> IMHO,
> 1. we should NOT put the proposed solutions in that draft, i.e. "if you want to do X, then use Y". My fear is that the requirements will be tweaked if people don't like the protocol/data model language.
> 2. the feedback must come from the constrained device experts. OPS should not be building a solution for a problem that we, OPS, think that the constrained devices experts have.
> 
> Regards, Benoit.
> 
>> Hi All,
>> 
> _______________________________________________
> Coma mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/coma

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Antonio Jara <[email-masked]>
Date: Fri, 1 Jun 2012 16:33:08 +0200

So..., any ToC in mind?, where we can see that parts we can provide
some text and relevant information.

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 5 Jun 2012 13:58:24 +0200

Hi Antonio,

there is no final ToC or text available right now.
All is open to your comment and suggestions.

I can imagine a ToC could possibly contain following:

   1. Introduction 
     1.1.  Overview
     1.2.  Basic scenarios in discussion
     1.4.  Constrained Device Classes 
   2. Terminology 
   3. Problem Statement 
   4. Requirements per Device Class 
   5. Security Considerations 
   6. Acknowledgments 
   7. References 

Cheers, 
Mehmet 

> -----Original Message-----
> From: ext Antonio Jara [mailto:[email-masked]]
> Sent: Friday, June 01, 2012 4:33 PM
> To: Zach Shelby
> Cc: Benoit Claise; Ersue, Mehmet (NSN - DE/Munich); Ron Bonica; [email-masked]
> Subject: Re: [Coma] New Maillist for the discussion on the Management of Constrained
> Networks and Devices
> 
> >> I believe it is time to think on what is needed for the management of constrained
> devices and how the OPS area could address the requirements.
> >>
> >> 1. we should NOT put the proposed solutions in that draft, i.e. "if you want to do X,
> then use Y". My fear is that the requirements will be tweaked if people don't like the
> protocol/data model language.
> >> 2. the feedback must come from the constrained device experts. OPS should not
> be building a solution for a problem that we, OPS, think that the constrained devices
> experts have.
> >>
> >> Regards, Benoit.
> >>
> >>> Hi All,
> >>>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 5 Jun 2012 14:05:05 +0200

>    5. Security Considerations 

I think device classes are one dimension but there are others. Lets
think also about "application scenarios or classes" (there might be
better terms): there will be applications and corresponding devices
where there simply is no explicit management ever (the device either
works or it is thrown away). Other scenarios may involve the need to
integrate constrained devices into a system also comprising more
traditionally managed devices. Other scenarios may be fully
application driven and any necessary management functions must become
part of that application.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 6 Jun 2012 10:52:10 +0200

Hi Juergen,

> part of that application.

Agree. Matching device classes to possible applications in use might not
be sufficient. A top down view for application driven scenarios would be
useful.

Could you describe the application classes and the list of relevant
scenarios you have in mind. Some draft text would be helpful.

Cheers,
Mehmet